Sie sind nicht angemeldet.

vossi

Fortgeschrittener

  • »vossi« ist männlich
  • »vossi« ist der Autor dieses Themas

Beiträge: 155

Wohnort: Hamburg

Lieblingscomputer: P500

  • Nachricht senden

1

Samstag, 19. September 2015, 18:10

XT bootet nicht von Floppy

Hallo,
ich habe zwei IBM XT Clone-Mainboards aus Taiwan. Eines mit einem "Computer XT Bios 3.0" und eins mit Phoenix Bios 2.51.
Die BIOSe lassen sich auch unter den unterschiedlichen Boards tauschen.
Beide Boards laufen mit einer Genoa-EGA-Karte und booten von einer MFM-Festplatte.

Nur leider booten beide nicht von Floppy.
Ich habe zwei verschiedene 8-bit-Floppy-Controller mit zwei Teac-360k-Floppys getestet.
Beide Controller+Floppys laufen in einem IBM-Board ohne Probleme.
Hab die DIP-Schalter-Stellungen auf dem Baord für die Floppys durchprobiert...


Hat einer eine Idee wo das Problem liegen könnte?

Christian

Stefan Both

Ware mit leichtem Fehler

Beiträge: 4 414

Wohnort: West- Nordostern

  • Nachricht senden

2

Samstag, 19. September 2015, 18:40

Kannst du die hd-controller karte mal testhalber
entfernen um zu sehen, ob dann von Disk
gebootet wird?!

Stefan

vossi

Fortgeschrittener

  • »vossi« ist männlich
  • »vossi« ist der Autor dieses Themas

Beiträge: 155

Wohnort: Hamburg

Lieblingscomputer: P500

  • Nachricht senden

3

Samstag, 19. September 2015, 19:15

Das hatte ich zuerst gemacht.
Den HD-Controller hatte ich erst später gesteckt um mal zu schauen ob er davon bootet.
Übrigens läuft das 82'er 8k IBM BIOS (ohne Basci nur die obersten 8k) nicht in den Boards - hätte ich eigentlich erwartet!

Peter z80.eu

Z80 Anbeter

  • »Peter z80.eu« ist männlich

Beiträge: 1 347

Wohnort: Mainz Umgebung

Lieblingscomputer: Kaypro 4

  • Nachricht senden

4

Samstag, 19. September 2015, 20:01

Sind das "ganz normale" Floppy-Controller, also keine Multi I/O Karten oder besondere FD-Controller (mit eigenem BIOS usw.) ?
Kannst Du - wenn Du von Platte bootest - die Floppies ansprechen (auch wenn das Booten nicht klappt) ?
"Wäre das Pferd eine Katze gewesen, dann wäre es den Baum hochgeritten" --- Und schaut auch mal bei meinem Blog vorbei ...

vossi

Fortgeschrittener

  • »vossi« ist männlich
  • »vossi« ist der Autor dieses Themas

Beiträge: 155

Wohnort: Hamburg

Lieblingscomputer: P500

  • Nachricht senden

5

Samstag, 19. September 2015, 22:58

Hi, ist ein IBM-XT-Controller und ein 8-bit-controller mit Uhr und Multi-IO.
Aber gut war der Tip mal HD und Floppy gleichzeitig anzuschließen und nach booten von HD den Zugriff auf die Floppy zu testen.
Hab zwei Floppys angeschlossen und der Zugriff auf B funktionierte - A aber nicht.

Und dann hab ich meinen - selten dämlichen Fehler - erkannt !!!!
Ich hab ein 34poliges MFM-Kabel erwischt, welches ja auch eine Drehung zum zweiten Anschluss hat - aber an ganz anderer Stelle!
Mit dem korrekten Floppy Kabel läuft jetzt alles wunderbar... ;-)

Danke für die Unterstützung

Komisch nur das zwei nachgemachte BIOSe in den Boards laufen, aber kein IBM-Bios - ich hätte erwartet das das geht.
Hat schon mal jemand in einem Fake Board ein IBM-Bios probiert?



Christian

kpanic

Erklärbär

  • »kpanic« ist männlich

Beiträge: 1 498

Wohnort: Bad Säckingen

Lieblingscomputer: alles vor '95, vor allem IBM-kompatible

  • Nachricht senden

6

Sonntag, 20. September 2015, 10:49

Hat schon mal jemand in einem Fake Board ein IBM-Bios probiert?

Ja, ich hatte mal einen Klon der schon als ich ihn bekommen hab mit gebrannten IBM-ROMs bestückt war, inkl. BASIC-ROMs.
Hat einwandfrei funktioniert.
Hängt natürlich immer davon ab wie exakt kompatibel das Board ist...
Gesendet von meinem Kühlschrank mit Magerquark...


Das Internet wird 1996 kollabieren.
(Robert Metcalfe, Erfinder des Ethernets, 1990)

*******

Furcht ist der Pfad zur dunklen Seite. Furcht führt zu Wut, Wut führt zu Hass, Hass führt zum unsäglichem Amiga.
(Yoda)

@kpanic

Thema bewerten