Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VzEkC e. V.. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

31

Montag, 17. Juli 2017, 20:37

Ich schau gerne nochmal nach.
Eingesetzt waren die auf einer PAK (ProzessorAustauschKarte) der c't.


http://www.datadelay.com/datasheets/ddu4.pdf

Hier ist schonmal ein Datenblatt eines ähnlichen Typs. Weisst Du, wie man Delay Lines testet? Ich ahne, dass hier ein weiteres Kaufargument für ein Speicheroszi heranwächst.
Link arms, don't make them

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

32

Montag, 17. Juli 2017, 22:51

Tolle Neuigkeiten zu Tripos - Ich habe Rückmeldung von (erimitierten) Prof. Martin Richards, dem Autor von Tripos, erhalten.
Er scheint interessiert mir zu helfen und die Sachen für mich zusammen zu suchen was er noch hat. Zumindest der Kernel und der BCPL Compiler ist wohl noch da.

http://www.cl.cam.ac.uk/~mr10/
Link arms, don't make them

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

33

Montag, 17. Juli 2017, 23:52

Ich mag die Sage immer mehr. In der hervorragenden Doku findet sich sogar die Delay Line. Sie erzeugt 60,70,260 und 370ns Verzögerung.
Link arms, don't make them

E. Dresen

Vereinsmitglied

  • »E. Dresen« ist männlich

Beiträge: 908

Wohnort: Werne

Lieblingscomputer: C64, IBM PC-kompatible Rechner

  • Nachricht senden

34

Montag, 17. Juli 2017, 23:55

Ich mag die Sage immer mehr. In der hervorragenden Doku findet sich sogar die Delay Line. Sie erzeugt 60,70,260 und 370ns Verzögerung.
Kurz gefragt: Bist du immer noch auf Fehlersuche ...?

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

35

Dienstag, 18. Juli 2017, 00:06

Klar
Link arms, don't make them

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

36

Dienstag, 18. Juli 2017, 00:16

Weisst Du, wie man Delay Lines testet? Ich ahne, dass hier ein weiteres Kaufargument für ein Speicheroszi heranwächst.

Dafuer brauchst du kein Speicheroszi.
Ein Funktionsgenerator mit Rechtecksignal am Eingang, bei einem 2-Kanal Oszi Eingang und Ausgang ans Oszi und messen.
Bei einem 1-Kanal Oszi den Input auf den Trigger-Eingang und den Kanal mal am Eingang, mal am Ausgang. Der Unterschied ist das Delay.

Fragen?


Hier ist schonmal ein Datenblatt eines ähnlichen Typs.

Sinngemaess sind die mir bekannten aehnlich.


Viel Erfolg
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

37

Dienstag, 18. Juli 2017, 22:54


Dafuer brauchst du kein Speicheroszi.

Viel Erfolg


Danke für den Tip. Analogsozi und Rechteckgenerator hab ich hier!
Mich würde interessieren, wofür die Delay Line überhaupt da ist (nicht jeder Computer hat eine). Eigentlich fällt mir da nur die Commodore A2000 / 68030 Turbokarten ein, die sowas haben. Dort gelten die Dinger als alterungsempfindlch. ich habe im Annex einen Ausschnitt des Sage-Schaltplans, vielleicht kannst Du oder sonst jemand, der mitliest das einordnen? Der Schaltplan ist ein wenig verwirrend, die Delay Line ist zweimal dargestellt, aber nur einmal vorhanden.
Weiterhin ist eine Tabelle angehängt, die verschiedene Sage-kompatible Delay Lines zeigt. Leider finde ich von all diesen kein Data Sheet. Was aber eigentlich nicht nötig wäre, wenn ich verstehen würde, was die "60er" Spalte für eine Bedeutung hat. Auch ein Delay in ns?
Demzufolge wären die gültigen Delays 60/70/250/370ns oder 60/90/290/375ns (und ich dachte immer die Abgriffe /Delays sind "regelmäßig")

Gruß
Stephan
»Toshi« hat folgende Bilder angehängt:
  • delay2.jpg
  • delay3.jpg
Link arms, don't make them

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Toshi« (18. Juli 2017, 23:01)


funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

38

Dienstag, 18. Juli 2017, 23:34

Mich würde interessieren, wofür die Delay Line überhaupt da ist (nicht jeder Computer hat eine).

Genau wie Monoflops werden die Bauteile gerne eingesetzt, wenn der Entwickler die Schaltung nicht anständig hinkriegt.
Mein Prof hat damals gesagt: "Die Anzahl der verwedeten Monoflops ist reziprok zur Intelligenz des Entwicklers."

Mal im Ernst: Seih froh das du solche Delay Lines nicht so oft siehst.
Ehrlich gesagt, ich weiss bis heute nicht wie die Dinger funktionieren.

Leider kann ich das U42 auf dem Schaltplan nicht gut lesen. Ich vermute die Tabelle listet die Pinbelegung bei unterschiedlichen Delay Lines auf.

Viel Erfolg
Flo
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

39

Mittwoch, 19. Juli 2017, 00:53

Das Ding kenn ich zwar nicht, aber es gibt/gab DelayLines von Dalles/Maxim. Ich meine die fangen mit DS1000 an. Ich schau gerne nochmal nach.
Eingesetzt waren die auf einer PAK (ProzessorAustauschKarte) der c't.

Zur Vollständigkeit:
Eingesetzt waren die auf der Speedup-16, eine 16 MHz Beschleunigrkarte fuer den 68000. (c't 10/1990, S. 330)
Heute gibt's die Nachfolger DS1100 bei Maxim Integrated.
Das nur zur Info.


Die in der Sage verwendeten DDU-7 scheint es auch noch geben bei Data Delay Devices.
Interessante FAQ
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

40

Mittwoch, 19. Juli 2017, 04:51

https://de.m.wikipedia.org/wiki/Verzögerungsleitung

Ich glaub in Oszis findet man solche Leitungen auch.

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

41

Mittwoch, 19. Juli 2017, 09:08

Ich glaub in Oszis findet man solche Leitungen auch.

Ebenso, wie im Artikel beschrieben, auch in jedem alten PAL-Fernseher.
Aber das sind analoge Verzoegerungen, die auch deutliche Verzoegerungen (PAL: 64µs) haben.

Mein Gemeckere betrifft diese digitalen Verzoegerungen, die ca. 5 - 10 Gatterlaufzeiten entsprechen. Vor allem in "modernen" Computern, die schon 'ne 68000 beherbergen. Das ist m.E. schlechtes Schaltungsdesign.
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

Schroeder

Vereinsmitglied

Beiträge: 1 163

Wohnort: Haltern am See

Lieblingscomputer: Mein erster 286er von 1988, läuft immer noch.

  • Nachricht senden

42

Mittwoch, 19. Juli 2017, 10:46

Ich glaub in Oszis findet man solche Leitungen auch.

Ebenso, wie im Artikel beschrieben, auch in jedem alten PAL-Fernseher.
Aber das sind analoge Verzoegerungen, die auch deutliche Verzoegerungen (PAL: 64µs) haben.

Mein Gemeckere betrifft diese digitalen Verzoegerungen, die ca. 5 - 10 Gatterlaufzeiten entsprechen. Vor allem in "modernen" Computern, die schon 'ne 68000 beherbergen. Das ist m.E. schlechtes Schaltungsdesign.


Hmm, ich tue mich schwer mit schlechten Schaltungsdesign und habe ein Beispiel.

In meiner Diplomarbeit habe ich einen DEC T11 und J11 an einen VMSbus adaptiert. Der VMSbus ist Signalmässig doch eher 68000er lastig und da waren einige Klimmzüge nötig die beiden Welten zu verbinden.
Zwei besondere Problemstellen:
1. Die CPUkarte vom Bus zu nehmen wenn der Arbiter das so wollte. Das ging durch erzwingen eines DMA Modus.
2. Die ganzen Daten und Adressen-handshakes im richtigen Timing zu erzeugen, aufwendig wenn die CPU diese anders oder gar nicht erzeugt.

Im letzteren Fall durften dann auch mal einige Inverter in Reihe die Verzögerung von den benötigten nS erzeugen.

In einem anderen Projekt hatten wir das Problem, dass Interfacebausteine für eine andere CPU Familie waren. Da mussten dann auch schonmal längere Delays herhalten.
Da die Interfacebausteine sehr speziell waren, gab es da auch keine Alternative.

Gruss,
Peter

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

43

Mittwoch, 19. Juli 2017, 11:33

Hmm, ich tue mich schwer mit schlechten Schaltungsdesign und habe ein Beispiel.

Ich kenne solche Probleme auch.
Und wie immer: Keine Regel ohne Ausnahme!

Ein paar Inverter in Reihe ist ja noch ok. Deren Verhalten ist ja ziemlich vorhersehbar und stabil.
Aber wenn so eine RC Kombination, am besten noch mit Elkos, dazwischen liegt, krieg ich Bauchschmerzen. Sowas ist dann ueber lange Zeit nicht stabil.

Auch ein "gutes" Problem ist, das Bauteile immer schneller werden.
Bei meinem Nascom-1 braucht der CharacterGenerator ueber 300ns fuer ein neues Datum.
Die EEPROMs mit 150ns Zugriffszeit (max.) kommen mit 30 ns aus.
Haette man an der Stelle ein weiteres FF investiert, waere nie ein Problem entstanden.

Ich mache viel mit FPGAs. Heute steht ein Speedgrade -5 (nur als Zahl) drauf, in 5 Jahren auch, aber das Ding ist doppelt so schnell.
Vor 20 Jahren ist uns dann so eine Inverterkette um die Ohren geflogen, nachdem es mehr als 5 Jahre funktioniert hat.


Bei einer Diplomarbeit oder im Prototypenstadium oder fuer die Reparatur eines Retro-Rechners sind solche Tricks (bedingt) erlaubt, um die Funktion zu erreichen.
Fuer danach sollte man sich genau ueberlegen, ob das sinnvoll ist.

Wie Einstein schon sagte: Alles ist Relativ.
So auch mit "schlechten" Schaltungsdesigns.

Gruss,
Flo
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

44

Mittwoch, 19. Juli 2017, 22:53

Die Delay Line wars nicht. Ich habe mich nun doch getraut, die Delay Line vom funktionierenden Board auszulöten und im "bösen" Board zu testen. Der Rechner zeigt noch das gleiche Fehlerbild. Und die Delay Line funktioniert auch noch (nicht thermisch zerstört).
Ich habe jetzt kurzerhand alle 74er ICs die auf dem Board eingesetzt werden bei Reichelt neu bestellt. Da alle gesockelt sind, und die Dinger nicht wirklich teuer, versuche ich das als nächstes.
Dann kann es eigentlich nichts mehr sein - ausser vielleicht noch Kontaktprobleme. Vielleicht muß ich dann doch alle Sockel tauschen. Leider ist das Board / die Pads sehr empfindlich....
Link arms, don't make them

Toast_r

2. stellvertr. Vorsitzender

  • »Toast_r« ist männlich

Beiträge: 4 197

Wohnort: 51.32,6.48544

Lieblingscomputer: CBM 720

  • Nachricht senden

45

Mittwoch, 19. Juli 2017, 22:57

Stephan, das sollst Du doch nicht!

Intakte ICs in fragwürdige Boards stecken -> Falsch, kann die intakten ICs zerstören
fragwürdige ICs in intakten Boards testen -> Richtig, kann normalerweise nix bei kaputtgehen.

E. Dresen

Vereinsmitglied

  • »E. Dresen« ist männlich

Beiträge: 908

Wohnort: Werne

Lieblingscomputer: C64, IBM PC-kompatible Rechner

  • Nachricht senden

46

Mittwoch, 19. Juli 2017, 23:17

Die Delay Line wars nicht. Ich habe mich nun doch getraut, die Delay Line vom funktionierenden Board auszulöten und im "bösen" Board zu testen. Der Rechner zeigt noch das gleiche Fehlerbild. Und die Delay Line funktioniert auch noch (nicht thermisch zerstört).
Ich habe jetzt kurzerhand alle 74er ICs die auf dem Board eingesetzt werden bei Reichelt neu bestellt. Da alle gesockelt sind, und die Dinger nicht wirklich teuer, versuche ich das als nächstes.
Dann kann es eigentlich nichts mehr sein - ausser vielleicht noch Kontaktprobleme. Vielleicht muß ich dann doch alle Sockel tauschen. Leider ist das Board / die Pads sehr empfindlich....
Ich würde beim RAM-Problem weitersuchen ... nur mal so ... :tüdeldü:

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

47

Mittwoch, 19. Juli 2017, 23:19

Das mache ich doch. Ich hab nur nicht ausschließlich die ICs im Ram-Umfeld bestellt.
Link arms, don't make them

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

48

Mittwoch, 19. Juli 2017, 23:20

Stephan, das sollst Du doch nicht!

Intakte ICs in fragwürdige Boards stecken -> Falsch, kann die intakten ICs zerstören
fragwürdige ICs in intakten Boards testen -> Richtig, kann normalerweise nix bei kaputtgehen.


Hmm. Du hast Recht. Das war wenig schlau.
Link arms, don't make them

E. Dresen

Vereinsmitglied

  • »E. Dresen« ist männlich

Beiträge: 908

Wohnort: Werne

Lieblingscomputer: C64, IBM PC-kompatible Rechner

  • Nachricht senden

49

Mittwoch, 19. Juli 2017, 23:21

Das mache ich doch. Ich hab nur nicht ausschließlich die ICs im Ram-Umfeld bestellt.
OK! Verfolge ja deinen Thread hier ganz gespannt, weil es mich echt interessiert ... ;)

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

50

Donnerstag, 20. Juli 2017, 21:29

Woher stammt denn der Name "Sage II"? Soll das der Nachfolger von SAGE sein? :D


Um den computerhistorischen Kontext hier nicht zu kurz kommen zu lassen, hier die Antwort von Rod:

Well, Sage Computer was the name of the company I started to build it,
and Sage I didn't loook right so we named it the Sage II, in honor of
the Apple II.

> Has it something to do with the 50's military computer

No. I didn't know about that at the time. Ironically, part of that
Army system was deployed here in Reno and is still stored up at Desert
Research.
Link arms, don't make them

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

51

Donnerstag, 20. Juli 2017, 22:05

Hallo!

Hab jetzt alle ICs (mit weissen Punkten markiert) ausgewechselt. Nur noch einige wenige sind offen. Ich habe langsam die Befürchtung, daß es das nicht ist....

Nur eins ist mir aufgefallen: Ein 74LS47 steckt in einem Sockel, der mit 74S47 beschriftet ist. Bei dem Board was läuft, ist auch ein 74S74 an diesem Platz. Leider ist das bei dem guten Board nicht gesockelt, da kann ich nicht einfach umstecken.

Lt. Wikipedia sollten 74S und LS doch fast gleich sein, ich zitiere mal:

74S – High-speed Schottky. Implemented with Schottky diode clamps at the inputs to prevent charge storage, this provides faster operation than the 74 and 74H series at the cost of increased power consumption and cost. 3 ns gate delay, 20 mW dissipation, released in 1971.
74LS – Low-power Schottky. Implemented using the same technology as 74S but with reduced power consumption and switching speed. Typical 10 ns gate delay, a remarkable (for the time) 2 mW dissipation, 4.75–5.25 V.

Oder können die 7ns was ausmachen bei so lahmen alten Kisten?
»Toshi« hat folgendes Bild angehängt:
  • wechsel.jpg
Link arms, don't make them

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Toshi« (20. Juli 2017, 22:19)


funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

52

Donnerstag, 20. Juli 2017, 22:37

Moin,

ich hab mir gerade mal den Schaltplan angeschaut. Vielleicht hast du da eine neuralgische Stelle gefunden.

Du meinst bestimmt das U34.
Das haengt direkt vor deiner DelayLine. 2 Gatter davor ist das U44, 74S240. Bestueckt ist ein LS240!
Angesteuert wird das U44 von AS (Adress Strobe). Das Signal sagt, das die Adresse am 68000 stabil ist (Gedaechnisprotokoll).
Daraufhin wird durch die DelayLine das Memory Timing generiert.
An der Stelle koennen ein paar ns schon Spass machen, vor allem wenn wir nicht wissen, wie stabil die DelayLine arbeitet.

Vielleich sind ein paar Versuche mit Kaeltespray hilfreich.

BTW: So eine Schaltung mit DelayLine und Memory Ansteuerung hab ich gerade durch Zufall im TRS-80 Expansion Interface gesehen.

Wie immer: Viel Erfolg!
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

53

Donnerstag, 20. Juli 2017, 23:33



BTW: So eine Schaltung mit DelayLine und Memory Ansteuerung hab ich gerade durch Zufall im TRS-80 Expansion Interface gesehen.

Wie immer: Viel Erfolg!


Hallo!

Ich hab grade den 74S74 aus dem laufenden Board ausgelötet, einen Sockel eingelötet und das 74S74 wieder in den Sockel eingesetz und gestartet. Blöderweise (ich ärgere mich schwarz) habe ich jetzt mein funktionierendes Board auch zerstört. Bekomme eine Fehlermeldung (Parity Error)....Oh mann...

Dummerweise sind die RAM Chips der ersten Reihe auch alle eingelötet. Aber vielleicht ist auch was ganz anderes kaputt.... Zweifle langsam dran ob ich die Dinger jemals ans laufen bekomme.

Kann jemand von Euch verstehen, wie ich aus der Fehlermeldung auf den vermeintlich bösen RAM IC schließe?
»Toshi« hat folgende Bilder angehängt:
  • parity error.jpg
  • mem.jpg
Link arms, don't make them

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Toshi« (20. Juli 2017, 23:38)


funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

54

Donnerstag, 20. Juli 2017, 23:58

Ist das gesamte Memory bestueckt oder nur die erste Reihe?
Die Adresse 7EC00 liegt wenn in der 4. Reihe.

Wenn nur die erste Reihe bestueckt ist, wieso zeigt der Rechner 512kB an?

Vielleicht ist die Schaltung an der Stelle wirklich etwas kritisch.

Irgentwie passt das mem.jpg aber nicht zur Fehlermeldung. Gibt's ein wenig mehr Erklaerung zur Fehlermeldung?
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

55

Freitag, 21. Juli 2017, 00:09

Hast du das Sage Diagnostic Guide?
Ab Seite ist der eingebaute Memory Test beschrieben.
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

E. Dresen

Vereinsmitglied

  • »E. Dresen« ist männlich

Beiträge: 908

Wohnort: Werne

Lieblingscomputer: C64, IBM PC-kompatible Rechner

  • Nachricht senden

56

Freitag, 21. Juli 2017, 00:11



BTW: So eine Schaltung mit DelayLine und Memory Ansteuerung hab ich gerade durch Zufall im TRS-80 Expansion Interface gesehen.

Wie immer: Viel Erfolg!


Hallo!

Ich hab grade den 74S74 aus dem laufenden Board ausgelötet, einen Sockel eingelötet und das 74S74 wieder in den Sockel eingesetz und gestartet. Blöderweise (ich ärgere mich schwarz) habe ich jetzt mein funktionierendes Board auch zerstört. Bekomme eine Fehlermeldung (Parity Error)....Oh mann...

Dummerweise sind die RAM Chips der ersten Reihe auch alle eingelötet. Aber vielleicht ist auch was ganz anderes kaputt.... Zweifle langsam dran ob ich die Dinger jemals ans laufen bekomme.

Kann jemand von Euch verstehen, wie ich aus der Fehlermeldung auf den vermeintlich bösen RAM IC schließe?
In der oberen Reihe sind zwei Parity "RAM-ICs" ... die 9. ... das dürfte dann der linke RAM-IC sein ... tippe ich mal.
»E. Dresen« hat folgendes Bild angehängt:
  • mem.jpg

Toast_r

2. stellvertr. Vorsitzender

  • »Toast_r« ist männlich

Beiträge: 4 197

Wohnort: 51.32,6.48544

Lieblingscomputer: CBM 720

  • Nachricht senden

57

Freitag, 21. Juli 2017, 00:16

Ein 74LS47 steckt in einem Sockel, der mit 74S47 beschriftet ist.

Das ist doch bestimmt ein Tippfehler, oder ?
74LS47 ist ein BCD zu 7-Segment Decoder-Treiber.
Wenn es stattdessen um einen 74S74 geht, ist der Unterschied zwischen S und LS laut meinem Datenbuch schon beachtlich.
S hat demnach 6 nS Durchlaufverzögerung, LS 19 nS.

funkenzupfer

Z80 Versteher

  • »funkenzupfer« ist männlich

Beiträge: 634

Wohnort: in der Nähe von 51°04'27.3"N 6°28'02.3"E

Lieblingscomputer: Video Genie System EG3003

  • Nachricht senden

58

Freitag, 21. Juli 2017, 00:31

Das ist doch bestimmt ein Tippfehler, oder ?

Ja, ist es. Beim 3. mal hat er es ja richtig geschrieben.
;------------------------------------
;----- ENABLE NMI INTERRUPTS
(aus: IBM BIOS Source Listing)

Toshi

Vereinsmitglied

  • »Toshi« ist männlich
  • »Toshi« ist der Autor dieses Themas

Beiträge: 3 076

Wohnort: Oedheim/BaWü

Lieblingscomputer: Sage II

  • Nachricht senden

59

Freitag, 21. Juli 2017, 00:37

Ein 74LS47 steckt in einem Sockel, der mit 74S47 beschriftet ist.

Das ist doch bestimmt ein Tippfehler, oder ?
74LS47 ist ein BCD zu 7-Segment Decoder-Treiber.
Wenn es stattdessen um einen 74S74 geht, ist der Unterschied zwischen S und LS laut meinem Datenbuch schon beachtlich.
S hat demnach 6 nS Durchlaufverzögerung, LS 19 nS.


Legasthenie am spâten Abend. Das war's aber auch nicht. Das böse Board mit dem 74S74 will auch nicht.
Link arms, don't make them

E. Dresen

Vereinsmitglied

  • »E. Dresen« ist männlich

Beiträge: 908

Wohnort: Werne

Lieblingscomputer: C64, IBM PC-kompatible Rechner

  • Nachricht senden

60

Freitag, 21. Juli 2017, 01:04

Ein 74LS47 steckt in einem Sockel, der mit 74S47 beschriftet ist.

Das ist doch bestimmt ein Tippfehler, oder ?
74LS47 ist ein BCD zu 7-Segment Decoder-Treiber.
Wenn es stattdessen um einen 74S74 geht, ist der Unterschied zwischen S und LS laut meinem Datenbuch schon beachtlich.
S hat demnach 6 nS Durchlaufverzögerung, LS 19 nS.


Legasthenie am spâten Abend. Das war's aber auch nicht. Das böse Board mit dem 74S74 will auch nicht.

Da kann man ja echt *mitleiden* mit dir ... ernsthaft. Gehe doch noch mal in Ruhe alles durch ... vielleicht hast du etwas übersehen ... klingt blöd, ich weiß, manchmal baut man etwas zusammen ... es funktioniert nicht ... und wenn man alles noch mal von Anfang an durchgeht ... dann klappt es dann.

Mann ... das Teil kostet ja mir sogar Nerven. Armer Toshi!

Nicht aufgeben! :thumbsup:

Thema bewerten