Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VzEkC e. V.. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

PeterSieg

Vereinsmitglied

  • »PeterSieg« ist männlich
  • »PeterSieg« ist der Autor dieses Themas

Beiträge: 2 711

Wohnort: Holzminden, 37603

  • Nachricht senden

1

Samstag, 28. Juni 2014, 13:41

Willem Eprommer unter Win 7-64 bit (+Linux)

Aus dem Internet und kurzform in deutsch.

Ich habe einen Willem Eprommer (PCB5) mit Eprom35 Software, die bis XP gut funktioniert.
Der USB Anschlus dient nur der Spannungsversorgung. Datentransfer erfolgt über die Parallelschnittstelle.

Unter Win7-64 bit gibt es nur Fehlermeldungen beim Start. Schuld ist wohl die 32-bit io.dll.

Findige User haben nun die Nutzung unter 64-bit ermöglicht.
Dazu wird anstatt der original io.dll ein Ersatz aus dem ZIP iowrapper.zip in das Programmverzeichnis kopiert und vor dem ersten Start
wird noch das benötigte tvicport (im gleichnamigen Zip) installiert.

Läuft bei mir nun einwandfrei unter 64-bit Win7.

(Ggf. noch unsignierte Treiber erlauben)

Links:
http://www.downtowndougbrown.com/2010/10…ndows-7-64-bit/
http://www.amibay.com/showthread.php?163…th-Win-7-64-bit

Peter
»PeterSieg« hat folgende Dateien angehängt:
  • iodllwrapper.zip (4,98 kB - 109 mal heruntergeladen - zuletzt: 14. August 2017, 16:01)
  • tvicport.zip (374,17 kB - 86 mal heruntergeladen - zuletzt: 14. August 2017, 16:01)
github.com/petersieg

hexagon

Vereinsmitglied

  • »hexagon« ist männlich

Beiträge: 4 548

Wohnort: 64653 Lorsch

Lieblingscomputer: C64, Amiga, Apple

  • Nachricht senden

2

Samstag, 28. Juni 2014, 14:47

Interessante Info. Danke. Ich habe einen Willem V4 Eprommer. Werde die Links mal genauer anschauen ob das auch dafür passt. Derzeit krame ich immer einen Windows 98SE Rechner hervor wenn ich ein Eprom brennen muss - kommt ja nicht so oft vor. Wäre unter Windows 7 schon einfacher. Hoffentlich hab ich da ne Kiste gebaut die noch einen Parallelport hat...

Viele Grüße
Andreas

PeterSieg

Vereinsmitglied

  • »PeterSieg« ist männlich
  • »PeterSieg« ist der Autor dieses Themas

Beiträge: 2 711

Wohnort: Holzminden, 37603

  • Nachricht senden

3

Dienstag, 5. August 2014, 19:59

Habe gerade noch gefunden, das es auch eine Version für Linux gibt:

http://spurtikus.de/basteln/willem_programmer_and_linux.html
http://sourceforge.net/projects/geepro/

Bei meinem Test-Ubuntu 14.04 LTS fehlen aber wohl libs und ich kann es nicht kompilieren.. :-(

Evtl. hat ja einer der Linux Guru's hier Interesse mal das Programm zu kompilieren und ein Binary Paket (tgz; deb) daraus zu bauen und hier einzustellen..

Ich kann es dann gerne unter Ubuntu 14 testen.

Peter
github.com/petersieg

ChaosRom

Fortgeschrittener

  • »ChaosRom« ist männlich

Beiträge: 371

Wohnort: Ditzingen

Lieblingscomputer: Ich rück keinen mehr raus!

  • Nachricht senden

4

Dienstag, 5. August 2014, 20:54

Hallo Peter,

leider ist meine Leitung nicht arg schnell und als KDE-User hab ich kein GTK.
Bis das ./waf configure das fehlende gtk () bemängelt hat, haben aber schon
tools aus den Paketen: gettext, intltool und pkg-config gefehlt.
Das rauszufinden ist aber garnicht so schwer. Ich hab das Paket "command-not-found"
installiert.
Nach der Zeile "Checking for program msgfmt : not found" hab ich auf der
Kommandozeile dann halt "msgfmt" eingegeben und als Antwort (von command-not-found)

Quellcode

1
2
$ msgfmt
The program 'msgfmt' is currently not installed.  To run 'msgfmt' please ask your administrator to install the package 'gettext'

Zu hören bekommen. So muss man sich durchhangeln. Als nächstes wird noch "libgtk-3-0" fehlen, aber ich lad grad was
großes runter und hab nur 2MBit (Rosa Riese sei dank) :cursing:

Viel Erfolg
Roman
Das Genie beherrscht das Chaos

ChaosRom

Fortgeschrittener

  • »ChaosRom« ist männlich

Beiträge: 371

Wohnort: Ditzingen

Lieblingscomputer: Ich rück keinen mehr raus!

  • Nachricht senden

5

Dienstag, 5. August 2014, 23:41

Also gut, ich habs doch geschafft.
Ich hab aber debian wheezy, aber die Pakete sollten unter Ubuntu eigentlich gleich heißen.
Hier mal was ich noch installiert hab:

Quellcode

1
2
3
g++
libgtk-3-dev
libxml2-dev


Raus kommt dann ein "build_directory", das ich angehängt hab
»ChaosRom« hat folgende Datei angehängt:
Das Genie beherrscht das Chaos

PeterSieg

Vereinsmitglied

  • »PeterSieg« ist männlich
  • »PeterSieg« ist der Autor dieses Themas

Beiträge: 2 711

Wohnort: Holzminden, 37603

  • Nachricht senden

6

Mittwoch, 6. August 2014, 17:41

@ChaosRom: Super! Vielen Dank. Gerade ausprobiert untern Ubuntu 14.04 und läuft!! Man muss nur das build_directory entpacken und dann sudo ./geepro starten. Bei mir musste PCB3 als Eprommer eingestellt werden. Habe gerade 2x erfolgreich 27C64 Eproms mit C64 Kernal gebrannt.

Damit ist der Willem nutzbar unter:
  • DOS
  • Win98/2000
  • Win XP
  • Win 7 32 + 64bit
  • Linux
  • Mac OS X ?
Und damit wohl einer der universellsten Eprommer was die unterstützten Betriebssysteme angeht.

Peter
github.com/petersieg

ChaosRom

Fortgeschrittener

  • »ChaosRom« ist männlich

Beiträge: 371

Wohnort: Ditzingen

Lieblingscomputer: Ich rück keinen mehr raus!

  • Nachricht senden

7

Mittwoch, 6. August 2014, 20:01

@ PeterSieg: Gern geschehen. :)
Wieso startest Du den als root (sudo)? Mit ner udev-rule kannst Du die Berechtigungen einfach setzen und Dich dann noch der richtigen Gruppe hinzufügen (/etc/group)
Das Genie beherrscht das Chaos

Thema bewerten