CBM 8050 - Hilfe bei der Reparatur

  • Hallo
    Ich benötige wieder etwas Hilfe bei der Reparatur. Nun geht es um eine CBM 8050
    Es geht um das Ergebnis von "aus zwei mach eins". Ich hatte 2 mechanisch erheblich beschädigte Laufwerke und konnte wenigstens eins daraus gewinnen, dass soweit ok scheint. Nach dem Einschalten blinken die LEDs einmal. Laut Servicehandbuch sollte es sich um einen Defekt im Bereich der 6532 handeln.
    Nach dem Einlegen einer Diskette läuft das betreffende Laufwerk kurz an. Bei der Eingabe von Floppybefehlen reagiert das Laufwerk scheinbar normal. Die Disk dreht ich und der Lese- Schreibkopf bewegt sich auch, zumindest hin und wieder. Die durchgeführte Formatierung der Disk blieb erfolglos. Der Schreibkopf hatte sich dabei nicht oder nur wenig bewegt. Lesezugriffe enden mit der Fehlermeldung "file not found error". Der Leseversuch der Disk könnte deshalb gescheitert sein, weil sie mit einer 1541 formatiert wurde.
    Kann mir jemand einen Hinweis geben, warum die Floppy nicht so will wie ich? Welche Auswirkungen hat es, wenn einer der beiden oder beide 6532 defekt ist/sind?


    Was ich bisher herausgefunden habe:
    - DOS 2.5, getestet und ok
    - beide 6502 scheinbar ok
    - 6522 scheinbar ok
    - GCR ROM defekt und durch 28C16 ersetzt


    Tommy

  • OK, also erstmal ein paar grunsätzliche Informationen:


    Das Diskettenformat der 8050 ist nicht kompatibel zu dem der 1541. Das Disketten sind untereinander nicht austauschbar.


    Vermutlich hast Du das Blinkes des erfolgreichen Selbsttests fälschlich als Fehler interpretiert.
    Die LEDs blinken beim Einschalten der Floppy bei erfolgreichem Selbsttest so:
    - Power LED rot, beide LW-LED ein für ca. 1-2 Sek
    - Power LED gelb, beide LW-LED aus für ca. 0,5 Sek
    - Power LED rot, beide LW-LED ein für ca. 0,5 Sek
    Danach Power LED gelb, beide LW-LED aus.
    Ein nicht erfolgreicher Selbsttest wird durch einen dauerhaften Blink-Code angezeigt,
    der so lange weiterblinkt, bis die Floppy ausgeschaltet wird.


    Die Fehlermeldung 'FILE NOT FOUND ERROR' ist ziemlich nichtssagend.
    Interessant wird das erst, wenn man den Fehlerkanal der Floppy ausliest.
    Unter Basic 4 mit 'PRINT DS$'
    unter BASIC 2 mit einem kleinen Programm:
    10 open 1,8,15
    20 input #1,a,b$,c,d
    30 print a;b$;c;d
    40 close 1


    Auch nach dem Versuch, eine Diskette zu formatieren,
    sollte der Fehlerkanal für weitere Informationen ausgelesen werden.


    Wie hast Du das defekte GCR ROM diagnostiziert?

  • Hallo
    Vielen Dank, für die rasche Antwort. Die Beschreibung des Blinkverhaltens des Laufwerks entspricht deiner Beschreibung. Ich habe dann wohl übersehen, dass der Fehlercode fortwährend blinkt. Dann währen die beiden 6532 doch ok. Das war für mich eh schon etwas ungewöhnlich. Ich habe ja 2 8050 und habe die 4 6532 in allen Kombinationen getauscht, ohne dass es eine Änderung gab. Ich wollte es nicht wirklich wahrhaben, dass mindestens 3 davon defekt sein sollen.
    Das die Disketten untereinander nicht kompatibel sind, hatte ich fast vermutet, wegen der TPI-Zahl.
    Den defekten ROM habe ich als 2716 mit meinem EPROM-Brenner ausgelesen (alle beide). Als Ergebnis hatte ich bei beiden vollständig nur FF. Laut entsprechender Datei im Internet solle nur jede 2. Zeile FF enthalten. Die jeweils 1. Zeile sollte "sinnvolle" Ergebnisse bringen. Daher vermute ich, dass er defekt ist. Wobei ich es ja auch schon wieder verdächtig finde, dass alle beide ROMs diese FF-Füllung aufweisen.


    Ich habe das Formatierungsverhalten noch einmal getestet. Der Lese- Schreibkopf bewegt sich in eine "Endposition" und bewegt sich dann während des Formatierens nicht mehr. Die Diskette jedoch dreht sich. Nach einiger Zeit endet scheinbar der Formatierungsvorgang ohne eine Fehlermeldung.


    Den Fehlerkanal habe ich ausgelesen und brachte folgendes Ergebnis:


    - Nach dem Einschalte: 73,cbm dos v2.5 8050,00,00
    - Nach einem load"$": w.o.
    - Nach einem Format: w.o.
    - Nach einem Save (Testprogramm): 21,read error, 39,01
    Gerät aus- und wieder eingeschaltet
    - nach einem load des Testprogramms: 73,cbm dos v2.5 8050,00,00

  • Hier mal ein kurzes Update zu meinen bisherigen Erkenntnissen.


    Der 901467-01 an UK6, der GCR-Decoder, ist doch nicht defekt.
    Beim Studium des Schaltplans bin ich darauf gestoßen, dass alle 3 CS-Leitungen dauerhaft auf low liegen. Daher konnte mein Programmer den Chip erst lesen, nachdem ich die CS-Leitungen "herausgezogen" und separat auf low gelegt hatte. Jetzt stimmen die Werte.
    Kurz danach wurde mir klar, dass der AT28C16 beim Lesen ohne Anpassung ohnehin nicht zu verwenden ist. Die auf PIN 21 liegende CS-Leitung trifft beim 28C16 am PIN 21 auf /WE. Laut Datenblatt, und auch von der Logik, muss dieser PIN zum Lesen auf High liegen.
    Beim 2716 sollte es funktionieren, da PIN 21 die Programmierspannung bekommt. Vermutlich spielt es beim Lesen keine Rolle, welches Potenzial da anliegt.


    Das Laufwerk jedoch, läuft trotz dieser Erkenntnis nicht korrekt.