• So, ich wollte hier mal noch ein Feedback zum "Neugerät" geben, was ich dank einer ziemlich aufwendigen Aktion nun hier stehen habe. Es geht um eines der "Altgeräte" aus Rosenheim, die hier in diesem Thread angeboten und hier in diesem Thread in Bildform schon zu besichtigen waren, bevor sie die heiligen Hallen im Auto von spunkt verlassen haben. Danke nochmal für die krasse Aktion. Wenn man so sieht, was da alles entsorgt worden wäre - wirklich schade drum wärs gewesen.


    Bei mir ist dann die Indigo2 gelandet.

    Eigentlich war in den Listen eine Indigo angeboten und möglicherweise kommt die auch mal noch irgendwann dazu, aber es war dann schon anhand der Farbe klar, daß es wohl keine solche sein wird, auch der Formfaktor paßte nicht. Die wäre natürlich auch sehr kultig gewesen, aber vielleicht ist die Purple I2 sogar die bessere Maschine, die kann man nämlich nach heutiger Definition sogar noch richtig benutzen, was mit der Indigo mangels CPUspeed wohl nur eingeschränkt funktioniert hätte.


    Zunächst aber mal landete ein Postbote, der ein kleines Postauto hatte, was gefühlt zur Hälfte mit einem einzigen Paket "gefüllt" war. Ich durfte das dann auch direkt am Auto abholen, wegen Gewicht und so ...


    und dann gings los mit auspacken


     


    und es ging schonmal gut los. Die Farbe paßte. 2 Füße kamen zum Vorschein. Und dann


     


    Polsterung, Polsterung, Polsterung ...

    bis man was erahnen kann


    Es mußte natürlich dann auch gleich mal geöffnet werden.


     


    Und man kann schon schön sehen, was so schick an dem Gerät ist: Das komplette linke Drittel der Maschine besteht aus Grafikkarte.

    In der Mitte sitzt das CD Laufwerk, darunter der MIPS Prozesser.

    Das auffällige und vermutlich empfindliche Folienkabel bindet die beiden Plattenschächte ganz rechts an. Dahinter das große Netzteil.


    Die Grafik kann unterschiedlich sein, besteht i.a. aber aus einem untereinander verkoppelten Steckkartensystem, die alle zusammen die Grafikpipeline in ganz klassischer Form abbilden. Quasi wie die großen SGI das auch machen - mit einer GeometryEngine für die eigentlichen Geometrieberechnungen ( Rotationen, Skalierungen, Translationen ), einem Rasterizerteil und einem Displaygenerator. Sher schön getrennt anzusehen bei Origin2000 und Onyx Geräten.


    Technische Daten zum Gerät gibt es schön aufbereitet hier

    http://www.xanthos.se/~joachim/Indigo2.html

    http://www.nekochan.net/wiki/SGI_Indigo2

    http://www.employees.org/~dric…Indigo2/Indigo2_Main.html

    und vor allem hier

    http://www.futuretech.blinkenlights.nl/i2.html

    mit Infos zur Graphik

    http://www.futuretech.blinkenlights.nl/extremegfx.html



    Ich habe dann erstmal geschaut, daß ich ein bißchen "Ordnung" mache. Und ja, es ist schwer, sich da zu beherrschen und nicht erstmal einschalten zu wollen, hat sich aber als günstig erwiesen.

         


    Und auch die Plastik mußte erstmal ins "die Wanne".

  • was nochmal einen guten Überblick gewährte.



    Beim Zerlegen muß auch eigentlich nur einen Teil der Front öffnen, einen Stahlstab entfernen ( nach vorn rausschieben ) und zwei frontseitige unter Abdeckung versteckte Plastikverriegelung freidrücken, dann kann man die komplette ober Plasitkhaube wie eine Motorhaube aufklappen und abnehmen.


    Nach Trocknen und Kontrolle der sichtbaren Teile habe ich mich erstmal der Festplatte gewidmet. Die ist 50pol SCSI und kann mitsamt Schlitten werkzeugfrei ausgebaut werden.


    Das kopieren mittels "dd" unter Linux ( dd if=indigoplatte of=ddkopie.dd bs=512 ) stoppte leider mittendrin und brach ab. Sektorfehler ... !

    Ärgerlich. Ca. 10 Sektoren nicht lesbar. Habe darum dann Teilkopien bis zur Fehlerstelle und ab dahinter bis zum Plattenende angelegt ( seek und skip als dd optionen und ein Taschenrechner damit man sich nicht verzählt ).


    Das ganze dann auf eine genullte Platte und die Fehler Sektoren dabei ausgelassen, damit es wenigstens halbwegs so angeordnet ist, wie im Original. Und gehofft, daß man nicht das RootVerzeichnis im Fehlerbereich dabei hat.


    Mittlerweile habe ich noch gefunden, daß man für genau so ein Problematik wahrscheinlich viel besser mit dem

    Program dd_rescue

    fährt. Das überspringt die Fehlstellen einfach und erspart so das Teilen und rumrechnen.



    Und dann, oder auch kurz davor, kam mal das erste vorsichtige Anschalten


       


    Sie funktioniert !


    Zwar erstmal nur bis zum Startbildschirm. Aber immerhin.

    Mit "hinv" kann man schonmal Daten abfragen. 96MB. Gute Grafik. Chips kommen alle.

    Also weiter



    Da ja nun die "andere Platte" zum Zug kommt, muß entsprechend der Bootparameter angepaßt werden. Macht man mit "setenv" und Abfragen mit "printenv".


    Und dann der erste Bootversuch - und siehe da


       


    Und sogar das Anmelden ohne Paßwort als Guest funktioniert. Glück gehabt.


    Nur der Bildschirmhintergrund paßt eher zum Vorgängermodell in TEAL.


    Schön wäre natürlich, wenn man jetzt das root Paßwort wüßte.

    Also mal geguckt, ob eines gesetzt ist



    Es ist. Jetzt kann man rätseln und probieren - oder John fragen. John the Ripper, um genau zu sein. Der kann mit sowas umgehen



    und findet auch was. BruteForce Angriff auf ein Paßwort, was mit "a" wie "aladin" beginnt, hat uch noch den Riesenvorteil, daß man nicht solange warten muß. Bei "zamberlan" oder "zaubermantel" hätte es VIEL länger gedauert.

  • Nun könnte man ja mal schauen, was die OriginalPlatte sagt.


    Leider kann man sie nicht mounten und auch xfs_check meldet kryptisches, was man erstmal noch übersetzen muß.


       


    Und auch das "fx" Tool ist mehr beim Anzeigen von Plattendaten hilfreich, wenn man nicht gerade neu Partitionieren will oder ein 1:1 Kopie anlegen will. Das wäre, wenns klappt, wahrscheinlich sogar die einfachste Möglichkeit, zumal man das fx auch aus der sash heraus starten kann, nur der Bootbefehl wird dann etwas unübersichtlicher.


    So bleibt es jetzt erstmal so wie es ist und der Mount Fehler muß halt meckern. Ich habe ja die Kopie und mit der läßt sich auch erstmal rumspielen.


     



    Daher interne Platte raus und starten von externer Kopie allein.


       


     


    Man könnte auch Software installieren, wenn man hätte - direkt aus dem Bootmenu heraus.

    Später vielleicht mal.


     


    Bildschirm paßt. Test auf Rechengeschwindigkeit machte man schon damals(TM) nicht mit Sinushüten sondern mit Mandelbroten. Flott und schick. Und dabei ist das Teil nicht wirklich ein Megahertzprotz.


    Richtige Benchmarks finden sich bei spec.org und Vergleiche der SGIs untereinander auf den den Seiten von Ian Mapleson.


  • Den Homeordner findet man ganz einfach oben in dem immer angezeigten Menu. Und auch ein paar Programme sind dabei. Etwa so eine Art Briefschreibprogram, was aber auch - natürlich - 3D Objekte mit einbauen kann. Die kann man dann nach Laune drehen oder vergößern oder auch nur verschieben.


     


     



    Die üblichen Desktopeinstellungen gibts auch - Fenster ausgefüllt, brauchen dann aber ganz gut Rechenzeit. Das läuft ziemlich sicher nicht über die Grafikbeschleunigung, da ist mein Acorn gefühlt schneller.


         


    Und es kommen jede Menge kleine Tools und Multimediasachen mit. CD abspielen - kein Thema. Audiosampling - kein Thema. Video aufnehmen -kein Thema.


     


    Und dann ist da noch dieser famose Demoordner. Sicher in Teilen jedem bekannt.


    Die berühmteste aller Anwendungen ist auch dabei ... DOOM


       


    und ebenso "richtige" Demos zur 3D GRafik - etwa schwimmende Haie, ala Nintendo 64 Demo ( wo mag das bloß hergekommen sein ... ). Die lassen sich auch öfter starten und das Fenster auf beliebige Größe ziehen. Und man kann das Gerät noch lange Zeit normal benutzen, ohne daß man Speedeinbußen bemerkt.

  • Danke !


    Und noch zum Schluß bißchen was Technisches.

    Es gibt natürlich wie in jedem Unixoiden so ein komisches Fenster mit Buchstaben. Da darf man alles das aufrufen, was sich in den schier unendlichen Unterordnern versteckt. Manches heißt bißchen anders als üblich - aber sonst, wie gehabt. So sind die /homes nicht unter /home sondern bei /usr/people zu finden. Dagegen gibts ein klassisches Init System unter /etc. Und / wird tatsächlich benutzt und ist nicht einfach nur ein Ankerpunkt für Verzeichnisse.


    Es gibt aber quasi alles was man so einstellen mag, auch per Mausklick. Und das beschränkt sich nicht auf Kleinigkeiten sondern auch Netzwerkverbindungen und Öffnen von Verzeichnissen nach außen oder Nutzerverwaltung und Plattenmanagment und BackUps kann man geführt und übersichtlich mit drei Klicks erledigen. Nur das Finden der Funktion ist manchmal tricky. Besonders bemerkenswert ist aber, daß das i.a. alles über so eine Art HTML Browser gesteuert wird. Die kannten da anscheinend Netzwerk wirklich schon und haben das so benutzt wie heute CUPS seine Einstellungen machen läßt.


     


     



    Und was braucht das alles - viel Speicher, zumindest für die Zeit.



    Ist aber auch egal, weil: ist ja vohanden ...
    Gut, dafür kam die Maschine auch fünfstellig Minimum und ExtraRAM war nochmal "extra", aber es ging dann - je nach Ausführung - auch bis in Bereiche hinauf, die man schon in Gigabyte benennen konnte.


    Die 3D Sachen, um die es bei der Maschine ja eigentlich geht, habe ich hier ein wenig außen vor gelassen. Ich denke aber, daß jeder bei YT was dazu finden kann.

    Viel interessanter als das ist aber möglicherweise die Texte zur GeometryEngine rauszusuchen und anzuschauen oder die ganzen Grafiksachen, die etwa auf der SIGGRAPH vorgestellt worden sind. Ich sag mal nur Barnsley Farn. Und für das allgemeine Verständnis aktueller 3D Technik ist das ja auch ganz hilfreich. Nur das man damals keine 3872 Streamprozessoren hatte, sondern wie hier in der großen Ausführung gerade mal 8 (!) Geometrieeinheiten.



    Also insgesamt - eine sehr cooooole Kiste ! Technisch, optisch, bedienungsfreundlich und 3D Power inklusive !

    Und man darf gar nicht anfangen zu lesen was etwa das XFS alles schon kann (1995) oder sich angucken wie perfekt das Multitasking da funktioniert.


    Vielen Dank nochmal für die Aktion an spunkt und bezogen aufs Gerät würde man sich auch heute ein bißchen mehr von diesem "Spirit" wünschen, den man da noch nachvollziehen kann.




    ( PS: add-on - Mir hat jemand erzählt, daß Rosenheim lange Zeit zu Beginn der 90er Jahre die Definitionen geliefert hat, wie man industriell Fenster anfertigt und könnte mir daher vorstellen, daß das Gerät für Visualisierungen dafür benutzt worden ist. Das ist aber reine Spekulation ... )

  • Hallo Thoralf

    sehr schöner Bericht ,habe gerade selbst eine Indy und eine Indigo 2 Max Impact 10000 bekommen.

    Grafikkarte Vollausstattung 512 MB von denen mir aber nur 448 angezeigt werden.

    Auf der Indy ,die leider nur eine 8 Bit Grafikkarte hat habe ich ein Irix 6,2 aufgespielt und aud der Indigo ein Irix 6.5.17 plus 6.5.22 update.

    Habe insgesamt 3 Wochen für die Installation gebraucht da mir ein externes CDROM. fehlte .


    Nun würde ich gerne mit der Indigo ins Netz gehen wollen was aber leider nicht klappt.

    Ich kann an andere Rechner im Netz ein Ping Senden aber komm nicht raus .

    Habe Versucht über die Oberfläche das ganze einzustellen.

    Hatte eigentlich gedacht es mit DHCP laufen würde.

    Der Browser sagt mir immer etwas von DNS fehler oder sowas in der Art .



    Bist Du mit deiner im Netz ?

    Haste vielleicht ein tipp für mich.


    Gruß

    Thomas

  • Nein, ich habe die bisher nicht im Netz gehabt und das auch nicht so wirklich vor. Aber eigentlich sollte das nicht völlig unmöglich sein.


    Dazu muß die SGI einen Namen bekommen (hostname), dieser muß in /etc/hosts und in /etc/sys_id auftauchen und im vorderen Teil übereinstimmen. Damit ping funktioniert muß die Ethernetschnittstelle aktiv sein. Damit die Maschine gefunden werden kann, muß sie eine Netzadresse haben, was man mit printenv auf der BIOSkonsole anzeigen lassen kann und mit setenv netaddress 192.168.x.x auch setzen kann.


    Möglicherweise ist das bei Dir alles schon OK.

    Dann fehlt noch der Eintrag für einen Nameserver in /etc/resolv.conf , dort muß die Adresse vom DNS des Netzanbieters rein, meist ist das auch einfach die Adresse vom Router selbst. Man kann auch erstmal 8.8.8.8 für den GoogleNameserver eintragen, wenn man keine andere Zahl zur Hand hat. Außerdem muß der RouteDaemon (BIND) und die Netzwerksoftware selbst (network; quasi der InternetStack) angeschaltet sein, was man anscheinend mit chkconfig macht.


    Die hochoffizielle Erklärung findet sich bei

    https://techpubs.jurassic.nl/l…-012/pdf/007-2860-012.pdf - "IRIX Admin: Networking and Mail"

    ( https://techpubs.jurassic.nl/manuals/0650/admin/index.html )


    und in einfache gibt es diese schöne Seite zum Thema

    https://software.majix.org/irix/network-setup.shtml


    Wichtig ist noch, daß man die unnötigen Einträge aus der /etc/hosts Datei löscht oder zumindest ausmarkiert, bis auf localhost.

    Und, daß man für alle User Paßwörter setzt. Die kommen stellenweise komplett ohne.



    Ansonsten: 2 sehr schöne Geräte. Mach mal Fotos, wenn mal Zeit ist und stell sie hier vor.

  • Hallo Thoralf


    erstmal Danke für das schnelle Anworten.👍

    Bin grad nicht Heim , werde aber wenn ich wieder an meine SGI komme das ganze mal Testen.


    Eigentlich habe ich mit Unix wenig zutun gehabt und wollte dies nun mit den beiden Rechnern ändern bzw. mich einwenig einarbeiten .

    Wie ich aus deinen Profil ersehen kann bist du wohl auch ein Fan von Acorn Rechnern , hatte ich auch mal (Acorn 3000 ,310 ,540,RiscPc)

    waren eigentlich meine besten Rechner .


    Gerade der A540 war ein klasse Gerät , hab ich Depp leider vor Jahren Verkauft.

    Fotos mache ich wenn Zeit ist gerne.


    Bis dahin erstmal Danke

  • Eine weitere Fehlerursache, wenn man zwar im lokalen Netz eine Verbindung bekommt, aber nicht darüber hinaus, kann ein nicht oder falsch eingetragenes standard Gateway sein.

  • ... Acorn Rechnern , hatte ich auch mal (Acorn 3000 ,310 ,540,RiscPc)

    waren eigentlich meine besten Rechner .


    Ja, super Gerätschaften. Gar nicht mal so die Einzelheiten, aber das Gesamtbild und die Benutzung sind da extrem gut.

    Ich habe Acorn damals(TM) aber auch so schick gefunden, wegen dem genialen Befehlssatz der CPU, der genialen Grafik und dem Speed, den die Maschine vermittelte. Das war gar nicht so sehr die reine Rechenleistung, aber die "Smoothness", wenn man das so nennen kann, in den Anwendungen und der Oberfläche.

    Außerdem sind die unglaublich gut aufgeräumt gewesen und logisch strukturiert aufgebaut, was die OS Aufrufe, das BASIC, die SWIs etc. anbetrifft.


    Gerade der A540 war ein klasse Gerät , hab ich Depp leider vor Jahren Verkauft.


    Kann ich nachvollziehen.

    Aber vielleicht tröstet Dich ja, daß Rechner auch einfach mal vom puren Rumstehen kaputt gehen und der A540 jetzt evtl. schon lange nicht mehr geht. Außerdem liegt die Zukunft - auch für RISC OS - nicht in der Vergangenheit, sondern eher bei so Geräten wie RhaspberryPi (3) oder dem Titanium Board von elesar.

    Von der reinen Benutzung ist mir bisher nichts Besseres untergekommen, weder bei den Homecomputern noch bei den "Großgeräten". Es fehlt aber an einigen Ecken, v.a. an Software, momentan insbesondere an MultiCore Unterstützung und am Webbrowser, wobei es bei letzterem vielleicht sowie sinnvoller ist, das von extern einzubinden (Entwicklungaufwand etc.; gleiches Problem gibts bei Amiga, Atari etc.).

  • Hallo

    also ins Netz bin ich nun angekommen😁😁😁

    Nun tauchen aber neuen Probleme auf welchen Browser kann man heute noch einigermaßen anwenden ?

    Das zweite ich habe eine Fast Ethernet Karte eingebaut ,kann die aber nicht ansprechen bzw. wird nicht angezeigt.


    Es ist die Phobos E100 (3c597)

    wie muss ich diese Installieren

  • http://www.sgidepot.co.uk/fastether.html

    Du brauchst Treiber, die sich bei

    http://www.sgidepot.co.uk/depot/ bei E100*.* finden. Inkl. Manual und einer Installanleitung im tar File.

    Auspacken mit "tar xvf filename" (unter Linux), wird aber ähnlich bei SGI sein. Hilfe dazu gibt es mit "man tar" auf der Konsole.

    Der ausgepackte Ordner für 6.5 ist der, der bei inst dann als Quelle angegeben werden muß.



    Und Sicherheitskopie der Treiber sicher verwahren. Die dürften GAAAANZ schwer zu finden sein, wenn die Seite oben mal verschwindet. Und die Rettung unter archive.org klappt nicht immer.

  • Zum Browser

    welchen Browser kann man heute noch einigermaßen anwenden ?


    die Antwort ist schlicht: Keiner. Zumindest von den dazumal gängigen, sprich Netscape/Mozilla. Und wenn man die benutzt sollte man tunlichst alles abschalten, was irgendwas ausführt, also Java, JavaScript etc.


    Für aktuellere müßtest Du bei "nekochan" suchen. Da gibt es einige kompilierte große Programme aus der GNU Welt und da wird sich sicher auch ein Browser finden, der dann mal wenigstens aus dem Jahr 2005 ist, geschätzt. FFox vermutlich.

    Evtl. gibts sogar Opera irgendwo.

    Die haben aber natürlich ebenfalls das Problem, daß sie das Gerät quasi komplett aufmachen, zumindest wenn auf der Gegenseite ein venünftiger "Angriff" wartet. Da muß man dann sehr diszipliniert surfen gehen. Und wahrscheinlich wäre auch noch sowas wie ein extra User nur fürs Browsen ganz hilfreich, das bietet dann noch bißchen Schutz, ist aber natürlich nervig, weil man da für andere Sachen dann das Abmelden-NeuEinloggen Spiel spielt.

  • Hallo

    die Seite hatte ich schon gefunden , nur mit dem entpacken will noch nicht so recht klappen.

    Aber wir bleiben am Ball.

    Mit den Browsern hatte ich es mir schon fast gedacht, ist aber nicht ganz so schlimm .

    Obwohl ich es schon nicht schlecht fand wie gut es sich mit dem Netscape noch Surfen lässt.


    Aber nun bin ich wenigstens in der Lage die Treiber und das ein oder andré zu Downloaden.


    In sachen Acorn habe ich übrigs sein Rasberry Pi 3 und ein Beagleboard xm .

    Und wenn es die Zeit zulässt werde ich demnächst mit einem Kollegen ein A310 zurück Bauen auf Athur.


    Gruß

    Thomas

  • Hallo Thoralf


    Treiber habe ich gefunden und auch Installiert, Karte wird aber nicht als fe0 erkannt.

    Ein überprüfen mit ifconfig zeigt mir ioctl (SIOCGIFFLAGS): no such interface.

    Das gleiche mit ec0 kappt.


    Und weil gerade alles so gut läuft schein die Batterie sich nun auch zu verabschieden.

    Es wird beim Starten Batterie Low und Datum überprüfen angezeigt .


    Zur Karte noch folgendes , es müsste ein Original Phobos E100 sein , hab’s mal mit ein paar Bilder verglichen, dementsprechend brauche ich doch keine

    patch zu Installieren?


    Batterie werde ich hoffentlich in der Bucht noch bekommen.


    Danke

    Thomas

  • Wegen Batterien such mal hier im Forum nach SUN und IDPROM und Umbau des DALLAS Chip.

    War grad neulich mal Thema und zieht sich als Problem durch alle Altgeräte, die einen derartigen kombinierten NVRAM mit eingebauter Batterie haben.


    Bei den Treibern mußt Du mal selber lesen, wenn man da noch was findet an Literatur, Handbüchern etc.

    Ich könnte mir vorstellen, daß man das Device unter /dev erstmal per Hand anlegen muß, damit der Treiber es überhaupt benutzen kann.

    Auf alle Fälle aber sagt ifconfig prinzipiell nur, daß es da halt keine entsprechende Datei findet; das testet selbst aber nicht aus, ob die Karte eingebaut oder der Treiber korrekt installiert ist. Evtl. auch mal gucken, ob in dem Treiberpäckchen evtl. noch irgendwelche Shelldateien enthalten sind, die das komplette Einrichten übernehmen.

  • Hallo Thoralf


    ja Du hast recht ich muss wohl noch sehr viel. Lesen.

    Bin natürlich nicht so im Thema wie hier der ein oder andere Profi-User, war halt immer nur Anwender.


    Aber heute war mal wieder Weihnachten ,habe ein Kollegen besucht der mir seinen Acorn Archimeds 310(RISC OS 2.0)

    mit einen Eizo Monitor Tastatur 2x und Maus geschenkt hat.

    Stand viele Jahre im Keller , ist einwenig verstaubt, aber .läuft.😀😀😀

    Er hatte damals sehr viel Geld Investiert, aufgerüstet auf 4MB, Arm 3 mit FPU und SCSI Controller,alles zusammen fast ein Kleinwagen.

    Leider kann ich keine Disketten Lesen , werden nicht erkannt ,SCSI Platte ist Defekt.


    Da aber für den ARM3 ein Modul geladen werden muss ist dieser zu Zeit Inaktiv.


    Werde jetzt erstmal den Rechner reinigen und dann mal ein paar Bilder einstellen.


    Thomas

  • So heute ist der Dallas ds1286 gekommen 😀wurde. natürlich sofort gewechselt.

    Datum ,Zeit neu eingestellt , läuft prima.


    Wenn ich mit dem Archi soweit zufrieden bin werde ich mich noch um die Ethernet Karte kümmern.

    Ersteinmal läuft auf der Indigo jetzt Irix 6.5.22 und das mit der Karte bekomme ich später auch noch hin.