Was kann man schönes mir einem Powermac G4/G5 oder Powerbook G4 machen

  • Mac OSX:


    Auf Powermac G4 läuft max: 10.4.11 (>=867MHz auch 10.5.8 ;-)

    Auf Powermac G5+Powerbook G4 läuft max: 10.5.8 (Leopard)


    Als noch gepflegten und gut nutzbaren Browser empfiehlt sich TenFourFox:

    https://www.floodgap.com/software/tenfourfox/


    Wer selbst Programme compilieren möchte/muss, sollte sich Xcode 3.1.4 von Apple installieren.


    Plus homebrew:

    https://github.com/mistydemeo/tigerbrew

    Da curl wegen openssl etc. Probleme machte habe ich das ZIP heruntergeladen und entpackt nach /usr/local (dann ist es im Pfad).


    Danach kann man sich mit brew install <paket> - dann benötigte Paket herunterladen. Habe ich z.B. mit sdl gemacht, um Salto kompilieren zu können.

    So konnte ich z.B. auch die open source Software minipro für den TL866 kompilieren (brew install libusb - wird noch benötigt).


    Hier gibt es noch weitere Info's:

    http://g5center.net/index.php

    http://www.oldapps.com/mac/de



    MorphOS:


    Was ist das?:

    "MorphOS is a lightweight, highly efficient and flexible desktop operating system. It includes primarily proprietary as well as

    open - source components. Its many features range from a modern exceptionally customizable graphical user interface, which can

    utilize 3D hardware acceleration, to a high-performance Just-in-Time compiler that emulates the 68k family of processors and thereby

    allows to transparently execute legacy applications developed for the Commodore Ax00 series of computers."


    Ich hatte beim Test noch die 3.9 Version. Inzwischen gibt es 3.10. Parallel dazu gibt es auch SDK (Software Development Kit).


    http://www.morphos.de/

    https://de.wikipedia.org/wiki/MorphOS

    https://www.heise.de/mac-and-i…-auf-G4-Macs-2228717.html

    https://library.morph.zone/MorphOS_key_applications

    http://morphos.lukysoft.cz/



    Linux (Yellow Dog Linux 6.2):


    Ist ein komplettes Linux mit älterem Stand (ca. 2008-9). Aber mit GCC etc. vieles dabei.


    https://de.wikipedia.org/wiki/Yellow_Dog_Linux

    http://osarchive.sda1.eu/yellow-dog



    Peter

  • Habe nun mal mit brew install sdl2 installiert und oberon-risc-emu compiliert - einwandfrei.

    Auch bochs habe ich compiliert bekommen - ist aber extrem laanngsaam..?


    Das habe ich übrigens von meinem G5 gesendet.


    Nutzt eigentlich noch jemand seinen G5/G4 zum compilieren etc. pp?


    Peter

  • meim Sohn hat unseren G5 nur zum Spielen benutzt. Jetzt hat er einen 2009er imac und der G5 ist nicht mehr interessant für ihn. Werde ihn weiter zum Browsen benutzen... Compiliert habe ich noch nicht darauf. Werde ich mir mal anschauen.

    "There is no reason for any individual to have a computer in his home." Ken Olson, president, chairmen and founder of Digital Equipment Corp, 1977

  • Danke Peter für die Infos in dem Thread.

    Hast Du schonmal folgenden Trippleboot installiert?


    PPC-Mac G4

    OS9 nativ

    OSX nativ

    Morphos


    Ich bekomme nach OS9 und OSX kein Morphos mehr auf meinen G4-MacMini.

    Der Morphos installer sieht sehr viele kleine 10MB Partitionen, keine Ahnung wo die herkommen.


    So sieht das dann aus: https://www.flickr.com/photos/…/albums/72157666841174377

  • Hi. Nein. Haben bisher nur MorphOS oder OSX immer nur separat installiert (Habe ja genug Systeme ;-) ).

    MorphOS habe ich 3.9 - die 3.10 ist aber auch schon raus..

    OS9 (möchte) ich gar nicht mehr verwenden - wird sonst einfach zu viel..


    Peter

  • Die Idee ist ja die OS9 Kiste einzusparen und mit der R9200 hat man fast schon die beste OS9 GPU in dem Mini,

    das hätte extremen Charme. Irgendwann probiere ich das noch mal.

    Ich wollte mit 10.3.9 und xCode mit Basic fertige Cracktros compilieren...leider scheiterte das an den nicht verfügbaren Addons für das Basic. Sehr schade, dass wäre krass gewesen mit PPC und 10.3.9 Cracktros der alten 8/16Bit systeme nativ auf dem Mac laufen zu lassen...leider eine Illusion.

  • Hier folgt nun eine kleine Leidensgeschichte - aber mit Happy End ;-)


    Ich hatte ein merkwürdiges Problem mit meinem G5 (auch mit dem G4), das ich über viele Wochen nicht lösen konnte - bis gestern!


    Folgendes: OSX 10.5.8. Arduino IDE 1.0.4 (letzte für PPC verfügbare). Ich habe mir die seriellen Treiber für z.B. CH341 etc. für 7€ gekauft und alles lief.

    D.h. ich konnte mit Arduino auch Clone programmieren etc. pp.


    Irgendwann (3x umgebaut/umgestellt - die G5+G4 stehen unter meinem Schreibtisch), lief das auf einmal nicht mehr??! D.h. orig. Arduino Mega lief, Clone nicht mehr. Serielle IF wurde erkannt, LED am Arduino leuchtet. ZTerm oder Serial2Go schienen völlig zugefahren zu werden, mit Zeichen, die wie ein C Quellcode aussahen, so daß ich sie hart abbrechen musste..?? Klar hatte ich auch andere Programme dazwischen installiert.. ich hatte das Problem nie gelöst/keine Ursache gefunden.. Gestern: Ich wollte mal sehen, was so passiert wenn ich einen Scanner (Canoscan Lide 25) am Mac anschließe (Ich träume immer noch davon, meine Linux Kiste in den Ruhezustand zu schicken und nur noch mit dem G5 zu arbeiten = unverbesserlicher "Spinner" . Ich weiß).


    Nun - es passierte genau NICHTS?!. Also google angeworfen.. Treiber/SANE/Twain.. - Vuescan..

    Vuescan installiert (letzte Version für PPC aus 2012/3). Erkennt auch den Scanner - aber irgendwie hakt das alles.. nach 10min ist er noch beim Color Calibration..??


    Ok. Kann evtl. nicht mit DIESEM Scanner . Bei Canon gabs noch Treiber + ScanToolbox - installiert - gleiches Verhalten..??!


    Dann kam mir in den Sinn in Frage zu stellen - ob da evtl. der USB Hub ohne eigene Stromversorung - evtl. nicht genug Strom liefern konnte..


    Also Scanner separat hinten an eine USB Buchse angeschlossen - und TADA!! Läuft!!


    Ah ha. Strom ist also das Problem - halt. Moment mal.. was ist denn mit den Arduinos.. GENAU! Identisches Problem!


    Ich hatte dazwischen den USB Hub gewechselt. Der davor lieferte wohl noch etwas mehr Strom aus. Daher lief damit alles. Dieser hier wohl nicht.


    Aber: Nun lief mein Arduino Clone wieder am G5. Dann aber mein Apple1 Emu Projekt mit 32kb SRam Karte und 8x 32k Ser.EEprom Karte dran gesteckt -

    wieder dieses komische Verhalten, das die Schnittstelle mit Müllzeichen zugebombt wird.. Arduino über Steckernetzteil versorgt = wieder alles ok!

    Dabei war auch der Arduino direkt am G5 eingesteckt - kein USB Hub dazwischen!


    Ergo: Anscheinend stellen PC's mehr Strom an den USB Ports zur Verfügung und der G5 tut genau dieses nicht!


    Nun weiß ich es und kann damit reagieren. Direkt angeschlossen und/oder mit separater Stromversorgung läuft nun alles am alten G5 ;-)


    Peter

  • Das hätte ich dir auch sagen können. :D Ist mir nämlich auch schon aufgefallen, das einige USB-Geräte (z.B. Externe Festplatte) teilweise am G4 nicht funktionieren ohne USB-Y-Kabel. Dieselben funktionieren aber am PC mit normalem Kabel. Ergo: Zu wenig Strom.


    Selbe verhalten bemerke ich, wenn ich ein USB-Stick an einer Apple-Tastatur einstecke und diese ist am Mac angeschlossen, dann kommt die Meldung es stehe zu wenig Strom zu Verfügung. Am PC mit der Selben Tastatur geht es ohne Probleme.