BASF Diskettenlaufwerk 6128 mech. Problem

  • Hallo!


    Ich habe neulich von Parser 2x BASF 360kB Diskettenlaufwerke aus einem Commodore PC-10 bekommen (Die ohne Knebel, sondern mit Ein-Knopf-Arretierungsmechanik)- Nochmals herzlichen Dank dafür!! Mal abgesehen davon, daß ich mich über diese von mir schon seit längerem gesuchten Drives für meinen PC10 sehr gefreut habe, scheinen sie leider ein mechanisches Problem zu haben. Die Diskette steckte noch in beiden drin, jedoch kann man mit Knopf-Bedienung die Diskette nicht Entriegeln.

    Was klappt, ist von oben, oberhalb des "AG" von "BASF AG" auf dem Typenschild, den grauen Haken um seine Achse zu drehen, damit die Diskette heraus kommt. ein Tropfen Öl hab ich auch schon versucht. Sehr merkwürdig, auf dem ersten Blick scheint nichts zu fehlen oder augenscheinlich beschädigt oder verbogen zu sein, verharzt ist die Mechanik auch nicht. Vielleicht kennt jemand das Problem?

    Gruß

    Stephan

  • Ich habe die beiden BASF-Diskettenlaufwerke so aus dem PC-10 entnommen, wie ich sie vorgefunden habe.


    Vielleicht kann 128er-Man dazu etwas sagen ... :grübel:


    Ich meine, dass in einem Commodore PC-10 Manual dieses BASF-Diskettenlaufwerk technisch beschrieben ist ... komme aber erst heute Nachmittag dazu, das rauszusuchen.

  • Ich hab vier von den Laufwerken (die ich sehr gern mag ;) )

    Meine funktionieren alle. Ich würde ja mal das 2. Bild vergleichen, aber leider ist es defekt!

    Lad das noch mal hoch!

    Das hab ich schon ein paar mal gehabt. Bug in Forensoftware? Toast_r , kennst Du vielleicht das Problem?

    Nochmal hochladen behebt den Fehler nicht. Bei mir ist das Bild io.


    https://photos.app.goo.gl/Qf9WtTJDnbztQywn6

  • Als ich den PC damals bekommen habe, habe ich die Disketten als Schutz für die Laufwerke reingetan, da ich das von der Commodore 1571 her gewohnt war. Die Laufwerke funktionierten damals einwandfrei (meine die Mechanik, ansonsten ausprobiert hatte ich die nie).


    Ich denke nicht, dass da irgendwas abgebrochen oder dergleichen passiert ist. Ich denke dass die Mechanik irgendwo einfach "feststeckt".


    Kanns leider nicht mehr verifizieren, da ich ein solches Laufwerk ansonsten nicht mehr besitze...:roll:

  • Ich habe hier auch noch ein BASF-Laufwerk, das sich genauso verhält.

    Der Auswurf klappt ebenfalls nur, wenn man an dem kleinen Haken etwas nachhilft.

    Damit hatte ich mich neulich schonmal Erfolglos auseinandergesetzt.

    Ich habe die Mechanik gründlich gereinigt und auf Beschädigungen usw. kontrolliert, konnte aber nichts feststellen.

    Mein Eindruck war, daß die Mechanik ursprünglich nicht gefettet/geölt war, also habe ich das erstmal gelassen, um nicht für unerwünschte Staubanhaftungen zu sorgen. Vielleicht sollte man das mal mit einem nicht fettenden Schmiermittel versuchen. Graphit wäre evtl. eine Möglichkeit, dann muß man aber äußerst sparsam dosieren, um sich damit nichts zu versauen.

  • Ich hatte auch mal so ein Laufwerk mit dem Problem. Liegt jetzt beim toast_r.


    Im Bereich, den fritzeflink fotografiert hat, gibt's ein Relais o.ä., das eine Verrigelung freigibt. Das war damals bei mir kaputt, abgebrochen o.ä., Wenn man es per Hand betätigt, kriegt man wenigstens die Disketten raus.


    Viel Erfolg

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • https://youtu.be/MnHTZGE2gtw

    Falls jemand ein funktionierendes rumliegen hat, könnte dieser jenige bitte mal schauen, wie sich die Messingfahne an der Torsionsfeder verhält, die im im folgenden Video runterdrücke, um den Diskettenauswurf einzuleiten? Vielleicht liegt hier das Problem. Schlecht wäre ein Nachlassen der Federkraft der Torsionsfeder als Problem, die ist wohl in der verwendeten Ausführung unbeschaffbar.....

  • Das verriegeln und entriegeln der Disk geht aber auch ohne Strom.

    Ich hab vier Laufwerke und alle sind einwandfrei.

    Bei mir sind die beweglichen Kulissen-Blechteile alle gefettet.

    Hier sind mal 5 Fotos des Ablaufs.

    1. ohne Disk

    2. Disk eingeschoben, Knopf gedrückt

    3. Knopf los gelassen - Disk verriegelt

    4. Knopf gedrückt

    5. Knopf los gelassen - Disk ausgeworfen.


  • Nein, kein Relais sondern eine Wippe. Das Federende der Schaltklaue hatte ich zurückgebogen damit der Auswurf nicht blockiert wird.

    Das Federende wird duch die Wippe bei Headload solange blockiert bis Headload ausgeschaltet ist. Wenn Headload aus ist dann ist der Kopfheber Oben und die Wippe zum Entriegelungshaken unten. Der Entriegelungshaken kann sich über den kleinen Zapfen heben und entriegeln.

    Im Problemfall ist die Wippe verbogen oder / und das Federdrahtende.


    Bitte mit originalem, unverbasteltem Laufwerk testen.



    Ungefähr so oder ähnlich. :)




  • Bei mir sieht alles genauso aus. Wenn das Blech runtergedrückt ist, was den Kopf zur Diskoberfläche freigibt, wird über die kleine kupferfarbene Wippe der Auswurf verrriegelt. Wenn das gelbe Blech 2mm hochsteht und den Kopf von der Platte abhebt, sollte die über die kleine Feder auf der Laufwerksaußenseite den Auswurf frei geben.

    Bei dir sieht es so aus, als wenn die Wippe auf dem Foto unten hochsteht und damit der Auswurf blockiert ist!


    Grün markiertes Ende muss hoch stehen und an dem gelben Blech anliegen, welches etwa 2mm den Kopf angehoben hat.

    Violett muss unten sein, dann ist der Auswurf möglich.




  • Das Problem ist demnach die Head-Load Mechanik.

    Ich habe einfach mal Spannung an den Zugmagnet angelegt. Der Stößel bewegt sich, aber der Arm tut es nicht.

    Offenbar fehlt (bei mir) zwischem dem Stößel des Hubmagenten und der Lasche am Head-Load Arm ein Verbindungsstück.

  • Bei mir sieht alles genauso aus. Wenn das Blech runtergedrückt ist, was den Kopf zur Diskoberfläche freigibt, wird über die kleine kupferfarbene Wippe der Auswurf verrriegelt. Wenn das gelbe Blech 2mm hochsteht und den Kopf von der Platte abhebt, sollte die über die kleine Feder auf der Laufwerksaußenseite den Auswurf frei geben.

    Bei dir sieht es so aus, als wenn die Wippe auf dem Foto unten hochsteht und damit der Auswurf blockiert ist!



    Beim manuellen Testen muß der Headloadhebel nach unten gedrückt werden - siehe Bild.




  • ...aber bei einem stromlosen Laufwerk sollte doch der Hebel eh oben sein und den Kopf angehoben haben!

    Bei meinen Laufwerken ist das bei allen so.

  • Gut, das Problem ist wohl auch der Headload. Der Stößel zur Betätigung des Hebels ist an der Stelle aus Kunststoff und nicht mehr komplett vorhanden.

    Allerdings schein bei meinem Laufwerk der Magnet auch nicht zu funktionieren. Für 'moderne' Rechner die den Laufwerkmotor nach Nichtzugriff abschalten kann der Headload vernachlässigt werden.

    Am Magnet ist bei meinem Laufwerk keine Spannung meßbar ...

  • Der Kopf wird über den gelben Headload-Hebel mit der Feder angehoben. Also ohne Spannung am Magnet sollte der Kopf immer angehoben sein.

    Der Magnet zieht den Hebel/Kopf runter. Das Gegenstück zum Hubmagnet ist ein kleines Metallteil/Dauermagnet? in dem senkrechten Blech am Hebel.

    Bei Fritz fehlt das Gegenstück!



  • Der Kopf wird über den gelben Headload-Hebel mit der Feder angehoben. Also ohne Spannung am Magnet sollte der Kopf immer angehoben sein.

    Der Magnet zieht den Hebel/Kopf runter. Das Gegenstück zum Hubmagnet ist ein kleines Metallteil/Dauermagnet? in dem senkrechten Blech am Hebel.

    Bei Fritz fehlt das Gegenstück!


    Schiebe bitte eine Diskette in das Laufwerk, verriegele es und mache dann nochmal ein Foto.

  • Der Kopf wird über den gelben Headload-Hebel mit der Feder angehoben. Also ohne Spannung am Magnet sollte der Kopf immer angehoben sein.

    Der Magnet zieht den Hebel/Kopf runter. Das Gegenstück zum Hubmagnet ist ein kleines Metallteil/Dauermagnet? in dem senkrechten Blech am Hebel.

    Bei mir fehlte auch das Teil am senkrechten Hebelteil, dadurch kann der Magnet den Hebel nicht runter ziehen. Auch muss der senkrechte Hebelteil mit dem Magnetkern verbunden sein.


    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • Der Kopf wird über den gelben Headload-Hebel mit der Feder angehoben. Also ohne Spannung am Magnet sollte der Kopf immer angehoben sein.

    Der Magnet zieht den Hebel/Kopf runter. Das Gegenstück zum Hubmagnet ist ein kleines Metallteil/Dauermagnet? in dem senkrechten Blech am Hebel.

    Bei mir fehlte auch das Teil am senkrechten Hebelteil, dadurch kann der Magnet den Hebel nicht runter ziehen. Auch muss der senkrechte Hebelteil mit dem Magnetkern verbunden sein.



    Die Feder 1 am Headloadhebel drückt den Hebbel nach unten.

    Die Feder 2 im Magnet drückt ohne Vmagnet den Headloadhebel nach oben.

    Zieht der Magnet an so wirkt nur noch die Kraft der Feder 1 welche den Hebel und damit den Schreib./Lesekopf absenkt.


    Bei meinem Laufwerk klemmte der Magnetstößel bedingt durch zersetzten Kunststoff.






  • Nein, die Feder 2 zwei drückt nur die Hubmagnetstange wieder raus, wenn der Hubmagnet keine Spannung mehr hat, also abfällt.

    Elektromagneten lassen ja von allein nicht so gern los ;)


    Wenn man eine Disk drinnen und verriegelt hat, geht lediglich der silberne große Teil in der Mitte runter und der gelbe Headloadhebel wird frei gegeben. Er bewegt sich etwas weiter nach unten.

    Die Diskette lässt sich nun aber noch entnehmen.

    Wenn der Hubmagnet anzieht, geht der Kopf auf die Disk und damit ist die Entnahme der Disk über den kleinen kupfernen Hebel gesperrt.

    Bei einem Laufwerk ohne Spannung drückt aber Feder 1 den Headloadhebel immer hoch, so dass eine Verriegeln/entriegeln immer möglich ist.