CBM 720 / Proxa 8700

  • Hallo ihr lieben Leute,


    ich bin neu hier (Hinweis von Nils Eilers) und schon etwas älter (Baujahr 50). Mit Commodore habe ich mich so von 1980 bis 1988 privat und beruflich beschäftigt. Davon übrig geblieben ist ein CBM 720d mit Proxa 8700, eine Disketten-Sammlung, einige Bücher, Handbücher und sonstige Unterlagen. Eigentlich wollte ich damals ja damit noch privat weiter machen mit dem CBM, aber Familie, Beruf, DOS, Windows, OS/2... Er hat brav die ganze Zeit in meinem Arbeitszimmer gestanden, ist ab und zu mal gestartet worden und das war es denn.


    Jetzt bin ich Rentner und habe wieder Zeit, mich mit dem Teil zu beschäftigen. Inzwischen ist noch ein 8032, eine 8250, eine SFD 2001 und ein PETSD+ hinzu gekommen. Die funktionieren alle ganz gut, nur die 8250 scheint auf D0 etwas zu schwächeln. Ach ja, dann habe ich noch ein IEEE-Centronics Interface, die Doku dafür muss ich aber noch suchen. Compiler sind mit Schwerpunkt 8032/8096 vorhanden, Programme ebenfalls, für den 720 existiert (nach meiner Erinnerung) nur die Textverarbeitung ProText. Was ich da eigentlich noch so habe, werde ich in der nächsten Zeit prüfen, ausprobieren und katalogisieren.


    Leider habe ich mit dem CBM 720 zwei Probleme. Die eingebaute Floppy (umgebaute 8250LP mit Proxa Mini-Platine) scheint einen Wackelkontakt in der Stromversorgung zu haben. Meist startet sie mit Fehlermeldung (5x Status/Floppy-LEDs), ein bißchen Bewegung am Versorgungsstecker (auf der Proxa-Platine) lässt sie dann ohne Fehler starten. Disketten werden auch ohne Probleme gelesen. Die Ursache konnte ich bisher visuell nicht finden, da ich kein Elektroniker bin, komme ich da auch nicht so richtig weiter.


    Der zweite Fehler liegt in der Proxa-Platine. Sie ist per Zwischenstecker am Tastaturport des 720 verbunden. Soweit ich das beurteilen kann, wird das gewählte 8032-Betriebssystem noch problemlos geladen, aber dann bleibt der Rechner bei der Umschaltung hängen. Er lässt sich dann auch nicht per Reset-Taste des 720 zurück holen. Könnt ihr mir bei diesen beiden Problemen helfen?

  • Hallo.


    Willkommen hier im Forum ! Schön, dass du jetzt wieder Zeit hast, dich um deinen klassischen Computer zu kümmern. Oft hilft da schon eine Reinigung der Pins und ein entfernen und wieder einsetzen der gesockelten Chips und die Geräte gehen wieder.


    Speziell in Sachen CBM Bürorechner bin ich quasi Neueinsteiger seit ein paar Monaten. Aber wir haben hier Leute im Forum/Verein, die speziell bei diesen Geräten richtig fit sind. Helmut Proxa ist hier übrigens auch als Axorp im Forum aktiv.



    Gruss Jan

    • Official Post

    Hallo JoMartin ,

    herzlich willkommen bei uns!

    Es freut mich sehr, einen Proxa 8700 Benutzer hier im Forum begrüssen zu dürfen,

    vor allem einen, der schon in den 80ern einen solchen Rechner benutzt hat.

    Die CBM 700 Rechner sind ziemlich selten geworden, Exemplare mit Proxa 8700-D Ausstattung noch viel seltener.

    Eine so seltene Maschine wieder in funktionierenden Zustand zu bringen ist Ehrensache. :)


    Vorab ein wirklich wichtiger Hinweis zu den Laufwerken im CBM 720 und der SFD 1001:

    Auslaufende Elkos in CBM 8250lp / SFD 1001 / CBM 8296d

    Damit ist nicht zu spassen. Der Zustand der meisten Laufwerke erfordert schnelles Handeln.


    5 x Blinken beim Einschalten der Floppy zeigt einen Fehler in der Zeropage der FDC CPU an.

    Daß das durch Fehler an der Stromversorgung verursacht wird, ist vielleicht möglich.

    Der Stecker für die Stromversorgung an der 8250mini Platine ist recht hoch belastet, er hat ja nur jeweils einen Kontakt für GND, 5V und 12V, worüber die ganze Doppelfloppy versorgt wird. Bei der SFD1001 mit nur einem Laufwerk sind original insgesamt 6 Kontakte vorhanen (3xGND, 2x5V und 1x12V).

    Als erstes würde ich an dieser Verbindung mal alle Kontakte reinigen und die Federspannung der Kontakte im Stecker kontrollieren.

    Da evtl. mal etwas nachbiegen, um die Federspannung zu erhöhen.

    Die CBM 700 Netzteile sind mit dem Alter auch recht fehleranfällig geworden.

    Häufig sind da die Elkos nicht mehr gut. Das geht auf die Leistungsfähigkeit des Netzteils, bis hin zum Totalausfall.


    Wird nach dem Laden der Proxa 7000 Software das Menü für die Auswahl der virtuellen 8032 Rechner angezeigt?

    Klingelt der Rechner, wenn Du nach dem Laden der Proxa 7000 Software den Reset-Taster betätigst?



    Gruß

    Christian

  • Hallo Christian,


    erst einmal ein Dankeschön für die schnelle Reaktion auf meine Fragen. Deinen Beitrag zu der 8250LP habe ich schon ganz interessiert durchgeschaut, ich habe mal vor ca. 2 Jahren etwas Entsprechendes im Netz gefunden, aber jetzt nicht mehr wiederentdeckt. Ich hatte auch schon einmal angefangen, eine Floppy etwas zu zerlegen, aber mich dann doch nicht so richtig rangetraut. Deine Tips werden mir da helfen. Eigentlich befindet sich ja auch ein (nicht benutzter) Stromanschluß auf der Hauptplatine. Würde es vielleicht helfen, das Versorgungskabel zu spleißen? Die Feder-Kontakte werde ich jedenfalls noch einmal prüfen und das Kabel auch gegen Spannungen (Abwinkelungen) schützen. Das Netzteil werde ich zunächst einmal optisch prüfen, oder macht das keinen Sinn?


    Das Proxa-Menü wird angezeigt. Der Rechner lädt dann auch das entsprechende System - und bleibt hängen. Dann aber total, Die Reset-Taste bleibt vollständig wirkungslos, kein klingeln. Der Rechner springt auch nicht auf das 720iger System zurück. Nach meiner Erinnerung ist Protext das einzige Programm, das ich als echtes 720iger Programm habe. Es schein einwandfrei zu laufen, demnach ist der 720iger-Teil des Rechners in Ordnung.


    Nächtliche Grüße aus Bremen

    Jochen

  • So, die Floppy scheint jetzt zu laufen. Es lag wohl tatsächlich an der Stromversorgung, die Federzungen des Steckers waren leicht korrodiert und zu locker. Und ein Kabel hing nur noch sehr locker in den Messerkontakten. Bei der Gelegenheit habe ich auch das Netzteil ausgebaut und optisch geprüft. Es war kaum verstaubt, die Elkos sehen (natürlich nur äußerlich) noch recht gut aus. Als nächstes werde ich mir die Elkos in den Laufwerken vornehmen....


    Ach und noch einmal kurz an Jan, danke für den Tip. Aber die ICs hatte ich schon zweimal raus und wieder rein, hat leider nichts geändert.... Um Lesefehler von der Floppy auszuschließen, habe ich das Proxa-Betriebssystem auch von SFD 2001 geladen. Leider mit dem gleichen Ergebnis.

  • Leider war das mit der Floppy wohl doch nicht erfolgreich, obgleich es erst einmal so schien. Ich habe mich jetzt noch ein bißchen eingelesen, wenn ich es aus den Service-Unterlagen richtig verstehe, soll man bei dem beschriebenen Fehler den 6502 und/oder?? den 6530 austauschen. Bei mir macht die Floppy bei jedem Einschalten aus dem kalten Zustand den Zeropage-Fehler. Wenn ich den Rechner dann eine Zeit lang "warm" werden lasse (2 bis 3 min.), ihn noch einmal ausschalte und wieder einschalte, ist alles ok. Wenn der Rechner in Betrieb war und wieder eingeschaltet wird, tritt der Fehler auch nicht auf. Die Bausteine auf der Mini-Platine habe ich vorsichtig herausgenommen und wieder eingesetzt, geholfen hat es nicht. Ist es dann mit Sicherheit einer der ICs oder kann es auch das Netzteil sein? Zweimal ist beim Einschalten Drive 0 (ohne eingelegte Floppy) angelaufen. Frage dazu (ich weiß es einfach nicht mehr!): Sind die Laufwerke eigentlich immer kurz beim Einschalten angelaufen?


    Das Verbindungskabel der 8700-Platine habe ich geprüft, Kontaktfehler sind nicht vorhanden. Die Pins auf dem 720iger Board sind vergoldet, die auf der 8700 metallisch blank. Demnach bliebe der 6526 als Fehlerquelle. Lt. diversen Foren soll er ja ein Schwachpunkt sein. Das Teil habe ich als Ersatz nur gebraucht oder (angeblich?) neu von privat gefunden. Frage: Wie kommt ihr an ICs, die nicht mehr lieferbar sind und welche Möglichkeiten gibt es zur Prüfung?

    • Official Post

    Hast Du noch eine andere CBM-Floppy?

    Dann könntest Du mal testweise aus dieser den 6530 nehmen.

    Der ROM-Inhalt des 6530 wird auf der 8250Mini Platine ausgeblendet, daher geht das.

    Ebenso kann man mal einen anderen 6502 ausprobieren.


    Die Beschaffung von ICs wie 6526 wird zunehmend schwieriger.

    Es tauchen leider auch immer wieder Fakes auf dem Markt auf. :(

  • Floppys habe ich noch. 8250 u. SFD1001. Hab mich nur noch nicht getraut, die ICs zu tauschen...


    Die SFD1001 habe ich vor ca. 1 Jahr als "grundüberholt und Elkos getauscht" gekauft. Das scheint auch so zu sein, der 6530 ist gegen einen 6532 mit der Platine von Ruud Baltissen getauscht. Aber die 8250 ist noch original. Der Tausch von 6502 und 6530 hat keinerlei Veränderung gebracht. Hab dabei eine Menge Zeit verbracht und die Steuerplatine vernünftig befestigt. Dabei ist mir aufgefallen, dass die 8250-Mini sehr sorgfältig aufgesetzt werden muss, sonst rutscht sie allzu leicht aus den Kontakten von 6502, 6530 und 6521. Aber das war es leider auch nicht. Inzwischen habe ich den Rechner diverse Mal an-/ausgeschaltet, in warmen und kalten Zuständen. Es sieht so aus, dass die Floppy beim Einschalten aus dem kalten Zustand die Fehlermeldung (5xBlinken) bringt. Lässt man den Rechner dann ca, 30 Sekunden laufen und schaltet ihn dann wieder aus und ein, ist alles ok. Wird er nur kurzfristig ausgeschaltet, tritt der Fehler nicht auf. Die Floppy läuft ansonsten auf beiden Laufwerken einwandfrei. Ist das typisch? Oder deutet es auf ein gealtertes Netzteil hin, in dem ein Bauteil erst "warmlaufen" muß?

    Den 6526 auf der Hauptplatine habe ich inzwischen auch getauscht. Auch dort ist keine Veränderung, die Proxa-Platine läuft nicht an. In der Bedienungsanleitung zur Proxa-Platine wird die Umschaltung sehr detailliert beschrieben. Demnach wird nach einigen Vorbereitungen die Stromversorgung des 6509 abgeschaltet und die des 6512 eingeschaltet. Das müsste doch auch mit einem einfachen Standard-Messgerät nachzuprüfen sein, oder ist das problematisch? Ich vermute mal einfach, dass für die Umschaltung das auf der Proxa-Platine befindliche Micro-Relais benutzt wird. Wenn das so ist, könnte auch das Relais oder der 6512 kaputt sein. Hat da jemand Erfahrungen?

  • Hallo Oldie,


    hab das erst jetzt gelesen. In der letzten Zeit hab ich wenig mit meinen CBM's gemacht und die letzten 3 Monate hab ich mich mit Bronchitis und Nebenhöhlen herumgeschlagen. An solch Dingen merkt man leider, dass man älter wird...


    Mit einer 8250LP kann ich nicht dienen. Die beiden Geräte sind bei mir in den 720iger bzw. einem 8296D eingebaut. An Compilern bzw. Interpretern habe ich UCSD-Pascal, COMAL und PETSpeed. UCSD ist auf dem CBM sehr langsam, weil vollständig Floppy-orientiert. PETSpeed hab ich nicht mehr so genau in Erinnerung, ich hab damit zuletzt vor ca. 35 Jahren gearbeitet. UCSD arbeitet nur auf 8096 oder 8296. Comal hab ich in Versionen für den 8032 und den 8096, beim 8096 bleiben ca. 38 kB RAM frei.


    Ich werde mich jetzt wieder etwas mehr mit meinen CBMs beschäftigen und hoffentlich endlich mein PET-SD zum Laufen bekommen. Wenn ich damit soweit bin, werde ich die Compiler/Interpreter einfach einstellen.


    Ach ja, COMAL gibt es auch für PC und DOS. Bei mir läuft es auf einem alten HP Omnibook 800 und unter DOS und VMWare-Player auf dem PC.


    Gruß aus Bremen


    JoMartin

  • hallo JoMartin


    hast du deinen 8700 nun zum laufen bekomme?

    dann würde ich dir gerne helfen, mein baby wieder zum laufen zu bekommen :)


    leider habe ich dein thema jetzt erst per zufall mitbekommen, da ich selten online bin.

    ich habe nach protext gesucht ;) welches ich auch vertrieben habe.

    ein sehr schönes textprogramm vom herrn schineis, hard und soft aus bayreuth.


    gruß

    helmut

  • Hallo axorp ,

    Zunächst einmal freue ich mich, dass ich nach so langer Zeit noch eine Reaktion bekomme. Danke!

    Protext habe ich noch auf Diskette für den 720. Das sollte sich als Image versenden lassen.


    Was den 8700 betrifft - der liegt zerlegt auf Eis. Mein Hauptproblem dabei ist sicherlich, dass ich zwar Hauselektrik kann, aber kein Elektroniker bin. Das schränkt meine Diagnosefähigkeiten auf ein Minimum ein. Hinzu kommt noch, dass mich auch viele andere Dinge beschäftigen…


    Der Rechner hat vor allem zwei Probleme gezeigt:

    - Die 8700-Platine startet nicht.

    - Das eingebaute 8250LP-Laufwerk bringt beim ersten Start einen Fehler. Er verschwindet beim Neustart.

    - Der 720-Teil lief bisher einwandfrei.


    Ich habe den Rechner damals bei Völkner gekauft, die 8250LP war vorhanden. Der Einbau der 8250LP und der 8700-Platine erfolgte bei Stephan Krämer/SK-Elektronik in Köln. Dabei wurde die 8250LP mit der 8250mini-Zusatzplatine umgerüstet, aber das habe ich erst vor zwei Jahren bei der näheren Beschäftigung mit dem defekten Rechner bemerkt.


    Die Vorschläge in diesem Thread habe ich ergebnislos umgesetzt, das Netzteil liegt bei mir zurzeit zerlegt und wartet darauf, dass neue Kondensatoren eingebaut werden. Die habe ich schon. Weiterhin ist mir aufgefallen, dass auf der 8250-Hauptplatine diverse Lötstellen “unsauber” aussehen.. - Aber ansonsten tappe ich einfach über den Fehler im Dunkeln. Über Tipps würde ich mich sehr freuen.


    Ich möchte den Rechner eigentlich mit den noch immer vorhandenen Programmen so herrichten, dass die vorhandenen Programme für Buchhaltung, Lohnbuchhaltung, Fakturierung usw. demonstriert werden können. So als Blick in die Vergangenheit der Computerei.


    Grüße aus Bremen

    Jochen

  • Hallo vossi

    Danke für deinen Hinweis. Ich habe damals den 720 und die 8250lp zusammen eingeschickt zum Umbau und natürlich nicht geschaut, was wieder zurück gekommen ist. Die mini-Platine ist mir erst jetzt aufgefallen, weil ich auch eine SFD 2001 habe, die Hauptplatinen habe ich nicht verglichen.


    Daraus folgt ja eigentlich, dass es bei diesen Laufwerken keine Probleme mit auslaufenden Kondensatoren geben sollte. Ist das so richtig? Und zweite Frage: Was ist eigentlich im 8296D verbaut? Den habe ich auch noch da stehen.


    Jochen

  • Die Mini8250 passt auch nur auf die SFD1001-Platine.

    Alle 1MB Laufwerke haben auslaufende Elkos auf der Motor-Platine!

    Im 8296D ist quasi eine 8250LP verbaut.

  • Was den 8700 betrifft - der liegt zerlegt auf Eis.

    und wartet auf wiederbelebung :)

    Der Rechner hat vor allem zwei Probleme gezeigt:

    - Die 8700-Platine startet nicht.

    - Das eingebaute 8250LP-Laufwerk bringt beim ersten Start einen Fehler. Er verschwindet beim Neustart.

    die meiste erfahrung der letzten jahre hat der christian Toast_r gemacht
    und viele proxa7000 und 8700 zum laufen bekommen. :)

    ich selbst hatte bis jetzt leider keinen platz zum basteln.
    aber inzwischen fange ich langsamm an, so hoffe ich, das ich zu meinem treffen, im september,

    etwas erstellen und zeigen kann.

    Ich möchte den Rechner eigentlich mit den noch immer vorhandenen Programmen so herrichten, dass die vorhandenen Programme für Buchhaltung, Lohnbuchhaltung, Fakturierung usw. demonstriert werden können. So als Blick in die Vergangenheit der Computerei.

    protext für den 700er hast du ja :)


    und es gab für den 700er auch ein sehr gutes buchhaltungs und lohn abrechnungsprogramm,

    auch aus bayreuth, vom kratzer von brünken. firma realtime software gmbh.

    welches wir auch vertrieben haben.


    Alle 1MB Laufwerke haben auslaufende Elkos auf der Motor-Platine!

    ja, alle 1MB low profile laufwerke.

    Die Mini8250 passt auch nur auf die SFD1001-Platine.

    ja, ich kam zum glück damals auf diese idee. die sfd1001 dazu zu nehmen.

    commodore wollte es nachbauen, erstellte eine kleine serie,

    da aber sie mir wieder mal mit versprechungen über ein paar hundert tausen dm veräppelten,

    war es die einzige sache, meiner ideen und hilfen, die ich ihnen nicht kostenlos überlassen habe.

    so habe ich ihnen klar gemacht, wenn sie es nachbauen, werde ich commodore verklagen.


    so haben sie es eingestampft.


    Im 8296D ist quasi eine 8250LP verbaut.

    ich selbst habe aber ein paar 8296 mit meiner 8250mini lösung umgebaut.

    erkennen kann man die äußerlich nur am typenschild hinten, da steht nicht 8296d sondern nur 8296 drauf.

    von meinen 8296d wurden aber nur ein paar dutzent gebaut, da die laufwerke für den 8700er benötigt wurden.


    auch von dem 700er, nur mit den internen floppys, dem cbm720D, dem proxa8700D oder dem ultra8700D,

    gab es nur ein paar dutzend. die meisten wurden gleich mit der proxa7000 (ultra7000) ausgeliefert.


    gruß

    helmut