IBM P70: Meine Odyssee

  • So, ich hab mich mal des IBM P70 angenommen, zu dessen Reparatur es an der letzten CC nicht kam.


    Allem Anschein nach ist die Grafikkarte, sprich, der Plasma Display Adapter, im Eimer.


    Das Höchste der Gefühle ist ein lustiges Schachbrettmuster, das ich auf dem Display zu Gesicht bekomme.

    Und zwar in Kombination mit einem langen und zwei kurzen Beeps.


    Hätte mir jemand einen passenden Plasma Display Adapter, wenn auch nur leihweise zum Testen? Mich würde brennend interessieren, ob der restliche Rechner funktioniert.


    P/N 38F7793

    FRU 38F4686

  • Bitte nicht gleich ausflippen, wenn ich etwas genauer nachfrage - die "Display Card" FRU 38F4686 gibt scheinbar in zwei Ausführungen, heissen aber beide gleich (gleiche Nummer). Siehe auch http://ps-2.kev009.com/ohlandl…l#New_System_Display_Card - hast Du also das "neue" Board ?


    Ich habe so ein P70, aber der hat scheinbar ein anderes Display Panel, weil die Nummer nicht 38F7793 lautet.

    Das mit dem Display-Problem habe ich zwar nicht so wie geschildert, jedoch abgewandelt: Je nachdem wie oft ich die hintere Gehäuserückwand abschraube, habe ich "Störungen" im Display, in Form von Streifen. Daher mein Tipp: Die Kontakte zum Display sind scheinbar hochfragil und haben wohl gerne mal einen Aussetzer/Kontaktprobleme. Wenn Du Dir sicher bist, dass es sich nicht um Kontakt-Probleme handelt, ignoriere mein Hinweis.

    "Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind."


    ... und schaut auch mal bei meinem Blog vorbei ...

  • Ja, es gibt tatsächlich zwei unterschiedliche Modelle im P70. Laut Hardware Manual gibt es zwei unterschiedliche Display Assemblies, jeweils mit eigenem Kabel und eigenem Display Adapter, die nicht untereinander kompatibel sind. Es muss also immer die passende Karte zum Display sein. Daher hatte ich auch die P/N und FRU angegeben. Anscheinend ist die Variante, die ich habe, die frühere (mein P70 ist von 1989). Nach deinem Link sieht es aber eher wie die neuere Karte aus. Jetzt stehe ich total auf dem Schlauch...


    Ich hatte die Karte schon komplett draußen, hab sämtliche Kabel zig mal umgesteckt, die Mondrian-Rechtecke sind das höchste der Gefühle was ich hinbekomme. Oder gar nichts. Die Pieptöne lang-kurz-kurz sind jedenfalls Grafikkartenfehler.

  • Das hört sich in der Tat wie ein Grafikkartenfehler an :-(

    Hier hat jemand durch Austausch von Kondensatoren wohl das Problem beheben können: http://www.vcfed.org/forum/sho…l-P70-386-with-no-display ...

    Btw. konnte man nicht auch versuchsweise auf einem externen Monitor was anzeigen lassen (entweder Plasma oder extern, aber wechseln könnte man doch) ?

    "Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind."


    ... und schaut auch mal bei meinem Blog vorbei ...

  • Das Problem ist, dass der externe Monitoranschluss ja mit auf der Plasmakarte sitzt. Eine zusätzliche 8514-Karte o.Ä. hab ich leider nicht.

    Hm, dann muss ich wohl tatsächlich Mal nach Elkos schauen. Viele sind ja nicht drauf...

  • Ich hab noch eine P70 hier; Hab ich vor gar nicht allzu langer Zeit von einem Kollegen übernommen und noch gar nicht getestet. Ich gehe davon aus, daß die Elkos vom FDD ohenhin getauscht werden müssen. Daher muß sie ohnehin aufgemacht werden.

    kpanic : Soll ich sie mal zum Shack mitbringen?

  • Nun, an der CRT hatte ich gestern den P70 mal aufgebaut, und oh Wunder, ich bekomme ein Bild. Zwar teilweise etwas unruhig, zittrig und flimmerig, aber ein Bild.

    Von der Referenzdiskette hab ich mal den Hardwaretest durchlaufen lassen. Das Ergebnis ist dieses:



    Die Kondensatoren auf dem PDA habe ich dann vorsorglich mal gewechselt, hat aber nichts geändert.

    Vielleicht versuche ich mal den Grafikspeicher nachzulöten.

    Zu dem Fehlercode 01490240 schweigt sich das Internet jedenfalls aus.

  • Ich werd noch irre mit dem Teil...

    Jetzt hatte ich das Display auseinandergebaut, hatte nichts gesehen, wieder zusammengebaut und der Fehler ist auf einmal weg. Ich hab dann den RAM wieder vollständig eingebaut, die Kingston DataCard wieder eingebaut, Referenzdiskette gestartet, ADF-Diskette für die KTM-DC32 rein, frisst er nicht.

    QBMCA gestartet: Die DataCard wird als unbekannte Karte gelistet, mit 71F4 statt 71D4.

    Dann hat mich der Rappel gepackt: Karte raus, Kontakte gereinigt, Kontakte der Riserkarte gereinigt, wieder zusammengebaut.

    Und, oh Wunder:

    Die Referenzdiskette frisst die Karte auf einmal problemlos.

    Jetzt scheint das gute Stück also wieder einwandfrei zu funktionieren:grübel:

    Lediglich das Display hat immer noch Bildstörungen, wahrscheinlich tatsächlich defekter Video-RAM. Und der Netzteillüfter fehlt nach wie vor. Toshi , kannst du mir mal ein Foto von der Lüfterhalterung machen? Ich muss mir da irgendwas zurechtbasteln...


    Jetzt kommts:

    Das Monster hat tatsächlich 24MB RAM, zwei Festplatten (originale 60MB DBA, zweite 210MB IDE auf der DC32) und WIndows 95 drauf =O

    Kann man so machen...

  • kpanic

    Changed the title of the thread from “IBM P70: Plasma Display Adapter” to “IBM P70: Meine Odyssee”.
  • Das freut mich wirklich für Dich (dass das Gerät einigermaßen läuft), auch wenn auf so einem Gerät natürlich OS/2 draufkommen muss, nicht Windows 95 ;-)

    "Probleme kann man niemals mit derselben Denkweise lösen, durch die sie entstanden sind."


    ... und schaut auch mal bei meinem Blog vorbei ...