Probleme mit Z80 Karten im Apple //e

  • Hallo zusammen,


    ich habe vor etlichen Jahren zwei CP/M Karten erstanden. Diese wollte ich nun testen bzw. softwaretechnisch in Betrieb nehmen.

    Es handelt sich um eine Microsoft Premium Softcard //e und eine ALS CP/M Card.

    Die Premium Softcard //e funktioniert als 80Z/64k Karte einwandfrei. Wenn ich CP/M 2.25 boote, dann schaltet die Anzeige in den 80Z Modus, der Cursor steht oben links und Schluss ist.

    Wenn ich die ALS CP/M Karte mit CP/M 3.0 starte, dann schaltet sie ebenso in den 80Z Modus um und dann passiert nichts mehr (mit einer normalen 80Z/64k Karte). An der CP/M 3.0 Software liegt es nicht, diese startet problemlos wenn ich die ALS Karte durch eine Z80+ Karte tausche.

    Die Z80B CPU habe ich auf beiden Karten gegen eine neue Z80B getauscht, keine Änderung.

    Hat jemand eine Idee was ich noch machen könnte ?


    Grüße

    Wolfgang

  • Ist nur eine Vermutung, auf der ALS Karte sehe ich RAM Chips, eventuell hat da einer oder mehrere Fehler bzw. ist defekt?! Ich habe eine Clone Z80 Karte ohne RAM, die nutzt das vom Apple zur Verfügung gestellte RAM wenn ich mich recht erinner.


    Hier etwas Lesestoff zur ALS Karte in Neudeutsch ;-)


    http://www.harrowalsh.de/Elekt…BOX/Manuals/ALSreview.pdf


    Nachtrag:

    https://mirrors.apple2.org.za/…20Cards/ALS%20CPM%20Card/

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88,

    C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E,

    Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

    Edited once, last by tokabln ().

  • Hallo Torsten,


    ja, die weitverbreiteten Microsoft Z80A Karten und deren Clones haben den Apple Ram genutzt.


    Den Ram habe ich auf der ALS Karte getauscht. Leider hat sich am Verhalten nichts geändert. Diskette bootet, Bildschirm schaltet auf 80Z um, dann hört das Disklaufwerk auf zu drehen und geht aus, das wars :-(


    Trotzdem Danke für den Tip,

    Gruß

    Wolfgang

  • Hast Du mal unter dem letzten Link nachgeschaut... da ist auch für die Karte passende Software verfügbar... eventuell ist die von Nöten !


    Daher hier noch mal:

    https://mirrors.apple2.org.za/…20Cards/ALS%20CPM%20Card/

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88,

    C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, T41, PS/2 (Model 40SX), PS/2E,

    Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • An der Software liegt es bei der ALS Karte nicht, ich hatte ja geschrieben, dass das CP/M 3.0 mit einer anderen Z80H Karte läuft. Ich hatte es sogar mit genau dieser Software getestet.

    Bei der Microsoft Premium Softcard //e habe ich auch mal den Ram getauscht (obwohl der Ramtest keine Fehler zeigte), alle ICs entfernt und wieder in die Sockel gesteckt, Kontaktspray... nix hat geholfen. Wenn ich den IIe einschalte und führe ein IIe programm aus oder mache einen Ramtest dann läuft alles. Boote ich dann CP/M 2.25 oder 2.26 hängt der Rechner wie beschrieben und die rote LED auf der Premium Softcard brennt. Wenn ich nun die Diskette mit Apple IIe Diagnostics starte gibt es einen Fehler, keine erweiterte 80Z Karte gefunden. Schalte ich den IIe aus und wieder an startet die Diskette und der Ramtest ergibt keine Fehler. Bin ein wenig ratlos...


    Gruß

    Wolfgang

  • Die ALS Karte bootet nun CP/M 3.0 . Parser hatte mich zu dem Thema kontaktiert und mich in meiner Ahnung bestärkt, doch auch mal die anderen ICs zu tauschen. Nachdem ich mich dazu durchgerungen hatte fiel mir ein, dass ich bei dieser Karte noch nicht alle ICs entfernt und wieder in die Sockel gesteckt hatte. Nach dieser Aktion startete die Karte CP/M. Sauber...


    Nun denn, bei der Premium Softcard wird mir ein Tausch der ICs wohl nicht erspart bleiben.

    Vielen Dank nochmal an Parser , ohne ihn hätte ich wohl noch mit weiteren Aktionen gewartet.


    Wolfgang