Retro Forum - Spanien: zur TA alphaTronic P2

  • Über den Tellerrand auf die TA alphaTronic P2 gesehen


    Über einige Links zu diesem Thema, hat mir jlopez mit geteilt, wie dort seiner

    alphaTronic P2 - erst OWNER - später mit meiner Hilfe zu

    (Software - remote Unterstützung) jetzt ein alphaTronic P2 USER geworden wurde.


    Zunächst war nur die Maschine ohne Disketten aus (Catalonia) nach Andorra gelangt.

    Wie oft war das Netzproblem gewesen!


    Hier habe ich offenbar die ersten alphaTronic P2 Beitrage (.es) in einem "Spanischem Retro-Forum" gefunden!


    Vor einiger Zeit hat jlopez einen kleinen Beitrag zur Netzproblemik hier verfasst - wie das power supply ersetzte.

    Inzwischen besitzt jlopez eine weitere alphaTronic P2x (offenbar mit 64 kB RAM) die aus Italien kam.

    Die Maschinen arbeiten offenbar jetzt ohne Probleme.


    Spannende Neuigkeiten -weiter eine P2 aufgetaucht:

    Seit kurzer Zeit taucht dort im Forum (.es) ein weiterer alphaTronic P2x Besitzer auf.

    Im spanisch - Original Forum-Eintrag hier:


    Re: Triumph Adler P2 y la página web más completa

    por overCLK » 18 May 2019 13:30


    Diese Maschine ist in sehr gutem Zustand, völlig ausgebaute und gesäubert.

    Ich hoffe - das dort die P2x mal unter Spannung starten wird.


    Für Software wird sicher mit Dank jlopez und helwie44 dort helfen.


    Helwie44

  • Hello, sorry for replying in English in a Deutsch thread.


    I've been talking with him, and unfortunately he's having a rough start. While his PSU is fully functional, one or many cards (we still don't know) appear to fail. It's sad to find that after so much time the only other computer known to be an exact match to my unit is broken...


    Edit: No, my Italian unit is a bare 48K P2. However both Spanish units I've seen were marketed simply as "P2" but had an internal 16K RAM expansion.

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

    Edited once, last by jlopez ().

  • Hallo gpospi -


    ich bin gespannt in welchem Zustand die evtl. jetzt eintrudelte P2 sein wird.


    Über den Link unterhalb meines Bildes habe ich ja eine sehr hilfreiche WEB-Sammlung zum Thema alphaTronic P2.

    ( ... ein spanischer P2 Interessierter sagt dort im Forum (es) ... etwa „“ sehr gräßliche Web-Seite, aber viele Informationen und Tools sind wunderbar.. „ frei übersetzt!).


    Man kann nicht alles haben - ich habe den Vorzug auf wirkliche INFORMATIONEN gesetzt.

    Ich hoffe, es werden nützliche Infos hier zu finden sein, falls noch was fehlt - bitte melden.


    Der USER netmercer hatte zunächst seine P3 / P30 mit cp/m und MSDOS 2.0 mit meiner WEB-Sammlung und einigen Hinweisen super in Gang gebracht. Auch vor relativer Zeit hatte er netmercer eine P2 abgestaubt. Auch einen seltenen P2 Fehler bei dem CRT-Controller wurde genial lokalisiert und schon lief alles - einfach nach dem CRT Chip 5027 (Baugleicher Typ Ersatz) austauscht läuft alles astrein.


    Grüße und viel Erfolg

  • Ja ich bin auch schon gespannt. Ich hatte im Rahmen meiner Schulausbildung mal mit einer P2 zu tun, somit wäre das nun quasi eine Rückkehr zu meinen EDV-Wurzeln. Die damals ebenfalls verwendeten Commodore CBM720 Rechner fehlen leider noch in meiner Sammlung.


    Laut Besitzer ist das System "ungetestet", das heißt wohl meistens "defekt". Ein grundlegender Test wäre ja einfach durch Anschluß ans Stromnetz durchzuführen, dann sollten zumindest die Power LED leuchten und das MOS Prompt erscheinen. Aber vielleicht habe ich ja Glück ;)


    Ich habe mir hier im Forum schon verschiedene Disk-Images runter geladen und auf Disketten übertragen. Allerdings habe ich bisher nur Basic und diverse Utilities gefunden, kein CP/M Diskimage. Es wäre toll, ein P2 48k CP/M Image im Teledisk / Imagedisk / SAMdisc hier hochzuladen. Das wäre dann für mich noch einfacher nutzbar als die Anleitung auf der "gräßlichen Webseite" (die habe ich mir natürlich schon angesehen). So exotisch wird das Diskformat der P2 ja hoffentlich nicht sein, ich habe mit den oben angeführten Tools jedenfalls schon Boot-Disketten für eine Vielzahl historischer Rechner erfolgreich archiviert und wieder erstellt (Alphatronic PC, Philips P2500, Sharp MZ-80B, Olivetti L1 M20). Und diese Rechner haben teilweise wirklich seltsame Formate (z.B. die erste Spur in FM und danach alles in MFM bei der Olivetti Maschine)...

  • alphaTronic P2 „Standard - Disketten - Format“


    In den nächsten Tagen werde ich einen „Extra-BLOCK“ für den cp/m TPA 4300h Betrieb einiges an z.B. .IMD Formate bei meiner „WEB-Sammlung“ dort abzulegen.


    Das alphaTronic P2 Diskettenformat oder der P2S, P2U Systeme sind Standard.


    Diskette: 16 Sectoren je 256 Byte pro Spur. Die Sectorfolge von 1 bis 16. Dann 40 Spuren von 0 bis 39. Untere Diskettenseiten bei cp/m ist als A: im unteren Laufwerk (meist BASF 6106 - also Einkopf für untere Diskettenoberfläche) eingerichtet.

    Boot-Laufwerk ist also das untere - wenn physikalisch auf Select-Brücke 0 gesteckt wurde ( ist Standard!). Das Oberes Laufwerk ist als B: erreichbar. Wenn es z.B. ein BASF 6108 Doppelkopf - Laufwerke wäre, dann sind jeweils die obere Diskettenseite über C: und über D: vom anderem Laufwerk - erreichbar. Daher sind also vier cp/m drive‘s eingebaut.

    Ach ja, die ersten 2 Spuren belegen das cp/m ( sowohl TPA 0100h oder TPA 4300H).

    Ab Spur 2 liegen die Directory-Einträge.


    Mit dem „ersten POWER-ON“ Test ist schon einiges zu erkennen - wo es evtl. haken könnte!


    Viel Glück...

  • Hello Helmut,


    And sorry for my English again! :D

    Well,the truth is that the translator exagerated. "Fea" means simply "ugly", not "very horrible". Also, he acknowledges your work at reuniting all this material as he said your page is "very interesting".


    Modern translators still don't do the job, translation requires understanding of the context in which the original message was said or written. A machine doesn't know of that: it simply crunches data to form a result, most of the time an inaccurate one.


    Three years ago my Win10 did a mess with my file system, and it may be the largest loss of data I've ever had. That stalled lots of software projects I was writing at the time, but if you want, I could dive on a backup again to see if I find something useful, as I did with the ROM visor. Maybe it's the right time to start closing unfinished things that I left.


    Your website is the only dedicated P2 site that I found, and you did a great job maintaining alive the core knowledge of this system. It is like a lighthouse in a rocky coast. Thank you

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • So, meine P2 ist da und leider haben sich meine Befürchtungen erfüllt. Der Lüfter läuft, aber sonst passiert nicht viel. Die CAPS LED der Tastatur leuchtet und beim Ein-/Ausschalten blitzt der Monitor. Ich bekomme aber weder eine MOS Meldung, noch laufen die Diskettenlaufwerke an (auch nicht wenn ich B oder B1 eingebe). Ich werde mich also wohl auf Fehlersuche machen müssen...

  • DIe 0.1A Sicherung S12 im Netzteil verabschiedet sich sofort beim Einschalten. Damit habe ich zumindest schon eine erste Spur. Nun ist natürlich die Frage, was tatsächlich alles defekt ist. Wenn ich die Schaltbilder im Systemhandbuch richtig deute, dann benötigen die diversen Steckkarten eigentlich nur die auch heute üblichen Spannungen von +5V, +12V und -12V. Somit müsste sich die Maschine ja wohl mit einem AT/ATX Netzteil auch (testweise) in Betrieb nehmen lassen (sofern die Karten noch funktionsfähig sind).

  • Sorry for my English (again). If the 5V are a problem and it's not a logic card malfunction, you may take a look at this thread. The capacitors on the logic boards tend to die, so it's not a bad idea to perform continuity tests between the 5v line and ground, the 12v line and ground and -12 and ground. If the led was shining it means the 5V should be ok.

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • Yes thanks, I am aware of this thread. Meanwhile I did some additional tests. The 5V power supply is ok. The problem seems to be in the 12V power supply. I get +12V at the floppy drive power connector, but the S12 fuse in the 5V power supply blows up. Consequently I assume that the -12V are not delivered properly on the backplane. However I am not testing this further for now, I will connect a new PC power supply and check if the machine shows any sign of life.
    It seems that the CPU board has been modified, I assume this is to allow higher speed on the serial interface. There is a sticker on the board stating "modified to use external clock". Anyway I hope that it was done properly and the board overall is still working.

    At least the monitor is still in fully working condition - just tested via my Alphatronic PC ;)

  • Now I have a small success - my P2 is (partially) alive. I used an ATX power supply and managed to reach the initial MOS screen. However I had to remove the memory board, as this is obviously broken - When I insert it, the power supply short circuit protection kicks in. Hence I need to investigate further the issues on this board. Without memory the P2 is still quite useless ;)
    At least the CPU and keyboard interface boards seem to work properly, as I can press various keys and get the correct responses in the MOS screen.

  • For the broken tracks, use a brush first to remove dirt and fragments of the coating that are hanging. Try to restore them with wire and ensure that there's no contact between tracks. If there's still a short, try replacing the capacitors.


    If still doesn't work, it's not necessary for you to acquire an original board. A month ago I built a 3 IC 48K board ("Pigmy"). If you want 48K you can build it but after 20/06 I'll resume active developmenton the second (and later the third) iteration of the board.


    Edit: Got confused with the image gallery... :fp:

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

    Edited once, last by jlopez ().

  • Schematics for "Pigmy"


    I was able to boot to CP/M (48K version). As you can see it is extremely simple. Things went wrong when I upgraded "Pigmy" to "Mammooth", it ceased to work. I don't want to spend more time with this wirewrap mess. It's very confusing and my hands tremble (in the past I killed a DS and 3 DS Lite while trying to repair them, and the cause were my trembling hands). There's not much space in the connector section... I have the gerbers for the 64K prototype and a first version of schematics for a complete 66+6K RAM-ROM replacement.

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • Sorry to hear that you have some health issues!
    I will try to build the SRAM card as designed by you. When checking the part supplies, I can find only 100ns SRAMs (HM62256BLSP-10). Do you think they will also work? As the P2 is quite old and slow, I assume that 100ns should also be good enough ;)

  • Sorry to hear that you have some health issues!
    I will try to build the SRAM card as designed by you. When checking the part supplies, I can find only 100ns SRAMs (HM62256BLSP-10). Do you think they will also work? As the P2 is quite old and slow, I assume that 100ns should also be good enough ;)

    Well, about the trembling, it's only an issue with high precision tasks, I wouldn't say its a health problem but it's true that sometimes it causes some trouble (like my poor Lites :D).


    The SRAM reference is "62256" because it's the one the CAD I'm using has on its database. Other pin-compatible SRAMs work well too, I used TC55328BD-25 and UM61256FK-15.

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • Now I ordered all necessary parts, but I need to wait a while to get some components from China. Then the "fun" starts, without a "proper" PCB it will be quite a mess to connect all wires correctly...

    I know what you mean... experience. After the exam I'll hurry to finish my project and provide some proper boards so people in your situation could repair it easily.

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • Ja, das habe ich geschrieben! Weitere Infos in den kommenden Tagen. :)

  • Hallo overCLK -


    es wäre schön, wenn du in dem "Spain - Forum" mit deiner damals eigenen alphatronic P2 dort vorgestellt war und einen kleinen Folgebeitrag hinterlegt.

    Eine Erfolgsmeldung - animiert oft andere USER wie ein zunächst großes Problem bestand - endlich eine erfolgreiche Reparatur erfolgte!


    Damit sind ja gerade Informationen ( Links zu Unterlagen und Erfahrungsberichte) für die historischen Rechner aus anderen Länder sehr wertvoll.


    Evtl. könnte auch dort ein Link auf die doch sehr erfolgreichen Arbeiten - wie hier

    im "FORUM - DE" eine TA alphaTronic Reparatur P2 in Gang erfolgte.


    Vielen Dank jlopez , gpospi , netmercer , rfka01 und viele meht für die wertvollen Beiträge und gerade etliche TA alphaTronic Px - Dokumente sowie passende Software.


    Viele Grüße und weiter viel Erfolg.

    Helwie44

  • Hallo helwie44.

    Das ist doch geplannt. Leider habe ich heutzutage nicht viel Zeit, um auf diese Dinge mich zu kümmern.

    Ich arbeite noch an meine Lösung für das Netzteil, habe eine Platte gezeichnet und jetzt warte ich auf der Lieferung.


    Nachdem ich fertig damit wird, dann Will ich ein Bericht in dem spanischen Forum schreiben.


    Viele Grüße und vielen Dank!


    Manuel