Retro Chip Tester Pro vom 8Bit-Museum.de (vormals "SRAM/DRAM-Tester")

  • Firmware wurde gerade aktualisiert. 353 Logic Chips in vier Menüs sind jetzt direkt auswählbar und testbar.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Schön wäre noch das Auswahlmenü zu ergänzen, dauert doch etwas bis man jetzt bei den hinteren Menüpunkten gelangt, vielleicht so:


    SRAM

    DRAM

    EPROM/PROM

    74xx Logic Tests

    40xx Logic Tests

    USSR...


    Und die Logic Tests mit vielen Einträgen:


    74xx Logic Tests

    - 14 pin

    - 16 pin

    - 18 pin

    - 20 pin


    Tolles Stück Hardware, dass immer besser wird, danke dafür :)

  • Du gelangst sogar recht schnell zu den letzten Punkten:

    JUMP -> eine Gruppe weiter

    und falls auf der Platine "JUMP" noch nicht vorhanden ist, dann SELECT & OK gleichzeitig drücken

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Hallo Stephan,


    mit der aktuellen Firmware läuft der Tester nicht mehr. Zumindest bekomme ich nichts auf dem Display angezeigt.

    Nach ein paar Mal hin und her tasten, kam dann irgendwann mal was. Sah aber so aus, als ob nicht genügend Spannung zur Verfügung steht.

    Also alles sehr schwach. Netzteil raus, wieder rein und die Anzeige ist wieder blank.

    Bin dann zurück auf die 1.8er und damit funktioniert er wieder.


    Edit: Kommando zurück. Nach einer Weile der Stromlosigkeit, funktioniert er jetzt wieder. Seltsam, aber gut..... Hat sich erledigt.

    Viele Grüße
    Thomas


    - WiC64 - The Commodore 64 Wireless Interface -> Homepage

    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

    Edited once, last by GMP ().

  • Es gibt mehrere Möglichkeiten dafür:


    - Könnte ein einfacher Wackler am Display gewesen sein. Der Steckverbinder ist ok, aber mit Kabelverlängerung kenne ich die Reaktion nicht.

    - Du hattest einen kleinen Kurzschluss am ATmega. Manchmal können Lötreste zwischen den Pins hängen, die einen kleinen Spalt bilden und soweit alles ok ist, aber wenn dann die Platine etwas bewegt wird, gibt es einen Kurzschluss.

    - Ein Chip ist defekt und hat einen internen Kurzschluss. Da habe ich zwei Stück in meiner Sammlung, die so etwas machen.

    - Ein Sonnensturm ;)


    Hätte mich auch sehr gewundert, wenn die 1.9er solche Symptome zeigt. Wenn eine Firmware einen Bug hat, zeigen sich meistens wirre Zeichen auf dem Display (dann ist die Speicherverwaltung wieder hinüber). Ich quetsche da aktuell schon recht viel in den ATmega rein.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Dann war es bestimmt der Sonnensturm. :D

    Viele Grüße
    Thomas


    - WiC64 - The Commodore 64 Wireless Interface -> Homepage

    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • Und wieder ein Update der 1.9 beta.

    Changelog:

    - gefundene Fehler werden angezeigt

    - 7411 Test war fehlerhaft

    - kleinere Optimierungen

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Es gibt jetzt auch einen kleinen Mod für die Hardware ;)



    Die 1.9 beta hat den Code aktuell noch nicht drin.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Hmmm... Habe die Platine gerade nicht zu Hand, kann also nicht nachsehen.

    Geht das nur direkt am Pin (Fitzelkram!), oder gibt's da eine Leiterbahn, die man irgendwo anzapfen kann?

    Fitzelkram, leider.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Ich hätte da einmal eine Frage:


    Der Speichertester ist ja in der Lage ca. 650 ROMs zu identifizieren. Dazu berechnet er eine CRC32 und gibt - sollte die CRC32 bekannt sein - die ROM-Bezeichnung aus.


    Ich habe noch Platz für knapp 800 ROMs. Welche System-ROMs wären noch sinnvoll mit aufzunehmen?


    Bei PET/CBM hatte ich schon ein paar Mal den Fall, dass die Beschriftung nicht mehr lesbar war, dann ist das Feature bei der Vielzahl an ROMs ziemlich praktisch. Bei anderen Systemen macht das vermutlich weniger Sinn.


    Vorschläge?

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • slabbi Hier Stephan.......:

    http://www.zimmers.net/anonftp/pub/cbm/firmware/index.html


    ..... kannst Du Dich so richtig austoben. :)

    Viele Grüße
    Thomas


    - WiC64 - The Commodore 64 Wireless Interface -> Homepage

    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • slabbi Hier Stephan.......:

    http://www.zimmers.net/anonftp/pub/cbm/firmware/index.html


    ..... kannst Du Dich so richtig austoben. :)

    Die und noch einige mehr sind vorhanden. Fast alle System-ROMs von Commodore, Sinclair, Atari und Apple sind in der Datenbank. Gestern hatte ich noch 800 weitere eingepflegt, so dass es jetzt über 1200 ROMs sind.


    Ich habe die Speicherverwaltung komplett umgeworfen, so dass ich jetzt mehrere Datenbanken nutzen kann. Da sind jetzt wieder ein paar kB frei.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Cool. Das Teil entwickelt sich wirklich zu einem Multitalent.

    Gestern habe ich eine Ladung DRAMs (50Stk.) 4164 aus China bekommen und alle mal durchgetestet.

    Bis auf zwei waren alle in Ordnung. :thumbup:

    Viele Grüße
    Thomas


    - WiC64 - The Commodore 64 Wireless Interface -> Homepage

    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • Und er wird immer besser: Jetzt sind es knapp 2000(!) ROMs, die er identifizieren kann.


    Ich habe gerade eine neue Testversion (v1.10 beta) hochgeladen.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

    Edited once, last by slabbi ().

  • Mal wieder ein Update:



    74xxx




    00, 01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 30, 31, 32, 33, 34, 35, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 58, 60, 61, 62, 64, 65, 73, 74, 75, 76, 85, 86, 90, 92, 93, 95, 107, 109, 112, 113, 114, 123, 125, 126, 128, 132, 133, 134, 135, 136, 137, 138, 139, 140, 141, 145, 147, 148, 149, 150, 151, 152, 153, 154, 155, 156, 157, 158, 160, 161, 162, 163, 164, 165, 166, 168, 169, 170, 173, 174, 175, 181, 182, 190, 191, 192, 193, 194, 195, 237, 238, 240, 241, 242, 243, 244, 245, 246, 247, 248, 249, 251, 253, 257, 258, 259, 260, 266, 280, 283, 292, 293, 294, 298, 299, 365, 366, 367, 368, 373, 374, 375, 377, 378, 386, 390, 393, 425, 426, 445, 465, 466, 467, 468, 540, 541, 573, 589, 595, 597, 670




    75xxx




    189




    40xx




    00, 01, 02, 08, 09, 10, 11, 12, 13, 15, 16, 17, 18, 19, 20, 22, 23, 24, 25, 27, 28, 29, 30, 31, 40, 41, 42, 43, 44, 48, 49, 51, 53, 66, 68, 69, 70, 71, 72, 73, 75, 76, 77, 78, 81, 82, 93, 94, 98, 106, 161, 162, 174, 175, 192, 193




    45xx




    01, 03, 06, 10, 11, 12, 18, 19, 20, 29, 32, 43, 72




    DDR




    DLxx




    000, 002, 003, 004, 008, 010, 011, 014, 020, 021, 030, 032, 037, 038, 040, 051, 074, 086, 090, 093, 112, 123, 132, 155, 164, 175, 192, 193, 194, 251, 253, 257, 259, 374, 540, 541, 299




    UdSSR




    153-555




    AG3, AP3, AP4, AP5, AP6, AP14, AP15, ID3, ID4, ID5, ID6, ID7, ID10, ID14, ID18, IE2, IE4, IE5, IE6, IE7, IE9, IE10, IE11, IE12, IE13, IE16, IE17, IE18, IE19, IM6, IP3, IP4, IP5, IP6, IP7, IR3, IR8, IR9, IR10, IR11, IR12, IR15, IR22, IR23, IR24, IR26, IR27, IR30, IR32, IR33, IV1, IV3, KP1, KP2, KP5, KP7, KP11, KP12, KP13, KP14, KP15, KP16, KP18, A1, LA2, LA3, LA4, LA6, LA7, LA8, LA9, LA10, LA11, LA12, LA13, LA16, LA19, LE1, LE2, LE3, LE4, LE5, LE7, LE11, LI1, LI2, LI3, LI4, LI6, LI9, LL1, LL3, LN1, LN2, LN3, LN5, LN6, LN7, LP5, LP8, LP9, LP10, LP11, LP12, LP13, LR1, LR10, LR11, LR13, LR4, SP1, TL1, TL2, TL3, TM2, TM7, TM8, TM9, TM10, TV6, TV9, TV10, TV11, TV15




    UdSSR




    561




    CMOS




    AG1, ID1, ID23, IE1, IE8, IE9, IE10, IE14, IE16, IE19, IE20, IE21, IM1, IM6, IR2, IR4, IR14, KP1, KP2, KP3, KP4, KP5, KT1, KT3, LA7, LA8, LA9, LE5, LE6, LE10, LI2, LN2, LN3, LP2, LP13, LP14, LS2, PR1, PW1, PW7, TL1, TM2, TM3, TR2, TV1, K1561KP1, K1561KP5




    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Es gibt wieder eine neue beta.


    Diesmal:

    - weitere Logik-IC Tests implementiert

    - drei Logik-Tests korrigiert

    - Blättern im Logik-IC Menü verändert: SELECT/JUMP: Vorwärts/Rückwärts, wenn die Tasten gehalten werden, wird die Suche schneller

    - es gibt jetzt ein Easter-Egg (ich hatte mal gehört, dass das in jede gute Software gehört) ;) - wer es findet, bitte nicht Spoilern.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Es gibt jetzt auch einen kleinen Mod für die Hardware ;)



    Die 1.9 beta hat den Code aktuell noch nicht drin.


    Das hat mir keine Ruhe gelassen, deshalb gibt es eine weitere Möglichkeit:


    Wer die obige Modifikation scheut (Besitzer der Platine Rev.8.1 können Pin 9 übrigens auf der Rückseite der Platine anzapfen, wie steht im Handbuch), kann auch Pin 1 des ZIF Sockels verwenden. Dazu wird - je nach Platine - der Buzzer mit dem linken oberen Pin des ZIF-Sockets verbunden und im Konfigurationsmenü "Hack:Beep ZIF1 (0):" ausgewählt.


    Solange diese Option aktiv ist und der Buzzer mit Pin 1 verbunden ist, können keine 28 bzw. 32pol ICs getestet werden.


    Möchte man dann wieder einen IC testen, der diesen Pin verwendet, muss der Buzzer abgetrennt werden (z.B. per Schalter) UND der Hack im Menü deaktiviert werden!

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • du bist ja richtig fleissig - ich bereue immer mehr, dass ich momentan nicht wirklich "kaufkräftig" bin - sonst würde mich das Projekt auch so langsam interessieren

    ..mal sehen, wie es in einigen Wochen aussieht

  • Shadow-aSc Keine Eile, ich habe immer noch ein paar Platinen übrig. ;)

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Heute habe ich es endlich mal geschafft meinen Tester aufzubauen. Jetzt benötige ich Schützenhilfe was das Flashen anbelangt. Ich denke das ich richtig nach Anleitung vorgegangen bin, bekomme allerdings in avrdude Fehlermeldungen angezeigt.



    Ich benutze einen relativ betagten USBASP Clone. Alternativ habe ich noch einen TL866 mit ISP Anschluß hier. Jemand eine Idee was ich falsch mache bzw. was ich ausprobieren kann?

  • Ich habe keine Erfahrung mit dem USBASP. Die Firmware von dem ist aber Uralt, d.h. da gab es noch kein Windows 10 etc.


    Unter https://forum.arduino.cc/index.php?topic=415210.0 habe ich folgendes gefunden:


    • Plug in USBasp
    • Download Zadig from http://zadig.akeo.ie
    • Start zadig
    • Options > List all devices
    • Select USBasp from the drop down menu
    • Select libusbK(v3.0.7.0) driver
    • Click Install


    Open device manager and check that the USBasp is installed successfully.

    Then make sure to use libusbK not libusb-win32.

    I had this problem because I was using the win32 driver. Replaced and it worked!


    K.A., ob das funktioniert. Wenn du in der Nähe von Bottrop wohnst, kannst du aber gerne zum Programmieren vorbeikommen.


    Gerade noch etwas gefunden:

    https://www.mikrocontroller.net/topic/425712

    und

    https://www.avrfreaks.net/foru…no-such-file-or-directory


    Da sind so viele Einträge von Anwendern die Probleme mit USBASP haben, da braucht man schon eine Suchmaschine , die in den Ergebnissen sucht ;)

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Wie ist denn Dein Aufruf?


    Er meckert ja folgendes an: avrdude.exe: error: usbasp_transmit: No such file or directory


    Gibt es die Datei usbasp_transmit bzw. das Verzeichnis?


    Der TL866 sollte eigentlich auch gehen.

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Als usbasp_transmit sollte vermutlich die Firmwaredatei zu sehen sein.


    Das Setzen der Fuses sollte wie folgt funktionieren:

    avrdude.exe -C"avrdude.conf" -v -patmega2560 -cwiring -PCOM5 -b115200 -D -U lfuse:w:0xff:m -U hfuse:w:0xdf:m -U efuse:w:0xff:m

    oder

    avrdude.exe -C"avrdude.conf" -v -patmega2560 -cstk500 -PCOM5 -U lfuse:r:-:i -U hfuse:r:-:i -U efuse:r:-:i


    Bei USBASP sollte eigentlich "-cusbasp" klappen. Ich würde es an deiner Stelle aber auch einmal mit -cwiring probieren, wenn ein USB2Serial-Treiber installiert wurde.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • Gibt es die Datei usbasp_transmit bzw. das Verzeichnis?

    Nein, die gibt es nicht.


    Der TL866 sollte eigentlich auch gehen.

    Ich habe es versucht, allerdings finde ich keinen 2560 in der Bauteileliste


    Bei USBASP sollte eigentlich "-cusbasp" klappen.

    Die Verbindung klappt auch mit diesem Aufruf, dennoch mit Fehlermeldung. Ich denke das Ding ist einfach zu alt



    Wenn du in der Nähe von Bottrop wohnst, kannst du aber gerne zum Programmieren vorbeikommen.

    Danke für das Angebot, von Osnabrück aus sind das aber ein paar Kilometer. Und bei der Menge an Firmwareupdates ...



    Edit:

    Ich habe mir jetzt ein Diamex direkt beim Hersteller bestellt. Wenn es damit nicht klappt gehts in die nächste Runde.

  • Ich habe mir jetzt ein Diamex direkt beim Hersteller bestellt. Wenn es damit nicht klappt gehts in die nächste Runde.

    Den Diamex setze ich selbst ein, der ist sein Geld wert.

    Es sollte dann ausreichen die beiliegenden Batch-Dateien zu starten.

    Erklärung gem. "§ 6 Übertragung von Nutzungsrechten" Abs. (1) der Nutzungsbedingungen:

    Hiermit erkläre ich, dass alle meine Postings mit deren Inhalten nicht der Creative Commons License (CC BY-NC-SA) unterliegen. Ich räume diesem Forum jedoch für meine eigenen Inhalte deren Veröffentlichung bis auf Widerruf ein.

  • slabbi Du kannst Dich noch daran erinnern, dass ich den gleichen Mist mit dem USBasp durchgemacht habe und mir dann auch den Diamex bestellt hatte? ;)

    Damit funktioniert es garantiert.

    Viele Grüße
    Thomas


    - WiC64 - The Commodore 64 Wireless Interface -> Homepage

    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de