Webserver auf einer 4000VLC mit SCSI2SD

    • Official Post

    Hallo!


    Meine Retroseite soll in Zukunft auf einer VAXStation 4000VLC gehostet werden.


    Ich möchte hier die folgenden Schritte in den nächsten Tagen posten:

    1. SCS2SD V5.1 konfigurieren

    2. OpenVMS 7.3 installieren

    3. Lizenzen eintragen

    4. TCP/IP installieren und konfigurieren

    5. Unzip laden und nutzen

    6. WASD installieren und konfigurieren


    Das Test Resultat dürfte dann so aussehen:



    Links die Webseite bereitgestellt von WASD und rechts veranschaulicht die home.html.


    WASD ist ohne SSL übersetzt da noch haproxy vorgeschaltet wird.


    Ich möchte nicht unerwähnt lassen, dass ich mit SCSI2SD immer mal wieder Probleme habe. Ich denke aber, es liegt an dem internen Anschluss der 4000VLC. Der scheint eine Wackelkontakt zu haben. Dazu mehr später. Extern läuft der Adapter.


    Bzgl. SCSI2SD habe ich drei RZ29B konfiguriert und eine RZ26L. Das läuft ab VMS 6.2 aber nicht mit 5.5! Diese mag die RZ29 so gar nicht!

    Das Backup Utility welches von der Installations CD gebootet wird braucht dringend eine detaillierte Einstellung der Sektoren. Das passende XML für die RZ29B-VA und RZ26L poste ich. Später auch für die RZ23 und RZ28.


    Morgen folgen die ersten Inhalte zum SCSI2SD.


    Gruss

    Peter


    Der glücklich ist, dass der Webserver läuft!

    • Official Post

    Zu Punkt 1, SCSI2SD V5.1 konfigurieren:


    Die 4000er läuft seit gestern Abend wieder durch nachdem ich das SCSI2SD in ein externes Gehäuse gepackt habe. Zusammen mit dem CD-ROM zur Installation. Ich bin mir sicher, das der interne 50 polige SCSI Stecker eine Macke hat. Die RZ23L die dort vorher dran war lief auch nicht. Die Aussetzer des SCS2SD waren auch immer unterschiedlicher Natur. Gestern hatte ich das SCSI2SD mal ein wenig bewegt und kurz darauf zeigte das PKA0: hunderte Fehler und das VMS stürzte ab.


    Im SCSI2SD steckt eine Class10 MicroSD über einen Adapter. Die 16GB sind aufgeteilt auf vier Devices:

    RZ29B, ca. 4GB

    RZ29B, ca. 4GB

    RZ29B, ca. 4GB

    RZ26L, ca. 1GB

    Eine RZ29B ist die Hauptplatte mit OpenVMS 7.3 und dem WASD Webserver DKA300. Eine enthält ein VMS 6.2 DKA200 und die kleine ein VMS5.5 DKA400. Das VMS 5.5 lässt sich aber nicht booten, ich benötigte das für die Wiederherstellung von Lizenzen. Dazu aber später mehr.


    Das SCSI2SD ist auf nicht terminiert gesetzt da es in einem externen Gehäuse mit Abschlusswiderstand steckt.

    SCSI2 Mode habe ich nicht zum laufen bekommen und ist daher deaktiviert. Das schaue ich mir später an wenn ich einen weiteren SCSI2SD bekomme.


    Parity muss zwingend aktiviert werden.


    Hier die Boardconfig:


    • Official Post

    Nun zu den Platten!


    Man kann sich die Sektoren der Platten ausrechnen und ins GUI von scsi2sd-util.exe eingeben. Hier kann man aber keine detaillierte Plattenstruktur eingeben. Das geht nur direkt im XML welches das Tool beim speichern erzeugt.

    Die Firmware hat die Platten auch ohne diese Details sauber gelistet aber beim Boot der OpenVMS 7.3 Installation CD wurden alle Devices als nicht erkannt markiert.

    Mein Ziel war es daher, dass alle Platten im VMS zu 100% wie eine Originale angezeigt wird.


    Hier die Konfig zu einer RZ29B als SCSI Device #1, DKA100:


    Wichtig: Sektorstart ist <0> da es das erste Gerät auf der SD Karte ist!


    • Official Post

    Und hier die RZ26L als SCSI Gerät #4, DKA400:


    • Official Post

    Da es mein Ziel war einen Webserver zu installieren habe ich mir als erstes die Minimalkonfiguration angeschaut.


    WASD braucht natürlich einen TCP/IP Stack und mindestens OpenVMS 7.0 oder höher. TCP/IP läuft nur auf Systemen mit mindestens 24MB physikalischen Speicher laut Unterlagen.

    Die 4000VLC kann max. 24MB Speicher und passt daher so gerade noch auf die Minimalkonfiguration.

    Ohne DECNet und anderen Firlefanz sieht die Speicherauslastung im Betrieb sehr gemütlich aus.


    $show sys

    "_TNA3:" ist meine Telnet Sitzung

    "WASD:80" der Webserver


    $show mem /full


    Das Swapfile ist nicht in Nutzung, ein Zeichen für ein nicht wirklich belastetes System.

    • Official Post

    Die Installation von VMS 7.3 ist recht einfach. Der Krux liegt beim Installationsmedium oder dem Zuspieler.

    Mit einer .ISO und der richtigen Software lässt sich gut eine CD brennen. Ich habe die mit ImgBurn unter Windows10 gebrannt.

    Mein Download kam entpackt als .img und ich habe es in .iso umbenannt und gebrannt.


    Beim CD-ROM Laufwerk als Zuspieler kennt VMS keine Gnade. Ich habe ein RRD43-AA verwendet. Ein Toshiba XM-4101B. Andere 512Byte/Sector können, müssen aber nicht gehen.


    Hinweis: In diversen Foren wird ISO/ISO9660 häufig mit einem Filesystem assoziiert. Das ist natürlich falsch. Versucht das .ISO mal auf Windows oder Linux einzubinden ;) Es ist ein .ISO aber mit dem Filesystem können beide OS nichts anfangen ...


    Hier ein Link zum Installations-Manual:

    http://h30266.www3.hpe.com/odl…vmsos73/6629/6629pro.html


    Wenn die VAX auf der Console alle nötigen Devices listet, einfach die Installation von der CD starten.


    In meinen Fall ist das CD Laufwerk DKA500:


    Also:


    $boot dka500:


    Das startet ein Standalone Backup von der CD.


    Nach Eingabe von Datum und Uhrzeit einfach nur noch das VMS073.b Saveset auf die Systemplatte "entpacken". Meine Systemplatte ist die DKA300:


    DKA500: CD-ROM

    DKA300: Systemplatte


    $backup /Image /verify dka500:vms073.b /save dka300:


    Wenn das durch ist wird das System angehalten: Halt Knopf drücken.


    Dann die neue Systemplatte booten:


    $boot dka300:



    Voila!

    • Official Post

    Eine kleine Hilfe falls es mit dem booten des Image nicht gehen sollte: Einbinden in simh und dort prüfen ob es bootet. Wenn ja, dürfte es eher am Zuspieler der VAX liegen.


    Wie man simh einfach und schnell als Docker Container lädt hatte ich mal hier beschrieben:


    VAX3900 Emulation unter SimH in einem Docker Container


    Zum Beispiel in der vax.ini:


    set rq3 cdrom

    attach -r rq3 /path/OpenVMS_VAX_7.3.iso


    einpflegen und versuchen von dua3: zu booten.

    • Official Post

    Zurück zur SCSI2SD Geschichte:


    Ich habe auch im externen Gehäuse den Adapter nicht arretieren können, gleiche Problem wie intern in der VLC.

    Habe dann den Verkäufer angeschrieben da mein zweiter Adapter diese Probleme nicht hat.

    Der Adapter wurde sehr kulant getauscht und der Ersatz läuft jetzt einwandfrei.

  • Toshi nicht Element der Menge der (Retro-)Gamer (als noch mit Tastatur gespielt wurde)?


    Schroeder wenn sich nun alle über den Exkurs in die Tastatur ergötzt haben, lösche am Besten diese Nachrichten ;)