Atari Festplatte vorm Wertstoffhof gerettet

  • Hallo, ich habe heute eine Vortex Festplatte vorm Wertstoffhof gerettet.

    Hier ein paar Bilder:


    Soweit, so gut. Wenn ich die Platte an den Strom hänge, blinkt die rote LED ein paar Mal und man hört eine relativ lautes Brummen - aber kein Anlaufen einer Festplatte! Ich habe auch eine andere Festplatte testweise angeschlossen, derselbe Befund!

    1. was kann ich tun?

    2. was muss ich beim Atari installieren, um später die Platte nutzen zu können?

  • Ich habe keinen Atari mit Platte, daher unter Vorbehalt: Du brauchst zumindest einen Plattentreiber bzw. ein Tool, was die Platte im System "anmeldet". HUSHI ist da einer, und hddriver ist wohl die 'moderne' all-in-one Lösung https://www.hddriver.net/de/ , allerdings pay-ware. Es gibt aber eine Demoversion.


    Das Brummen kann entweder die nicht loslaufende Platte oder einfach nur das Netzteil sein. Kann man rausbekommen, wenn man da einfach mal das Stromkabel von der Platte selbst abzieht.

    Das es einfach nur eine SCSI Platte mit "Zussatzplatine" ist, braucht man dafür auch keine Atari, um zu testen, sonder kann die HDD vermutlich auch direkt in einem PC testen, natürlich dann befreit von dem Adapterplatinchen.


    Was manchmal alte Platten haben, ist, daß sie ein Startkommando zum Hochfahren erwarten, wenn das nicht kommt, dann läuft sie halt nicht an. Könnte der Grund sein, daß da nichts losgeht. Aber Achtung: Das sind auch genau die Platten, die man am Ende manuell "parken" muß, man sollte also vorher gucken, ob das Testsetup auch das kann.

  • Krass!


    Ehrlich gesagt bin ich doch etwas verwundert, dass solche Sachen immer noch auf den Wertstoffhof landen.

  • Der Treiber egal welcher muß laufen. Ich kann mich dunkel erinnern, daß man den - keine Ahnung wlechen ich da hatte - in einen Auto Ordner gelegt hat und außerdem mußte man mal irgendwann noch ein Laufwerks Icon manuell für C anlegen. Das muß mit der dektop Datei gespeichert werden und Anklicken funktioniert natürlich nur, wenn der Treiber an ist. Icon anlegen macht man oben über die Menu Leiste ganz rechts.


    Vermutlich gibt es für die Vortex Laufwerk eine Diskette, die zum Lieferumfang dazugehörte. Wahrscheinlich wäre es das einfachste, sich exakt diese im Netz zu suchen. Das erspart einem jede Menge Ärger mit basteliger Software aus anderen Quellen.

  • Wenn ein Treiber auf der Platte installiert ist, sie eingeschaltet wird, komplett hochgefahren ist und dann der ST eingeschaltet wird, bootet der ST automatisch von der Platte. 8-) Falls kein Treiber auf der Platte installiert sein sollte, dann tut's auch eine Bootdiskette mit dem entsprechenden Treiberprogramm im "AUTO"-Ordner: Platte einschalten, komplett hochfahren lassen (Platten LED blinkt nicht mehr), ST einschalten und entsprechende Bootdiskette ins Floppylaufwerk legen. Der Treiber wird geladen beim Booten und man kann die Festplatte dann unter dem Menü "Extra" --> "Laufwerke anmelden" sich herholen. Der Laufwerksbuchstabe sollte dabei groß geschrieben werden und man sollte mit "C" anfangen. Jede weitere Partition (sofern vorhanden) kann man sich dann darüber holen.

  • Ok, dann bräuchte ich zunächst also eine Bootdisk mit dem entsprechenden Treiberprogramm, gibts die im Netz?

    Bootet der ST nicht automatisch von der Platte?


    Das mit dem Treiber ist so 'ne Sache. Kommt drauf an, welcher Treiber zum Einrichten der Platte genutzt wurde. Für die Vortex Platten gab es einen eigenen Treiber:

    http://www.atarimuseum.de/download.htm


    http://www.atarimuseum.de/downloads/treiber/VORTEX_HD.zip

  • Mehr Infos zur Vortex HD 20 und den dazugehörigen Treiber gibt's hier:


    http://www.stcarchiv.de/stc1987/04/vortex-hd


    Und aus dem angehängten PDF lassen sich sicherlich auch noch ein paar Infos ziehen. :)

  • Vielen Dank! So, die Platte hängt am Atari ST 1040 Stf. Hab sie eingeschaltet, das Brummen ist wieder da, 20 sek gewartet und den Atari ST eingeschaltet....und....... schade er bootet nicht von der Platte! Zeigt nur A und B an, die Platte blinkt 4x dann Pause und dasselbe immer wieder... falls das ein Code ist (?), wie gehe ich am sinnvollsten weiter vor. Ich hatte noch nie ne Platte am ST, hab den in den 90ern immer nur für MIDI genutzt....

  • Ohne gemessen zu haben, dann wurde doch aber die von der Platine der Festplatte abgehende rote LED nicht blinken, oder?

    Übrigens: das Blinken ist: 1x kurz, 3x lang....

    Was das Blinken angeht: Wenn es sich um einen Fehlercode handeln sollte, musst Du mal schauen, welche Festplatte in dem Vortex-Gehäuse verbaut wurde. Dann google oder Co. bemühen und die entprechende Anleitung suchen. ;)

  • Es gibt Neuigkeiten, ich hab die Daten vom oben genannten Link zur Vortex auf eine Diskette gemacht , dann die Platte angemacht, dann den Atari mit eingelegter Disk, siehe Bilder:

    Hier erst mal die Daten meines Ataris.

    Das kam nach dem Booten von der Disk. Dann nach dem Tastedrücken:

    Er zeigt zwei Partitionen an, wenn ich drauf klicke kommt das:


    Und nun?


    Noch zwei Fakten:


    Die Zusatzplatine wird beim Betrieb richtig warm und der Lüfter dreht nicht.

    Die LED blinkt unermüdlich 1x kurz und 3x lang....


    Bin für weitere Tipps dankbar

  • Hast Du einen Spannungsmesser ? Damit sollte man mal die Spannungen messen - wo Toast_r oben schon vorgeschlagen hat.


    Der Lüfter dreht bei solch alten Gehäusen eigentlich auch permanent und ist normalerweise noch nicht temperaturgeregelt.


    Wenn die Spannungen OK sind - 5V an rot + schwarz und 12 V an gelb + schwarz am Anschlußstecker an der Platte, dann würde ich als nächstes mal noch vorschlagen, mal die Vortex Doku suchen zu gehen, z.B. bei dev-docs.org oder bei archive.org. Die soll nämlich laut dem oben verlinkten Testartikel sehr gut sein. Außerdem findet sich da auch noch, daß der original Treiber VHDT.PRG heißt. Den kann man auch noch suchen. Ansonten kannst Du auch mal nach AHDI gucken - aber egal welcher, primär muß wohl erstmal die Platte anlaufen.


    Rein prinzipiell kannst Du, wenn Du sowas da hast, die Platte wohl auch mal probehalber durch eine andere SCSI Platte ersetzen. Das kann sich allerdings auch als komplex erweisen, weil man am Atari "Parity" beachten muß, wobei möglicherweise das genau das ist, was die große Zusatzplatine macht. Ist also eher was, wenn alles ander nicht geht.


    Wenn Du einen Bastel-PC hast, ist eine Option die Platte - und nur diese - also ohne Anbauplatine und abgekopplet von ihrem Netzteil - einfach mal da ma Netzteil anzuschließen, und zu schauen, ob sie hochläuft. Wenn ja, weißt Du eigenlich auch, daß dann irgendwas mit dem Netzteil in dem Vortex Gehäuse kaputt ist.


    Anschließend muß man dann aber die Platte sehr vorsichtig behandeln, weil der Kopf nach dem Abschalten dann natürlich nicht geparkt ist !



    und da noch ein anderer Treiber - wobei der Vortex HDPlus wahrscheinlich schon der passendere ist.

  • $13 also Bootsektor anlegen? Platte ist also nicht formatiert?

    Kann durchaus auch sein. Da sollten aber auf der Diskete mit dem Treiber (HDPlus) noch andere Programme drauf sein - u.a. sicher eines zum Formatieren.


    Die Laufwerke, die angezeigt werden, sind beim Atari eher so eine Art Icon als Platzhalter. Die legt man an und nur wenn der Treiber auch läuft passiert beim Draufklicken was. Die Information dazu sollte in der Datei desktop.inf stehen, die an sich auch auf der Diskette sein muß. Der Treiber selbst liegt im AUTO Ordner, denn er startet ja anscheinend automatisch, wenn die Diskette eingelegt ist. Wenn nun aber die Platte nicht formatiert/partitioniert ist, macht auch die Fehlermeldung Sinn, daß er eben keine Platte findet.


    Guck halt mal ob Du eine README auf der Diskette findest oder ein FORMAT Programm.



    Wenn das FORMAT Programm fragen sollte, ob es den Treiber auf Platte installieren soll, dann auf JA klicken - dann kann man sich später das Laden von Diskette schenken, sofern es klappt.

  • diese alten Festplatten "fressen" sich gern fest - da war neulich schon ein ähnlicher Thread:

    MFM Festplatte 20MB


    laut der Aussage dort kann man den Plattenmotor vorsichtig per Hand andrehen, bis das Lagerfett sich wieder bissl verteilt - wenn du beim Einschalten lediglich ein Brummen hörst, würde ich sagen, du solltest die Platte erstmal anwerfen

  • Das mit dem Platte andrehen kam von mir.
    Dazu brauchst aber eine Platte wo du von unten, unterhalb der Platine an den Motor ran kommst. Siehe Bild hier: MFM Festplatte 20MB, #66


    Aber wie weiter oben bereits gefragt, bitte die 12V prüfen.
    Obwohl wenn sie auch am PC-Netzteil nicht läuft, dann ist sie entweder "ganz defekt" oder der Motor hängt bzw. ist "verklebt". Bei jemand anderem hat es geholen, den Schriitmotor für die Kopfbewegung vorsichtig zu verdrehen. Das geht natürlich nur so ein Schrittmotor vorhanden und von Außen zugänglich ist.


    mfG. Klaus Loy

  • Jetzt muss ich mal hier einmischen, weil es ja scheinbar trotz hilfreicher Tipps nicht vorran geht...



    Der Plattentyp ist bekannt und selbst auf der Vereinshomepage dokumentiert. https://th99.classic-computing.de/h/txt/3767.txt Tante Google findet das selbe dann nochmal hier https://stason.org/TULARC/pc/h…21MB-3-5-HH-SCSI1-SE.html


    Es wurde schon angeregt, das Netzteil des Festplattengehäuses durchzuchecken. Das sollte unbedingt getan werden. Dass der Gehäuselüfter nicht dreht, kann nämlich in der Tat ein Indiz dafür sein, dass das Netzteil keine 12V liefert, oder wenigstens irgendwo in der Verkabelung der Spannungsverorgung ein Wackler ist. Es kann natürlich auch der Lüfter defekt sein.


    Und ohne 12V startet so eine Platte auch nicht und blinkt mit etwas Glück freudig Fehlercodes.


    Code
    Indicator ---------
    The drive has a single LED visible through the front facia, designated LED1. This LED will only be on when the drive is selected, otherwise it will be off. At the end of the power-up routine the LED will remain off.
    This LED is also used to flash fatal error messages should such fault conditions exists on the drive.

    Leider sind da keine Fehlercodes beschrieben, wird man wahrscheinlich auch nicht mehr finden.


    Dan allgemein zum Atari und Festplatten.


    Der ST (usw.) kann von einer Platte booten, wenn

    - die Geräte miteinander richtig verbunden sind. Bei vielen Platten gibt es gleich zwei DMA-Anschlüsse, einer ist mit "In" und der andere mit "Out" beschrifttet, das muss man schon richtig machen

    - die Platte keine Fehlercodes dauerhaft blinkt, siehe oben. (Megafiles und SH-20x und ähnliche ACSI-zu-MFM-Platten müssen anfangs erstmal ihre Konfiguration von der Platte einlesen und blinken und rattern dabei freudig rum, beruhigen sich dann aber und warten geduldig bis was am Bus passiert.

    - man den ST einschaltet, nachdem sich die Platte "beruhigt" hat. Es sei denn man hat TOS 2.06, TOS 3.06 (TT) oder 4.0x (Falcon); da ist nämlich eine Wartefunktion eingebaut, wo der Rechner erstmal genüsslich Speicher testet und anschließend noch eine Warteschleife mit immer kürzer werdendem Balken anzeigt. Man kann da natürlich jederzeit eine beliebige Taste drücken, und dann gehts los, es sei denn man hat der Platte nicht genug Zeit gegeben.

    - Der Festplattentreiber auf der Platte installiert ist. Denn der ST hat da nur einen Mnimalcode im ROM, der lediglich den ersten Sektor der ersten gefundenen Platte ausleist und wenn er da gültigen Programmcode findet, den ausführt, das ist dann hoffentlich der Urloader für den Plattentreiber, der als Datei im Rootverzeichnis der Platte (z.B. als ahdi.sys oder hddriver.sys) liegen muss. (Diese Datei dort also nicht weglöschen, wenn man die da findet).


    Letzteres ist eine Prozedur, die man manuell beim Neu einrichten der Platte durchführen muss. Man kann das mit dem HDPlus machen, aber da der nirgends dokumentiert ist, empfiehtl es sich für einen Anfänger, es erstmal mit einem dokumentierten Plattentreiber zu machen. Das wäre zum einen der käuflich zu erwerbende HDDRIVER (kostet aktuell 40€) oder eben der originale AHDI von ATARI, denn für den gibt es eine mühsam zusammen gestellte Online-Anleitung, die sich speziell an Einsteiger richtet.


    Dabei gillt: JEDE Platte am ST/TT/Falcon lässt sich grundsätzlich mit dem AHDI von Atari zum Laufen bekommen, außer sie ist zu groß (oder es ist die c't Billiglösung mit OMTI-Controller). Auch die Vortex, denn die müssen grundsätzlich alle zum Booten AHDI-kompatibel sein. Und "zu Groß" heißt da, Laufwerke ab 1GB (was ACSI normalerweise maximal adressieren kann), auch da fällt die Rodime sicherlich nicht drunter. Größer geht, wenn man HDDRIVER und passende Hardware hat, sprich, einen ICD-kompatiblen ACSI-zu-SCSI Hostadapter, der von Vortex gehört sicher nicht in diese Kategorie, oder einen TT oder Falcon mit SCSI, oder einen Falcon oder ST-Book oder einen entsprechend nachgerüsteteten TT oder ST/STE mit IDE-Interface.


    Daher, sofern die hardwareseitigen Grundvorraussetzungen, siehe oben (richtige Verkabelung, Platte meldet keine Fehler sondern fährt sauber hoch) gegeben sind, kann man mit der Platteneinrichtung loslegen.


    Ich verlinke hier mal die AHDI-Anleitung von Michael Bernstein, die ist gut verständlich und erklärt Schritt für Schritt, wie man vorgeht. Wer das schonmal unter MS-DOS gemacht hat, wird einige Ähnlichkeiten dahin entdecken:


    - Bei MFM/RLL-Platten erstmal Lowlevel formatieren (bei SCSI und IDE nicht notwendig!), vergleiche beim PC mit dem debug.exe in das Plattencontroller-BIOS springen und das dort machen.

    - Partitionieren (fdisk)

    - Partitionen formatieren (vergleiche "format c:)

    - Festplattentreiber installieren (vergleiche fdisk Partition aktivieren, MBR schreiben, Sys c;)

    - erstmalig davon booten, und dann die zusätzlichen Partitionen als Laufwerke anmelden und "Arbeit sichern" damit die Icons für die Laufwerke mit dem Desktoplayout in der DESKTOP.INF bzw. NEWDESKINF gesichert werden (da gibts keine vergleichbaren Schritte auf dem PC)


    Die Schritte lassen sich alle mit den Tools auf der AHDI DIskette durchführen. Dazu muss der ST von dieser Diskette booten, damit er aus dem AUTO-Ordner erst mal den Plattentreiber von Diskette lädt (AHDI.PRG).


    Da gehts lang: http://www.mbernstein.de/atari/system/hd/ahdi.htm


    Mit anderen Plattentreibern, gehts wie geschrieben im Prinzip genauso. Nur wenn man es noch nie gemacht hat, sollte man es erstmal mit AHDI oder HDDRIVER machen, weil man da einer existenten Anleitung folgen kann. Zur Auswahl hat man dann neben AHDI und HDDRIVER, den HDPlus, CHBD (Scheibenkleister), Hushi, SCSI-Tools, ICD, und viele weitere Treiber, die alternativ genutzt werden könnten, aber alle ihre eigenen Vor- und Nachteile haben. Und bei jedem sehen die Installations- und Verwaltungsprogramme anders aus, machen aber letztlich alle das gleiche. Manche dieser Plattentreiber funktionieren nur richtig, wenn sie herstellereigene Hostadapter erkennen, ansonsten fehlen z.B. wie beim ICD der Schreibcache. Sonderausnahme ist die schon erwähnte c't Billiglösung, die ist sehr speziell und zu nichts kompatibel...

  • So, es gibt Neuigkeiten, der Lüfter läuft! Ich schalte also zunächst die Platte ein , 15 sec später den Atari und lasse ihn von der Disk Booten. Jetzt erscheint das Bild von gestern nicht mehr, stattdessen vernehme ich von der Festplatte ein klak-klak, dann fährt der ST hoch, zeigt zwei Bomben, dann aber dasselbe wie vorher. Will ich jetzt das HD Plus Programm laden um die Festplatte zu initialisieren oder zu formatieren, bekomme ich wieder die zwei Bomben und er bricht das Laden ab..... und nu?

  • Der kann die Daten auf der Platte nicht lesen, irgendwas ist da im Bootsektor, was er nicht mag. Versuche folgendes.


    Besorge dir den AHDI 6.x und entpacke den auf eine Diskette, vergiss den HDPlus, den brauchst du nicht. Letzte Version: http://www.atarimuseum.de/downloads/treiber/ahdi6061.zip


    - Platte aus

    - Rechner ohne Diskette starten, warten bis er am Desktop ist

    - Festplatte einschalten und warten, bis sie bereit ist

    - Diskette einlegen

    - Diskette öffnen - ACHTUNG KEIN RESET MACHEN

    - AUTO-Ordner öffnen

    - AHDI.PRG oder SHDRIVER.PRG (oder wie auch immer das heißt), manuell durch Doppelklick starten

    - Nun nach der Anleitung von Michael Bernstein vorgehen, ab dem Punkt wo partitoniert wird. Das heißt:

    - HDX.PRG aus dem HDX Ordner starten.

    - Hier weiter machen, zum partitionieren/formatieren: http://www.mbernstein.de/atari/system/hd/ahdi.htm#part

    - wie dort beschrieben nach dem Partitionieren Reboot, AHDI von Diskette booten

    - HINSTALL starten, Treiber installieren http://www.mbernstein.de/atari/system/hd/ahdi.htm#install

    - usw.