CPC 464 defekt??? HILFE !!!

  • Hallo Leute !
    Ich habe Heute einen CP464 bekommen.
    Ich habe das Gerät an meinen GT65 angeschlossen. Es kommt zwar ein Bild mit Rand, aber alles leer ... ich meine keine Zeichen auf dem Bildschirm! :shock: Was ist das Problem??? Könnt Ihr mir helfen??? :(


    Nette Grüße


    Maik

    "Aus dem Esel macht man kein Reitpferd; man mag ihn zäumen, wie man will."

  • Mhh...mach´ doch mal ein Foto und stelle es hier ein.


    Du kannst ja auch mal den Compi öffnen und die gesockelten Chips vorsichtig festdrücken. Vielleicht sind es nur Kontaktprobleme.
    (Weiß jetzt gar nicht mehr, ob nur die Z80 gesockelt war...)

  • Quote from "Octoate"

    Bild waere schon nicht schlecht...
    Piept denn der CPC wenn du auf Backspace drueckst (Lautstaerkeregler hochdrehen)?


    Probier ich heut Abend. Bilder folgen!!! :)

    "Aus dem Esel macht man kein Reitpferd; man mag ihn zäumen, wie man will."

  • Quote from "viddi"

    ...Du kannst ja auch mal den Compi öffnen und die gesockelten Chips vorsichtig festdrücken. Vielleicht sind es nur Kontaktprobleme.
    (Weiß jetzt gar nicht mehr, ob nur die Z80 gesockelt war...)


    Nur zwei Chips sind gesockelt, unter anderem die CPU. Die habe ich schon angedrückt, daran liegt es aber leider nicht :cry:
    Bilder folgen noch! :)

    "Aus dem Esel macht man kein Reitpferd; man mag ihn zäumen, wie man will."

  • So, hier mal die Screenshots! :( und er piept nicht wenn ich Backspace drücke... Blind ein Tape laden funktionierte auch nicht... :cry::cry::cry:

    "Aus dem Esel macht man kein Reitpferd; man mag ihn zäumen, wie man will."

  • Sieht nach dem Z80 aus.
    Kommt mir bekannt vor.
    Z80 mal austauschen.
    GateArray müsste OK sein, weil ja noch der BORDER dargestellt wird.


    Handelsüblicher Zilog Z80 passt.


    Defekter CRTC sieht oft so aus wie in meinem Anhang
    (Border fehlt, nur 2 schwarze Streifen auf grauem Grund)

  • Hm, wenn der Z80 nichts machen würde, gäbs doch keinen Border, weil niemand den CRTC/Gate Array programmieren würde. Kaputten Z80 hatte ich übrigens noch nie...


    ROM kommt natürlich noch in Frage. Besonders gerne, wenn EPROMs im CPC stecken, die dann im Laufe der Jahre ihren Inhalt teilweise verlieren.

  • Ja das ROM kann es natürlich auch sein.


    Ich hatte schonmal einen defekten Z80.
    Da hatte ich ein ähnliches Problem.
    Allerdings mit blinkendem Border.
    Da hat auch nichts mehr reagiert.


    Für den Ur-CPC (mit den hohen Tasten) habe ich übrigens noch ein komplettes Board (funktionierend)
    Gern auch im Gehäuse, allerdings ist das Tape-Laufwerk nicht mehr so dolle...

  • Na, den Z80 kann man ja recht einfach austauschen. Gibts ja in fast jedem Elektronikgeschäft für ein paar Euro - wäre also ein Versuch wert.


    Bei allen schwerer zu diagnostizierenden Fehlern würde ich wahrscheinlich bei einem 464 den Aufwand nicht treiben und mir bei eBay günstig Ersatz beschaffen, wenn du nicht gerade an genau DIESEM CPC464 hängst.

  • Hy, auf jeden fall, wenn Ihr die Eproms oder andere Bausteine rausschmeischt, würde ich empfehlen die Pins abzuzwicken (nahe am IC) und an die dann nen Sockel zu löten.
    Beim CPC ist das Lötzinn mit einer etwas höheren Temperatur. Das heisst, wenn man das mit dem Löten nicht zu 100% kann (wozu ich mich inzwischen auch zähle) kanns passieren, dass die Platine bzw. Lötaugen dann etwas drunter leiden.
    (Dr. Zed und Nil bitte net schlagen, ich finds so persöhnlich einfacher, da bei einem wechsel einer Kaputten Buchse hab ich schliesslich zwei Leiterbahnen durch Kabel ersetzt weil ich da sowas von rumgebrutzelt hab... ;)