Probleme mit XT-CF Rev. 3 in Olivetti M19

  • Hi, ich hatte mir mal als Vorrat drei XT-CF 2b aufgebaut und hingelegt. Diese Variante des Controllers ist Low-Profile, und damit genau passend für den M19, der ja auch nur 2 Lowprofile-Slots hat. Außerdem habe ich einen dieser einst von Pollin für 2 Euro verschleuderten 128 MB DOMs von PQI dafür verwendet, und wollte das Ganze mit hilfe von dem originalen MS-DOS Version 2.11 der M19 installieren. So jedenfalls der Plan, aber momentan bin ich teils etwas ratlos ob des Ergebnisses:


    1. MS-DOS 2.11 kann offensichtlich nur eine Festplattenpartition verwalten, das 128er DOM damit in 4 32 MB Partitionen zu teilen geht nicht, aber hier kann ich auch auf das Olivetti-DOS 5 ausweichen, welches ich auf meinem M21, M24 usw. verwende. Das käme auch zugute, wenn ich mal den 8088 durch einen V20 ersetze, um ein ZIP-LW per Guest.exe anzusteuern - ok evtl. geht beim M19 auch der Palmzip-Treiber, den ich bei der M24 nicht zum Laufen bekomme. Da wäre also ein Lösungsweg vorhanden, aber.


    2. Ich kann den Flashbaustein mit xtidecfg nur einmal flashen? Rekonfigurieren und neu flashen klappt nicht. Eigentlich wollte ich versuchen, die unter 3 erfolgten Effekte damit zu tilgen. Aber leeres Flash zu beschreiben, XT-IDE-BIOS wieder auslesen oder von Disk einlesen, rekonfigurieren und wieder flashen klappt nicht, gibt immer einen Fehler.


    Erschwerend kommt allerdings dazu, dass xtidecfg.exe immer von einem Farbmonitor ausgeht, so dass ich z.B. immer nur den aktuell ausgewählten Menüeintrag lesen kann, der Rest erscheint immer Grün auf Grün, weil der Monitor nunmal monochrom ist. Auch wenn ich unter DOS erst Mode 80 für einen Mono-Monitor eingebe (mode mono versteht DOS 2.11 nicht), vermute ich dass in dem Fehlermeldungsfenster noch irgendwas wichtiges in dem grünen Feld drin steht. Ich sehe es aber nicht...


    Als Basisadresse des Flashs nehme ich c800h und als Flash-Typ den 32er, mit dem in xtidecfg auswählbaren 8, 16 oder 64kB chip klappt es nicht (den 2er habe ich erst garnicht versucht, der macht ja keinen Sinn). Aber der SST ist ja eigentlich viel größer. Als BIOS habe ich das ganz aktuelle verwendet.


    3. Zum eigentlichen Problem, weswegen ich versuchen wollte, den Controller zu rekonfigurieren. Es ist möglich, dass der M19 PC etwas zickig ist und damit Ursache des Problems. Aber irgendwie muss es doch gehen, denn diese XT-CF 2b brauche ich eben zum einen im M19, außerdem will ich mal versuchen, die Textverarbeitungssysteme ETV 260 und ETV 3000, welche ja auch auf dem M19 Mainboard basieren, damit auszustatten. Und diese Textverarbeitungssysteme sind nicht gerade wartungsfreundlich, etwa 50 (!) Schrauben, bis man das Mainboard unter den Abschirmblechen und dem Typenraddrucker herausgeschält hat... Ok, an die ISA-Slots kommt man einfacher dran, aber dennoch...


    Die Probleme wären:


    a) Der PQI DOM wird abwechselnd mal mit 128 oder 256 Zylindern erkannt. Je nachdem wie er gerade erkannt wird, lässt er sich auch partitionieren, mit einer Partition von 64 Zylindern, was dann den von DOS 2.11 maximal unterstützten 32 MB entspricht. Das biosdrvs.com Tool liest dann die Kapazität des DOMs richtig aus. Das könnte ein Problem von DOS 2.11 sein, hier könnte ich auf DOS 3.20 oder besser 5.0, alles auch Olivetti-branded, umsteigen.


    b) Mal kann ich partitionieren, Reboot, format c: /s, copy a:*.* c: und alles funzt, mal nicht, weil nach dem Reboot die angelegte Partition nicht mehr da ist, oder plötzlich eine 2. Partition mit 0 Spuren und Non-DOS da ist, und dann wieder werden mal 128 mal 256 Zylinder erkannt. Mir gelang es auch einmal nach einem Warmstart vom DOM zu booten.


    c) Wenn ich den M19 ausschalte, und wieder einschalte, ist keine Partition mehr da, manchmal erkennt das XT-IDE-BIOS nochwas und versucht davon zu booten und bleibt hängen, was auch wieder mit der alternierenden Erkennung der Kapazotät (128 oder 256 Zylinder) zusammen hängen kann.


    Hier wollte ich wie gesagt, verschiedene Parameter im XT-IDE Controller ausprobieren, aber ich kann ja nicht neu flashen...