IBM 5170 - Restaurationsthread

  • IBM-Fetischisten!


    Los gehts- der nächste Rechner ist dran. Ich hab ihn schon eine ganze Zeit- aber ohne die Tantalseuche zu beheben, schalte ich sowas sicher nicht ein. angst


    Das Netzteil hatte ich schon vor Monaten zerlegt, gereinigt und auf suspekte Bauteile geprüft.





    Dann wieder alles zusammengeschraubt und bis heute stehenlassen.

    Also- jetzt endlich erstmal ALLES aus dem Gehäuse raus:






    Hier warten über 50 Tantalkondensatoren... mir graust.

    Der MFM-Controller, sowie die MFM HDD sind sicher nicht original, der Rest hingegen schon.

    Interessanterweise passt die Platte, sowie der Controller dennoch zur Zeit, weil der IBM laut Stempel im Gehäuse von 1988(!) ist.



    Und kuckt mal, welch Schmankerl sich im Innern findet- eine echte IBM EGA Grafikkarte MIT zusätzlichem Speicher! :love:

    Fehlt nur der Feenstaub- ein 5154 EGA-Monitor, für den ich wohl mein Hirn geben würde. So muss eben der 5153 herhalten, die Karte kann man dafür umjumpern.

    Falls dennoch jemand einen 5154 abzugeben hätte- nunja... fragen kann ich ja mal. :)



    Das Gehäuse trocknet bereits auf der Heizung, allerdings war es so dunkel, dass ich die Bilder hierzu nachreichen muss.

    Lediglich eines gibts noch- für alle, die schmerzfrei sind:



    Richtig, ich habe nicht einen einzigen IC entfernt, bevor es in die Dusche ging.
    Kommt aber wohl alles danach noch- mir ist es so irgendwie lieber, dann werden die auch gleich vernünftig sauber.

    Das Mainboard wurde danach mit Isopropanol abgewaschen und sofort auf die heisse Heizung gestellt- wird schon schiefgehen, notfalls läge noch ein von Richi wieder reaktiviertes Board hier. :)


    Die Tage gehts weiter- das Gehäuse ist schonmal richtig schön geworden nach dem Vollbad. :)


    Viele Grüsse,

    Matthias

  • Viel Spass mit den Tantalkondensatoren.:evil: Bei meinem 5155 waren es "nur" ca. 40 Stück.

    Ob Reichelt wohl bald die Kondensatoren ausgehen? :/

    Ich habe noch 56 Stück hier- von der damaligen Restauration des 5150 und 5155.

    Eigentlich wollte ich mit dem Rest den 5160 UND den 5170 machen- wird aber nix werden. :D

    Ich mag die Dinger auch nicht nur im 12V-Zweig wechseln. Wenn, dann gleich ALLE neu.

    Das ist abernicht das original Netzteil. In meinem ibm Netzteil ist mindestens drei mal so viel drinnen ;)


    Christian

    Da hast du recht- und ich bin total froh drüber. :)

    Das Original ist ein Platinen- und Bauteilgrab. Von außen (Schalter) ist es aber für mich "nah genug" dran.


    Leider ist aktuell die Sonne nicht präsent, weshalb das Retrobright der Laufwerksblende warten muss.

    Andererseits hab ich mir überlegt, gleich ein 3,5"-Laufwerk zu verbauen. Mal sehen, ob ich eines finde, welches farblich und zeitgenössisch passen würde. Sonst bleibt's beim 5 1/4" einzeln. Verwendet wird der Riesenklumpen doch ohnehin nicht- wozu auch? :D

    Schön isser einfach.

    Welche Platten waren denn in diesen Teilen verbaut? Die Tandon war's nicht, soviel ist klar. Da es ein 88ger ist, hat IBM evtl. auch schon halbe Bauhöhe 5 1/4" verwendet- Seagate ST?

  • :(:motz:

    Dafür sammle ich nicht von jedem Gerät 482 Stück. :D

    Gibt ja hier im Verein auch Leute, welche fünf und mehr SX64 horten. Ich suche einen, müsste den dann aber zu 1000€ in der Bucht erwerben. :cry2:


    Sollte ich doch mal mehr Platz haben, werden die schönen Maschinen auch adäquat aufgestellt- versprochen! :saint:

  • ich erwähns gern nochmal: ich hab exakt 1 ..nochmal in Worten: EINEN C64 ...okok - ich hab noch nen Micro, nen Tube, ein Tuning-Board, nen Modular ..und jetzt neu nen ATX ...aber das sind ja auch alles "andere" Geräte :tüdeldü:


    und ich hab auch exakt 1 128D:saint:

  • CBM_Ba , um auf die eingebauten Festplatten zurückzukommen, bei meinem ist unterhalb der zwei 5,25 Zoll LW`s noch eine ST251 (halbe Bauhöhe) verbaut gewesen.


    Gruß Jens

    Hallo Jens,


    meinst du, die war von IBM original da drin?

    Leider ist meine 251er defekt- aber sowas lässt sich bestimmt noch irgendwo auftreiben. Und ich mag den Klang der alten Seagate unglaublich gerne. :)

  • Das lässt sich ggf. anhand der Modell Nummer ermitteln:


    https://www.pcjs.org/machines/pcx86/ibm/5170/

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • CBM_Ba , laut Aussage des edlen Spenders ist der PC aus erster Hand, und nur die Batterie wurde erneuert. Eine spezifizierte Modellnummer ist nicht zu finden (nur 5170), Baujahr 1983), HD-Controller ist für zwei MFM-HD + Floppy (Bj. 1983). Die erste HD ist eine Seagate ST4026 volle Bauhöhe. Was mich an der o.g. ST251 wundert, ist dass sie eine Frontblende mit LED hat. Dies macht mit dem Deckel und der originalen Front keinen Sinn.


    Mit freundlichen Grüßen Jens

  • Du meinst den Lärm. Klingt ja eher wie startender Düsenjet, wenn man das Ding einschaltet. ;)

    Dieser herrlich rauh-summende Ton des Plattenmotors in Kombination mit dem Stepper löst ungelogen Gänsehaut bei mir aus. :)

    Vor 27 Jahren gabs im Ort einen Second-Hand Computerhändler, von dem wir günstigst ein paar alte MFM-Platten nebst Controller kauften (die Platten waren damals schon antiquiert :D ). Erinnere mich noch genau, als wir die dann an einem alten 386 testeten.

    Seither liebe ich diesen Klang einfach. Für mich ist es der "typische" Festplattensound- SO müssen die sich anhören.

  • Burschen!


    Es ist zwar schon ziemlich weit mit meinem psychischen Gesamtzustand- SOWEIT jedoch auch noch nicht. :D


    Zurück zum 5170:

    Heute ist ausnahmsweise mal viel passiert- es gibt aber wenig Bilder (meistens so, wenn man wirklich produktiv ist).

    Der Rechner läuft wieder, nachdem die 50 Tantalkondensatoren durch Neuware ersetzt wurden. Ok, vielleicht lief er auch davor- wie ihr jedoch wisst, teste ich sowas ungern. :)


    Erster Testlauf nach dem TantalWAHN:


    Ich kann sie langsam nimmer sehen- wirklich ned:


    Und hier ist er dann reingewandert- in all seiner überholten Pracht- ins frisch gewaschene Gehäuse:


    Anschließend alles komplettiert und erneut getestet. Diesmal mit einem 5151 an der EGA-Karte, damit ich wenigstens ein Bild habe.

    Den 5153 schalte ich erst wieder ein, wenn dort die Elkos raus sind... Richi weiß GENAU, weshalb... :D

    Der Rechner hatte seine Einstellungen verloren (die Batterie war ja abgeklemmt). Also mittels der Original IBM PC/AT Diagnosedisketten alles neu eingestellt.

    Die Festplatte war anfangs ein wenig tricky, weil es sich ja um eine Tandon TMS 262 handelt, und nicht um ein IBM-Teil.

    Hier gab minuszerodegrees super Auskunft und schlug mir den Typ 6 vor. Volltreffer, der Rechner bootete von HDD.


    Was ist heut in Summe passiert:

    - Tausch aller Tantalkondensatoren (auch die sämtlicher Steckkarten)

    - Tausch der HDD-Led am Frontpanel (die alte war durchgebrannt- wohl, weil sie irgendjemand an +5V angeklemmt hatte?)

    - Einbau eines PC-Speakers (hat gefehlt, da muss ich mir aber noch eine Halterung konstruieren und drucken)

    - Reinigen/Schmieren des 1.2MB-Floppylaufwerks


    Was steht noch an:

    - Blende unterhalb des Floppylaufwerks retrobrighten

    - Bestände durchwühlen, ob sich ein farblich passendes 3 1/2"-Laufwerk finden lässt

    - Zusammenschrauben


    Ich mach die Tage Bilder, heute hab ich das irgendwie dezent unterschlagen (und andererseits kennen die Interessierten den 5170 ja ohnehin).


    Viele Grüsse,

    Matthias

  • CBM_Ba , laut Aussage des edlen Spenders ist der PC aus erster Hand, und nur die Batterie wurde erneuert. Eine spezifizierte Modellnummer ist nicht zu finden (nur 5170), Baujahr 1983), HD-Controller ist für zwei MFM-HD + Floppy (Bj. 1983). Die erste HD ist eine Seagate ST4026 volle Bauhöhe. Was mich an der o.g. ST251 wundert, ist dass sie eine Frontblende mit LED hat. Dies macht mit dem Deckel und der originalen Front keinen Sinn.


    Mit freundlichen Grüßen Jens

    Ich glaube zwar auch nicht, dass die Platte da original ist. Aber "unnütze" Frontplatten habe ich mitunter anderswo schon gesehen, sogar in meinem ersten IBM AT Clone vor 35 Jahren (Tandon 20MB/3.5"). Da wurde einfach eine "Standardplatte" produziert und überall hinein geschraubt, die Blende stört ja nicht.

  • Ich hab hier noch eine Control Data 43MB MFM liegen.

    Diese Platte hatte 1995 einen suspekten Defekt, im Innern war irgendein Plastikarm verkeilt, so dass sie nur noch laut klackerte und nicht mehr lief.

    Ich hab dann damals mit einer Kombizange(!) diesen Arm rausgebrochen (ich war ein 14 Jahre junger Bub) und die Platte danach mit TESAFILM wieder zugemacht (umwickelt, weil ich die Schrauben beim Aufmachen kaputtgemacht hatte).

    Und ihr werdet es kaum glauben- als ich sie vor einem Jahr wieder reaktiviert hatte, ging sie noch?! :D

    Also hab ich ihr neue Schrauben spendiert und sie wieder in einen Schub geräumt.

    Nunja- zeitlich würde sie gut passen, auch der Klang stimmt. Ob sie allerdings noch lange laufen würde, ist fraglich.

    Vielleicht versuch ich's die Tage mal- und berichte. :)


    Hier noch ein Bild einer vergleichbaren Platte (kann grad kein Bild von meiner machen):

    https://www.recycledgoods.com/…-43-mb-mfm-hh-hard-drive/


    Viele Grüsse,

    Matthias

  • Ja das stimmt- die Platten können wirklich was ab. Bei den 3,5“ern sieht’s da schon anders aus.


    Heute hab ich die Frontblende gebleicht, leider wurde sie leicht fleckig. Um nun Lackierversuche machen zu können, hab ich sie schnell nachkonstruiert- so kann ich schön spielen und mache das Original nicht kaputt:




    Falls die stl-Datei jemand brauchen kann, einfach melden. ;)

  • Vielleicht sollten wir mal eine Unterrubrik anlegen, wo STL Dateien abgelegt werden können. Allein die Sortierung wäre aber wohl etwas schwierig...


    Nachtrag: ich habe dazu mal einen Thread hinsichtlich Meinungsbildung angelegt...


    Verbleib / Sammlung von STL Dateien von Forenmitgliedern

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

    Edited once, last by tokabln ().

  • Burschen,


    der Rechner ist soweit fertig.

    Ich hab nach über 25 Jahren durch Zufall alte IBM Diagnose-Disketten gefunden, welche es mir ermöglichten, das Setup des 5170 auszuführen und nach Batteriewechsel alles wieder einzustellen.

    Die Disketten konnte ich nie gebrauchen- keine Ahnung, wo die überhaupt her kamen? :)

    Da sieht man mal: Hebt man's lange genug auf, macht es vielleicht doch ab und an Sinn.


    Eigentlich wollte ich dann ein 3 1/2"-Laufwerk verbauen (habe eines inkl. Adapterrahmen auf 5 1/4", welches farblich perfekt passen würde)- aber leider will der Original-Floppycontroller kein 1,44MB-Laufwerk haben. Und einen anderen Controller möchte ich ungern verbauen.

    Da ich den Rechner ohnehin nicht nutze, reicht auch das standardmäßig verbaute 1.2MB 5 1/4".

    Außerdem fehlte der PC-Lautsprecher gänzlich, weshalb ich einen passenden Halter konstruiert und gedruckt habe, um ihn verbauen zu können.





    Was man noch tun könnte/was noch zu tun ist:

    - Zeitgenössischere HDD verbauen (aktuell ist die 3 1/2" trotz ähnlichem Alter so etwas wie Frevel)

    - Monitor 5153 komplett recappen (hierzu hat Richi freundlicherweise bereits die Teile bestellt)


    Aktueller Stand:

    - Tastatur zerlegt, gereinigt

    - Rechner komplett recapped, gereinigt inkl. Mainboard, Steckkarten, etc...

    - Laufwerk gereinigt und gefettet


    Sauberkeit:



    Der 5151 passt einfach nicht auf den 5170, da muss das 5153-recapping bald starten! :)



    Wenn der Monitor angegangen wird, melde ich mich hier wieder.


    Bis dahin: Behandelt euren Altcomputerschrott, wie ich es zu tun pflege- als sei er ein Teil von euch! :)

    • Official Post

    Eigentlich wollte ich dann ein 3 1/2"-Laufwerk verbauen (habe eines inkl. Adapterrahmen auf 5 1/4", welches farblich perfekt passen würde)- aber leider will der Original-Floppycontroller kein 1,44MB-Laufwerk haben.

    Der FDC müsste problemlos mit 3,5" zurechtkommen, sowohl DD als auch HD.

    Wenn es da Probleme gibt, dürfte das eher am BIOS liegen.


    EDIT: Das stehts ja: http://www.minuszerodegrees.ne…s/5170_bios_revisions.htm

  • Hmm, ich scheine ein Typ 1 Motherboard zu haben- das neueste Bios sollte aber dennoch passen... müsste ich mal eins Brennen und erneut Testen.

    Kann es unter anderem auch an der von mir verwendeten Diagnose-Software liegen? Die müsste doch den Support für 1.44MB überhaupt auch erst anbieten, richtig?

  • Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Bezüglich der Tantalkondensatoren hätte ich mal ne frage, was passiert wenn die Hops gehen? Die machen doch sehr laut Knall und Puff soweit ich weiß

    Ich habe zwei Acer 1100/16 eins Funktioniert nicht mehr (wie ihr aber auf dem Foto hier seht so hab ich das Board aus der Bucht geangelt) hat jemand den 387 um 180 Grad verdreht aufgesetzt. Der Co ist auf jeden fall mit Inneren Verletzungen verstorben ! Habe einen zweiten und der hat keine >20mOhm zwischen den Massepins. Trotzdem läuft das Board nicht mehr an. Die Bios Roms habe ich geprüft sind noch Funktional (auch wenn ich gern die vom Nachfolger dem 1100/20 oder neuer mal gern testen würde)


    die Braun/Roten Tantals sind noch gemütlich 54 Stück, ABER habt ihr mal die Cyangrünen neben jedem Schaltkreis gezählt *hierbitte ein weinendes Smiley einfügen*


    129281-acer-1100-jpg

  • Foristen,


    wieder ein Puzzlesteinchen fertig, ich habe den Muttertag sinnvoll genutzt und den zugehörigen 5153 endlich überholt. :)

    Dank Richi 's Elkolieferung (DANKE!) wurden heut alle gepolten Biester und die Netzteil-Filterkondensatoren getauscht, eine Komplettreinigung (Gehäuse geduscht + Schmutzradierer), sowie eine rudimentäre Justage vollzogen- ich bin happy, endlich kann man den Monitor einschalten, ohne die Bude abzufackeln. :D


    Anbei ein paar wahllose Bilder der Aktion:



    Hier die Kondensatoren:


    ...und hier in voller "Pracht" mit dem 5170 und Norton Commander:


    Der Focus und die Helligkeit mussten intern justiert werden, der Rest sieht wirklich super aus.

    Ganz so hell geht er nimmer, aber es reicht- und er läuft ja eh NIE.


    Irgendwann teste ich dann noch, ob sich das 1,44MB-Laufwerk noch verbauen lässt- das ist ja auch noch offen.


    Viele Grüsse,
    Matthias