XT-IDE rev 4 in Olivetti PCS286 - SD Adapter am internem Controller

  • Moin Leute,


    ich hatte meinen Olivetti PCS286 für einen schnellen Test einer XT-IDE Karte auseinander genommen.

    Der Test mit meiner Karte war ok.


    Was mich bei der Gelegenheit aber wundert - mit dem internen IDE Controller bekomme ich kein Laufwerk über das XT IDE BIOS erkannt.

    Das Rechner BIOS unterstützt ja leider nur 20 und 40MB Festplatte - die HDD die ich beim Kauf bekam, war schon defekt - keine Ahnung, ob unrettbar (für mich vermutlich schon). Die liegt hier noch.


    Jedenfalls habe ich da einen IDE SD Adapter im Moment an der XT-IDE angeschlossen.

    Mit der Konfiguration eines zweiten 16 Bit IDE Controller auf Port 170h wird kein Laufwerk gefunden. Im System-BIOS hatte ich zumindest kein Laufwerk angegeben, das hat ja eh nicht hin.

    Hat das irgendwer schon Mal zum laufen bekommen - wird da vielleicht ein anderer Port genutzt?

    Ich finde dazu leider keine Infos.


    Ich würde gerne nur das XT-IDE Bios auf einer Netzwerkkarte nutzen, um mir A) die Karte und B) den Slot zu sparen (sowie 16 Bit Modus).

    Danke für einen Tipp!


    Gruß

    Mario

  • ok, so was hatte ich befürchtet.

    Danke für die Info. Ich geb noch nicht auf, aber werde auch nicht zu viel Zeit investieren... Sonst hätte das sicher irgendwer schon Mal irgendwo notiert.


    Gruß

  • Halte mich bitte auf dem Laufenden. Ich tendiere momentan dazu, einen SCSI-Controller einzubauen, und dann RaSCSI oder BlueSCSI. Das geht auf jeden Fall. Aber der PCS hat bei mir nicht die Prio, wie andere PCs, die ich noch nutzbar machen möchte. Ein XT-IDE finde ich in der PCS-Kiste zu schade, weil der Controller besser zu XTs passt, wo man keine 16-Bit-Erweiterungsmöglichkeit hat.

  • So in etwa? ::ghost::



    Es geht mit meinen IDE/SD Adapter nicht, aber mit Compact flash Karten. Eine 2GB wollte zwar nicht so Recht, aber ich hatte Erfolg mit einer 512MB Karte.


    Man nimmt einen 16 Bit ISA Controller und muss Port 1F0 nehmen.

    Wenn man als primären Port nicht den onboard nimmt, sondern zb xtide, dann könnt der onboard als zweiter und landet als Voreinstellung immer auf Port 170.

    Dann scheitert es...


    Gruß Mario

  • Du meinst den XT-IDE?

    Das ist ja quasi nur das XT IDE Universal BIOS auf dem FlashROM, welches hier noch auf einer XT-IDE rev4 sitzt.


    Die Flash Karte hängt am internen Controller, den das XTIDE BIOS übernimmt.

    Beim einschalten gibt es trotzdem immer noch eine BIOS Fehlermeldung, wegen des unbekannten Plattentyps - die muss man dann bei jedem Kaltstart bestätigen.


    Mario

  • Das Stelle ich jedes Mal ein.

    Vielleicht kann man das BIOS entsprechend patchen. Ich muss mich gerade in das Reverse engineering vom robotron EC1834 BIOS einarbeiten. Vielleicht hilft mir das für spätere Versuche 😉


    Gruß Mario