Siemens PG 740 (486DX100) Tastatur funktioniert nicht und wo finde ich Grafiktreiber usw für das Ding?

  • Hallo beisammen,


    ich habe hier einen Siemens PG 740 (486DX100) hier. Das Gerät läuft bis auf die Tastatur soweit gut, nur sind beim Vorgänger keine Windows 98 Treiber installiert worden. Hat jemand von euch einen Link wo ich die Treiber für die Com-Ports, die Grafikkarte und Simatic Net finden kann?



    Simatic NET ist die Schnittstelle zum Programmieradapter, oder?



    Außerdem läuft die „integrierte“ Tastatur/Trackball nicht. Rechner läuft hoch, es leuchtet keine LED, auch nicht die Num-Taste bei Betätigung. Wenn der Rechner hochgefahren ist, reagiert die Tastatur weder auf eine Taste noch über den Trackball. Das Kabel hat einen PS/2 Stecker und laut klingeltest ist es ok.


    Eine andere Tastatur über einen Maus/Tastaturadapter an einem PS/2 Splitt-Adapter funktioniert einwandfrei.

    Was kann ich an der Tastatur machen? Bringt es was, wenn ich nachlöte, oder zerstöre ich damit die Folientastatur endgültig?


       


    Hat jemand Tipps zur Tastatur oder zu den Treibern?


    Danke schon mal.


    Viele Grüße


    Klaus

  • Moin,


    zum eingebauten Trackball:

    Der muss, wie schon oben angemerkt, im BIOS des Rechners als "intern" angewaehlt werden um zu funktionieren.

    Einstellung "extern" waehlen, wenn eine Maus o.e. am seriellen oder Maus-Port angeschlossen wird.


    Zur Tastatur, das ist ein ganz vertracktes Ding, sie wird beim Start des Rechners geprueft (was genau???) und wirft dann

    die Meldung "Keyboard Error" aus. Andere Tastaturen funktionieren ohne Probleme an diesem Rechner.

    Als Workaround also erstmal eine andere Tastatur und eine externe Maus, mit der richtigen Einstellung im BIOS anschliessen.


    Bei meiner Tastatur Elektronik lag der Fehler in der Kontaktgabe des Zentral-ICs der Tastatur zur flexiblen Leiterplatte.

    Mit ein wenig Druck an den richtigen Stellen (ich hatte mir ein passendes gemachtes Stueck einen Korkens auf die Kontaktstreifen gelegt, der dann vom Gehaeuse eingequetscht wurden) bekam ich die Tastatur wieder zum Laufen.

    Wie genau die Kontaktgabe von Zentral-IC zur flexiblen Leiterplatte stattfinden soll ist mir unlar, geloetet wird da nicht.

    Ich hatte den Eindruck, es lag ein Klebestreifen zwischen Leiterplatte und den IC-Pins.

    Aber wie soll der leiten?

    Gibt es sowas?

    Aber wie leitet der nur an den richtigen Stellen?

    Ich hatte mal nach "3M Z Axis Conductive Tape" gesucht und fand das Produkt §M 9703 ganz praktisch und hilfreich.

    Aber noch funktioniert es mit dem Korken ;)


    MfG

    Bernhard

  • Moin

    Bernhard


    Was genau, wie der Aufbau der Tastatur Schnittstelle ist, kann ich auch nur raten,

    Vermutlich wurde dieser erweitert auf die Sondertasten für die Programmierung


    Hast du noch von deiner Reparatur /mit dem zusätzlichem Drücken über den Korken noch ein paar Bilder


    tintin

    Kannst du auch noch Bilder erstellen von der Internen Adaption innerhalb der Tastatur,


    Dies wäre die damalige Ersatzteilnummer der Tastatur

    C79451-A3461-D26

    Ggf findet sich ja mal was in einer Aktion,

    oder gibt auch Firmen welche diese noch anbieten, einfach google


    Ansonsten wäre Eichler, lektronix, radwell usw eine weitere Möglichkeit für den Erwerb von solch einer

  • Oah, wo soll ich da jetzt nur anfangen.

    Erstmal Danke an alle!


    Im Bios war alles richtig eingestellt. Das mit den vergessenen Biosdaten war nach dem Erststart, da habe ich mich bei Foto vergriffen. Die Pufferbatterie hält ca. 1-2 Tag alle Daten im Bios. Tausch ich aber noch. Da aber eine andere PS/2-Tastatur und Maus am selben Anschluss funktioniert haben, liegt es wohl auch nicht an der Einstellung. Außerdem gibt es im Bios keine Einstellung zur Tastatur oder Maus außer der Num-Taste on/off.


    Erstelle bitte noch weitete die detailreichere Bilder für die Identifizierung,

    vom PG 740 gab es meines Wissens 3 oder 4 differenzierte Hardware Versionen

    Hier ein Blick aufs Bios:




    Mit ein wenig Druck an den richtigen Stellen (ich hatte mir ein passendes gemachtes Stueck einen Korkens auf die Kontaktstreifen...

    Dein Korkentipp war schon mal goldrichtig. Beim Starten leicht auf die Folie drücken und schon geht die Tastatur und der Trackball. Nach einer Weile hat sich die Verbindung dann wieder gelöst und der Rechner piept nur noch. Doch einem Neustart mit Handauflegung hat es wieder funktioniert. Ich werde die Korkenvariante mit Moosgummistreifen auch machen. Ich berichte.


    Die Folientastatur erinnert mich ein bisschen an die aus dem Sinclair Spectrum. Dort sind mehrere Folienlayer übereinander gelegt, die mit Klammern am Gehäuse fixiert und niedergedrückt werden um Kontakt herzustellen.

    Kannst du auch noch Bilder erstellen von der Internen Adaption innerhalb der Tastatur,


    Dies wäre die damalige Ersatzteilnummer der Tastatur

    C79451-A3461-D26

    Ein Blick in die Tastatur findest du im ersten post ein Bild. Oder was soll ich forografieren?


    Mit den Treibern komme ich aufs erste nicht zurecht, ich muss mich nochmal etwas genauer damit auseinandersetzen, die sehen aber nach Win3.1x aus.

  • Also mal wieder ein Update. Ich habe die Tastatur gepimpt und die Bios Batterie erneuert.


    Ich habe die Idee von Bernhard aufgegriffen, aber keinen Korken benutzt, ich habe ein Moosgummikossen zusammengebaut.
    Also ich habe Moosgummi-Klebeband in mehreren Schichten zusammengeklebt, dabei aber in den ersten Schichten den IC ausgspart um nich unnötig Druck darauf auszuüben. Das 'Kissen" ist so groß, dass es hauptsächlich die Folienkontakte zusammendrückt, die bei geschlossenem Gehäuse auf die Platine drückt. Läuft bisher schon eine Woche lang problemlos und ohne Fehler. Nur der Trackball hackt einwenig, was damit aber nichts zu tun hat.


     




    Die CMOS Baterie habe ich auch ausgetauscht. Die habe ich online gekauft, und hätte laut Verkäufer für den Rechner passen sollen. Hat es auch fast. Die werte waren identisch, nur der Stecker ist um einiges höher, so dass das Netzteil im verbauten Zustand direkt auf den Stecker aufliegt und die Kabel wegdrückt. Das hat mir nicht gefallen, deshalb habe ich den Stecker von der alten Batterie auf die neue angelötet und dann befestigt. Passt also jetzt auch.




    Bei der Gelegenheit hier nochmal ein Blick auf die Platine (ohne Netzteil)




    ...

  • Jetzt fehlen mir nur noch W98SE Treiber.

    Den PCMCIA Treiber habe ich installieren können,

    Der Wester Digital Grafikkarten Treiber fehlt mir noch. Jetzt geht nur 640x480 bei 16 Farben.

    Wenn jemand von Euch was hat, bitte Info an mich, wenn man den Treiber mit einem anderen Treiber ersetzen kann, wäre ich auch über Infos dankba.




    Leider fehlen am Gehäuse 2 Gummiecken. Ich habe die von Hinten unten genommen, dass man es nicht sieht. Außerdem fehlt mir die Laufwerkklappe. Dafür habe ich eine andere Klappe übrig. Also falls jemand Gummiecken oder die Klappe hat, bitte gebt mir Bescheid!



  • Der Wester Digital Grafikkarten Treiber fehlt mir noch. Jetzt geht nur 640x480 bei 16 Farben.

    Auf Graphics driver in the PG 760/740/720 steht:

    Quote

    For the chip set WD90C24 there is no special driver for WINDOWS 95. The graphics interface is already in WINDOWS 95. Special drivers for WD90C24 are only needed under WINDOWS 3.x or other operating systems.

    ... wahrscheinlich ist er bei Win98SE auch noch dabei ... und ist ja auch installiert ...

  • Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Also mal wieder ein Update. Ich habe die Tastatur gepimpt und die Bios Batterie erneuert.

    Kenne dass man sowas mit dem Lötkolben fixt (vgl. Gameboy-Display)

    CMOS-Batterie neige ich dazu einfach das alte Kabel an neuen Rohzellen anzulöten

    Mhm... Geräte Erkennung und danach WesternDigital-Standartgrafikkarte auswählen?

    Siehe: https://thinkwiki.de/370#Treiber und http://www.ollis-place.de/2008…ssiker-ibm-thinkpad-370c/

  • Mhm... Geräte Erkennung und danach WesternDigital-Standartgrafikkarte auswählen?

    Die Standartgrafikkarte hab ich installiert, nur kann ich trotzdem nur 640x480 16 Farben auswählen. es wird nichts anderes angeboten.




    Die Links schau ich mir später an.

  • Ne, nicht Standard-VGA, sondern WD. Zumindest bei CirrusLogic weiß ich, dass die alten ISA-Karten so laufen

  • Die Standartgrafikkarte hab ich installiert, nur kann ich trotzdem nur 640x480 16 Farben auswählen. es wird nichts anderes angeboten.

    In Bild #2 ist die Karte mit dem "Ausrufezeichen" markiert: steht das da noch? Auch könnte eine entsprechende MONITOR.INF-Datei (nicht "Standard-Bildschirmtyp") für Win9x notwendig sein ...

  • Beim IBM Tinkpad 370 mit der WD Grafik gibt es auch probleme.


    Eine eventuelle Lösung für dein Problem Die VESA Treiber von IBM (für DOS) installieren. Der Treiber schreibt sich in die config.sys ein und wird beim booten geladen. Danach sollte sich ohne Probleme die Farbtiefe ändern lassen.


    Als anhang mal noch gleich der Treiber.