Multimeter - Frequenzmessung

  • Wer misst misst Mist ...



    Heute ist wohl nicht mein Tag ...

    Seit Stunden drehe ich mich im Kreis, weil ich zu blöd bin es richtig zu machen! :D



    Ich möchte eine Platine in Betrieb nehmen.

    Da mach ich aus einem 10 MHz Takt einen Quadratur Takt, zweimal 2,5 MHz, 90° verschoben.

    Hab da keine Probleme erwartet, weil ich das schon öfter gemacht habe.


    Nun habe ich entdeckt, dass mein treues Multimeter (UNI-T UT61E) auch Frequenz messen kann. :)

    Fein dachte ich, zum schnell kontrollieren spare ich mir so das Oszi.



    Am Eingang sind die 10MHz da, das Multimeter zeigt es exakt an.

    Leider kein Signal am Ausgang.

    Große Verwunderung ...

    CPLD neu gebrannt, immer noch nix.


    Steckboard genommen, der CPLD arbeitet tadellos?!!

    Naja, Lötstelle am PLCC Sockel vergessen, grrrr!


    ----


    Nachgelötet ...

    ... und siehe da, nun klappt es auch mit dem E Signal, brav 2,49999 MHz laut dem Multimeter.


    Nun kommt es.

    Zur Sicherheit noch das Q Signal geprüft ...

    ... das Multimeter zeigt 5 MHz an!

    5!


    X-mal hin und her gemessen, das Multimeterzeigt immer das selbe an, 2,5 MHz und 5 MHz.



    Leider hab ich dem Gerät vertraut.

    Hab die Gleichungen geprüft, - alles in Ordnung.

    Hab es im Simulator überprüft, - laut Simulator sollte es in Ordnung sein.


    Verzweiflung ...

    ... unsinnige Versuche gestartet, die Lötstellen nachzulöten.


    Da mir die Ideen ausgegangen sind, habe ich doch mein Oszi geholt.

    Und siehe da, zwei wunderschöne Rechteckkurven, brav 90° verschoben!!

    Das Oszi zeigt auch die Frequenz an, tadellos.


    Multimeter zum gegen prüfen, 5MHz!!!!




    Wie kann es denn das geben?

    Ein kleiner Glitch im CPLD?


    So ein Dreck, die Frequenzmessung am UNI-T ist wohl völlig ungeeignet (für mich). ?(

  • Ein kleiner Glitch im CPLD?

    Koennte sein. Den solltest du aber auch mit dem Oszi sehen koennen.


    Du hast an dem UNI-T bestimmt die normalen Messleitungen benutzt, keinen Tastkopf.

    Die Messleitungen sind fuer diese Frequenzen nicht geeignet. Da weisst du nicht was im Messgeraet ankommt.


    Vor langer Zeit hab ich einen 4MHz Z80 Takt mit solchen Messleitungen an ein Oszi angeschlossen. Es wurde einen nahezu Sinusschwingung angezeigt, wenigstens die Frequenz war ok. Tastkopf dran, alles ok.


    So ein Dreck, die Frequenzmessung am UNI-T ist wohl völlig ungeeignet (für mich). ?(

    Wie du sagst, wer viel misst misst Mist.

    Allerdings gehoert die Interpretation der Anzeigewerte zur Aufgabe des Bedieners !

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • na, wenn an Q zwei Signale mit je 2,5MHz und 90° Phasenverschoben sind, dann is doch klar, dass das Multimeter 5MHz anzeigt? ...der interpretiert die steigende Flanke des 2. Signals als zusätzlichen Takt... dann kommt eben das doppelte raus? :nixwiss:

  • na, wenn an Q zwei Signale mit je 2,5MHz und 90° Phasenverschoben sind, dann is doch klar, dass das Multimeter 5MHz anzeigt? ...der interpretiert die steigende Flanke des 2. Signals als zusätzlichen Takt... dann kommt eben das doppelte raus? :nixwiss:

    Nee, aus dem Takt generieren sich ZWEI Ausgangssignale: Q und E


    Q und E sollen beide 2,5 MHz haben (ein viertel des Grundtakt), nur ist Q zu E verschoben um 90°.



    Es hat sicher was zu tun damit, dass es ganz normale Mess-Strippen sind, kein Tastkopf.

    Ich wüsste auch nicht, wie man einen Tastkopf anschließt bei dem Ding.

    Es hat ja nur die Anschlüsse für die normalen Mess-Strippen.

  • Nee, aus dem Takt generieren sich ZWEI Ausgangssignale

    achsoo - ich dachte, auf dem einen Port liegen zwei übereinander :tüdeldü:

    Ich wüsste auch nicht, wie man einen Tastkopf anschließt bei dem Ding.

    mit BNC -> 4mm Adapter?

    https://www.mouser.de/ProductDetail/Cal-Test/CT2939?qs=vgjKjNJexTjoXh8l4YkSEA%3D%3D&mgh=1&vip=1&gclid=Cj0KCQjw5ZSWBhCVARIsALERCvzeoSdYHVjriHmmWb3GYMbNCR6YADwTqv3cY1iwB_GPEICEGLb7_-gaAguIEALw_wcB

  • Für das obige Meßinstrument gibt es einen passenden BNC Adapter:


    https://www.pinsonne-elektronik.de/pi10/pd65.html


    Art.Nr.:PD-01065

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • ah super - vielen Dank für den Link, ist zwar:

    Quote


    - derzeitig nicht lieferbar -

    ..aber immerhin weiss ich jetzt, wie das Ding heisst, ich hab nämlich dank cethewe auch ein UNI-T Multimeter, da kann ich mal bei anderen Anbietern guggen, ob ichs irgendwo finde