SCSI-ZIP ... seltsammes... SCSI-Terminierung

  • Ich bin gerade dabei, meine Olivetti M380 laufwerkstechnisch etwas schick zu machen, denn ich habe ja kürzlich ein 1GB JAZ- und 100 MB SCSI-Zip bekommen.


    SCSI-Konfiguration wie folgt:


    - ID 0 320 MB Platte Imprimis ...

    - ID 1 erstmal frei

    - ID 2 erstmal frei

    - ID 3 650 MB Platte DEC RZ56

    - ID 4 neu: 1 GB Jaz extern

    - ID 5 neu: SCSI-Zip extern

    - ID 6 Grundig CD-Brenner

    - ID 7 Adaptec AHA 1542A


    Terminierung auf der Imprimis am Kabelende an, und auf der anderen Seite des internen SCSI-Kabels bisher auch am Hostadapter, weil ich extern nichts dran hängen hatte.


    • Nebenbei: Sicher wird jetzt jemand fragen, warum ich die DEC Platte auf ID 3 habe. Das hat einen Grund, denn die muss erst per SCSI-Kommando gestartet werden, das macht aber der Adaptec 1542A nicht, dass können erst die 1542Cx. Statt dessen wird sie von ASPIDISK.SYS gestartet, die Platte hat auch keinen Jumper, wo man dieses Verhalten umstellen könnte. Natürlich geht das auch, wenn die Platte auf ID 1 ist, das hat aber eine andere Auswirkung: Die RAM-Optimierungen von QEMM386 passt nicht mehr, je nachdem die Platte vom 1542A-BIOS oder von ASPI4DOS ins System eingebunden wird. Beim Kaltstart wäre es ASPIDISK.SYS, nach einem Reset das 1542A-BIOS, die Folge wäre, dass ich je nach Optimierung eine andere Speicherkonfig hätte, nicht mehr alle Treiber könnten hoch geladen werden, usw. Das 1542A BIOS sucht nur auf ID 0 und 1, so ist sie auf ID 3 vor dem SCSI-BIOS versteckt und wird immer von ASPIDISK.SYS verwaltet... Gut, zurück zum Thema


    Momentan funktioniert alles so wie es soll, sprich das SCSI-Zip 250 ist das letzte Laufwerk am Bus, ist am ZIP-LW terminiert und alles geht. Ich habe Laufwerke von C: bis F: und Dateien hin und her schaufeln geht problemlos, momentan schaufle ich testweise alles von der DEC-Platte auf ein Jaz-Medium (verify on), klappt.


    Ich hatte aber zwischendurch statt des 250er das ZIP 100 dran, und da sieht es anders aus. Zum einen ist es dem ZIP 100 scheinbar nicht egal, ob man den rechten oder den linken SCSI-Anschluss an seiner Rückseite nimmt, am rechten Anschluss funktioniert der ganze SCSI-Bus nicht, egal ob Terminierung an oder aus ist.


    Das ZIP 250 hing bisher an einem meiner Atari TT, dort hängt jetzt erstmal das ZIP 100. Dort verhält es sich ähnlich, wenn am ZIP 100 die Terminierung an ist, findet der TT die Quantum-Platte nicht, wenn sie aus ist, gehts. Auch hier geht es nur mit dem linken SCSI-Anschluss am ZIP.


    Es ist gerade so, als ob auf dem ZIP 100 der Terminierungsschalter falsch herum beschriftet wäre... Kann das jemand bestätigen?

  • Bei meinem ist die Terminierung aktiv, wenn der Schiebeschalter unten ist. Die Anschlüsse sind wirklich nicht gleichwertig, es geht immer links rein und rechts raus. Das habe ich auch lernen müssen.


    Keine Ahnung, wieso das so ist- vielleicht hat das etwas mit dem Aufbau bei der Parallelport-Version zu tun. Dort war ja der Parallelport durchgeschleift und das Laufwerk per Parallel-to-SCSI Bridge angebunden (so erzählt man sich zumindest)

    Erfahrung ist Wissen, das wir erwerben, kurz nachdem wir es gebraucht hätten.


    Mein Netz: Acorn | Atari | Milan | Amiga | Apple IIGS | Macintosh | SUN Sparc | NeXT |SGI | IBM RS/6000 | DEC Vaxstation| Raspberry Pi | PCs mit OS/2, BeOS, Linux, AROS, Windows, BSD | Stand-alone: Apple //c | Sinclair QL | Amstrad | PDAs