Power Supply: Fix the unbroken?

  • Hidiho,


    nachdem ich mir in der letzten Zeit 'mal wieder mehr gegoennt hab', vor allen Dingen Apple-II Erweiterungskarten, bei derem multizilliardenstelligen aufgerufenen Preis mir "damals" jeglicher Kaufgedanke eiligst entfleuchte 8| , musste ich feststellen, dass meine Apple's irgendwie immer mehr "zickten". Mal wurde nicht anstaendig gebootet, wenn mehr als eine Diskettenlaufwerk angeschlossen war, mal liefen die Disk-Laufwerke hoerbar nicht richtig mit (z.B. bei ADTpro: 20 Spuren sauber kopiert und ploetzlich hatte man das Gefuehl (vom Geraeusch her), dass die Disk nicht richtig drehte und dann hagelte es ploetzlich Schreibfehler auf Disketten, die beim Test vorher fehlerfrei waren). ?(


    :soonbart:
    Nunja, gehen wir von einem durchschnittlichen Herstellungsdatum von 1985 aus, sind die Systeme jetzt um die 30 Jahre alt. Obwohl Einzeltests (mit z.B. APEX) erstmal keine klare Fehlerursache lieferten, mutmasste ich doch, dass die Elkos im Netzteil einfach am Ende waren und Stromspitzen die Spannung manchmal zu sehr in den Keller schickten.


    Also flugs das Teil aufgeschraubt und nachgeschaut ... die Typen notiert und bei einem bekannten Internetanbieter neue Elkos fuer drei Netzteile mit mind. 10000h bei 105 Grad (oder mehr, wenn angeboten), sowie etwas hoeherer Spannungsfestigkeit (je nach Verfuegbarkeit) - aber gleicher Kapazitaet - bestellt.


    Leider zog sich das Ganze doch recht lange hin, da DHL meinte, das Paket wegen "Beschaedigung der Umverpackung" (ich sag dazu "kein Bock oder zu blau an Karneval") nochmal unter die Fittiche nehmen zu muessen (dauerte ganze zwei Wochen), aber heute kam das Paket mit den Elkos (ENDLICH) an.


    Ich hab' mir direkt am Nachmittag meinen Test-Apple-IIe geschnappt und alle Elkos und die beiden Funkentstoerkondensatoren gewechselt (*). Nach dem Ausloeten hab' ich dann auch schnell einmal mit einem (Billig!-)Kapazitaetstester die noch vorhandene Kapazitaet geprueft. Mal abgesehen vom erwarteten schlappen Erscheinungsbild der Elkos sprang eigentlich Elko 10 auf meiner Arbeitsskizze (Auf der Platine C7 gelabelt - nahe dem Transformator) ins Auge. Erst wollte der Tester im Auto-Modus gar nichts sagen und beim Festlegen auf eine bestimmte Kapazitaetsspanne sprach er dann von abngeblichen 4,5 statt 47 Microfarad.


    :!: Ich muss ausdruecklich betonen, dass der Kapazitaetstest mit einem Billig-Tester aus Chinaland durchgefuehrt wurde und die Kondensatoren koennen unter Netzspannung ganz andere Probleme zeigen, als bei einem simplen Test mit mit zwei handelsueblichen 1.5V Akkus.


    Hier die Tabelle mit den a) Positionen lt. meiner Skizze [siehe Bild X], den b) original eingebauten Elkos, c) den nach dem Ausbau gemessenen Kapazitaeten und d) den Daten der neu eingesetzen Ersatzkondensatoren:


    Pos. -- original -- gemessen -- neu


    1 -- 16V 330µF -- 289µF -- Panasonic 10000h, 330µF, 50V, 105°C, 5mm
    2 -- 16V 330µF -- 292µF -- Panasonic 10000h, 330µF, 50V, 105°C, 5mm
    3 -- 16V 330µF -- 294µF -- Panasonic 10000h, 330µF, 50V, 105°C, 5mm
    4 -- 16V 330µF -- 290µF -- Panasonic 10000h, 330µF, 50V, 105°C, 5mm


    5 -- 16V 1000µF -- 978µF -- Panasonic 10000h, 1000µF, 35V, 105°C, 5mm
    6 -- 16V 1000µF -- 969µF -- Panasonic 10000h, 1000µF, 35V, 105°C, 5mm
    7 -- 16V 1000µF -- 939µF -- Panasonic 10000h, 1000µF, 35V, 105°C, 5mm
    8 -- 16V 1000µF -- 1002µF -- Panasonic 10000h, 1000µF, 35V, 105°C, 5mm
    9 -- 16V 1000µF -- 964µF -- Panasonic 10000h, 1000µF, 35V, 105°C, 5mm


    10 -- 10V 220µF -- 4,5uF (!) -- Panasonic 5000h, 220µ, 16V, 105°C, 2,5mm (10000h waren leider nicht verfuegbar :( )


    11 -- 250V 47µF -- 56µF -- Europe Chemi-Con 10000-12000h, 47 µF, 400 V, 105°C, 7,5mm
    12 -- 250V 47µF -- 57µF -- Europe Chemi-Con 10000-12000h, 47 µF, 400 V, 105°C, 7,5mm
    13 -- 250V 47µF -- 55µF -- Europe Chemi-Con 10000-12000h, 47 µF, 400 V, 105°C, 7,5mm
    14 -- 250V 47µF -- 53µF -- Europe Chemi-Con 10000-12000h, 47 µF, 400 V, 105°C, 7,5mm


    15 -- 250V 0,1µF fo=4.9MHz -- 188nF -- Panasonic, X2, 100 nF, 275 V~, 15mm Rastermaß


    16 -- 250V 0,47µF fo=1.9MHz -- 536nF -- Panasonic, X2, 470 nF, 275 V~, 22,5 mm Rastermaß


    Ich hab' vor und nach dem Umbau auch mal Messungen mit nem Oszi durchgefuehrt, aber hier gab' es keine offensichtlichen Unterschiede (oder ich bin einfach zu bloed - was durchaus ein valider Grund waere) aber der Apple - testweise mit allen spannungsfressenden Karten, die gerade herumlagen, vollgestopft (1MB RAM, Super Serial, 2xDisk Controller mit 4x Disk ][ Laufwerken [die alle gleichzeitig beim Einschalten Strom ziehen] , Z80 CPU und Time ][ Clock Card) laeuft supergut und knackig - kein Zicken, kein nix - also definitv nichts objektiv Messbares aber durchaus subjektiv Erfahrbares. Ich kann nur mutmassen, dass die Spannungs-Drops zu kurz waren, um sie mit meinen bescheidenen Erfahrungen und dem alten Oszi zu beobachten. Definitiv laeuft der dieser Apple IIe jetzt wieder 1a. :freude:


    Kurz noch ein paar Anmerkungen:


    :) An sich positiv zu vermerken ist, dass der Netzteilhersteller an verschieden grosse Bauformen von Entstoerkondensatoren gedacht hat und es dementsprechend keine Probleme gab, von der Dimension her Kleinere einzubauen (da sind je Kondensator sechs Bohrungen in der Platine, so dass eigentlich jedes gaengige Format passt).


    :( Sehr negativ hingegen war die Verwendung von Riesenblobs an Heisskleber bei den Grossen Elkos (11-14 in meiner Skizze) zu vermerken. Das war eine sch*^&%-Wulackerei, die Elkos da sauber 'rauszubekommen.


    :| Die Platine hat nur auf der Unterseite Loetbahnen, die sich sehr schnell von der Platine loesen wollen. Hier ist fixes Arbeiten mit dem Loetkolben vonnoeten! Gerade an den Stellen, wo die Elkos oben festgeklebt waren, hatte ich 1-2 mal das Gefuehl, dass das Ganze schiefgeht. Also definitiv nichts fuer Anfaenger. Profi bin ich ja auch nicht, aber ein wenig Uebung mit dem Loetkolben sollte man mitbringen! Ich hab' auf jedenfall schon leichtere Aufgabenstellungen gehabt ^^


    :huh: Wenn das Netzteil jetzt immer noch Probleme machen wuerde, taete ich mir den Widerstand R4 direkt neben dem Elko C7 (Meine Skizze: Kondensator 10) naeher ansehen. Die Platine ist dort recht angesengt, was darauf hindeutet, dass der Widerstand sehr(!) heiss geworden sein muss. Aber da der Rechner jetzt wieder fein funzt, hab' ich mir diese Muehe gespart und evtl. lag es ja auch am kaputten C7. Aber ich hab' ja noch neue Elkos fuer zwei weitere Netzteile und dann werd' ich da mal nochmal naeher hingucken.


    (*) Falls sich wer fragt, warum alle Elkos wechseln, wenn der Kapazitaetstest doch sagt, dass der eine oder andere Elko noch durchaus im Toleranzbereich liegt: Das Ausbauen der Netzteilplatine ist nicht ohne und kostet *richtig* Zeit und Nerven (Netzteil 'rausfriemeln, aufschrauben, Kabelfuehrung loesen, Netzschalter und dann letztendlich die eigentliche Netzteilplatine ausbauen -- und das Ganze danach in umgekehrter Reihenfolge wieder zusammenbauen). Selbst wenn man gute Marken-Elkos kauft, sind die paar Euros mehr gut investiert, wenn man gleich alle auswechselt. Ich hoffe, dass ich *dieses* Netzteil erst wieder in 30 Jahren (so ich denn den Apple dann noch habe und auch selbst noch lebe) oeffnen muss.


    -- Klaus


    (spaet geworden - und das Ganze nach einem Dartabend in der Altstadt - und jetzt noch Photos suchen / machen ... *phew*)


    PS: Hmm - hab' wohl die Fotos von nach der Umbauaktion ohne eingelegte SD-Karte gemacht und will das Netzteil jetzt nicht nochmal ausbauen - mache die Tage nochmal vorher/nachher Fotos von nem anderen Apple IIe Netzteil

  • Super Anleitung, vielen vielen Dank! Ich hatte mir so etwas auch vorgenommen, aber mich bisher immer darum gedrückt, weils halt noch geht :-)
    Jetzt scheint es aber keine Ausreden mehr zu geben.

  • Heute war's mal wieder soweit, ein weiteres Apple-Netzteil war am Ende und bekam heute neue Elkos und Entstoerkondensatoren.


    Da es baugleich mit dem aus dem ersten Artikel war, spare ich mir mal weitere Details und poste fuer die Interessierten nur die Restkapazitaeten der ausgebauten Kondensatoren (ich hab' wieder direkt alle gewechselt, damit das Teil als abgehakt gelten kann). Als Ersatzteile habe ich auch die gleichen genommen, wie im ersten Artikel, da ich mir damals direkt Kondensatoren fuer 4 Netzteile geordert hatte.


    Gemessene Kapazitaeten der ausgebauten Kondensatoren:


    1-4 -- 16V 330µF: 264µF, 250µF, 282µF, 288µF


    5-9 -- 16V 1000µF: 570µF (!), 927µF, 947µF, 960µF, 831µF,


    10 -- 10V 220µF: 176µF


    11-14 -- 250V 47µF: 57µF, 55µF, 56µF, 56µF


    15 -- 250V 0,1µF fo=4.9MHz: 132nF


    16 -- 250V 0,47µF fo=1.9MHz: 460nF


    -- Klaus

    [ ... to boldly code where no byte has gone before ... ]