FALCON030 / DOS - ich bin ratlos - wer kann helfen

  • Worum geht es? Ich will auf dem FALCON die Falcon-Speed unter MS-DOS oder DR-DOS laufen lassen. Normalerweise sollte es einfach funktionieren. Sollte :cursing: ! Dem ist aber nicht so. Da ein Bild mehr sagt als 1000 Worte habe ich daraus eine Bildergeschichte gemacht. Diese Vorgänge hebe ich mit CF-Karten und mit HDD's mehrmals durchgeführt. Das Ergebnis ist immer haargenau das Gleiche. Ich beziehe mich im Beispiel auf die CF, weil der Begriff schön kurz ist.


    Zuerst wurde die CF vorbereitet. Um absolut sicherzugehen habe ich die CF mit einem Tool von HP formatiert (nur beim letzten Versuch). Danach ab in den FALCON. Der wurde von Diskette gestartet und die CF eingerichtet.



    Da es für mich gut ausschaut, habe ich den Vorschlag des Programms angenommen und den FALCON neu gestartet. Anschließend erfolgte die Überprüfung der Einstellungen und die Installation des HDDRIVER 9.09 wurde durchgeführt.



    Nun war unter TOS Alles o.k., die Laufwerke wurden unter Extras angemeldet und die Arbeit gesichert. Weiter ging es mit der Installationsdiskette der Falcon-Speed (6.21). Das Ganze ist in den nächsten Bildern dargestellt.



    Mit der FLS_INST werden die Grundeinstellungen der Falcon-Speed vorgenommen (grüner Rahmen). Das Vorhandensein einer Festplatte habe ich mit JA beantwortet. Danach erfolgte die Zuweisung der Tos-Partitionen zur DOS-Installation.
    Das zukünftige Laufwerk C: würde in der Partition E erstellt und das zukünftige Laufwerk D: in der Partition F. Dann folgt nur noch Kleinkram, wie Tastaturlayout, Grafiktreiber und Zuordnung der seriellen Schnittstellen. Damit war die Vorbereitung abgeschlossen und die Einstellungen wurden für das Startprogramm gesichert. Dann wurde das Falcon-Speed-Programm gestartet (roter Rahmen im Bild 5).


    Ich war zufrieden als der Start erfolgt war. Das Laufwerk war zu sehen.


    Also wurde von der Installationsdiskette MS-DOS 6.22 FDISK gestartet. Wow sah das gut aus. Die Laufwerke konnten ausgewählt und kontrolliert werden. Da die Partition noch nicht aktiviert war, habe ich die Aktivierung durchgeführt.



    Nun folgte der übliche Programmhinweis "Das System wird neu gestartet. Legen Sie eine MS-DOS-Systemdiskette ..." Danach schlägt MS-DOS die Formatierung vor. Das habe ich akzeptiert und die Formatierung läuft. Dann erscheint die Anzeige, dass 100% erreicht wurden.



    Das war es dann, denn hier ist das Ende erreicht. Nichts geht mehr :cursing: . Also, versuchte ich das Ganze manuell zu erledigen. Natürlich mit dem üblichen Spiel, Format C: /s und das Ergebnis ist im letzten Bild zu sehen.


    Auch hier geht gar nichts. Wie oben schon geschrieben, das Ergebnis ist auf CF, auf HDD, mit MS_DOS, Mit DR-DOS, immer das Gleiche. Beim DR-DOS sehen die Meldungen nur etwas anders aus und die Überraschung kommt erst ganz zum Schluß, wenn die Konfiguration des VIEWMAX abgespeichert werden sollen.


    Wer kann mir hier weiterhelfen?

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Erstmal eine grundsätzliche Frage: Warum so eine Spielzeug-CF mit 128 MB? Und dann Diskettenpartitionen mit 32 MB? Da kann man es ja auch gleich sein lassen, da bekommt man ja fast nix drauf. Sowohl DOS als auch TOS kann mit wesentlich größeren Laufwerken umgehen. Ich habe in meinem einen Falcon eine 32 GB CF drin, aufgeteilt in 16 1GB Partitionen und eine 16 GB Partition für MiNT (Partitionstyp LNX). Den anderen statte ich demnächst auch so aus. Oder ist das nur zum Testen?


    Dann sollest du es wirklich mal mit der neuesten DOS-Version manuell machen, die du auftreiben kannst. Vielleicht mal freedos ausprobieren. Auf jeden Fall auch mal PC-DOS 7.1 testen.


    1. FDISK Partition(en) einrichten, C: aktiv setzen
    2. fdisk /mbr
    3. format c: (ggf. auch format d: usw.)
    4. sys c:


    Etwas anderes was du ausprobieren kannst: Nimm mal statt HDDRIVER den originalen ATARI AHDI in der neuesten Version, dann aber erstmal mit einer kleinen CF (meinetwegen die 128er, es dürfen aber ruhig 2 64er Partitionen sein!)

  • Hallo 1ST1,


    ja die 128er ist nur zum Test, um Fehler auszuschließen. Ich habe jetzt die Originaldokumentation zur Falcon-Speed zur Hand. Dort lautet die Empfehlung 32 MB Systempartition und die weiteren Partitionen je max. 128 MB. Außerdem sind die 128er Industrial-Versionen, die alle als DOS und/oder als Linux-Laufwerke verbaut waren und die ich, zusammen mit etlichen 512er CF aus dem Schrott habe.


    Den Ansatz mit dem ATARI AHDI werde ich noch heute probieren. Mal schauen wie es ausgeht.

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Hallo Reiner


    Ich hatte in den 90ern auch mal ne Falcon Speed. Ich meine, dass sie nach dem Einbau eines Coprozessors nicht mehr richtig funktioniert hat. DOS liess sich auch nicht mehr installieren, weil es Probleme mit den Laufwerken gab. Funktioniert hat es mit 4 MB RAM und ohne Copro. Woran es nun schlussendlich lag, weiss ich auch nicht. Das Teil hat genervt und ich habe es Mike vom ATARI-Museum gegeben.


    Grüessli, Uli

  • Ja so kleine CFs habe ich auch, aus irgendwelchen alten CISCO-Geräten usw. rausgeholt, bevor die zum Schrotti gehen. Für einen XT oder so sind die paradiesisch groß, aber für einen Falcon ist das zu klein.


    Wenns mit AHDI klappt, solltest du mal Uwe Seimet mit dem Problem kontaktieren.

  • So langsam glaube ich, dass es an den "modernen" DOS-Versionen liegt. Mittlerweile habe ich als Laufwerkstreiber Hushi, und die ATARI AHDI / HDX Software in der Version 3.5 und 5.2 getestet. Das Ergebnis endet immer wie eingangs beschrieben. Dabei spielt es auch weiterhin keine Rolle ob die CF oder die HDD installiert sind. Machen die 6er DOS'se im hardwarenahen Teil (FDISK / Format mit Zusatz /s) etwas anders als ihre Vorgängerversionen? Nach einem Telefonat mit Didi wird diese Vermutung stärker. Also bin ich auf der Suche nach MS-DOS 4 und / oder MS-DOS 5.

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Hallo Reiner


    Ich hatte damals DOS 6.2 und Windows 3.1 drauf. Die Einschränkungen schrieb ich ja schon vorher. Die Frage bleibt: Wozu?


    Grüessli, Uli

  • Hallo Uli,


    just for fun. Es gibt zwei Gründe. Erstens, wenn die Falcon-Speed schon vorhanden ist, dann soll sie auch funktionieren. Zweitens, wenn der Falcon zusätzlich auch DOS kann spart es Platz. Manchmal brauche ich einen zweiten DOS-Rechner um meine geplante Mailbox zu testen. Ich will dann einfach sehen, wie sie ein Außenstehender im Terminal angezeigt bekommt.
    Hattest Du Dein DOS 6.2 gleich installiert oder war da vorher schon ein anderes DOS drauf? Didi hatte z.B. erst das 5er drauf und später auf das 6.22 umgestellt.


    Viel Grüß
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Hi


    Ich hatte nur das 6.2. Aber die Details weiss ich nicht mehr. War vor 20 Jahren.


    Grüessli, Uli

  • Hallo Uli,


    und ich dachte Du hast ein Laaaangzeitgedächtnis :D . Macht ja gar nichts, ich sehe es sportlich, irgendwann gibt es die Lösung. So muss ich halt ab und an in den Keller und Teile holen für einen Behelfsaufbau. Dann teste ich immer mit "Freiluftverdrahtung" :tüdeldü: . Die Bewegung tut mir auch gut, Kalorien verbrennen :D .


    Viele Grüße
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Die Idee mitohne Coprozessor und mit nur 4 statt 14MB RAM ist auf jeden Fall gut und sollte ausprobioert werden. Vielleicht ist das ja nicht kompatibel. Wenn das auch nichrt hilft, oder dir der Falcon ohne Copro und nur 4 MB ziu doof ist, lass es lieber und stell dir einen richtigen Zweit-PC hin. Der Falcon ist eh zu schade für MS-DOS.

  • Hallo 1ST1,

    Die Idee mitohne Coprozessor und mit nur 4 statt 14MB RAM ist auf jeden Fall gut und sollte ausprobioert werden. Vielleicht ist das ja nicht kompatibel. Wenn das auch nichrt hilft, oder dir der Falcon ohne Copro und nur 4 MB ziu doof ist, lass es lieber und stell dir einen richtigen Zweit-PC hin. Der Falcon ist eh zu schade für MS-DOS.

    Wenn ich es nicht auf einer CF hinbekomme, so dass ich wechseln kann, hast Du mit Deinem letzten Satz ohne wenn & aber Recht :thumbsup: . Aber sportlich ist die Herausforderung schon. Ich bin allerdings ein schlechter Verlierer und so lange die Chance besteht binde ich mir die Zeit an's Bein :D , nerve meine Mitmenschen um zum Ziel zu kommen.


    Momentan habe ich eine CF im PC total gebügelt. Dann in den Falcon geschubst und von Diskette, mit einem der letzten AHDI, gestartet. Jetzt bereitet der AHDI gerade die CF vor. Wenn es tatsächlich nichts wird, habe ich ja noch die Möglichkeit die Falconspeed mit einer DOS-Disk zu verwenden. Das hätte von Anfang an ausgereicht :tüdeldü: , aber sie Satz 2 und 3 :D . Weiterhin sind 4 MB nicht mehr möglich, habe nur noch 14 MB, als Prachtexemplar von Lynxman. So, AHDI ist fertig ich muss weitermachen.
    Gruß
    Reiner


    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Ich denke, das war es mit einer DOS-Partition auf dem Falcon :( . Der neue AHDI erklärt in seinen Meldungen gleich was ihm nicht gefällt. Damit habe ich erst einmal zwei Antworten warum es in den zurückliegenden Tagen nicht funktioniert hat.
    Bei der Partitionierung erscheint die Meldung "Cannot read root sector from the disc!" Dann führt AHDI zwangsweise eine Formatierung durch. Anschließend erfolgt die Partitionierung.
    Wenn das System den notwendigen Neustart ausführt gibt AHDI eine weitere Meldung aus "Not Bootloadet". Diese Programmversion ist die erste Version mit derartigen Meldungen. Damit gibt es das erste Mal Antworten. Nun ist auch klar, warum ich unter FDISK die Partition auf AKTIV setzen wollte und keinerlei Änderung zu verzeichnen war. FDISK wurde beendet, zur Kontrolle neu gestartet und in der Statusanzeige war das A verschwunden. Alle anderen AHDI-Versionen und auch der aktuelle HDDRIVER haben die Infos nicht ausgegeben.


    Gruß
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Vergiss einfach mal das mit dem Unterschied zwischen CF und Festplatte. Da gibts nämlich aus der Sicht des Falcon keinen. Der kann nicht unterscheiden, ob das eine mechanische Platte oder nur Flash ist. Der muss eine CF auch nicht anders ansprechen als eine Platte, denn eine CF emuliert eine Platte. Ein IDE-Interface im PIO-Modus besteht als Befehlen zum Ansprechen von CHS (Clyinder, Head, Sektor), ja auch eine CF-Karte gaukelt sowas vor, wenn sie so angesprochen wird. Alternativ können IDE-Laufwerke auch per LBA angesprochen werden, logic block adressing (also alle Sektoren des Laufwerks einfach von 0 bis n durchnummeriert, ohne dass man sich um CHS nicht mehr kümmern muss), aber das beherrscht der Falcon nicht, und selbst da ist auf dem IDE-Interface kein Unterschied zwischen einer Platte und einer CF zu sehen! Den Unterschied CF/PLatte kann einen Rechner erst sehen, wenn er ein AHCI-SATA-Interface hat, und das hat der Falcon nicht. (Vielleicht erinnerst du dich, erst Windows 7 konnte von Flashlaufwerken richtig profitieren, weil ändere Windows-Versionen den Unterschied nicht sahen und auch Flash versuchen zu defragmentieren...)


    Also, konzentriere dich mal auf das Wesentliche. Und das ist, dass der FalconSpeed irgendwelche IO-Adressen braucht, damit der 386SX und der 68030 dessen Hardware ansprechen und konfigurieren können muss. Und die Adressen müssen irgendwo liegen, wo beide CPUs dran kommen können, Und da es beim Falcon keinen dediziertes IO-Adressing gibt, sondern alles Memory.Mapped ist, muss das in dem Adressbereich liegen, der zwischen 4 und 14 MB liegt, oder wie die FPU adressiert wird.

  • Diese Meldung von AHDI kann ich dir auch erklären:


    Der Festplattenmamager kümmert sich ja um as Ansprechen der Platte. Das Diskformat kann daher von Plattentreiber zu Plattentreiber varieren. Die Meldung von AHDI sagt schlicht, dass er mit der Partitionierung modernerer Plattentreiber nichts anfangen kann. Es ist also nicht was grundsätzlich falsch mit dem Laufwerk, sondern AHDI kann das nur nicht lesen.

  • Ich nehme stark an, daß du von einer Floppy gebootet hast.
    Das NOT BOOTLOADED sollte eigentlich nur sagen, daß auf der Platte kein Bootloader sitzt, aus dem heraus AHDI gestartet wurde.

  • Moin Jens,
    nein es war keine Floppy. Es waren verschiedene CF-Karten und eine ganz normale Festplatte. Der Ablauf ist ja wie in Startbeitrag schon beschrieben. HDD / CF einbauen und einrichten. Von HDD / CF starten (FDD ist leer). Wenn das System fertig ist, zuerst Fall_Inst starten und Laufwerke zuweisen. Dann die Falspeed.prg starten um die Falconspeed zu aktivieren. Läuft bis dorthin auch wunderbar. Einzig, ich bekomme mit FDISK die DOS Partition nicht aktiviert und AHDI gibt die Hinweise aus. Der Format-Befehl läuft bis zur Anzeige 100% und dann ist Schluss. Die Anzeige bleibt stehen, nichts geht mehr. Format c: /s wird auch nicht ausgeführt, der Rechner geht einfach in den DOS-Prompt zurück. Wenn ich zum Beispiel einfach eine DOS-Installation laufen lassen will, dann bricht sie immer beim Schreiben der msdos.sys ab.
    Zur Sicherheit hatte ich die Screenblaster abgenommen, die FPU draußen, keine Chance. Ich glaube auch, dass 1ST1 mit seiner Vermutung Recht hat. Ich kann es aber nicht testen, da ich kein 4 MB RAM-Modul habe. Sonst hätte ich die 14 MB zum Test einmal rausgenommen.
    Ich denke, dass ich den Falcon zur CC mitbringe, dann können wir es gerne noch einmal probieren. Die konfigurierten CF und die HDD liegen unverändert im Schrank. Solltest Du noch ein 4 MB Modul haben, dann können wir zum Test auch mal das 14er rausnehmen.


    Gruß
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Moinmoin.
    Es wundert mich, daß der Plattentreiber nicht von Floppy gestartet wurde.
    Ich hatte die Nachricht damals als Anfänger, als ich meine Festplatte 'aufgeräumt' hatte.
    AHDI funktionierte aus irgendwelchen Gründen *rofl* nur von Floppy und spuckte die von dir beschriebene Ansage aus.
    Nachdem mir dann jemand erklärt hatte, was ich da angestellt hatte, habe ich DEN Fehler nicht mehr gemacht.


    In meinem kleinen Falcon sitzen 4 MB plus eine FX-Card, mit der ich auf 14 MB komme.
    Im großen 14 MB.
    Ich garantiere nicht, daß ich weitere 4 MB Karten habe, aber falls mir eine in die Finger fallen sollte, bringe ich sie mit.

  • Hallo Reiner


    Ich habe mindestens zwei 4MB-Karten. Ich bring eine zur Classic mit.


    Grüessli, Uli

  • Ich danke Euch, dann nehme ich diesmal tatsächlich den Falken mit. Dann fehlt nur noch Didi55, mit dem hatte ich zu dieser Sache telefoniert, in der Bastelrunde und wir sind ein fröhliches Quartett. Ich mache schon mal eine Liste, so dass ich Alles dabei habe. Eine Kiste Tannenzäpfe, einige CF's, die verwendeten Disks, Dokumentation und Treiber, dann können wir mal die Sache gemeinsam nachstellen.


    Mit freundlichen Grüßen
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Vielleicht sind wir dann ein Quintett, demnächst machen wir HomeConmäßig aus, ob/wie wir hoch kommen, und wenns klappt werde ich wohl auch meinen Falcon und einen TT mitbringen, und wer weiß was sonst noch...

  • Hallo 1ST1,
    das wäre doch gar nicht schlecht. Dann lernen wir uns zur CC in Nordhorn auch mal persönlich kennen. Dann wäre es schon praktisch, vorausgesetzt niemand hat etwas dagegen, das wir in der Halle eventuell zusammen gruppiert werden.


    Gruß
    Reiner

    --- Der Fischkopp aus dem wilden Süden ---
    --- reiner-schulz.org ---

    --- BBS-Mailbox 0049 7131 970251 ---

  • Kleine Atari-Ecke?
    Bin grundsätzlich dafür.
    Vielleicht gleich neben der Apple-Ecke? ^^

  • Aber nur, wenn senildatasystems auch direkt nebenan ist :D Der nimmt so gerne Sachen, die andere nicht mehr brauchen :biglach:

  • Hallo,


    tja, ähm, dieser Thread ist schon etwas alt...

    Hat es denn abschliessend eine Lösung gegebn?


    Ich habe aber gerade auch einen FalconSpeed bekommen und in erfreut eingebaut.


    HW-Konfiguration: FPU, 14MB, HDDRIVER v10.x, Treibersoftware v6.20


    Das FLS_INST bombt sehr oft, ab und an startet es aber dann doch und man kann die Konfiguration durchführen.


    Eine zeitlang habe ich schon befürchtet, es geht nur von Diskette; mein Falcon hat aber stattdessen ein ZIP-Laufwerk :-) Ein Testeinbau einer echten Floppy brachte keine Besserung. Das FALSPEED startet mit 4MB, aber auch mit 14MB. Die FPU scheint nicht weiter zu stören.


    Was ich bisher nicht hinbekommen habe, ist die Festplatte "zu sehen", Das BIOS-Bild meldet immer "none". Egal, ob mit/ohne FPU, 4/14MB und als HDD-Treiber habe ich den HDDRIVER und ICD probiert. Ist auch egal, welche Konfiguration mit FLS_INST eingestellt ist.


    Oder funktioniert HDD mit der Betriebssoftware in Version 6.20 einfach noch gar nicht?


    Hat da jemand vielleicht einen Tipp?