Mal wieder Lust in Mailboxen zu stöbern?

  • Das MultiTel D kennt nur mark/space/even/odd. Nur mit space gelingt eine Verbindung, ich sehe auch alle alle möglichen Texte, aber es hat den Anschein, als würden wie wild Eingaben getätigt, obwohl ich keine Tasten drücke...

    Bei 8 Datenbits und dem Parity=0 kann das Parity als Startbit interpretiert werden.

    Probier mal 7 Datenbits wenn moeglich, dann steht dir allerdings nur der 7bit ASCII Zeichensatz zur Verfuegung.

    Wenn ich es richtig sehe, habe ich mit space = keine Parität und die Bitzahl ist 7. Mehr kann ich am Multitel nicht einstellen:


    Gruß

    Roland

  • Dann wird's wohl nicht besser.

    Ich teile deine Vermutung. Es werden immer 8bit (7 Data + 1 Parity) gesendet.


    space = keine Parität

    Bei Parity = Space wird ein konstantes 0-Bit gesendet. Bei "Keine Paritaet" wird kein P-Bit gesendet.

    Ob ein Bit Parity oder Data ist, weiss keiner. Das geht erst aus den Einstellungen hervor.

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • Es gibt NetFoss von Mike Ehlert.

    Läuft zuverlässig und ist Freeware.

    das kommt als nächstes drann :-)

    der ZERBERUS benötigt mindestens 570Kbyte, passt das?

    QEMM habe ich allerdings auch noch, wenn nötig.

  • Es gibt NetFoss von Mike Ehlert.

    Läuft zuverlässig und ist Freeware.

    das kommt als nächstes drann :-)

    der ZERBERUS benötigt mindestens 570Kbyte, passt das?

    QEMM habe ich allerdings auch noch, wenn nötig.

    Echt? Was haben die da denn verbockt? Hier lief die Mailbox immer am Netware-Server. Und unter Desqview. Ich glaube nicht, dass das funktioniert hätte.

    AlphaNET und NCBmail waren da auf jeden Fall sparsamer.

  • Geht es jetzt noch um dieses Thema: "Mal wieder Lust in Mailboxen zu stöbern?"

  • Es gibt NetFoss von Mike Ehlert.

    Läuft zuverlässig und ist Freeware.

    Hätte mich auch gewundert, wenn es sowas nicht schon gäbe. ;)

    Ich habe gerade gesehen, dass das ein 32/64-Bit-Programm für Windows ist. Wie funktioniert das denn? Meine Mailbox-Software läuft ja nicht unter Windows sondern entweder auf einem realen DOS-PC oder in einer DOS-Emulation unter Virtual Box.

    Mal schauen, vielleicht habe ich ja mal Lust und Zeit einen Arduino bzw. ESP als Telnet-Modem zu programmieren.

    Im Prinzip habe ich sowas schon gemacht (ist keine große Sache und gibt es bestimmt auch zigfach im Netz), ich müsste nur die notwendigen AT-Befehle implementieren.

  • Moin moin,

    wenn jemand den ZERBERUS besucht, wäre es nett, mit S für Senden, eine Nachricht an SYSOP zu hinterlassen.

    Noch schöner ist auch ein AINtrag, also Userantrag.

    Ein ? zeigt die Optionen an.

    In den vielen Jahren ist doch einiges in Vergessenheit geraten,

    deswegen freue ich mich über eine Nutzung und Rückmeldungen.

    Auch technische Rückmeldungen sind willkommen.


    Wolfgang Mexner wollte die Software unter open source stellen, wenn es mehr Aktivität gibt, macht er es vielleicht auch.


    Eine schönes Wochenende, wünscht,

    ElRetro

    --

  • Moin moin,

    Aktualisierung ZERBERUS Mailbox:

    zum Testen ist ARCHIVUM, mein ZERBERUS System, mit telnet erreichbar:

    adlernet.dynaccess.net:2001

    wenn verbunden wird ATA angezeigt,

    jetzt CONNECT eingeben, nur Grossbuchstaben, Return

    User: GAST

    Passwort: GAST

    NEU:

    Auf Port 2 ist jetzt auch ein MODEM angeschlossen:

    02921-9442014


    Freue mich über TestRückmeldungen!


    Spass am Gerät,

    wünscht

    ElRetro

  • Wer also Lust zum Testen hat: Mein ZyXEL U-1496 S+ wartet an 02151 - 747 62 747

    War gerade mit ZyXEL 1496 EG+ fuer 3,2Min im System, dann kam NO CARRIER.

    Bitte gebt mir mal eine bewährte Konfiguration zwischen 2 ZyXEL.

    Wenn ich das so schnell gesehen habe, wurde 19200 angezeigt.

    benutzt: DOS 6.22 mit TELIX, 16550 FiFO

    cu

    ElRetro

    --

  • Mit realem Modem dürfte nur noch 14.400 funktionieren, da das der FAX-Standard ist und dieser als Direktanwahl über das VoiP unterstützt wird.

    Hierfür soll man Audio-Codec G.711 verwenden. Alternativ könnte man auch T.38 probieren.


    Für T.38 muss der Provider mitspielen.

    G.711 kannst du selbst in deiner Fritzbox auswählen indem du das Endgerät in der Fritzbox als FAX ausgibst (nutze den Assistenten dafür).


    https://de.wikipedia.org/wiki/G.711

    https://de.wikipedia.org/wiki/T.38

    Neo Geo | C64 | A500+ | A1000 (GB-Edition) | A3000D rev.9.01 | A4000D rev.B | Compaq Armada 4200

  • CELL-Mode aktivieren: ATS49.7=1

    Damit gibt es gewöhnlich auch über VoIP eine sehr stabile Verbindung, wenn auch nicht so schnell.

    Details im Handbuch, Kapitel 13 (Cellular-Modus).

    Da ist sehr gut beschrieben, wofür der Modus gedacht ist (Cellphone).

    Die beschriebenen Probleme kommen einem bei VoIP spontan bekannt vor.

  • CELL-Mode aktivieren: ATS49.7=1

    Damit gibt es gewöhnlich auch über VoIP eine sehr stabile Verbindung, wenn auch nicht so schnell.

    Details im Handbuch, Kapitel 13 (Cellular-Modus).

    Da ist sehr gut beschrieben, wofür der Modus gedacht ist (Cellphone).

    Die beschriebenen Probleme kommen einem bei VoIP spontan bekannt vor.

    Den Tipp muss ich mir für mein 1496 E+ merken... Danke :)

  • Moin moin,

    ich kriege bald ne Krise,

    der Code ist die original MODEM.MBX von ZERBERUS.

    Was meldet mir ZERBERUS:

    "falsche CONNECT Meldung"

    dann dauert es 10 Sekunden,

    die Anzeige geht weiter mit einer CONNECT Meldung und über das anrufende MODEM kann ich mich normal

    am ZERBERUS anmelden.


    Sagt das irgendeinem hier etwas?

    Vielleicht die ehemaligen ZERBERUS betreiber?


    grummelt

    ElRetro


    # Modemdatei fr das ZYXEL-Modem 1496EG Plus 20211104

    # ElRetro

    # S0=0

    # S49.7=1 Cell Mode

    #

    # Lockedspeed 57600 kann evtl. Probleme machen, wenn man a) keinen

    # 16550AFN auf der Schnittstellen-Karte hat oder b) eine ROM-Rel. < 4.05

    # hat. Ich hatte auch mit der Rel. 4.02 keine Probleme.

    #

    # Sollte man die Datenbank ASSI benutzen, gehen eh nur 19200.

    #

    # Interessant ist RINGING. Sollte die Serverbox gerade stundenlang

    # verteilen oder gar offline sein und man hat (wie hier eingetragen) bei

    # der NO CARRIER- Meldung RINGING eingetragen, so legt das ZyXEL beim

    # vierten Freizeichen auf und die Box steht den anderen Nutzern wieder

    # zur Verfuegung.

    #

    #

    ZyXEL U-1496/1496B/1496E

    # Anzahl Connect-Meldungen fr das Modem

    20

    # Anzahl Init-Zeilen fr das Modem

    2

    # Initialisierungsbaudrate

    Lockedspeed

    Hardwarehandshake

    57600

    # Anruf erkennen - Leerstring = Hardwaremaessig ueber Pin 22

    RING

    0

    # NO Carrier Meldung / RINGING bewirkt, dass das Modem beim 4. Freiz. auflegt!

    NO CARRIER

    0

    # Timeout-Meldung des Modems

    NO DIALTONE

    0

    # Modem online schalten

    # (darf nicht gleichzeitig mit AUTOANSWER gesetzt werden

    # sonst legt das Modem nach dem RING sofort wieder auf)

    #

    ATA\r

    0

    # Modem offline schalten

    # Wenn hier was steht, wird DTR nicht auf LOW gezogen

    #

    # Modem w„hlen

    ATM1DP%s

    0

    # Modem Busy

    BUSY

    0

    # Fastinit fuer das Modem

    AT\r

    OK

    100

    #

    # Faxspezifikation

    #

    FAX.BAT

    CONNECT FAX

    100

    #

    # Grundinitialisierung des Modems

    #

    # Initstring 1. Zeile Modem - Reset

    AT Z1\r

    OK

    1200

    # Modem-Init Zeile 2

    AT &FX6&D2M1L5&K4&N0N0S0=0S49.7=1S7=90S2=255*Q0&W1\r

    OK

    800

    #

    # Connect-Meldungen des Modems

    #

    # 300 Baud Verbindung

    CONNECT

    300

    # 300 MNP Verbindung

    CONNECT /ARQ

    1200

    # 1200 Baud Verbindung

    CONNECT 1200

    1200

    # 1200 MNP5 Verbindung

    CONNECT 1200/ARQ

    2400

    # 2400 Baud Verbindung

    CONNECT 2400

    2400

    # 2400 ARQ Verbindung

    CONNECT 2400/ARQ

    4800

    # 4800 Baud Verbindung

    CONNECT 4800

    4800

    # 4800 ARQ Verbindung

    CONNECT 4800/ARQ

    9600

    # 7200 Baud Verbindung

    CONNECT 7200

    7200

    # 7200 ARQ Verbindung

    CONNECT 7200/ARQ

    19200

    # 9600 Baud Verbindung

    CONNECT 9600

    9600

    # 9600 ARQ Verbindung

    CONNECT 9600/ARQ

    19200

    # 12000 Baud Verbindung

    CONNECT 12000

    19200

    # 12000 ARQ Verbindung

    CONNECT 12000/ARQ

    19200

    # 14400-Verbindung

    CONNECT 14400

    57600

    # 14400 ARQ Verbindung

    CONNECT 14400/ARQ

    57600

    # 16800-Verbindung

    CONNECT 16800

    57600

    # 16800 ARQ Verbindung

    CONNECT 16800/ARQ

    57600

    # 19200 Verbindung

    CONNECT 19200

    57600

    # 19200 ARQ Verbindung

    CONNECT 19200/ARQ

    57600

  • Mit der Einschränkung auf bestimmte Connect-Meldungen muß man natürlich dafür sorgen, daß vom Modem auch genau diese kommen.

    Geht das wirklich nur mit fest vorgegebenen Meldungen, oder kann man da auch mit Platzhaltern arbeiten?

    Wenn das ginge, würde ich da mit sowas wie 'CONNECT 14400*' arbeiten.

    Die Vielzahl der Möglichkeiten/Kombinationen, die das ZyX zurückmelden kann, würde ich da nicht einpflegen wollen.

    Aus dem Stand fallen mir einige Suffixe ein, die da vorkommen können: /V42B, /MNP5, /ARQ, /SREJ, /ZYX, /CELL.

    Oder einfach komplett ohne Suffixe, und den Modem-Init entsprechend anpassen.

    Der ist eh viel zu lang für ein ZyX, das mit AT&F (Werkseinstellungen) eigentlich perfekt arbeitet.


    PS.: S49.7 würde ich persönlich im Mailbox-Modeminit nicht verwenden.

    Meiner Meinung nach sollte die Auswahl, ob der Cell-Mode genutzt werden soll, der Anrufer treffen.

  • Hallo Toast_r,

    Danke für die Hinweise,

    nur AT&F hat das Problem nicht beseitigt.

    Nach dem ATA wird der CONNECT angemeckert,

    die HS LED blinkt, Sekundentakt,

    nach 10 Sek. stellt der ZERBERUS eine 14400 Verbindung her,

    und es kann ein Login durchgeführt werden.

    cu

    ElRetro

  • Moin moin,

    beim NetCom+ hatte ich auch schon Probleme mit den Verzögerungszeiten,

    ist mir gerade wieder eingefallen,

    habe jetzt in der MODEM.MBX sie Verzögerungszeit nach dem Kommando ATA

    von 0 auf 100 geändert, jetzt klappt es.


    Das System ist jetzt wieder auf TELNET, zu DESQview bin ich heute auch nicht gekommen,

    einen schönen Abend noch, wünscht,

    ElRetro

    --

    PS:

    adlernet.dynaccess.net:2001

    wenn verbunden wird ATA angezeigt

    jetzt CONNECT eingeben, nur Grossbuchstaben, Return

    Name: GAST

    PW: GAST

    ? gibt Hilfe

  • Mit Platzhaltern geht nicht.

    CONNECT 14400 schein mir die beste Lösung zu sein,

    vielleicht gelingt es mir die CONNECT Meldungen auf "1" zu reduzieren,

    laut Handbuch Kapitel 8-3 ERGEBNISCODE 17

    CONNECT 14400

    muss das dann X4 sein?

  • das war jetzt erstmal erfolgreich, jetzt gibt es einen 14400 CONNECT ohne Fehlermeldung,

    Login als normaler Nutzer klappt,

    Point klappt noch nicht.

    gute Nacht