Posts by Edelrost stahlfrei

    Da sehe ich kein Problem. Diese Befehle heißen genau richtig. Sie waren von den Herstellern nie dokumentiert, sie sind ein Zufallsprodukt entstanden aus dem Zwang Transistoren zu sparen.

    Dennoch sind sie AFAIR vereinzelt verwendet worden. Ich meine mich zu erinnern, daß insbesondere einige Spiele nicht liefen, sobald ein 65c02 in der Kiste steckte. Leider kann ich Dir aber keine konkreten Titel nennen, bei denen das vorgekommen sein soll.

    Nicht, daß Du mich falsch verstehst: ich finde die Illegal Opcodes eine spannende Sache an den NMOS-Chips.

    Zweifellos, obwohl deren Nutzen vermutlich in den meisten Fällen eher begrenzt war. Aber damals[tm] zählte jedes Byte und jede Mikrosekunde.


    Mathias, diesmal mit besten Grüßen (sorry für das Weglassen im Vorposting, ich bin von MacSOUP gewöhnt, daß das automagisch eingefügt wird.)

    Bei einer 65816 bleibt das Problem, daß manche Software, die die undokumentierten Befehle der 6502 nutzt ("illegal opcodes"), nicht läuft und u. U. nicht sinnvoll gepatcht werden kann. Dann lieber einen 6502, so daß man zwischen einer klassischen und "modernen" CPU wie der 65SC02 wählen kann. Mir wäre wichtig, daß man - zumindest optional - das gleiche Timing wie beim originalen europlus hat.

    So ein Exemplar habe ich noch, aber leider im "Basislager" (sprich: Elternhaus), und dort liegt auch noch eine sehr rudimentäre Geweichsanbrausung herum. Leider ist es mir nie gelungen, sie zuverlässig zum Laufen zu bringen, sie leidet unter Alzheimer... Stups mich ggf. per PM an, so als Erinnerungsstütze, denn die besagte Geweichsanbrausung habe ich definitiv hier - das weiß ich deshalb sicher, weil mir unlängst beim Packen der Umzugskartons das Faltblatt in die Finger geraten ist. Damit ist die Herausforderung auch schon angesprochen: Ich hause zwar schin in der neuen Hütte, aber noch zwischen Kisten und Kartons :-/ Sobald ich das Papier gefunden habe (und ich es nicht vergesse, deshalb die Bitte um den Anstupser), lege ich Dir das gerne mal auf den Scanner.

    Sobald der Duo-Disk Controller wieder drin steckt, läuft er Bootprozess IMMER über den Duo-Disk Controller, sprich Diskette drin oder nicht, ich komm an den CFFA nicht mehr direkt ran, nur wieder über meinen besagten Weg "ProDos von Diskette booten und dann Pr#6.

    Das muß so sein: Beim Start fragt der Apple alle Slots in absteigender Reihenfolge, beginnend mit Slot 7, daraufhin ab, ob sich ein Floppycontroller darin befindet. Falls er einen findet, führt er die Befehle auf dem vorgefundenen Boot-PROM aus.

    Ok, also wenn schon dann richtig, also Disketten Controller in Slot 6 und CFFA in Slot 5 gesteckt, nur ... das ändert leider nix. Wieder verhindert der Disk Controller das ich an die CFFA ran komme.

    Wie beschrieben: Ändere die Reihenfolge der Karten. Achte darauf, daß die CFFA rechts vom Floppycontroller steckt, dann sollte es wie gewünscht laufen.

    Irgendwie hat meine Kiste auch noch eine Macke, denn wenn ich die Ausschalte und gleich danach wieder einschalte läuft die nicht in den Bootup rein, sondern am Monitor erscheinen u.U. die Anzeigen von vor dem Ausschalten (der Videoram ist also nicht resettet).

    It's not a bug, it's a feature... Im Ernst: Wenn Du die Kiste nur sehr kurz ausschaltest, dann ist sie ja gar nicht wirklich aus gewesen. Im Netzteil, auf dem Motherboard und nicht zuletzt in den Chips (die einzelnen Speicherzellen sind im Grunde Kondensatoren) stecken viele, viele Kondensatoren, die die Spannung noch eine Weile halten können. Wenn Du nur ein, zwei Sekunden die Stromzufuhr unterbrichst, dann sinken die Spannungsniveaus nach und nach ab, und je nach Dauer des Ausschaltens werden machen Informationen gehalten, während andere Bits zufällig gesetzt sind. Schalte die Kiste für mindestens zehn Sekunden aus, dann sollte sie einen sauberen Kaltstart hinlegen.

    Gut das heute chlechtes Wetter ist, da kann ich ja noch ein bischen rum probieren.

    Viel Erfolg!