Posts by rfka01

    masi hat mir seinen Olytext 20 (und auch den Brother SK-64) vererbt, nochmals herzlichen Dank ... und dieser funktioniert tatsächlich, so dass ich noch ein paar weitere Screenshots vom System zeigen kann:


    Das System bootet ins Olytext-Textverarbeitungsprogramm:




    von dort aus kann man mit F12 in ein Systemmenü kommen:




    Dieses bietet menügesteuert die Funktionen der üblichen CP/M-Utilities wie STAT, PIP usw. an.




    Nettes Oly-Logo an der rechten Seite :)


    Vom Menü aus kommt man zur CP/M-Kommandozeile, auf der man aber - mangels Systemprogrammen - nicht viel anfangen kann.




    Mal sehen, ob ich eine Diskette mit ein paar Progrämmchen zum Ausprobieren zusammenstopseln kann.

    Hast Du schonmal probiert, das Olytext zu entfernen (z.B. von einer Sicherungskopie mit Supercopy) und zu schauen, ob dann die CP/M Prompt kommt?

    Noch nicht ...


    Achtung, im ersten Post habe ich das Software-Archiv nochmal verändert, weil die eigentlichen Diskettenimages gefehlt haben. Leider enthält die Arbeitskopie offenbar persönliche Daten, daher habe ich sie wieder aus dem Archiv entfernt.

    Hier hatte ich nach Infos und Software zum Olytext 30 gefragt, und masi hat sich eingeklinkt und die ROMs seines Olytext 20 ausgelesen - kein XT wie der Olytext 30, sondern eine Z80 / CP/M basierte Maschine.


    Vor einigen Tagen hat mich Toshi auf einen Oly 20 hier in der Nähe aufmerksam gemacht, den ich gestern abgeholt habe.


    Das Wichtigste voraus: Bei meinem Gerät waren zwei Originaldisketten dabei, eine davon anscheinend unbenutzt und schreibgeschützt. Die ROMs haben den gleichen Inhalt wie die aus dem Oly 20 von masi . Disketten-Images und ROMs habe ich an diesen Post angehängt.


    Ansonsten besteht mein Gerät aus der Zentraleinheit, einem bernsteinfarbenem Monitor mit FBAS-Anschluss, einer Tastatur (leider bröselt die Ummantelung des Kabels bereits bei scharfem Hinsehen ab) und einem Olympia ESW 2000C Typenraddrucker (versteht angeblich Diablo-Codes).




    Das Netzteil des Rechners ist anscheinend defekt - es läuft nicht einmal der Lüfter an. Die Sicherung ist in Ordnung, und die Bauteile auf der Platine sehen unbeschädigt aus - da muss mal ein Eggschberde ran.


    Praktischerweise hat Olympia die Stromversorgung über einen normalen Molex-Stecker, wie er für 5.25"-Diskettenlaufwerke verwendet wird, auf das Mainboard geführt. Ich konnte das Gerät also an ein normales AT-Netzteil anschließen, und siehe da - der Rechner bootet von einer Diskette im linken Laufwerk.



    Das System bootet ein CP/M 2.2 und lädt dann automatisch die Textverarbeitung Olytext (d'uh!). Ab Werk waren auch Disketten mit Micropro-Software wie Wordstar erhältlich.


    Soweit so gut, leider funktioniert die Tastatur nicht - oder das System funktioniert nicht ohne Drucker - das wird noch auszuprobieren sein. Die Handbücher scanne ich bei Gelegenheit noch ein und lade sie auch hier hoch.


    Robert

    Files

    • ROMs.zip

      (5.56 kB, downloaded 2 times, last: )
    • Software.zip

      (753.45 kB, downloaded 5 times, last: )

    Servus,

    Peter, sind Deine Rainbows +, A oder B Maschinen? Im Falle von A wäre ich dringend an ROM-Dumps interessiert ... ich habe mal angehängt, was hier nach Service-Manual aussieht.


    Gruß

    Robert

    Hallo Fritz,

    danke für den Hinweis - denn das wollte ich eigentlich auch in meinem Post erwähnen. Die von Fritz empfohlene Methode klappt beim 3125 einwandfrei - das Gerät bootet vom seriell angebotenen Diskettenimage. So konnte ich den Zugriff auf meine Flash-"Festplatte" wieder herstellen, indem ich über das serielle Disk-Image den passenden Treiber geladen habe.


    Ich hatte mit der config.sys gespielt - ohne Einbindung des Treibers auf dem Laufwerk, das es betrifft (Flash-Laufwerk C) (wirr, ich weiß) nicht mehr erkannt, man hat also auch keine Möglichkeit, die config.sys wieder zu ergänzen. Und mein Flash-Startlaufwerk A ist schreibgeschützt, so dass ich die dort vorhandene config.old nicht umbenennen, löschen und mangels Platz auch keine neue Datei erstellen konnte. Wie das im täglichen Regelbetrieb funktioniert hat, weiß der Geier ...


    Robert

    Hallo miteinander,

    ich habe ein NCR Tablet 3125 bekommen. Den anderen Thread unter IDE Emulatoren? habe ich aufmerksam gelesen, herzlichen Dank fritzeflink und kpanic für das Bereitstellen von Dateien.


    Ich konnte mir einen Disketteneinschub und das passende Laufwerk ausleihen und eine Bootdiskette erstellen und die anderen Dateien per Laplink sichern. Das Ergebnis hängt hier an :) Interessant dabei dürfte vor allem die Windows 3.1 Beta mit den Pen-Programmen sein.


    Der Rechner hat keine eingebaute Festplatte, sondern ein Flash-Laufwerk, das nicht im BIOS eingestellt wird.


    kpanic , mit welchem Tool hast Du Deine Festplatte gesichert (Du hast Images im oben genannten Thread gepostet).


    Ich suche noch einen Stift für mein Tablet, und - falls jemand sowas zufällig über hat - auch das Diskettenlaufwerk mit dem Platineneinschub.


    Robert

    Files

    • NCR3125.zip

      (5.82 MB, downloaded 4 times, last: )

    Was für ein Schätzchen hast Du denn da, 1ST1?

    Ich habe in dieser Übergangszeit von Windows 3.0 / Windows 3.1 / WfW meine Diplomarbeit geschrieben und bin reumütig wieder zu meinem WordPerfect für DOS zurückgekehrt, nachdem die mir damals verfügbaren Windows-Textverarbeitungen (wimre eine Word- und eine Wordperfect-Version) ein paar mal den Text massiv durcheinandergehaut hatten.


    True Type kam auch erst mit Windows 3.1 so dass vorher die Druckerausgabe teilweise mau war.

    Hallo Toshi,

    ich konnte bislang nur in der Emulation testen.

    Könntest Du zu Testzwecken bitte die PC8SYS.IMD nochmal zurückschreiben und bei Dir booten?


    PC8SYS.IMD zeigt bei mir in der Emulation nur einen geraden Strich nach dem Boot, bei TANVEDT.IMD und NVEDIT.TD0 marschieren Zeichenketten über den Bildschirm.

    Nach dem Boot mit der roycpm.td0 aus http://oldcomputers.dyndns.org…troarchive.org/index.html von fritzeflink kann ich aber sowohl kermit als auch nvedit aufrufen - dafür schon mal vielen Dank.


    Robert

    Hallo Peter,

    Du kannst Rainbow-Disketten von Images mit einem 1.2MB-Laufwerk in einem DOS-Rechner schreiben.


    @fritzeflinks Archiv ist wieder mal bestens bestückt:


    http://oldcomputers.dyndns.org…rainbow/images/index.html


    Teledisk findest Du hier:


    http://www.classiccmp.org/dunfield/img54306/teledisk.htm


    Das Diskettenformat ist einseitig, 10 Sektoren/Spur, 80 Spuren ...


    Meistens funktioniert es, DD-Disketten zu verwenden, klassisch wären QD (96tpi).


    HD-Disketten werden nicht/nicht dauerhaft/fehlerhaft funktionieren, weil sie andere Magnetisierungseigenschaften haben.


    Falls alle Stricke reißen, kann ich auch Disketten für Dich erstellen.


    Gruß

    Robert

    Ich wollte mal vorsichtig anklopfen, ob Du die Notebooks versenden konntest, charmanta ... hätte Dir gerne die Versandkosten überwiesen, aber ich habe auf meine Nachricht mit der Adresse keine Antwort bekommen.

    Liebe Freunde der leichten Muse und schweren Rechner,


    dank vieler Infos (und auch der Bootdisk) hier aus dem Forum wird die Emulation der Alphatronic P30 in MAME so langsam.




    DOS bootet bereits, und wie auf der echten Hardware muss man DISDEU.SYS aus der config.sys entfernen, damit die Anzeige auf dem Haupt- (FBAS)-Schirm bleibt.


    Zum Test des DOS und möglicherweise der Grafik suche ich nun weitere Disketten-Images - für die P30 habe ich bislang nur das DOS.


    Ich spreche mal direkt Ajax an (er schrieb, dass er Disk-Images hat), netmercer und Toshi (er hat es geschaft, Software auf P30-Disketten zu kopieren). Vielleicht gibt es ja auch andere User hier, die sich bislang noch nicht aus der Deckung gewagt haben.

    Genial wäre Software, die die Grafikerweiterung bedient, und somit etwas auf dem zweiten, digitalen Monitor darstellt.


    Das wäre sicherlich nicht nur für die Emulation, sondern auch alle P30-Hardware-Besitzer interessant.


    Herzliche Grüße


    Robert

    Kurzer Zwischenbericht: die beiden Nanos sind sehr unterschiedlich (Marcus, welche Geräteausführung hast Du, meiner ist ein 2515).


    Bei mir klappt die hintere Gehäuseseite komplett nach oben und beinhaltet das Netzteil, bei Marcus bleibt das Netzteil im Unterteil stehen, von oben her wird nur eine Platte abgenommen.


    Die Kartenkäfige sind von der Länge her nicht untereinander austauschbar, außerdem gibt es eine kurze Steckverbindung, die bei Marcus auf die Hilfs-Backplane des Kartenkäfigs geht, bei mir auf die Haupt-Backplane im Gehäuseboden. Mein Kartensatz in Marcus' Rechner piept auch, Marcus' Kartensatz in meinem Rechner piept nicht, bootet aber auch nicht.


    Reset-Signal? Möglich, aber für mich nicht nachverfolgbar ... ich schnitze mir jetzt erst einmal Laufwerksschienen, damit ich das Ding sicherer transportieren kann.


    Gruß

    Robert

    Hallo Felix, was jetzt noch fehlt ist die Systemstarteinstellung, also ob die Standard-Konfigurationsfiles autoexec.bat und config.sys vom ROM oder die angepassten von der Festplatte ausgewertet werden.


    Du kannst in diese Richtung auch "zu Fuß" testen, ob die virtuellen Laufwerke angelegt werden, indem Du z.B. "dir e:" eingibst. Dann müsstest Du das gleiche sehen, wie wenn Du "dir c:\block\set" eingibst. Lass Dir auch mal den Pfad nach Systemstart mit "path" anzeigen.

    Wenn du die Laufwerke e: - s: nicht anzeigen kannst, wird wahrscheinlich die angepasste autoexec.bat nicht gestartet.


    Die Auswertungen mit "errorlevel" scheinen Menüs mit Zahlen abzufragen, die in den Dateien wie "dienst.bld" abgelegt sind.


    Das ist hier ganz gut erklärt.


    Du kannst die einzelnen Einträge auch von Hand testen: Nimm Dir einen Unterabschnitt, z.B. für ein Spiel:


    Code
    1. :keen
    2. cls
    3. cd\spiele\keen
    4. keen1
    5. cd\
    6. goto spiele

    und schaue, ob das funktioniert (den letzten Befehl weglassen).


    kpanic war schneller: Die Pfadangabe für Wordstar fehlt. Entweder liegt eine Kopie von Wordstar in jedem Dokumenteverzeichnis, oder es ist "blank" im Hauptverzeichnis oder im DOS-Verzeichnis abgelegt.


    Die Untermenüs für Wordstar wechseln nur in das Dokumentenverzeichnis und rufen Wordstar auf, so dass dieser beim Start die gerade relevanten Dokumente ohne Verzeichniswechsel anzeigt.


    Gib von C:\ aus mal "dir ws.* /s" ein.


    Robert

    Quote

    Meiner funktioniert fehlerfrei... Also dann erblasst mal.... hehehe!

    Ich habe jetzt lange überlegt, ob und wie ich auf diesen Post antworte und hoffe einfach, der freundliche Mensch mit Quaderno war nur nervös beim Formulieren, weil es sein erster Post hier war.


    Schön, dass Deine Kiste funktioniert. Stell doch mal ein paar Bilder ein und erzähl, welche Software Du darauf laufen hast und du dafür empfehlen kannst. Oder ein paar wilde Stories mit Quaderno, Telefonzelle und Datenklo.


    Robert

    Hallo Herr Wiertalla,

    das Problem mit meinem Nano ist viel grundlegender als eine falsch abgespeicherte oder zurückgeschriebene Diskette, es ist ein Hardware-Problem: Der Rechner piepst vom Einschalten weg, sogar, wenn man ihm den Kartenkäfig nimmt.


    Robert

    So ... leider spielt mein Nano nicht mit. Mit dem Einschalten fängt er an zu piepsen, und er bootet leider auch nicht. Das Laufwerk A: läuft an.

    Das Piepsen bleibt auch, wenn ich ihm die Karten nehme ... k.A. was da los sein könnte.


    Robert

    Interessant wird's nochmal heute abend ... ich probiere mal, meinen Nano auch zum Leben zu erwecken. marno's ist im Prinzip ein tragbarer ITT3030 ... meiner hat einen anderen Kartensatz - u.a. mit einem R6545 anstelle des sonst bei SKS gängigen 9027/5027/5037 CRT-Bausteins.


    Ich muss mich jetzt mal intensiv mit dem Thema 3d-Druck befassen, da ja der DHL-Transport alle Laufwerksschienen zerstört hat. :cursing:

    Ein freundlicher Herr aus Schweden hat mir Diskettenimages von einem Nano 2500 geschickt und auf seiner Seite verlinkt - ich bin immer noch baff, dass nicht alles von diesen hübschen Rechnern im Orkus verschwunden ist.


    http://softsector.aplaholm.se/computers/


    Ole hat auf seiner Seite auch noch ein paar Utilities für andere Rechner, ein Besuch lohnt sich also.


    Robert

    Hier mal was interessantes zum Thema Systemdateien:


    https://de.wikipedia.org/wiki/IO.SYS


    Quote

    Während des Bootvorgangs wird der Bootsektor vom Bootdatenträger in den Speicher eingelesen und ausgeführt. Der DOS-Bootsektor lädt die ersten drei Sektoren der Datei IO.SYS / IBMBIO.COM. Zu diesem Zeitpunkt ist der Treiber für das FAT-Dateisystem noch nicht geladen, wodurch diese Datei erstens ganz am Anfang des Datenbereichs des Datenträgers, zweitens unfragmentiert und drittens die erste Datei im Hauptverzeichnis sein muss. Ab DOS 4.0 darf die Datei bis auf die ersten drei Sektoren fragmentiert sein. Mit DOS 5.0 darf die Datei auf einem beliebigen Ort des Datenträgers gespeichert sein, wobei hier auch die ersten drei Sektoren zusammenhängend (nicht fragmentiert) sein müssen;[2] die entsprechenden Angaben werden im Bootsektor hinterlegt.


    http://thestarman.pcministry.com/asm/mbr/DOS50FDB.htm


    MSDOS.SYS muss also die zweite Datei auf der Diskette sein.


    Das gleiche gilt entsprechend für die COMPAQ/IBM-Äquivalente IBMDOS.COM und IBMBIO.COM.


    Wer also nicht die von mir im vorletzten Beitrag verlinkten funktionierenden Images nehmen will, muss a) einen Compaq-Bootsektor nehmen und b) die Systemdateien einzeln in der angegeben Reihenfolge auf die Diskette kopieren und dann c) mit attrib auf hidden und system setzen.


    Gruß

    Robert