VICE unter X11

  • Hallo Linuxer,


    manchmal ist es ja doch ganz praktisch, nicht an der Original-Hardware arbeiten zu müssen, sondern im Emulator mal eben schnell was ausprobieren zu können. Dabei hat mir der VICE früher unter Windows ganz gute Dienste geleistet -- aber seitdem ich den 64-Emulator unter Debian Linux (Sid) zu verwenden versuche (d. h. seit ettlichen Jahren), scheitert es daran, dass das *loslassen* der Umschalt-Taste nicht erkannt wird, bis das x64-Fenster den Fokus verliert und wieder bekommt. Ziemlich lästig -- bei lO"$",8 hat man spätestens bei dem Komma ein Problem.


    Habt ihr dieses Phänomen auch schon beobachtet -- und gar eine Lösung dafür gefunden?


    Grüße --

  • Zumindest unter Ubuntu 10.04 tritt das Problem nicht auf, und zwar weder mit VICE 2.2 aus den Standard-Repos / GTK-Version), noch mit einem selbstgebauten VICE 2.2 oder VICE 2.3 in der SDL-Version.

  • Bei mir läuft Vice unter Linux (Ubuntu und Suse) seit einger Zeit nicht mehr. Leider ... :(

    Viele Grüsse
    Roman
    --------------------------------------------------------------------------------------------------------------
    ...auch das Zukünftige wird ein Morgen haben, das es zum Gestrigen werden lässt...


    Viele Grüsse aus der Schweiz
    http://webnose64.ch

  • So,


    scheint ein KDE4-Problem zu sein. Unter anderen Oberflächen (xfce, KDE4-loser Obenpox-WM) klappt's nämlich.


    Das Problem tritt übrigens bei *allen* VICE-Emulatoren *außer* xpet auf. Komisch.


    Da der Fehler zumindest unter Ubuntu nicht auftritt, ist es jetzt vielleicht mal Zeit für einen Bug-Report bei Debian. Fragt sich nur, ob unter VICE oder unter KDE4...


    Grüße --