Posts by Asklia

    Du Glücklicher hast eine Platine :-)


    Im F64 habe ich soeben die Links zu einem passenden terminalprogramm bekommen, mit dem ein 80xx/uMMF (endlich -) ein passendes 6809 Terminalprogramm ausführen könnte.


    Bin gespannt, ob und wann es wieder Platinen geben wird. Endlich eine Anwendung für einen alten 80xx im Serverraum :-)

    Bin sehr beeindruckt! Da würde ich auch gar zugerne mein Interesse an einer Platine anmelden; auch wenn die Protoys alle bereits vergeben sind.


    Vorsichtige Frage: Wären statt der Spannungsregler mit Kühlkörper nicht pin- und bauform-kompatible Schaltregler wie etwa die von ezsbc.com eine Alternative? Brauchen nur halb so viel Strom und werden nicht heiss.


    Erste Bilder hier: https://www.forum64.de/index.p…e-f%C3%BCr-cbm-netzteile/

    Nachtrag: Der 8296-D ist gerettet :-)


    Habe heute ein Ersatzlaufwerk für das defekte Drive 1 erhalten. Interessanterweise hat das neuere JU-570-2 gegenüber dem älteren Typ JU-570 ein paar Kabel weniger am Sammelstecker. Natürlich mussten bei dem Laufwerk auf der Motorplatine auch erstmal alle kleinen schwarzen Laufwerkskondensatoren ausgetauscht werden; die fingen gerade an auszulaufen. Platinenschäden gab es netterweise aber noch keine.


    Blende natürlich mit gewechselt: Der Laufwerkshebel beim 8296-D ist ja designbedingt kleiner als bei den Laufwerken einer SFD-1001 oder einer 8250 LP.


    "cA" geht wieder auf beiden Laufwerken. Nun steht ein wunderschön erhaltener 8296-D im technischen und optischen Bestzustand bald zum Verkauf :-)

    Das Programm wäre ja schon mal ein Anfang. Leider ist der Userport des 8000 wohl nicht identisch mit dem eines C64; ein C64 RS-232 Adapter (sprich: Pegelwandler) dürfte wohl kaum an einem 8000er funktionieren.


    Wenn die Pinbelegung bekannt wäre, könnte man ein solches teil selber bauen. Habe sowas für den c64 auch gemacht. Die MAX-232 oder 234 Bausteine waren dafür der Fortschriftt.

    Hallo


    Ich bin auch auf der Suche nach einem Terminalprogramm für meinen 8296-D: So bekommt oder besser bekäme der noch einen schönen Sinn im Serverraum. Aber der Lnk oben ist leider tot.


    Und weiss irgendjemand mehr über ein "richtiges" RS-232 Interface? In alten Unterlagen bei Protext fand ich eine Werbung für eine MFC-03 Multifunktionskarte mit Real-Time clock und RS-232 (für bescheidene 748 DM), die intern auf die Erweiterungspfosten kommen sollte.


    So etwas suche ich...

    Hallo


    Ich hatte bei meinem 8296-D das gleiche Phänomen. Hatte auch das Kabel mal versetzt aufgesteckt. Hat mich einen 6522 gekostet.
    Danach gingen die Floppy-Lämpchen wieder beim Reset richtig an und aus.


    ds$ brachte meinen Rechner auch zum Hängen. Da hatte ich das Flachbandkabel vom IEEE Bus versetzt auf der CPU Platine aufgesetzt. Da ist (zumindest bei meinem 8296) der Stecker auch wieder breiter als der Pfostenverbinder.

    "Es existieren bestimmt doch noch original Einbausätze, die man untersuchen- und somit nachbauen könnte."


    Gewiss: Von denen ist ja die Erkenntniss mit der Erweiterung des 6530 ROMs auf 2k (statt 1k). Und genau dafür braucht man eine Erweiterungsplatine mit Verbindung zum 6502 Sockel. das wichtigste ist ja die Software - und die ist gerettet und auch hier hochgeladen.


    NW hat dies auf elegante Art mit seiner 6502RR realisiert. Da die Platine und GAL aber nicht perfekt passten, mussten wegen der Adressraumanpassung einige Leitungen anders verdrahtet werden. Die Platine war ja für den Adressraum einer 1541 und PET vorgesehen. Und der FDC hat eine ganz andere Aufteilung; noch vom alten 6504 in der 2040 bis 4040.


    "Wieso kann man nicht das bestehende Layout nehmen und die gefädelten Änderungen zusammen in ein neues Layout einfließen lassen."


    Lass dich nicht abhalten ;-)

    Kleine Anfängerfrage: Wieso gibt jede Variante von "HEADER" einen Syntax Error? Ich dachte, Basic 4.0 kennt den Befehl zum formatieren?


    header "leer"
    HEADER "leer"


    oder auch mit Parametern


    HEADER "leer",I01,D1,U8


    alles gibt "Syntax Error"?

    Kannst Du ausschließen, daß es am Schreib-/Lesekopf liegt?
    Die Motorelektronik könnte man ja vielleicht retten.
    Vielleicht passt auch eine von einem anderen Matsushita-Laufwerk.

    Ja: Mit dem Wechsel der Motorelektronik (und Motor) wandert der Fehler ins andere Laufwerk. Das mit der Drehzahl könnte ja sein, aber mir fehlen die Einrichtungen. Ich habe keine 8296-Diskette und bekomme das Image auch nicht auf eine Diskette. Die Software zur Zoomfloppy ist totaler Murks - ich habe die nie ans Laufen gekommen. Miot 64 bit schon gar nicht, und mit 32 Bit hagelt es nur Fehlermeldungen. Gerade mal Images auf eine 1541 schreiben ging mit einem USB2Serial Adapter; mit der Zoomfloppy nie.


    Also suche ich einen Motor oder ganzes Laufwerk JU 570 (mit oder ohne -2).

    Nicht auf der Hauptplatine :roll:


    Sowas mag ich ja auch gar nicht. Auf der 6502RAMROM. Jedenfalls solange, bis NW entweder ein neues Layout für die Speedos Erweiterung oder eben ein neues GAL entworfen hat. Ich hätte mir ja auch eine fädelfreie Version gewünscht :-)


    Aber besser so als gar nicht: Speedos ist für die Nachwelt gerettet und funktioniert mit halbwegs vorzeigefähiger Ästhetik. Der ehemalige Hersteller existiert zwar noch als kleiner Computerhandel. Aber der Entwickler ist verstorben. Alle alten Unterlagen - insbesondere CBM Entwicklungen - sind entsorgt und vernichtet. Da ist also definitiv nichts mehr vorhanden.

    Nachtrag zum Lesefehler von Drive 1:


    Mit einem "geliehenen" Laufwerk aus einer SFD funktioniert ein cA auch auf diesem Laufwerk. Die Analog-Platine ist also einwandfrei. Nun brauche ich nur noch eine neue Motorelektronik oder Laufwerk - die SFD soll ja nicht geschlachtet werden.

    6530: Ich weiss. aber die invertierten Signale kann man mit einer kleinen Fädelei auf der unterseite der 6530-EPROM Adapterplatine anpassen. Im TTL-Chip sind ja noch einige Gatter zum Invertieren frei.


    Wenn man keinen 6530 mehr hat, wird es schwieriger. Obwohl es jetzt ja auch das Layout zum Nachbau gibt. Würde gerne ein paar 6530-6532 Platinchen anfertigen lassen, falls noch jemand Interesse hätte.

    Speedos ist eine veränderte Software für den DOS-6502 und FDC-6502 einer 8250/8250LP. Das neue ROM ist aber grösser und benötigt eine Adressleitung mehr, als der 6530 im Sockel zur Verfügung hat. Diese wird mit der 6502RAMROM bereitgestellt und ersetzt - wie schon
    zuvor das EPROM auf der 6530 Huckepackplatine - das interne ROM des
    6530.


    Die Platine selber ist die ganz normale 6502RAMROM. Diese steckt wie stets im Sockel des 6502 und hat zur Decodierung des Adressraums ihr eigenes GAL. Dieses erweitert den ROM Bereich des FDC 6502 anstelle des alten 1k des 6530. Und blendet auch gleich das internen ROM des 6530 aus; deswegen kann der von der Adapterplatine mit externem EPROM wieder ohne EPROM in seinen Sockel.


    Die geänderte Speedos Software steckt insgesamt:
    a) in dem EPROM der RAMROM für den FDC 6502
    b) in den beiden EPROMs auf der Hauptplatine für den DOS 6502. Wenn man Pech und eine Revision A ROM Platine hat, müssen dafür auch Adapter her.


    Leider passt das GAL nicht ganz auf die Erfordernisse der Adressraumdecodierung des FDC 6502. NW hat das damals mit einigen Fädeldrähten gelöst. Das habe ich nachgebaut. Der aufmerksame Beobachter sieht ein paar rote Glitzerspuren auf der Platine.


    Man braucht:
    a) eine 6502RAMROM
    b) Mut zum Auftrennen von ein paar Leiterbahnen und Fädeldrähten auf der Platine
    c) ein spezielles GAL anstatt des Standard-GALS der 6502RAMROM (Datei weiter oben)
    d) insgesamt drei EPROMs (Dateien weiter oben)
    e) eventuell die ROM-EPROM Adapter


    Hier noch andere Bilder:
    http://www.forum64.de/index.php?thread/55281-speedos-von-edotronik-f%C3%BCr-cbm-floppies/&postID=914508#post914508


    Einloggen gibt deutlich grössere bilder :-)
    Jetzt besser?

    Speedos: Naja, eigentlich ist ja alles gesagt oder vorhanden.


    Dazu gibt es einen grossen Thread im Forum64. Ist ein gefädelter Nachbau mit der 6502 RAMROM Platine von Nicolas Welte. Von ihm habe ich auch dir EPROM Inhalte. Die Hardware 6502RAMROM kann man bei Sinchai erwerben.


    Wenn man eine 8250 Platine mit 2364 ROMs anstatt 2564 EPROMs hat, braucht man noch ROM-2-EPROM Adapter; etwa 2364 auf 2764. Das Layout der ROM-Adapter gibt es bei Donaupeter. Ich habe mal welche nachmachen lassen. Der 6530 kommt dann auch ohne Adapterplatine direkt in den Sockel. Sein ROM wird nicht benötigt; das ist im EPROM der 6502RAMROM.



    Hier nochmal ein paar Links mit Bildern:


    http://www.forum64.de/index.php?thread/62684-goldrausch/


    http://www.forum64.de/index.php?thread/6…0-und-sfd-1001/


    http://www.forum64.de/index.php?thread/5…ppies/&pageNo=6


    Datei zum Download mit EPROM & GAL Inhalt sowie Fädelanleitung:
    8296-D findet sein Laufwerk nicht mehr


    Der Einbau in einen 8296-D geht genauso wie in einer 8250LP.


    Bei Fragen dazu einfach melden :-)

    Habe selber den nächsten Defekt gefunden: Auf beiden (!) Floppy-Digitalplatinen war der 6522 des zweiten Prozessors gestorben. Habe meine "Goldvorräte" sprich Goldbeinchen-Keramik Rockwell 6502, 6522 und 6532 ganz mutig eingestzt: Und siehe da, der ganze Spuk ist weg - bei beiden Boards!


    Des Rätsels Lösung? Die Floppy-LEDs lässt wohl der 6530 auf dem Huckepack Board blinken; deswegen erscheint der Reset noch ganz normal. Die Statusabfrage geht stets problemlos über den ersten 6502 und seine beiden 6532. Die Motoren aber steuert der 6522 des zweiten Prozessors über die Analogplatine. Wieso jetzt aber bei beiden Boards die 6522 gestorben sind, bleibt wohl auf ewig unklar. Wohlgemerkt, mindestens einer beim Einschalten am Morgen!


    Nun sind bei beiden Boards (fast) neue 65C02 von Rockwell (mit gelasertem "Produktionsdatum" 1426, glatte Fälschung) und 65C22N vom WDC drinne. Das spart auch gleich Strom und Wärme.


    Danke für's mitlesen, mitfühlen und diskutieren! Nun werde ich mal meine 6502 RAM ROM umfädeln fürs 8250 Speedos. Es dürfte vermutlich nicht viele 8296-D mit Speedos geben ;-)


    Gruss
    Asklia

    Bin ratlos: Mit zwei verschiedenen Floppy-Digitalplatinen "hängt" das System beim Zugriff auf die Laufwerke. Der Reset wird sauber ausgeführt (korrektes Blinken der Status-LED Rot-Grün und der Laufwerks-LEDs). "print ds$" zur Laufwerksabfrage geht jedesmal mit beiden Platinen. "cA" bewegt seit heute kein Laufwerk mehr.


    Mit meiner "heiligen" externen 8250LP geht es erfreulicherweise. Aber auch dort will die zweite Digital-Platine (mit den Pfostenverbindern nach unten) nicht auf die Laufwerke zugreifen.


    Hat da noch jemand einen Tipp oder Idee?

    Bin der Sache etwas näher: Es gibt da offenbar mehrere Fehlerursachen.


    Ein "print ds$" geht mit der internen Floppy jedesmal. Ein "cA" aber nicht. Entweder passiert gar nichts oder die Floppy setzt die LED auf rot und antwortet nicht.


    Mit einem externen CBM-IEEE Kabel bekomme ich - natürlich bei abgezogenem Flachbandkabel zur internen Floppy - von einer externen nur "Device not present". Verwende ich zur externen 8250 das interne Flachbandkabel, so funktioniert auch "cA" einwandfrei. Man sollte meinen, das Kabel wäre defekt: Aber nein, mit einem 8032 funktioniert dieses Kabel wiederum prima. Eigentlich ist es ja dioe gleiche passive Verbindung wioe das internen Flachbandkabel.


    Werde also Kabel und insbesondere die Anschlusskontakte der Platine prüfen. Auf jeden fall scheiden der 6520 und die IEEE Treiber aus. Die interne Floppy hängt sich offenbar weg, wenn man nicht nur den Status abfragt, sondern auch die Laufwerke anspricht. Das ging aber vorgestern noch.


    Auf jeden Fall geht die Hauptplatine bis auf die mysteriöse Verbindung zu den Laufwerken via CBM-IEEE Kabel einwandfrei. Schonmal etwas weiter gekommen.


    Eine Reserveplatine für die Floppy liegt bereit: Dummerweise ist die aus einer "echten" 8250LP und hat die Pfostenverbinder zur Analogplatine nach unten zum aufstecken. Müsste also umgelötet werden: Das Flachbandkabel kann mann nicht einfach von unten aufstecken - da würden alle Kontakte gespiegelt :~)

    Sehr merkwürdig: Heute die beiden 6520 und den 74LS17 gesockelt und - da noch keine neuen 6520 in Reichweite - die beiden einfach mal vertauscht. Viel besser ist da aber noch nichts gweorden: die Tastatur geht; der 6520 war also wohl nicht defekt.


    Ein "print ds$" gibt nach einem Reset meistens den Floppy-Status. Aber schon ein "cA" lässt das System ohne Raktion des Laufwerkes hängen. Der Austausch des 7417 hat jedenfals auch keine Änderung erbracht. Gleiches gilt für ein externes Laufwerk: Entweder gar keine Antwort oder "Device not present".


    Sehr übel: Die Motorola IEEE Treiber Bausteine habe ich nicht. Hat jemand noch eine andere Idee?


    Könnte eines der beiden PLAs spinnen und diesen Fehler verursachen?

    Naja, habe so schnell nichts billigeres gefunden. Es waren übrigens 6520, nicht 6522. Zwei goldene 6821 zum Auslöten habe ich für 9 + 6.50 noch genommen.


    Der 8296-D hat ja schon 400 gekostet und ist leider reichlich defekt. Das ärgert mich schon eher.

    Danke


    Habe bei ebay bereits zwei Rockwell 6520 zum halbwegs moderaten Preise von insgesamt 35 Euro (geliefert) bestellt.
    Da sind sogar noch ein paar lila/goldene 6820 und bulgarische Nachbauten bei ebay zu haben.


    Werde dann mal die 40-Beiner auslöten und Sockel verteilen. Unfassbar: Der benachbarte 6522 wurde bereits einmal ausgelötet und ein Ersatzbaustein von 1980 wieder ohne Sockel (!) eingelötet. Der Rest ist von 1984. Und der 6545 trägt auf der Oberseite keinerlei Kennzeichnung.