Beiträge von vossi

    Mit ebay Global Shipping ist es natürlich versichert.

    Aber für die Verpackung ist dein Verkäufer verantwortlich. Global shipping Transportiert das Gerät nur nach Deutschland und erledigt die Zollabfertigung.

    Bei mir hat Global shipping schon einmal einen 200 Euro Schaden aus eigener Tasche ersetzt. Ich konnte das Gerät behalten und der Verkäufer wurde auch nicht belangt, da der Laserdiscplayer gut verpackt war.


    Wenn die Verpackung natürlich nicht ausreichend war, wird wohl der Verkäufer zahlen müssen - war doch sicher Paypal / also Käuferschutz. Mangelnde Polsterung ist ja Schuld des Versenders. Da zahlt Paypal.


    PS: Ware muss so verpackt sein, das sie einen Sturz aushält. Schau mal bei DHL in die AGB zum Thema Verpackung! Wenn die Ware defekt ist, ohne das das Paket äußerlich entsprechend beschädigt ist, war die Ware nicht ausreichend verpackt!


    PS2: Ich hatte auch schon mal einen zerbrochenen 5153 bekommen. Die Gehäuse sind sehr zerbrechlich. Da benötigt man ein paar lagen Luftpolsterfolie, dann dicke Luftpolsterfolie und anschließend an allen Seiten (besonders die Ecken) zerknülltes Packpapier. Der Karton sollte rundherum 10cm größer sein!


    Christian

    Hi, das ist der OPL2-Chip - also Adlib kompatibel.

    Dieser FM-Chip ist am Port 220 erreichbar (ggf per Jumper änderbar) und benötigt keine Treiber.

    Wenn die Karte auch eine ADC/DAC hat (also digitaler Sound) oder einen Mixer (wie auf einer SB), benötigt man dafür ggf. Software.

    Wenn Sie SB-Kompatiblen Digi-Sound hat benötigst du auch keinen Treiber.

    Selbst einen Midi-Schnittstelle bei Port 330 (ggf. einstellbar) benötigt keine Treiber.


    Du solltest die Blaster Variable in die Autoexec schreiben - aber auch die benötigen viele Spiele nicht:

    BLASTER=A220 I5 D1 P330 T3 (das wäre die SB2 Variante)


    Wenn die Karte per Sofware konfiguriert wird (also mit EEprom) bräuchte man Software dafür, aber das ist bei einer 8bit Karte wohl ausgeschlossen.


    Poste mal bitte ein Bild der Karte!


    Christian

    Hallo,

    meine cbm2-v9958-card ist nun fertig.

    Sie erweitert einen 6xx oder 7xx um den MSX2+ VDP mit 128kB dediziertem RAM.

    Der V9958 hat seine Ports bei $FD900-$FD905.

    Außerdem habe ich ein ROM bei $F1000 eingebunden, in dem sich die cbm2-Fonts befinden.

    Die Fonts habe ich auf 6x8 Matrix angepasst, da der VDP nur 512 Pixel horizontal kann.

    Um die Karte so klein zu gestalten, das sie in einen 6xx passt, habe ich soj-drams verwendet (eins ist auf der Rückseite).

    Ein GAL 16v8 ist für die CSW/CSR Erzeugung zuständig.

    Fast sämtliche cbm2-Software läuft mit dem V9958-Kernal, da so gut wie alle Programme die Bios-Print Routinen benutzen.

    Space Chase läuft natürlich nicht, da es direkt in das Screen-Ram schreibt.

    Die SOJ Sockel löte ich, in dem ich den Boden vorsichtig entferne und dann von innen löte. Der Boden muss aber hinterher wider eingeklebt werden, da sonst die Höhe der Rams nicht stimmt. Man die RAMs aber auch ohne Sockel auflöten.


    Alles was ihr benötigt ist hier: https://github.com/vossi1/

    (Gerbers, gal-jedec, font-rom, Kernal, 8088-6509-Loader)


    PS: Falls Jemand spezielle Teile benötigt oder nicht in der Lage ist die Platine zu löten, kann er sich gern an mich wenden. Einige Platinen habe ich auch noch übrig. Bitte PN schreiben...


    Karte::



    Color-Kernal: 8088-Karte:


         


    256-Farben-Modus 7: 32-Sprites 16x16:


         

    Danke. Ich kann heute auch nicht mehr sagen, wo ich den Schaltplan her habe. War halt in meinen Unterlagen. Aber eigentlich kann es nicht das Netzteil vom 6xx sein. Der hatte keinen Monitor und ein Anschlusskabel für den Monitor ist bei meioner Zeichnung mit drin, ebenso für die Floppy-Einheit


    Aber zu den Elkos. Als Laie weiß ich einfach nicht, welche ich habe.Sind die schönen orangen Teile aus Japan?

    Ja, genau. Aber ich würde auch alle tauschen.

    Der Schaltplan ist vom 6xx - der hat auch den TL494 und ist sekundär getaktet. Das ist deutlich einfacher aufgebaut als das vom 7xx, da der ja auch noch 'ne Doppelfloppy und einen Monitor mit versorgen muss!

    Hi, der Schaltplan passt nicht. Ich glaube das ist der vom 6xx.

    Ich habe auch noch nirgends einen für das EU-Netzteil vom 7xx gefunden.Deshalb hab ich ihn reverse-engineered.

    Er ist bei Bo zum download: http://www.zimmers.net/anonftp…ers/b/cbm700-ceag-PSU.jpg


    Defekt sind immer nur die Roderstein Elkos. Die japanischen Elkos sind eigentlich immer OK gewesen - und ich hab schon div. dieser Netzteile ertüchtigt. Es kündigt sich mit Pfeifen an und irgendwann ist Schluss.

    Einige Rifas sind mir auch schon hochgegangen. Ich baue immer hochwertige X2 / Y2 MKP/MKT ein - die werden mich wohl überleben ;) Ich habe auch noch nie einen defekten X/Y MKT/MKP gesehen - es rauchen immer nur die RIFA/WIMA ab. Vermutlich weil das Kunstharz spröde wird und durch die Wärme im Betrieb bricht.


    Chritian

    Das ist mit dem 37poligen Stecker am IBM FDC angeschlossen.

    Könntest du dies bitte näher zeigen ... hast du dir ein Zwischenkabel gebastelt ... oder ist das die besagte spezielle IBM Adapter Card?

    Nur die IBM FDC-Adapter haben diesen Anschluss für Floppy 3 und 4 . Allerdings fehlt dort eine Stromversorgung. Ich habe eine Eigenbau-Floppy (nicht von mir) in der das Kabel auf den 40 poligen Floppy Stecker adaptiert ist.

    Ich hatte das auch schon mehrfach, das ich den dispute canceln sollte und sie mir das Geld mit Paypal gesendet haben.

    So sieht Ali halt den dispute nicht mehr!

    Dabei macht man aber minus, da man noch die Paypal Gebühren abgezogen bekommt.


    Allerdings musste ich auch schon Sachen zurückschicken (mit Tracking) um mein Geld zurück zu bekommen.

    Das ging bis 2018 immer gut als Versandtasche für 3,70+Einschreiben=6,20 nach China.

    Aber das ist jetzt vorbei - die Post hat das für Privatkunden gestrichen!


    ...und die Rückversandkosten bekommt man nicht erstattet.


    Ich hatte letztens auch einen Fall, wo mein Paket nicht angekommen ist. Ali hat aber zu meinen Ungunsten entschieden, da laut Sendungsverfolgung das Paket in Deutschland ausgeliefert wurde - aber beim Zoll in Frankfurt - und dort ist es verschollen!!!


    Christian

    Bitte.

    Ich hab jetzt zum DRAM eine extra +5V Leitung mit 470uF direkt am DRAM.

    Am V9958 hab ich 22uF, obwohl es keinen Unterschied macht.


    Das ist jetzt allerdings wieder mein Sony 9 Inch Broadcast Monitor und auf dem roten Bild sieht man ein paar Fettfinger ;)


    OK, Problem beseitigt. Nach Begutachtung diverser Pläne hab ich die Lösung!

    Philips hat 22uF an den 9938 und an das Ram gehängt. Das beseitigt das Problem aber nicht ganz.

    Im FS-A1 ist 1000uF am 9938 und 22uH in der +5V vom v9938. Auf das beseitigt das Problem nicht.

    Ich hab sogar 22uH da gehabt zum testen ;)


    Im FSA1WSX haben sie gar keinen dicken Elko mehr am V9958 !!!!

    Eine Spule haben sie in der +5V vorgesehen, aber nicht bestückt und gebrückt.

    Die Lösung: 470 uF direkt am DRAM !

    Genau das hab ich gemacht - Problem weg.

    Hast Du neben einem keramischen Kondensator (typ. 100nF) auch einen fetten Elko an der Spannungsversorgung direkt am V9958?

    Hallo, nein daran hab ich natürlich nicht gedacht. Ich hab eben mal 220uF getestet, damit werden die Streifen deutlich schwächer!

    Also liegt es auf jeden Fall an der Stromversorgung. Ich hatte den v9958 ja auch schon auf dem Steckbrett an meinen LC64 (PLC c64) und an einem Atmega angeschlossen und hatte keine Probleme. Aber da hatte ich natürlich auch ein großes Linearnetzteil.

    Vielleicht ist das Schaltnetzteil vom 7xx schuld. Ich werde morgen mal den 7xx mit drei Netzgeräten testen - nur mal aus Neugierde, ob es dann ganz weg ist.

    Vielleicht muss ich auch noch kleine Drosseln zur Entstörung in die RGB-Ausgänge stzen - das hab ich auch schon mal im Philips MSX gesehen, aber eben auch nicht bei allen MSX2. Bei Panasonic sind keine Drosseln.


    Vielen Dank für den Tip!!!

    Hallo, meine V9958-color-graphics-card für die cbm2 Rechner läuft mittlerweile wunderbar.

    Sogar das Kernal habe ich umgeschrieben, so dass die Karte voll unterstützt wird.

    Leider habe ich leichte senkrechte Streifen-Schatten. Diese sind natürlich bei einfarbigem Hintergrund am deutlichsten.

    Bei bunten Bildern oder schwarzem Hintergrund fällt das nicht auf.

    Im MSX2 von Philips oder Panasonic macht der v9958/38 keine Streifen.

    Ich habe verschiedene Chips probiert, ich habe andere Transistoren als Emitterfolger verwendet, ich habe noch mal 75 Ohm Widerstände an die Ausgänge gelegt oder Elkos zur Entkopplung probiert.

    Ich habe auch komplexe Emitterfolger mit Elkos davor und dahinter und eigenem Spannungsteiler für den Arbeitspunkt probiert - änder aber alles nichts an den Streifen....


    Woran könnte das noch liegen?


    Was ist auf Mac unter „EC“?


    Peter

    EC = el capitan ;)

    Ich denke, das Minipro von Linux das gleiche ist, nur das ichs auf dem Mac kompiliert habe.

    Erst hatte es nicht funktioniert aber ich hab dann festgestellt, das es mit libusb nur am usb2-Port geht.

    Eigentlich komisch, da obencbm und mein avrisp auch am usb laufen...

    Ansonsten würde ich auch gern gegen Porto-Erstattung ein zugesendetes Eprom brennen - sofern es mein Topmax wirklich kann, aber das werde ich demnächst mit dem Diag-Rom testen.


    PS:

    Mein Minipro läuft jetzt auch am Mac unter EC. Und das schneller als mit jeder Windofs software:

    Da ich immer wieder ein verändertes Kernal für den cbm2 assembliere und gleich brenne um es zu testen, brauche ich nur cursor hoch und enter drücken um die Kommandos zu wiederholen - extrem schnell und komfortabel. Natürlich könnte man das auch noch mit einem kleinen script mit einem Befehl machen!

    Ich musste bei einigen Eproms auch schon mal die Brennspannung erhöhen, da der TLL weniger verwendet hat als eigentlich im Datenblatt steht.


    PS: Die Eproms muss man nach dem UV-löschen etwas abkühlen lassen, sonst lassen sie nicht brennen - ich würde so eine halbe Stunde warten!

    Der Brenner steckt am externen USB Hub mit ext. Stromversorgung, habs erfolglos unter Win XP und Linux (Wine) ausprobiert. Lesen und Selbsttest geht. Nur schreiben nicht.


    Gruß

    Stephan

    Hallo, nur aus Eigeninteresse: Wird der bei dir unter Linux in Wine erkannt - also du kannst ein Eprom lesen?

    Ich hab ihn auf dem Mac unter Wine nicht zum Laufen bekommen!

    Unter Parallels in Win7 lief er früher, aber nun wird er zu 90% nicht mehr erkannt... :(

    Wie hast du das gemacht?

    Der Original-IBM AT-Controller unterstützt prinzipiell alle Platten.

    Er hat auch keine Bios-Format-Routine wie bei WD oder ST.

    Dafür muss man bei IBM immer die Diagnose-Disk verwenden.

    Wieviele Festplatten unterstützt werden hängt nur vom Bios ab. Es gibt drei Versionen von IBM für den 5170.

    Die erste Version von 84 unterstützt nur wenig Typen.

    Es gibt auch ein AMI Bios, was im AT läuft. Das hat schon ein richtiges cmos-Setup intergriert und unterstützt 47 Typen inkl.User Typ!

    Das ist sehr zu empfehlen:

    http://www.minuszerodegrees.net/bios/bios.htm


    Christian

    Die Karte war natürlich auch im AT verfügbar. 1984 gab es noch kein VGA!

    Auch mit einem CGA Monitor ist die super, da man 320x240 mit 16 Farben darstellen kann.

    Das ist bei Spielen um Welten besser, als die CGA-Grafik mit der Türkis/Pinken-Augenbeleidigung!


    Ich hab die im 5160 (mit 5153) und im 5170 mit BGC36.

    Den 5154 hab ich auch, aber der BGC36 ist deutlich besser.


    Später gab es für den AT den PS/2-Display-Adapter, der quasi den 5170 auf VGA/MCGA gepimpt hat. Das war auch für den AT nur eine 8bit-Karte (hab ich hier)


    Christian

    Irre!

    Ich habe mir zum CDTV einen schönen, schwarzen Philips VS0080 gekauft - das ist ein Super-Monitor - der schafft sogar 60 Hz über RGB (Japan MSX-Computer). Und einen reserve VS0080 hab ich auch noch ;)

    Vielleicht ist es sogar die gleiche Hardware - der 1084s-P1 (auch in schwarz) ist ja von Philips hergestellt!

    Bei den PS/2-FDD's würde ich sogar sagen, Funktionsquote nach Elkotausch: 75%. Defekte R/W-Köpfe habe ich auch schon gesehen, sind aber selten. Schlimmer sind die Schäden bei diesen FDD's, wenn SMD-Ekos bereits auslaufen sind. Es ist wie bei den Amigas, durchfressene Leiterbahnen sind da fast schon die Regel. Im Übrigen, ich habe noch einen ganzen Karton voll defekter MFM-Festplatten, ich schmeiss ja nix weg.

    Ja, bei den Floppys ist die Quote besser. Ich hab auch schon welche justieren können - nach der Trial/Error Methode ;)

    Bei den 3,5" MFM Platten von Tandon hab ich auch schonmal das Laufwerk einer defekten mit der Platine einer anderen verheiratet. Ich behalte auch alle alten Platten für Ersatzteile!