Frage zu Probleme mit MFM Festplatte

  • In dem XT von MarNo84 war eine MFM Platte verbaut, die ich mir gerade vornehme. Es ist eine BASF6188R mit (lt. Google) 10MiB. Der Controller ist ein OMTI5520A.


    Erst lief die Platte gar nicht an, nach ein paar Versuchen hat es dann funktioniert. Beim ersten Anlaufen hat es noch gedauert, bis sie die Drehzahlen erreicht hatte.
    Als die Platte dann lief, habe ich mit einer DOS6.22 Bootdiskette 'debug' gestartet mit 'G0C800:6'. Als erstes hat das formatieren fehl geschlagen, die Platte hat aufgehört zu drehen und die LED der Platte hat rot anfangen zu blinken. Nach dem nächsten Neustart nochmals versucht, dann hat die Formatierung angefangen, nach ein paar Sekunden dann aber wieder das gleiche Problem. Platte hat aufgehört zu drehen. Beim dritten Versuch ging es dann, die Formatierung lief vollständig durch, das Verify danach auch. Das Programm hat dann einen Neustart gemacht. Normal ist die Platte jetzt soweit, das man sie High-Level formatieren kann, also fdisk und format mit DOS. DOS sagt mir allerdings, dass Probleme beim lesen der Platte aufgetreten sind.


    Also habe ich nochmal das debug angeworfen und nochmal Low-Level formatiert. Aber dieses mal nicht mit den Autowerten vom Controller, sondern manuell eingetragen. :



    Was bedeutet 'Write Buffer failed'? Wie kann ich das umgehen?
    Das sind die Parameter, die ich zur Platte im Netz gefunden habe.
    Die Defektliste ist übrigens leer.


    Programme wie SpeedStor oder Spinrite finden die Platte nicht. Speedstor sieht zwar den Controller, meldet aber 'Controller not response'
    Das ganze ist auf einem 486er Board aufgebaut, andere MFM Platten hab ich an dem Rechner schon erfolgreich formatiert. Nur dieses mal komme ich nicht dahinter... :grübel:


    Das Datenblatt zum Laufwerk gibt es hier:
    http://maben.homeip.net/static…20ST506%20Hard%20Disk.pdf

  • Würde sagen, die Platte ist nach den vielen Jahren schlicht kaputt.


    Vielleicht hilft neue Elkos zu verbauen, Mechanik neu schmieren, aber mach dir da keine allzugroßen Hoffnungen.


    Eins fällt mir noch ein: Dein 486 läuft mit 8 oder mehr MHz auf ISA. Vielleicht mal in dem XT bei 4,77 MHz ISA Takt versuchen.