Posts by klaly

    CC ist mir aktuell zu weit.

    Mein nächster Event ist VCFb am 12. und 13.Oct in Berlin.
    Da bin ich alle Jahre, nur als Besucher.

    Das IC 74LS156 hab ich heute bekommen.
    7-Segment Anzeige mach aber leider nur undefiniertes Zeug.

    Muss wohl näher untersucht werden.
    Ich han das SDK-85 erstmal wieder zur Seite gelegt.

    mfG. Klaus Loy

    Hi Toast_r,
    ich wollte schon fast ja sagen. Aber den 74LS156 gibt es beim Reichelt.
    Und wir machen Montags fast immer eine private Reichelt Sammelbestellung in der Firma.
    D.h. ich bekomm es ohne Streß bis ca. Donnerstag.
    Danke für dein Angebot.

    mfG. Klaus Loy

    EPROM erfolgreich geschossen, SDK-85 Test negativ, weil ich leider kein 74LS156 IC habe. Das scheint einigermaßen selten zu sein. nichts in meinem Fundus zu finden :-(


    mfG. Klaus Loy

    @Toaster_r,


    ja kann ich dir zusammen packen, leider ist der Prommer cumputer (ein Thoshiba T5200) aktuell nich am Netz. D.h. ich müsste alles über Disketten rüber ziehen.

    Mal schaun, wieviel das wird, ok, dein ZIP hat auch nur 1,9MB.

    mfG. Klaus Loy

    Was mich noch mehr ärgert, als dass 8755 Device nicht gesehen hab,
    ist mein angefangenes Arduino Steckbrett mit dem 8755.
    Zumindest werd ich das soweit fertig bauen, dass ich mal zumindest lesen kann.

    detlef ,

    die Arduino Schaltung hat doch eine Programmierspannung von 25,5V für VDD vorgesehen. Ich hab mir extra schöne StepDown Wandler vom Chinesen dafür her genommen. Leider alles erstmal nur halfertig.

    Hier das Schaltblid vom github:


    mfG. Klaus Loy

    @Toaster_r,


    ich habe ALL-03 Version V9.10, ...

    Getstern hatte ich bei EPROMs Intel geschaut und dort 87Cxxx gefunden, keinem 8755.
    Also auch unter MCU, aber dort nicht weit genug runter geblättert.
    Jetzt wo ich nochmal geschaut hab, hab ich unter MCU Intel auch den 8755A gefunden.


    werd gleich mal das brutzeln eines 8755 versuchen.

    mfG. Klaus Loy

    Hi Toast_r,

    leider bietet mein ALL-03 den 8755 nicht an.
    Evtl. müsste man da Programmteile dazu installieren.
    Ich hab eben angefangen den Arduino Programmer zusammen zu stecken. Das Arduino Projekt ist schön gemacht, mal schaun, ...

    Hab leider wieder wenig Zeit.
    Ansonsten hab ich drei Stück 8755 da liegen, das heißt aber nicht dass ich welche kaputt pruzeln möchte.


    Die anderen Teile für mein Board hab ich auch da.



    mfG. Klaus Loy

    Hallo liebe Leute,


    heute wollte ich ganz stolz mal eben einen 8755 für mein SDK-85 programmieren, ... :-(

    Aber meine beiden PROMER: ALL-03 und Conitec GALEP-III können keinen 8755, schade.


    Aber es gibt eine Arduino Selbstbau Lösung:

    https://github.com/TomNisbet/TommyPROM


    Muss ich halt das mal aufbauen, bzw. zusammenstecken.


    mfG. Klaus Loy

    ... und ich hab aktuell keine Zeit.
    Muss erst nächste Woche noch "meine" zwei TRS-80 fertig machen und weg bringen.
    Ansonsten ist dieser Thread sehr gut und wird noch etwas an Inhalt bekommen.

    Danke an mikemcbike, für die beiden Files.
    Ich hab ja auch zwei binaries gefunden, muss ich mal vergleichen.
    Mal schaun, ...

    Wenn mein SDK85 vollständig ist und läuft, dann gibts auch ein Bild davon.



    mfG. Klaus Loy

    Hi fritzeflink,

    die Handbücher hab ich schon, nur die Info daraus ist noch nicht in meinem Kopf angekommen.
    Man hat halt einfach zu wenig Zeit. Aber Stückchen für Stückchen krieg ich das schon hin.
    Aktuell hab ich halt ein einziges Bootmedium NewDos80, welches ich von Gotek, oder 5 1/4" Disk booten kann. Außerdem hab ich es als NewDos80.DSK vorliegen, so dass ich auch mit TRS-80 Emulator (sdltrs.exe) spielen kann.

    Was mir noch gefallen würde, wäre ein altes TRS-DOS als *.DSK und/oder als *.hfe (für Gotek).
    Wenn jemand sowas hätte, bitte her damit.

    mfG. Klaus Loy

    Ich hab zur Zeit drei TRS-80 Model 1 zuhause stehen.
    Leider gehört mir davon nur einer und da auch nur das Grundgerät.

    Die beiden anderen sind mit ExpUnit und gehören dem Hans Franke und sie sollen in sein "Computeum" kommen. Ich hatte/habe sie nur um sie wieder in Gang zu bringen, was auch gelungen ist.


    Aktuell experimentiere ich da mit NewDos80, mit einem Gotek "Laufwerk" und einem 5 1/4" Floppy Laufwerk herum. Leider weiß ich nur wenig über NewDos80.

    mfG. Klaus Loy

    Hi Mike,

    wenn dann bräuchte ich primär den SDK-85 Monitor Inhalt.
    Das andere EPROM enthält vermutlich eigene Funktionen des Besitzers.

    Grad hab ich nochmal gegoogelt, und hab dann doch noch was gefunden, was ich gestern Abend nicht fand oder übersehen hatte: http://www.nj7p.info/Computers/Software/Mon.html


    Hier liegen mehrere Monitore ab, auch ein SDK-85 Monitor.
    Alerdings stimmt der Inhalt des Binär Files nicht 100% mit dem Listing aus dem SDK-85 Handbuch überein.

    Mal schaun, ob ich damit ein EPROM schießen kann welches dann auch funktioniert.


    mfG. Klaus Loy

    Hi Mike,

    wenn dann bräuchte ich primär den SDK-85 Monitor Inhalt.
    Das andere EPROM enthält vermutlich eigene Funktionen des Besitzers.

    Grad hab ich nochmal gegoogelt, und hab dann doch noch was gefunden, was ich gestern Abend nicht fand oder übersehen hatte: http://www.nj7p.info/Computers/Software/Mon.html


    Hier liegen mehrere Monitore ab, auch ein SDK-85 Monitor.
    Alerdings stimmt der Inhalt des Binär Files nicht 100% mit dem Listing aus dem SDK-85 Handbuch überein.

    Mal schaun, ob ich damit ein EPROM schießen kann welches dann auch funktioniert.


    mfG. Klaus Loy

    Hallo liebe Leute,

    ich habe heute auch ein neuestes Etwas bekommen.
    Nachdem ich damals ca. 1985 ein SDK-85 Kit zusammen löten durfte, hab ich mir sowas immer wieder gewünscht und nun, nach ca. 35 Jahren hab ich mir eins auf ebay gekauft. Das Board kam aus USA und war nach 10 Tagen da, echt schnell.


    Leider hab ich nur ein Teilsystem gekauft: ebay link


    Und hier noch das Bild (wer weiß wie lang der Link geht):


    Die fehlenden Chips sind nicht wirklich ein Problem, auch einen 8755 EPROM-IO hab ich.


    Aber ich bräuchte den Inhalt des Monitor ROMs.

    Wenn das jemand hätte und mir senden könnte wär das schön.

    Der google konnte kein Monitor ROM finden.

    OK, im Handbuch wäre das Listing enthalten, aber ich hab keine Lust zum abtippen.


    mfG. Klaus Loy

    Hallo liebe Leute,

    ich habe heute auch ein neuestes Etwas bekommen.
    Nachdem ich damals ca. 1985 ein SDK-85 Kit zusammen löten durfte, hab ich mir sowas immer wieder gewünscht und nun, nach ca. 35 Jahren hab ich mir eins auf ebay gekauft. Das Board kam aus USA und war nach 10 Tagen da, echt schnell.


    Leider hab ich nur ein Teilsystem gekauft: ebay link


    Und hier noch das Bild (wer weiß wie lang der Link geht):


    Die fehlenden Chips sind nicht wirklich ein Problem, auch einen 8755 EPROM-IO hab ich.


    Aber ich bräuchte den Inhalt des Monitor ROMs.

    Wenn das jemand hätte und mir senden könnte wär das schön.

    Der google konnte kein Monitor ROM finden.

    OK, im Handbuch wäre das Listing enthalten, aber ich hab keine Lust zum abtippen.


    mfG. Klaus Loy

    Hallo liebe Leute,


    weil ich grad S5 SPS gelesen habe, ...
    Ich möchte heuer auf VCFe in München zwei Siemens PGs 685 und 675 zeigen, Technik aus den 80ern.

    Auf beiden läuft CP/M86 oder eine Abart davon. Das 685er hat eine Festplatte,
    das 675er bootet sein CP/M (vermutlich CP/M) von Diskette.

    Die Geräte möchte ich ausstellen, weil ich sie halt habe und weil es für manche Leute interessant sein könnte.

    Es wird auch eine kleine S5-95U SPS dabei sein, so dass ein paar kleine SPS Anwendung in KOP/FUP und AWL erstellt werden können.


    Falls jemand zum VCFe kommt, schaut euch die PGs an.


    mfg, Klaus Loy aus Nbg.

    Hi Kenny,
    ich hatte damals 1980 einen Eurocom I, das war schon ein schönes Teil, hatte dazu Kassetennrecorder, VIC-1 Video Interface, Tastatur, Phillips Mini-DCR, Lorenz LO15 Fernschreiber (als Drucker).


    Software:
    Editor, Assembler, ein paar assembler Spiele, Basic.
    Alles immer schön langsam von Kassete geladen.


    Leider wurden die Sachen irgendwann weg gegeben.
    Und so ca. vor 15 Jahren ist die Nostalgie Phase angebrochen.

    Ich hatte jahrelang auf Ebay ausschau gehalten und konnte so ein Teil wieder kaufen.

    Heute hatte ich zufällig ein wenig rum gegoogelt und dabei Doku von ELTEC und
    speziell auch vom Eurocom I gefunden.


    Link: ELTEC_at_bitsaver.org


    Ich möchte dieses schöne Teil mal bei Gelegenheit auf einem VCFe oder VCFb ausstellen.
    VCFb ist übrigen am 14 und 15.10.2018 in Berlin.


    mfG. Klaus Loy

    Super, aber ich werd jetzt erst mal Feierabend machen.
    Hab grad ein wenig mit AFDpro auf den FDCgeschrieben .
    Es ging nur Motor An und aus, mehr "kann" ich noch nicht.

    Wollt grad mal nach einfachem Controller Code schaun, ...
    Ich werd mir das Zeug von kpanic ansehen.


    Danke und gute Nacht

    Klaus Loy

    Hi fritzeflink,


    beide Tools probiert, keine Änderung Steppulse immer 3ms Abstand.
    Beide Tools melden 12ms.


    Nun die Vermtung, dass evtl. mein Floppy Controller auf dem Chipsatz das nicht tun mag.
    Vieleicht steck ich mal einen anderen Floppy Controller rein.

    Oder ich müsste den Controller direkt ansteuern, was ich mir als nicht einfach vorstelle.

    Auf jeden Fall erst mal vielen Dank.


    MfG. Klaus Loy

    Hi fritzeflink,


    Danke für die Antwort.


    Das Programm habe ich angepasst, aber wohl noch nicht das "Zeug" mit den Stepraten.
    M.Tischer schreibt da etwas von der Disk Drive Parameter Tabelle.

    Vermutlich muss ich da nochmal was dran drehen und dann messen.

    Seit heute Abend habe ich ein SALEA Logik Analyser dran hängen, an den Signalen Direction, Step, Track0
    Und daher weiß ich, dass es wohl ein Timing Problem ist.


    Nun werde ich auch dein oben verlinktes Dokument mal etwas studieren.


    Klar ist boot von 8" unsinnig, aber ich möchte hin bekommen.


    mfG. Klaus Loy

    Jetzt hab ich nochmal was probiert:

    Statt dem 8Zoll Laufwerk hab ich ein 1.2MB Laufwerk mit 77 Tracks, 1 Head, 15 Sektoren formatiert.

    Genau so wie ich die 8 Zoll Scheibe formatieren möchte.
    Physikalisch Formatieren OK.

    Logisches Formatieren mit Bootsektor, 2x FAT und Direktory OK.

    Sys A: für Systemübertragung funktioniert.

    Dir A: funktioniert, es liefert COMMAND.COM

    Boot von dieser ""halben" 1,2MB Diskette funktioniert.


    Also sollte es auch mit der 8" gehen, wenn sich das Stepraten Problem lösen liese.


    Info zum BIOS:

    AMIBIOS (C)1994

    (433AUE23) UMC880 For 486 PCI Green_PC


    Notfalls wird das BIOS umgepatch.
    Falls sich der Parameter darin finden lässt und falls da keine Prüfsumme drüber ist.


    Noch was, Steprate laut SA-800 Handbuch 8ms.
    Daher geht es am Anfang mit 6ms, aber mit späteren 3ms haut es nicht hin.


    MfG. Klaus Loy

    Hallo liebe Leute,

    ich bräuchte nochmal ein Rat, ...


    Im Prinzip kann ich ich nun meine 8Zoll Floppy formatieren.
    Aber ansonsten mag der PC nicht wirklich damit umgehen.
    Das Problem scheint die Steprate für das Spur suchen zu sein.
    Beim Einschalten macht das Laufwerk das normale "öhhh öhhh" Geräusch und sucht seine Spur 0, was auch einwandfrei funktioniert.
    Die Step Pulse dafür kommen mit 6ms Abstand und 14µs Pulsbreite.


    Beim Formatieren läuft der Kopf von Spur 0 bis Spur 77 sauber vorwärts.
    Danach sollte das Laufwerk wieder zurück auf Spur 0 positionieren, um z.B. den Bootsektor zu schreiben.

    Dies gelingt nicht !

    Direction geht auf High (für zurück fahren), aber die Steppulse kommen mit nur noch 3ms Abstand, was wohl für das 8Zoll Laufwerk zu schnell ist. Der Kopf bleibt nahezu auf der Stelle.


    Frage:

    Wie könnte ich die Steprate verändern ?

    Als PC kommt ein altes Motherboard mit einem 486 zum Einsatz.


    Das Formatieren mache ich übrigens mit einem Programm von Michael Tischer, wovon ich den C-Sourcecode habe. Das Programm ist soweit eigentlich OK. Wenn alles klappt, darf ich den Source des original und des modifizieten Formatierprogramms hier rein stellen.


    Aber da ist aktuell noch das Steraten Problem.


    Für Hinweise und Tipps wäre ich dankbar.


    mfG. Klaus Loy

    Neues von der 8" Disk:

    1. format a: /1 /n:15 /t:77
      geht nicht, es kommt weiterhin "Paramter nicht kompatibel"
      es wird DOS6.22 verwendet.
    2. NFORMAT.EXE, welches ich schön im Netz fand, funktioniert zum Teil.
      Man kann ein eigenes Format einstellen, z.B. 74 Tracks, 15 Sec, 1 Head
      Aber das Programm missachtet die max Tracknummer und fährt immer in den Anschlag rein
      und dann bleibt es mit ... hängen und muss abgebrochen werden.
      Die Rohformatierung scheint dann aber bereits OK zu sein.
    3. Auf diese Roh formatierte Disk konnte ich mit AFD-Pro den Bootsektor lesen, der enthält F6, F6, ...
      Dann hab ich umgepatcht in "Hallo Welt" und den Sektor wieder geschrieben. Leider blieb AFD-Pro
      dabei hängen, so das ich rebooten musste.
    4. Danach konnte ich mein "Hello World" im ersten Sektor wieder ein lesen :-)
    5. Also ist NFORMAT schon mal ein Teilerfolg.
      @ftrizeflink ein Danke für den Tip.

    Mal schaun ob ich den NFORMAT von meinen 77 Spuren oder weniger überzeugen kann. Der würde dann vermutlich auch einen Bootsektor, FAT und Directoty anlegen.


    mfG. Klaus Loy

    Hallo kpanic,


    dein Kommando sollte ich heute Abend mal probieren.
    Aber vermutlich mag er da auch wieder den Parameter /1 nicht annehmen.

    Erst mal mal Danke für deine Kommando.

    Mal schaun ...


    Wenn es mit Format nicht geht, dann habe ich als Plan B einen Code aus einem alten Buch von M.Tischer "PC intern 4"

    Das ist ein C-Programm zum formatieren von Disketten. Das Programm kann zwar auch erst mal nicht mit 8", aber der Code kann ja abgeändert werden .



    mfG. Klaus Loy

    Der Link von fritzeflink:

    http://www.vcfed.org/forum/sho…Inch-Drives-in-the-IBM-PC

    ist sehr interessant.


    1. erwähnt er Sektorgrößen mit 128 Byte, wobei DOS damit vermutlich nicht sinnvoll umgehen kann. Und daher davon auch nicht booten kann.


    2. Die Verwantschaft von 8" und 1.2MB Laufwerk, vermutlich wegen der Drehzahl 360 1/min und MFM mit 500 kBit/s, was beim XP natürlich sowieso nicht geht.


    Mal schaun wie ich die Kiste dazu bringe: 77 Tracks mit 15 Sec a 512 Byte, nur Seite 1 zu schreiben.
    Und ob da ein FAT Filesystem drauf funktioniert. Und am geilsten wäre booten davon.
    Nützlich ist das natürlich gar nicht.


    Da gab es doch irgend ein Kennungbyte im Bootsektor der Diskette, welches die Diskparameter definiert.

    Mal googeln, ...


    mfG. Klaus Loy

    Hallo Leute,


    danke für die vielen Infos.


    1. der Tip von Toaste_r mit den 1,2MB im BIOS scheint sinnvoll.

    2. der Hinweis von fritzeflink, 77 Track, sehr gut.
    Mit BIOS Einst. 1,2MB und dann: Format A: hat er was getan und ist tatsächlich in den Anschlag innen rein gefahren :-(


    Die Infos muss ich nun erst mal durch arbeiten.

    Wie gesagt Danke schon mal.


    mfG. Klaus Loy

    Hab es grad nochmal probiert,


    Im BIOS ist für Laufwerk A 720KB eingestellt.


    Format mit folgenden Parametern aufgerufen:

    C:> FORMAT A: /U /T:80 /N:8 /1 // N:8 war nur mal ein Versuch irgendeine Sektoranzahl zu nehemen.


    Fehler: Parameter nicht kompatibel.


    mfG. Klaus Loy

    Hallo liebe Leute,


    weiß jemand wie ich ein 8Zoll Laufwerk bzw. ein 8" SS,DD Diskette am PC (alter 486 er) formatiren kann ?
    Das Laufwerk ist ein Shugart SA-801, es ist elektrisch bereits richtig angeschlossen, und reagiert auch. Aber beim Formatieren kommt irgend eine Fehlermeldung von Format Programm, die jetzt grad nicht zur Hand habe.


    Nächste Frage hierzu, welche Parameter bräuchte ich eigentlich fürs Formatieren ?

    Wieviel Sektoren pro Track ?
    Das Laufwerk sollte 80 Tracks haben, wenn ich micht nicht irre. Daraus müsste sich dann eine Kapazität in xxx kByte ergeben.

    Am VCFB 2017 war ein 8Zoll Laufwerk an einem PC ausgestellt und die Jungs dort hatten die Disketten mit DOS formatiert.
    Evtl. sogar davon gebootet.

    Leider hatte ich die Details dazu nicht erfragt, bzw. sie meinten, dass sie länger damit rum experimentiert hätten.


    Ich würde gerne mein 8" Laufwerk am VCFe 2018 in München, zusammen mit KryoFlux austellen und zeigen wie man alte CP/M Disketten damit lesen kann.


    Zusätzlich möchte ich es auch an einem PC betreiben können und davon DOS booten.
    Daher die obige Frage.


    Für Hinweise wäre ich dankbar.


    mfG. Klaus Loy aus Nbg.

    Hallo liebe Leute,

    seit ein paar Tagen versuche ich Infos über das diesjährige VCFe 2018 in München zu bekommen.

    Leider ohne Erfolg.

    Die Seite VCFe.org scheint tot zu sein sein, auch die emai: Org@vcfe.org nicht.


    Einen Kontakt zu Hans Franke habe ich leider nicht.


    Frage:
    Weiß jemand näheres ?
    Termin der Veranstaltung ?
    Wo könnte man sich als Aussteller anmelden ?

    mfG. Klaus Loy