Reparaturhilfe iMac G3 gesucht

  • Servus,


    ich bin gerade dabei einen Fehler bei meinem iMac G3 350MHz zu suchen.

    Er schaltet nicht ein.

    Ich habe mir das Servicemanual von Apple zu Hilfe genommen. Leider bisher ohne Erfolg.

    Die Sicherung ist ok, die 5V an J9 liegen an, die -1,2V an C10 auch.

    Wenn ich versuche einzuschalten, knacken die Lautsprecher kurz und mehr tut sich nicht.

    Die Backup-Batterie war leer, habe sie ersetzt und den PMU-Reset Knopf gedrückt.


    Momentan bin ich mit meinem Latein am Ende.

    Hat jemand von Euch schon mal Reparaturversuche an einem iMac G3 unternommen?


    Gruß


    Andi

    Retrogaming und klassische Computer

  • Dazu die erste Frage: Welchen Typ Logic Board / Power Supply / Converter Board

    hast du in deinem iMac G3 ?


    LG Rappi


  • Ich mache von allen Reparaturen immer ein Dokument von dem, was ich

    gemacht habe. So kann ich bei einer Wiederholung dieses Dokument zu

    Rate ziehen.


    Also hier der Einstieg, miss mal diese 3 Spannungen vom Logic Board

    zum Converter Board nach:


    Pin 2: +12 Volt


    Pin 4: +5 Volt


    Pin 14: +3,3 Volt




  • Ja schon klar, du musst das am offenen Herz messen. Mit ein wenig

    Vorsicht ist das schon machbar.


    Du hast ja schon die anderen Volt gemessen. "Die Sicherung ist ok,

    die 5V an J9 liegen an, die -1,2V an C10 auch."


    LG Rappi

  • Ich hatte genau den gleichen Fehler, der iMac liess sich nicht einschalten.

    Der Fehler lag beim Down Converter Board. Soviel ich noch weiss, konnte

    ich die Spannung messen.


    Kontrolle ob der iMac überhaupt Strom bekommt:

    Beim Einschalten mit dem Frontknopf hört man ein leises Klicken.

    Gleichzeitig leuchtet auf dem Logic Board die grüne LED.




    Du hast ja bei ausgeschaltetem aber angeschlossenen iMac schon die

    Erhaltungsspannung von 5 Volt gemessen. Auch die -1.2 Volt an C10 waren i.O.

    Was passiert mit diesen -1.2 Volt, wenn du den iMac versuchst ein zu

    schalten? Da müssten dann die Spannung auf 21 Volt springen.


    LG Rappi

  • Das Converter Board hab ich schon ausgetauscht. Leider das gleiche Fehlerbild.

    Ob das Board natürlich gut ist, weiss ich leider nicht.

    Die grüne LED leuchtet nicht.

    Ich kann gerne mal messen, inwiefern sich die Spannung ändert, wenn ich den Einschaltknopf drücke.

    Retrogaming und klassische Computer

  • Bei meinem Logic Board habe ich damals das gemessen:


    Ausgeschaltet: -1.16 Volt

    Eingeschaltet: 20.20 Volt


    Ich habe gelesen, wenn der Wert am ausgeschalteten iMac

    zwischen -1.1 und +1.0 Volt liegt, so ist das Logic Board in

    Ordnung.


    Vielleicht liegt es am Einschaltknopf. Hast du schon versucht den

    iMac mit der Tastatur ein zu schalten? Achtung, ich habe da schon

    beobachtet, dass nicht alle Tastatur-Typen funktionieren.


    LG Rappi

  • Ok,


    das kleine Board mit dem Einschaltknopf habe ich auch schon getauscht, ohne Erfolg.

    Wenn ich den Einschalter drücke, dann knacken die Lautsprecher. D.h., der Knopf sollte eigentlich funktionieren.

    Retrogaming und klassische Computer

  • Servus Rappi,


    ich hab jetzt nochmal gemessen.

    Die Spannung bleibt auf -1.3V.

    Auch wenn ich den Einschalter betätige?

    Meinst Du das Converter-Board hat eine Macke? Da kann ich nur bei einem Pin 7V messen.


    LG


    Andi

    Retrogaming und klassische Computer

  • Du hast ja geschrieben, dass du das Converter Board schon ausgetauscht hast.

    Vielleicht wäre es ein Ansatz, das Converter Board nochmals zurück zu tauschen.

    Wenn du dann wieder die 7V messen kannst, dann würde der Fehler wahrscheinlich

    nicht beim Converter Board liegen. Das wäre dann schon ein grosser Zufall,

    wenn beide Converter Boards genau den gleichen Fehler hätten.

    Edited once, last by Rappi ().

  • Ja, aber ich glaube, das hatte ich gemessen und es war der gleiche Wert. Mit welcher Spannung und auf welchem Pin wird das Converterboard denn gespeist?

    Retrogaming und klassische Computer

  • Ja, aber ich glaube, das hatte ich gemessen und es war der gleiche Wert. Mit welcher Spannung und auf welchem Pin wird das Converterboard denn gespeist?

    Das ist ziemlich kompliziert und nicht einfach ein Power Board und

    ein Logic Board. Da kenne ich mich auch zu wenig aus, wie das genau

    funktioniert.


    Eine Schwachstelle bei diesem Converter Board ist der Zeilentrafo.

    Dieser wird im iMac zu warm und bekommt mit der Zeit

    Isolationsfehler und die Hochspannung fällt zusammen.

  • Ich komme zurück auf deinen Versuch, den iMac G3 zu reparieren.


    Eine wichtige Frage wäre noch, konntest du in der Vergangenheit diesen

    iMac schon starten, oder hast du diesen so bekommen?


    Wenn dieser iMac aus dem Jahr 1999 mit den Fruchtfarben ist, dann hat

    er original das System OS 8.6 installiert.


    pasted-from-clipboard.png


    Viele der Benutzer haben aus Unwissenheit einen Update auf 10.x gemacht.

    Leider geht das nur, indem man zuerst einen Update auf OS 9.x macht.


    Beim Update auf OS 10.x wird ein Teil der Firmware im ROM neu geschrieben.

    Wenn jetzt jemand den direkten Update von OS 8.6 auf OS 10.x macht, so wird

    dabei dummer weise keine Überprüfung gemacht und die Firmware wird geschrottet.

    Das hat dann zur Folge, dass der iMac sich tot stellt.


    Threads zu solchen toten iMac findest du sehr viele. Die haben alle den Fehler

    gemacht und wollten direkt auf OS 10.x Updaten.


    Um solche iMac wieder zu beleben müsste man das ROM mit der originalen

    Firmware wieder bespielen. Das ist ein 1 MB grosser Chip, der diese

    Firmware enthält. Leider findet man im Netz nirgends diese Firmware, man

    müsste diese aus einem originalen iMac kopieren und dann auf diesen toten

    iMac schreiben.


    LG Rappi

  • Hi Rappi,


    ich hab den iMac so bekommen. Es ist einer aus 1999 (Blueberry).

    Was der Vorbesitzer gemacht hat, kann ich leider nicht sagen. Aber das klingt natürlich schon plausibel.


    Allerdings habe ich jetzt auch ein anderes Mainboard (ein 2000er 400MHz DV) probiert und auch hier funktioniert der iMac nicht.

    Aber auch hier kann ich nicht sagen, ob das fehlerfrei ist.


    LG


    Andi

    Retrogaming und klassische Computer

  • Dein iMac G3 Blueberry aus dem Jahr 2000 wird mit diesem Logic Board

    sicher nicht laufen. Das hat ja 400 MHz und dein Blueberry ist nur für

    266 MHz oder 333 MHz ausgelegt-


    Da heisst es: "Ausser Spesen, nichts gewesen."


    LG Rappi

  • Das originale Mainboard hat 350MHz und meines Wissens nach ist das nur eine abgespeckte Version ohne Firewire und VGA-Ausgang.

    Da sollte das 400MHz schon auch drin laufen.

    Ich werde ihn morgen mal soweit zerlegen, dass ich das Analogboard ausbauen kann und werde mir da mal die Elkos anschauen.

    Vieilleicht liegt da ja der Hund begraben.


    LG


    Andi

    Retrogaming und klassische Computer

  • Hast du auch das Problem, dass die grüne LED nur ganz kurz aufblitzt, so als ob das NT startet und dann abschaltet wegen Kurzschluss?
    So einen haben wir auch noch...

    ::solder::Ich "darf" beruflich basteln...

  • Hast du auch das Problem, dass die grüne LED nur ganz kurz aufblitzt, so als ob das NT startet und dann abschaltet wegen Kurzschluss?
    So einen haben wir auch noch...

    Da muss ich ein wenig ausholen um den Fehler (vielleicht) zu beheben.


    Generell muss man davon ausgehen, dass das von Apple empfohlene

    RAM-Maximum von vielen überschritten wird. Das geschieht auf eigenes

    Risiko und funktioniert anfangs auch ziemlich gut. Mit der Zeit zeigt es

    sich aber z.B. wenn die 64 MB RAM durch 128 MB RAM oder die 128 MB

    RAM durch 256 MB RAM ersetzt werden. Plötzlich zeigen sich dann Fehler

    wie das einfrieren des Bildschirms. Dies geschieht z.B. dann, wenn eine

    grosse Datenmenge kopiert wird. So stürzt der iMac nach 5-10 Minuten ab.


    Die Jahrgänge 1998/99 haben noch 32 MB RAM PC100 SDRAM, da geht nichts

    höheres.


    Aber auch die RAM selbst können nicht kompatibel sein. Wenn man neue

    RAM einsetzt, so bleibt der iMac tot oder schaltet sich ein, zeigt aber einen

    schwarzen Bildschirm. Die Geschwindigkeit muss dabei auch <= 10 NS sein.


    Was kann man tun? Als erstes würde ich die Grösse der RAM anschauen.

    Wenn das 32/64 MB RAM sind, so sollte die erste Hürde überwunden sein.

    Dann würde ich mit nur einem 32/64 MB RAM starten, ich glaube die Bank

    ist egal. Startet der iMac immer noch nicht, dann die Bank wechseln.

    Dann mit einem anderen 32/64 MB RAM das Gleiche versuchen.


    LG Rappi


    Nachtrag: Es gibt auch unmotivierte Abstürze. Der erste £Gedanke ist,

    dass der iMac zu heiss wird und sich abschaltet. Besonders wenn man die

    Harddisk beobachtet, die ziemlich heiss wird. Ich denke aber, dass dies an

    den RAM liegt.

    Edited 3 times, last by Rappi ().

  • Ja, bei Bastelgeräten kann es sein, dass falscher RAM verbaut wurde.

    Ja, bei aufgerüsteten Geräten kann minderwertiger RAM Probleme größerer Kapazität machen.

    Ja, sollte man mit einer Handvoll diverser 32/64MB testen

    Aber nein: Funktionsfähige 256MB in einem G3 werden nicht plötzlich inkompatibel

    ::solder::Ich "darf" beruflich basteln...

  • Ja, bei Bastelgeräten kann es sein, dass falscher RAM verbaut wurde.

    Ja, bei aufgerüsteten Geräten kann minderwertiger RAM Probleme größerer Kapazität machen.

    Ja, sollte man mit einer Handvoll diverser 32/64MB testen

    Aber nein: Funktionsfähige 256MB in einem G3 werden nicht plötzlich inkompatibel

    Zu deinem Nein. "Funktionsfähige 256MB in einem G3 werden nicht plötzlich inkompatibel"


    Wenn mit dem iMac ein Update auf OS 10.x gemacht wird, so wird dann plötzlich

    der gesamte Speicherbereich genutzt und das führt zu dieser Inkompatibilität.

    Spätestens beim Kopieren von Dateien im hohen Bereich wird dieses RAM "gefüllt"

    und führt dann zum Einfrieren des Bildschirms.


    LG Rappi