MOUSE lebt

  • Hallo zusammen,


    ich habe heute den Tag damit verbracht die Platine die ich für meinen 65C02 Singleboard-Rechner bestellt habe zu debuggen.
    Nachdem meine Hoffnung, das der Kleine auf Anhieb funktioniert sich nicht erfüllt haben, hat es eine ganze Weile gedauert, bis ich auf die Fehler gekommen bin.


    Die Platine habe ich mit KiCad layouted, was auch recht gut funktioniert. Wir haben ja für unser VC4000 MultiRom Modul schon recht gute Erfahrungen damit gesammelt. Allerdings scheint KiCad bei Zeichnen von Leiterbahnen und dem Wechsel zwischen zwei Layern, bzw. dem Anknüpfen einer Leiterbahn an eine bereits vorhandene mittels Via noch einige Schwierigkeiten zu haben. Bei der Menge an "false positives" an fehlenden Verbindungen, sind mir tatsächlich zwei fehlende Teilstücke beim Routen nicht aufgefallen. Die waren auch gerade bei der Read/Write Logik und dem PullUp der /WE Leitung des EEPROMs, was dazu geeführt hat, das die Maschine den eigenen EEPROM zufällig neu beschrieben hat, was zu sehr seltsamen Effekten, die sehr schwer reproduzierbar waren, geführt hat.


    Zusätzlich habe ich im Schema auch noch zwei Adressleitungen in der Decoder-Logik vertauscht, was zu Glück nur zwei Chip-Select Signale betrifft. Damit liegt der Display-Port jetzt auf $C000 statt auf $A000 und der Expansion Port auf $A000 statt $C000.


    Von den 8k ROM nutze ich gerade mal 3,5k und habe ein eigenes Monitorprogramm laufen, eine Programmiersprache namens VTL-2 und sogar ein MicroChess Programm. Gesteuert wird der Computer über eine Serielle Schnittstelle, die per Serial2USB Adapter an meinem Mac hängt. Der Adapter versorgt die Schaltung auch gleichzeitig mit Strom.


    Vom "OS" gibt es ein kleines Video: https://www.youtube.com/watch?v=Ih2gI3Gpod8

  • Super! Ich freue mich schon, den Kleinen auf dem VzEkC-Stand auf dem VCFB kennenzulernen.