Posts by Roland_t29

    zur Erheiterung schlage ich mal diese Lektüre vor: Real Programmers don't use Pascal. Dieser Artikel ist Kult und spricht mir 100% aus dem Herzen.


    Ich selbst habe 1977 Fortran und Assembler gelernt (auf einer Univac 9200 !). Fortran habe ich nie gebraucht, vom Assembler zehre ich noch heute. Computersprachen kommen und gehen - ein echter Programmierer braucht einen guten Macro-Assembler - sonst nichts ;)


    btw: bei uns im Technikum29 werden die alten Computer in ACT-V, RPG-II und APL programmiert, oder wie unsere Tabelliermaschine gleich mit dutzenden Patchkabeln auf dem Steckbrett. Wer die Hölle mitgemacht hat lächelt nur über Basic-Spaghetticode !


    Roland

    Für ein Bastelprojekt habe ich mir eine CPU 68020 16 MHz in PGA-Gehäuse per eBay besorgt. Leider habe ich keinen Computer, in dem ich das Stück mal probeweise einsetzen könnte um es zu testen. Hat vlt. jemand im Raum Frankfurt/Main eine entsprechende Möglichkeit ? Ich würde gerne mal kurz vorbei kommen wollen, um das Teil zu testen, versenden würde ich es ungern. Wg Corona: bin geimpft, komme natürlich mit Maske, halte Abstand...


    Gruß

    Roland

    Betriebssystem, das Amboss heisst

    Gerne kann ich beim Archivieren der Disketten helfen falls die verschickt werden können, ebenfalls beim archivieren der Dokumentation..


    Heute aus den Tiefen der Depots des technikum29 ans Tageslicht gebracht: ein Siemens 6610

    Ich wäre sehr an Disks oder Disk Images interessiert, da ich für meine beiden Systeme keine habe...

    Hallo fritzeflink und horniger,


    zu dem Siemens/Tandberg 6610:


    mittlerweile habe ich die Dokumentation (jeweils Deckblatt) und die Software (ca 60 Disketten) mal fotografiert zwecks Dokumentation. Der Rechner läuft leider nicht an, das Netzteil piept im3-Sekundentakt, ich nehme an, Sicherheitsabschaltung.


    Ich werde jetzt erstmal versuchen, das Gerät wieder zum Laufen zu bekommen, Disketten oder Doku würde ich im Augenblick nicht zum Kopieren verschicken wollen - auf Anfrage kann ich Teile kopieren, bei Bedarf bitte PN


    Gruß

    Roland

    Ich hätte Interesse an einem 9153C, oder, falls man sich da nicht einig wird, einem 9122C. Preis ist natürlich abhängig vom Zustand und vor allem vom Typ: die Tabelle nennt bei beiden Geräten die "C"-Variante, bei den Bildern fehlt sie (9122) bzw. ist es ein 9153A. Da die Bilder vom hp Computer Museum sind nehme ich an, sie sind nur Stellvertreterbilder.


    Roland

    Das ist ein Tandberg Computer, den es auch in kleinerer Ausbaustufe als Terminal gab. 8080 oder 8085. CP/M und ein eigenes OS (TOS).


    https://youtu.be/KS_NOJSkpe0


    Ich wäre sehr an Disks oder Disk Images interessiert, da ich für meine beiden Systeme keine habe...

    Der Hinweis auf Tandberg ist gut: in dem Konvolut waren auch Unterlagen von Tandberg zu dem Monitor/Computer und das Beste, eine riesen Blechkiste, ordentlich befüllt mit Ersatzplatinen und div Adapterstecker, wohl für den Service gedacht, mit dem Label "Tandberg"


    Wie gesagt, ich mache die Tage mal Bestandsaufnahme was wir an Disketten haben, dann können wir gerne auch Kopien erstellen !


    Roland

    Bevor wir (technikum29) dieses Gerät auf unserer Webseite vorstellen hier eine "exklusive" Vorab-Vorstellung:


    Dank der Hilfe des IBM-Museums in Böblingen konnten wir den Urgroßopa des IBM-PCs, den IBM5100, wieder in Betrieb nehmen. Warum Urgroßopa ? Wenn man die Abstammung IBM 5100 - 5110 - 5120 - 5150 (=IBM PC) zählt, kommt man vom Urgroßvater über den Großvater und den Vater zum Sohn :)


     


    Der 5100 (erstmals vorgestellt 1975) basiert auf einer 16Bit-CPU (IBM-PALM-Prozessor) mit 1.9 MHz und bildet per Mikrocode eine IBM /360 nach. Darauf läuft dann ein ein /360 Basic bzw wahlweise auch /360 APL. IBM sparte sich so eine typspezifische Softwareentwicklung.


    Bei unserer Maschine hatte ein sterbendes Schaltnetzteil mehrere Chips auf div. Platinen mit in den Tod gerissen. Dank der super Unterstützung durch Mitarbeiter des IBM-Museums und mühsamer Ersatzplatinensuche per eBay USA gelang es, die Maschine wieder 100% zum Laufen zu bekommen. Einzig beim Drucker 5103 klemmen noch 2 Nadeln, das bekommen wir auch noch hin.



    ein kleines Basic Programm läuft



    Viele Diagnosebänder helfen bei der Fehlersuche, ein DC300-Format Bandlaufwerk ist mit an Board.



    ein besonderer Modus: die ersten 640 Bytes des Speichers können jederzeit hardwaremäßig in Hex angezeigt werden. Da dort auch die Register der 4 Interruptebenen liegen, kann man der CPU beim Arbeiten zuschauen. Die "kaputten" Zeichen sind kein Problem des Charactergenerators sondern haben sicht während der Belichtung geändert


    Und ein besonderes Gimmick: AUf den vielen Spielebändern ist u.a. ein StarWars, direkt unter Umgehung von Basic/APL über den COM-Slot programmiert, um flüssiges Spiel per Tastensteuerung zu ermöglichen.


    Roland

    Die Tastatur sieh ein bissel so aus also oben rechts ein Schredder integriert wurde....

    Ansonsten ziemlich cool das ganze.

    Das ist eine Ablage für z.B. Bleistifte.


    Ansonsten dürften die Kartons mit Dokumentation Aufschluss geben...?

    ja, da steht Arbeit an, ich muss das Ganze mal sichten und inventarisieren, dann sehen wir weiter...


    Roland

    Update zu dem Thema:


    Ich traf heute einen Mitarbeiter des IBM-Museums. Sie sind nach wie vor in den alten Räumlichkeiten. Wg. Corona war aber über ein Jahr kein Museumsbetrieb (Führungen, interne Reparaturtreffen) möglich. Da sich die Sammlung in einem Laborgebäude befindet, ist der Zugang für Externe aus Sicherheitsgründen sowieso extrem eingeschränkt.


    Der Umzug nach Ehningen steht immer noch an - Details hierzu erhielt ich keine.


    Roland

    Heute aus den Tiefen der Depots des technikum29 ans Tageslicht gebracht: ein Siemens 6610 mit 2mal 6414-Floppies, insgesamt 4 8"Laufwerke, Hunderte von 8"-Disketten und 2 große Kisten voller Dokumentation. Noch habe ich keine Ahnung von der Architektur und welche Hardware verbaut ist. Mit einem Betriebssystem, das Amboss heisst - das läßt tief blicken...


    ich werde zu gg. Zeit weiter darüber berichten !


      


    Sollte jemand "sachdienliche Hinweise" zu dem System machen können, bitte gerne melden !


    Roland

    ja ! Aber statt MU-Metall zu nehmen könntest du versuchen, den Trafo etwas verdreht (Position ausprobieren) an seiner alten Position zu befestigen, das könnte auch schon helfen (achte auf die Anschlüsse, keine Kürzschlüsse erzeugen)


    Roland

    ...

    MU Metall ist nicht gerade billig. Aber wenn ich wüsste, dass das wirklich das Problem behebt, würde ich das Geld natürlich investieren. Hat da jemand von euch Erfahrung ?


    Gruß Jan

    Hallo Jan,


    ich würde das mit MU-Metall nicht angehen. MU-Metall hilft nur bei magnetischer Einstreuung. MU-Metall ist teuer, muss passgenau und ohne Lücke um den Trafo angebracht werden. Bei mechanischer Bearbeitung (Biegen, ...) verliert MU-Matall seine Wirkung und muss erneut ausgeglüht werden.


    der Vorschlag von Toshi, den Trafo mal in seiner Position zu verändern, ist genau richtig ! Nur so bist du sicher, dass das die Ursache ist.


    Roland

    super, du bist "drin" ! Ich hatte RTOS seinerzeit auf dem Atari genutzt, um mit der PAK68 und dem 68882 eine sehr schnelle und leistungsfähige Programmierumgebung für meine numerischen Aufgaben zu haben. Viel Spass damit.

    Hallo Reinhard,


    und noch ein Hinweis: schau dir die ersten Bytes des RTOS-ROMs mal mit einem Hex/ASCII-Editor an, bei mir (RTOS UH für Atari) sieht es so aus:


    Der String "Nuc..." ist schon mal ein gutes Zeichen, hier befindet sich der Nukleus von RTOS. Die Einsprungadresse ist relativ zum Beginn bei $18. Da steht ein unbedingter Sprung (60 00 00 E2), noch ein gutes Zeichen (zu was der Einsprung bei $1C gut ist weiss ich nicht)

    Ab $20 steht der "Scan-Bereich", d.h. der Bereich im ROM, in dem der Nukleus die einzelnen Scheiben des RTOS-Systems sucht, um eine Adresstabelle im RAM zu erzeugen (die Tabelle liegt dann ab absolut $0400). Beim Atari, wo das RTOS-Image ab $5000 liegt, scannt er demnach von $5000 + $0 bis $27000 (das LSB zählt nicht, sondern markiert den Bereich als "relativ")


    Dieser Kaltstart kann einige Sekunden dauern, bis sich das System mit seiner Startmeldung meldet.


    Ich hoffe, das hilft etwas weiter und deine RTOS-Implementierung ist nicht zu unterschiedlich


    Roland

    hast du beachtet, dass RTOS im Supervisor-Modus gestartet werden muss ?


    Roland

    War die denn dejustiert? Normalerweise wurde bei den PETs und CBMs nicht am Tonkopf rumgeschraubt, so wie das später die C64-User gemacht haben - warum auch immer. :nixwiss:

    da man nie weiss, wer da schon mal dran gedreht hat, ist es immer gut, die Spaltlage des Tonkopfs wieder exakt senkrecht zur Bandlaufrichtung einzustellen. Allerdings muss man drauf achten, dass das Bezugsband, auf das ich justiere, auch wirklich mit normgerechter Spaltlage beschrieben wurde. Ich nehme da immer eine gekaufte Cassette (die blaue LP der Beatles :)

    Wenn da mehr gedreht wurde und auch die gesamte Kopflage quer zum Band neu eingestellt werden muss, wird es komplizierter. Allerdings erzwingen die Kassetten-Tonköpfe eine halbwegs ordentliche Lage mit kleinen Führungen. Mit dem Nachteil, dass bei Fehljustage das Band am Rand stark beansprucht wird und wellig wird.

    Toshi, das ist einfach super !! ED, PIP, MBASIC laufen bei mir, sogar ein Sargon Schachprogramm läuft ! Das war super einfach, nochmals vielen Dank. Damit steht meinem Atari die große weite Welt des CP/M offen :)


    Gruß

    Roland

    Hallo Toshi,


    danke für deine Hinweise. Die Anleitung kenne ich, mit der habe ich auch die CP/M-Diskette auf Atari mit den Utils erstellt. Die Programme TOSCPM.COM und CPMTOS.COM liegen von daher auch vor.


    Mein verbleibendes Problem ist, woher ich zB ein MBASIC.COM (oder ED.COM oder PIP.COM oder ...) für CP/M bekomme, das ich dann auf dem genannten Weg auf die Emulator-CPM-Diskette bringen kann. Die Dateien sind nämlich nicht in dem Emulatorpaket enthalten (das vermerkt auch die o.g. Anleitung).


    Im Internet gibt es viele Diskimages (.IMD-Files), die müsste ich mit dem IMD-Programm erstmal in eine "echte" Diskette wandeln und dann von dem zugehörigen CP/M-System (das ich ja nicht habe) zB via serielle Schnittstelle auf den Atari(Emulator) bringen.


    Eine Alternative, die ich angehe, ist:

    Ich habe von einem 8080-System eine 8"-Floppy des CP/M-Systems. Wenn ich die auf meinem DOS-Rechner (er hat eine 8"-Floppy) lesen kann, könnte der Transfer zum Atari klappen. Ich werde berichten...


    Meine Hoffnung war, jemand wäre den steinigen Weg schon gegangen und hätte direkt auf Atari übertragbare Files, die ich dann mit TOSCPM.COM wie auch die anderen Utiliteis rüberspielen könnte,


    Ich weiss, die ganze Aktion ist recht sinnfrei. Mit CP/M auf einem Atari zu arbeiten (zumal auf dem 1040st mit nur einem Diskettenlaufwerk) hat keinen produktiven Nutzen. Mir geht es einfach um den Erhalt und die Betriebsbereitschaft dieses Tools zu Demozwecken.


    Gruß

    Roland

    Hallo an die Atari-Freunde in der Runde,


    hat es jemand geschafft, den CP/M-Z80-Emulator auf dem Atari ST in ein brauchbares System zu verwandeln ? Ich bin so weit, dass ich den Emulator und einige Atari-spezifische CP/M-Utilities habe und erfolgreich CP/M auf dem ST starten kann (d.h. ich lande am "A:"-Prompt und kann zB "DIR" ausführen). Allerdings fehlen mir die üblichen CP/M-Tools wie ED und PIP und auch eine nutzbare Programmiersprache (Basic, gerne auch Pascal). Mir ist unklar, von woher und vor allem wie ich die Dateien auf meine CP/M-Diskette am Atari bekomme.


    Gruß

    Roland

    Hallo, ich repariere gerade einen 260st und suchte einen Ersatz für das separate Netzteil zu dem Rechner. Dabei ist mir ein Punkt aufgefallen, den ich nach Recherche noch nicht erwähnt fand: der alte 260/520st benötigt zum Betrieb nur 5V mit ca 1.5 A. Die beiden Spannungen +12V / -12V aus dem sep Netzteil dienen ausschließlich der Spannungsversorgung der RS232-Schnittstelle ! Wenn die also nicht benötigt wird, kann man die weglassen und kommt mit einem einfachen 5V-Netzteil aus.


    Im Atari 1040 werden die beiden 12V-Spannungen für RS 232 auf der Hauptplatine mit einem DC/DC-Wandler generiert. Das Schaltnetzteil muss dann nur noch zusätzlich +12V liefern für die Floppy. Ein 1040st, der ohne oder nur mit sep. Floppy betrieben wird sollte also auch mit einer einfachen +5V-Betriebsspannung laufen


    Roland

    Hallo Roland,

    die vorläufige Ausgabe von der Bedienungsanleitung habe ich auch. Falls Du nicht unbedingt darauf versessen bist, die selber zu scannen würde ich damit weitermachen.

    ...

    Viele Grüße

    Mathias

    Hallo Mathias,


    naja, "versessen" bin ich nicht wirklich drauf, das Teil ist sehr dick. Wenn du schon dran bist, überlasse ich es dir. Falls es dir zu viel wird, sag mir einfach die Seitennummer und ich mach weiter,


    Gruß

    Roland

    Es wäre gut, wenn Roland die Bedienungsanleitung von 1980/81 scannen könnte. Davon hab ich nur die vorläufige Ausgabe.

    Gruß

    Mathias

    Hallo Mathias,


    ich habe die Unterlagen heute gefunden, meine Bedienungsanleitung "Personal Computer PC100" ist wie auch das "Assembler-Handbuch" jeweils die vorläufige Ausgabe von 1979/80. Hat sich damit ein Scan erübrigt ?


    Gruß

    Roland


    Es wäre gut, wenn Roland die Bedienungsanleitung von 1980/81 scannen könnte. Davon hab ich nur die vorläufige Ausgabe.

    Gruß

    Mathias

    mach ich, bin jetzt aber 2 Wochen im Urlaub und muss danach schauen, ob die Unterlagen im Depot oder im Museum liegen. Der Depotzugang ist leider etwas restriktiv


    Gruß

    Roland

    Hallo DiMa,


    der 48G hat mindestens 2 Probleme:


    1. fehlen einige Pixelspalten, was erstmal nur ein kosmetisches Problem ist. Ursache ist ein Streifenleiter zum Display (liegt waagrecht unter der Blende am unteren LCD-Rand. Manchmal hilft (eine zeitlang) vorsichtiges Drücken auf den Bildschirmrand.

    2. ist der Kontrast viel zu hoch, drücke nach dem Einschalten wiederholt ON und die Plustaste gleichzeitig. Evtl. taucht dann ja was Lesbares auf dem LCD auf, was weiterhilft


    Eine Übersicht zu den verschiedenen Reset-Methoden finden sich ja im Beitrag vor meinem. Viel Glück !


    Gruß

    Roland

    Dem Betrieb des Bitel mit DBT03 standen ein paar Probleme im Weg:


    * seltsame TAE-Steckerbelegung meines DBT03

    * Umschalten des DBT03 im Inneren an seinem Mäuseklavier

    * Einstellung des Bitel auf "Bitel wählt"

    * Umgehung der fest programmierten Anschlusskennung im DBT03


    Nach vielen Hinweisen und Ausprobieren konnte ich mich jetzt mit den Bitel 3210 und einem DBT03 erfolgreich mit dem neuen BTX-Server verbinden.


    Mein "Kochrezept" für Nachahmer:


    * Anschluss an TAE-NFF-Dose, N-Buchse 2-5 permanent (Draht einlöten) verbinden

    * 3210 Anschluß F, DBT-03 Anschluß N

    * im DBT-03 am Mäuseklavier Brücke 6 und 7 schließen

    * 3210 von Standardeinstellung "Modem wählt" auf "Bitel wählt" setzen (Aufruf Testprogramm mit SHIFT und allen 4 Cursortasten gleichzeitig, Passwort "test", dann Menüpunkt 3)

    * BTX-Server-Tel.Nr im 3210 unter "BTX-Zentralen" ablegen

    * Start BTX am 3210, Auswahl der Tel-Nr aus BTX-Zentralen-Menü

    * wenn der Anmeldebildschirm erscheint und in der Anmeldekennung irgendwelche Zeichen vom DBT03 stehen (bei mir "0916"):

    * mit Cursor links zum Zeilenanfang gehen und die Zeichen mit der LEERTASTE überschreiben, mit # abschließen

    * Teilnehmerkennung mit # abschließen

    * Passwort nur # eingeben


    jetzt ist man "drin", zB auf der DB-Seite:



    Das BTX-Projekt ist eine tolle Sache und sehr schön für Museumsvorführungen geeignet.


    Christian aus diesem Forum hat dem technikum29 einen DBT03-Simulator geschenkt, damit können wir dann sowohl "wie früher" als auch "zeitgemäß" unsere BTX-Terminals vorführen. Dafür ein großes "Danke" !


    Gruß

    Roland




    Hallo Detlef,


    jederzeit kannst du an die PDPen "ran", besonders unsere PDP12 (eng verwand mit den 8en) bedarf der Zuwendung. Und meine PDP8-Replika stelle ich auch gerne ins Museum, wenn es dir hilft ! Im Keller warten 3 PDP8E darauf zu einer funktionierenden Maschine "gemerged" zu werden. Und , und, und ...


    Gruß

    Roland