Posts by Tux

    @rfka01:


    Hallo Robert,


    einfach wird das nicht (MAME).

    Ich beschäftige mich zwar nicht mit MAME, wohl aber mit PCem.

    In den momentanen Quellen von PCem ist der NEAT-Chipsatz nur sehr rudimentär umgesetzt.

    Da ergibt sich genau das gleiche Bild, das Du hier gepostet hast.

    Es ist mir aber gelungen, die NEAT-Implementation von 86Box (hier: Datei "m_at_neat.c") mit viel Gefrickel mal provisorisch in PCem einzubauen, und dann startet der 8810/30 unter PCem (mit dem BIOS von hier) unter DOS bis zum Prompt ohne Gemecker durch (!).


    ABER: Keinerlei Reaktion auf Tastatur-Eingaben...

    (Im Setup des BIOS geht's noch, nach dem weiteren Bootvorgang nicht mehr).

    Vermutlich hat die Kiste einen speziellen Keyboard-Controller, der unter PCem jedenfalls nicht erkannt wird.

    Ob also MAME da weiter ist?


    NIXDAS: Kannst Du evtl. Angaben zu dem Keyboard-Controller machen?

    Auf dem Bestückungsplan kann ich nicht genug erkennen :-)


    Viele Grüße, Frank

    GKTINY vom 10.06.2000 läuft auch auf einem 8086.
    Speicher-Verbrauch 288 Bytes.
    ASM-Quellcode liegt auch vor.


    GKTINY kommt wohl mit "GERKEYB" von Sebastian Schuberth.


    Sollte er nicht mehr im WWW zu finden sein, ggf. PM, dann maile ich ihn zu.


    Viele Grüße, Frank

    Hallo Peter,


    das Folgende bezieht sich auf den Treiber mit svgaptch
    ("This tool should patch svga256.drv to make it VESA compliant.")
    Findest Du im Netz, falls Du nicht genau den schon hast und meinst.


    Treiber installieren nach der dem Patch beilieg. Anleitung:
    Svga256.drv is a 256 color video driver included in WfW 3.11 with support
    for special graphics chipsets only.
    - copy svga256.drv in the directory where svgaptch.exe is located.
    - enter "svgaptch -p". It should display some messages what it has done.
    - copy the patched svga256.drv back to the windows 3.1 system directory



    system.ini OHNE Patch (sozusagen "default"):
    [boot]
    386grabber=vga.3gr
    oemfonts.fon=vgaoem.fon
    fixedfon.fon=vgafix.fon
    fonts.fon=vgasys.fon
    display.drv=vga.drv
    aspect=100,96,96
    [boot.description]
    display.drv=VGA
    [386Enh]
    display=*vddvga
    [svga256.drv]
    dpi=120
    resolution=3
    svgamode=56



    system.ini mit SVGA 1024x768:
    [boot]
    386grabber=vgadib.3gr
    oemfonts.fon=8514OEM.FON
    fixedfon.fon=8514FIX.FON
    fonts.fon=8514SYS.FON
    display.drv=SVGA256.DRV
    [boot.description]
    aspect=100,120,120
    display.drv=Super VGA (1024x768, 256 colors, large fonts)
    [386Enh]
    display=vddsvga.386



    system.ini mit SVGA 800x600 (nehme ich z.B. für meinen alten Asus EeePC):
    - wie oben unter SVGA 1024x768, aber/bis auf: -
    [boot.description]
    aspect=100,96,96
    display.drv=Super VGA (800x600, 256 colors, small fonts)
    [svga256.drv]
    dpi=96
    resolution=2
    svgamode=48



    meine mich zu erinnern, daß man das aber nach Installation des gepatchten Treibers auch via setup.exe (im Win-Verz.) einstellen kann.


    Gruß Frank

    Der Drucker ist wohlbehalten bei mir angekommen, nochmals Dank an blinddarm :-)


    Head: Genau, ich oute mich als aus dem "medizinischen Bereich" kommend.
    Die dämlichen Kassenformulare mit ihren x Durchschlägen...


    Allerdings will ich mal sehen, ob ich ihn mit dem speziellen Printer-Interface an meinem C128 zum Arbeiten bewegen kann.


    @Thoralf: Ebenfalls d'accord, allerdings schadet es nix, mal zur Überbrückung ein Ersatzgerät in petto zu haben, falls der eigentliche Drucker plötzlich abk*ckt...
    Hier auf dem Lande bin ich nicht eben von Läden umzingelt, die neue Nadeldrucker zum Kauf herumstehen haben, und bevor meine Arzthelferinnen sich 'nen Wolf schreiben, bis ein Neugerät da ist, macht das bißchen Gilb und die kleine fehlende Abdeckung im Zweifel wenig aus :-)


    Cooler Film übrigens *g*

    Hat jemand von Euch eine Möglichkeit gefunden, die DOS-Version zu konfigurieren?
    Das im Handbuch erwähnte "MCONFIG.COM" (für DOS) scheint ja nirgends zu finden zu sein...?


    Frank

    Nachtrag:


    Da existiert doch tatsächlich noch eine Version 0.9.8.1 von cbmlink
    und ich war zu blöd die war wohl zu gut versteckt *hüstel*


    Immerhin, das Linux-Binary von cbmlink 0.9.8.1 läuft :P
    -
    allerdings die DOS-Version (auf dem gleichen PC!) immer noch nicht...

    Hallo zusammen,


    hat zufällig jemand cbmlink-0.9.7 mit 64net-Kabel (Kabel der v1) ans Laufen bekommen?
    Ich habe sowohl die DOS- als auch die Linux-Version kompiliert und getestet.


    Egal ob ich die (64net-) C128-Version des Servers auf meinem C128D starte,
    oder (im C64-Modus) die C64-Version, es klappt einfach nicht.


    Ein Defekt des Kabels selbst scheidet aus, da die 64NET-Software
    (64NET v1.82.65 unter DOS) funzt.


    Auf dem DOS- oder Linux-Rechner erkennt cbmlink den angeschlossenen Commodore
    korrekt, wirft aber dann je nach Befehl eine Fehlermeldung aus
    (z.B. beim Leseversuch einer Datei vom C128 zum PC: "rdfile: installation failed")...


    Ist natürlich (wie wahrscheinlich alles hier) nicht überlebenswichtig,
    mich ärgert nur, daß ich es nicht hinbekomme, zumal ich das Kabel schon mal habe...


    Ach ja: Das von cbmlink wohl favorisierte Kabel ("PC64") besitze ich nicht,
    kann ich also nicht testen.


    Gruß Frank




    also, so um die 100 .ROL-Dateien habe ich hier noch rumfliegen,
    Listing siehe Dateianhang.


    Bei Interesse packe ich ein ZIP-Päckchen (PM, E-Post-Adresse),
    sind ungepackt 1.1 MB.


    Gruß Frank

    Files

    • rol.txt

      (6.75 kB, downloaded 29 times, last: )

    Zumindest FreeDOS bekommst Du problemlos auf die gleiche Partition wie ein (MS-)DOS.


    Der FreeDOS-Kernel bootet nämlich nicht (nur) via CONFIG.SYS,
    sondern (als erste Wahl, sofern vorhanden) "FDCONFIG.SYS".
    Dortens kannst Du dann den Namen (und kompletten Pfad) der FreeDOS-eigenen
    "autoexec.bat" (in der "shell=...") - Zeile festlegen, dito für command.com von FreeDOS.


    Z.B.:
    shell=c:\freedos\command.com /P=C:\freedos\FDAUTO.BAT


    Mehrere MS-DOS auf der gleichen Partition geht wohl nicht.


    Gruß Frank

    tjaaaa, in der Bucht suche ich schon seit 2 Wochen... Pustekuchen...


    Ein Franzmann bietet dort eine für € 65,- (plus 10,50 Versand) an - echt jetzt? X(


    Und aus Amiland kommt man mit Versand und Zoll
    auch bei den günstigsten Angeboten locker über € 50
    (und die akzeptieren sowieso meist nur Paypal)


    scheint also schwierig zu sein :(

    Hallo zusammen,


    ADTPro via Audio habe ich zwar am Laufen, aber... aber... (*gähn*)


    Es hat nicht jemand von Euch zufällig eine Super Serial Card für meinen Apple //e übrig?


    Viele Grüße, Frank

    Hach ja, die Adlib war meine erste Soundkarte... sauteuer damals...
    Und als ich dann eine SBPro hatte, hab ich Idiot sie verscheuert :fp:


    Was genau SOUND.COM so treibt, weiß ich zwar auch nicht, aber RBIL (Ralf Brown's Interrupt List) liefert einige Hinweise:


    Int 65/SI=0000h
    - Ad Lib SOUND.COM - INITIALIZE (RESET)


    Int 65/SI=0003h
    - Ad Lib SOUND.COM - SET STATE


    Int 65/SI=0004h
    - Ad Lib SOUND.COM - GET STATE


    Int 65/SI=0006h
    - Ad Lib SOUND.COM - SET MODE


    Int 65/SI=0007h
    - Ad Lib SOUND.COM - GET MODE


    Int 65/SI=000Ch
    - Ad Lib SOUND.COM - SET ACTIVE VOICE


    Int 65/SI=000Dh
    - Ad Lib SOUND.COM - GET ACTIVE VOICE


    Der Adlib-Rol-Player läuft jedenfalls nicht ohne, ebenso verlangten einige Spiele explizit diesen Treiber (ich erinnere mich z.B. an SPELLCASTING 101).
    Etliche Programme/Spiele hatten aber auch eigene Treiber dabei.


    Ein besserer Ersatz ist zumeist "SB-SOUND.COM", denn der kann wieder entladen werden.


    Gruß Frank

    Vielen Dank für die Rückmeldungen und Tipps :-)


    Toshi: Danke für den Hinweis; das mit der Geschwindigkeit war mir bekannt, ich würd's zumindest anfangs halt mal in Kauf nehmen.


    Selbstbau kommt für mich eher nicht in Frage, ich habe zwar gelernt, Menschen aufzuschneiden und wieder zusammenzunähen, aber mit dem Lötkolben bin ich wohl eher der krasse DAU... :S


    "Echte, klassische" CP/M Rechner:
    wunderbar, ja, aber das kann ja Wochen dauern, bis irgendwo einer auftaucht, der nicht ungeprüft und/oder zu E-Bucht-Mondpreisen zu bekommen ist... (?)


    Insofern war ich für mich zu ähnlichen Schlußfolgerungen gekommen, wie Peter und Ajax es schreiben.


    Und: wenn nebenbei dann auch noch ein paar Spiele laufen, nehme ich das gerne mit :D
    (besitze nämlich auch keinen C64).


    Frank

    Hallo zusammen,


    ich suche einen Commodore C128, am liebsten als Plastik-/Blechdiesel, evtl. auch C128+Floppy.
    Hintergrund: Ich möchte mehr mit CP/M machen und bin so langsam in der Phase, wo ich das Emulator-Geraffel leid bin - echte Hardware muß her!
    Vielleicht hat ja der ein oder andere aus diesem Forum noch ein - bitte funktionstüchtiges - Gerät abzugeben, das sich sonst nur im Schrank langweilt.


    Natürlich wäre auch ein Apple //e mit Z80-Karte eine Option für mein Vorhaben, aber die scheint es ja - außer in der Bucht zu Mondpreisen - kaum noch zu geben :(


    Gerne PM (mit Preisvorstellung) an mich.


    Viele Grüße,


    Frank