Posts by ktf

    Bissl alte Shugart-Doku:



    und Alignment disks (1×8" und 2×5¼"):



    Optisch sehen die Disks noch gut aus. Ob sie noch sinnvolle Informationen enthalten muss ich erst noch testen...


    -- Klaus

    SAS, das ist aber in dem Fall sicherlich nicht "Serial Attached SCSI", .... Kompaktdrucker, die haben einen Humor in Paderborn...

    Naja, verglichen mit Zeilendruckern, ist der sehr kompakt! 8-)


    Die ND04 waren eigentlich unkaputtbar. Wir hatten die z.b. bei den Testsystemen als Konsolprotokolldrucker im Einsatz.


    Problem wird sein, den an andere Systeme als Nixdorfs anzuschliessen. Wenn ich mich recht erinnere, was SAS ein Serielles Multiplex-Protokoll, aber ob das mit einem anderen bekannten Protokoll verwandt ist... :nixwiss: keine Ahnung.


    -- Klaus

    Vorsicht bei den ISA-Slots, in der aktuellen c't Retro ist da ein Artikel drin, DMA-fähige Karten wie Adaptec 1542 wirst du da drin möglicherweise nicht laufen bekommen, weil die letzten ISA-Implementierungen auf neueren Boards kein ISA-DMA mehr unterstützen. Ansonsten würde ich noch zusehen, dass du dem Ding noch "etwas" RAM spendierst, 1 GB ist für Win 7 nicht gerade üppig.

    Hatte da schon nachgesehen: ISA-DMA Channel und IRQs sind alle sauber im BIOS konfigurierbar (muss man dann natürlich auch machen) - und zu dem 1GB RAM: Da wird noch was aus einem anderen Rechner transplantiert, der faul im Flur rumsteht. :-)


    -- Klaus

    Mal ein relativ neues Etwas (zumindestens für meine Verhaeltnisse, wenn's ums Hobby geht):



    Ein tragbarer Industrie-PC von Advantech (PWS-1419TP). :announce:


    Und, was soll der "neumodische Scheiss" hier? :motz:


    Nun, ich habe lange nach einem Gerät gesucht,

    • was portabel und robust ist (gegeben: Rugged Case / Military Standard, das Gehäuse und auch die Tastatur ist aus Aluminium)
    • was ordentlich Leistungsreserven hat (gegeben, Intel T2500 Prozessor, 2GHz, 1GB RAM, ein Memory-Slot ist noch frei)
    • in das man anständige grosse SSDs verbauen kann (gegeben: SATA Anschlüsse auf dem CPU-Board)
    • was Möglichkeiten für alte Schnittstellenkarten bereitstellt (gegeben: 4 freie PCI-Steckplätze und vier freie ISA-Steckplätze!!!)

    Diese Kombi war gar nicht so einfach zu finden - gerade die Kombination ISA-Slots und moderne CPU-Boards ist selten.

    Das Schnuckelchen wird meine universelle Bridge zur Retro-Welt, mit Platz für so nette Klamotten wie IEEE-488 Karten, aber auch Digital- und Analog-I/O-Karten für Bastelprojekte. ::solder:: Da tragbar, kann man den Rechner dann auch dort aufstellen, wo man ihn braucht und (!) auch schnell mal zu einem Retro-Treffen mitbringen.


    Momentan ist noch ein Windows-7 drauf, das wird aber demnächst einem Linux weichen müssen, sobald ich mir eine SSD dafür besorgt habe (obwohl eine kleine DOS-Partition sich auch als praktisch erweisen könnte). Das Einzige, was ich mir noch genauer angucken muss, ist, ob ich da noch irgendwie ein modifiziertes 5 1/4" Diskettenlaufwerk einbauen kann, dann kommt da auch noch das Kryoflux-Board rein :-) (ein 3 1/2" Diskettenlaufwerk und ein DVD-RW-Laufwerk hat das Teil schon.)


    Was momentan das Anschalterlebnis trübt, ist ein alter Mini-Lüfter im Netzteil, der die Geräuschkulisse eines Starfighters entwickelt, aber das ist das kleinste aller Probleme :-)


    Hier noch das ein paar Bilder vom Innenleben, nachdem ich die verbauten Interfacekarten entfernt hatte:



    -- Klaus

    Hmm Backplane und eine 5V-Stromversorgung... seltsam


    Wild guess: - vielleicht hatten die Cardridges mit Batterie- oder Kondensatorgepuffertem Static RAM zum schnellen Lesen/Speichern, die man bei Bedarf in den Rechner gestopft hat und um die zu lagern diente dann diese Box, die den Stand-By-Strom bereitgestellt hat.


    Aber das ist nur ne wilde Vermutung - gefunden hab' ich auf die schnelle auch nix.


    -- Klaus

    Schon ein paar Tage her, dass die folgenden Klamotten hier eingetrudelt sind, aber ich hatte noch keine Fotos gemacht...


    Als erstes kam (aus den USA) ein S-100-Bus System:




    Ja, es hat ein IMSAI Front-Panel und nein, es ist kein IMSAI 8080. IMSAI hatte damals Gehäuse und Komponenten auch einzeln verkauft. So wie es aussieht ist das Gehäuse, die Backplane und das Frontpanel tatsächlich von IMSAI, die wichtigsten Karten (incl. der Z-80 CPU-Karte) sind jedoch von Jade. Ich schätze es daher grob auf Baujahr 1979/1980 (genaueres kann ich erst sagen, wenn ich die verbauten Chips genauer angesehen habe). Entweder Homebrew oder von einem kleineren Händler zusammengebaut.

    Ich hatte noch keine grossartige Zeit, mich dem System zu widmen und wollte es daher jetzt noch nicht aus Neugier auseinanderrupfen. Der Vorbesitzer schrieb recht nett: "It powers up and LEDs illuminate, and the switches do things, but not what they're supposed to do." :grübel:


    Also definitiv etwas für lange Winterabende. 8-) Quasi mein vorgezogenes Weihnahtsgeschenk an mich selbst. :xmas:


    Da die Fragen immer kommen: Kostenmässig lag das Teil bei ~ €700 (Auktionspreis), mit Transport und Zoll lag man dann bei ~ €1000-1100. Schon allein daher will ich mir bei dem System richtig viel Zeit lassen, alles gründlich zu checken und Instandzusetzen. Ein standesgemäßes Terminal (Televideo) hab' ich, eine passende Floppy-Unit suche ich noch. Momentan plane ich erstmal, ein externes TRS-80 II 8"-Laufwerk zu verwenden. Lt. Internet sind da Standard-Shugart-Laufwerke verbaut...


    Nunja - dann ist da ja noch das Strom-Problem. Hier habe ich wohl definitiv etwas zu billig eingekauft:



    Das Gerät tut zwar, was es soll (110V liefern), jedoch um den Preis, dass mir bei drei von vier mal Einschalten (egal, ob mit oder ohne Last) die Sicherung rausfliegt :motz:. Das Gerät hat wohl definitiv keine Einschaltstrombegrenzung (klare Kaufwarnung!). Zunächst hab' ich überlegt, ob ich da selbst eine reinfriemle, habe mich aber aus Gründen des Garantieerhalts dagegen entschieden und mir eine externe von ELV geholt:



    Nun, diese funktioniert einwandfrei (klare Kaufempfehlung). Kein Rennen zum Sicherungskasten mehr :)


    Also: Der Winter kann kommen :) Dann gibts auch einen netten Thread zum IMSAI - versprochen!


    -- Klaus

    Hurra!


    Ich hab' noch eine neuere Version der SW gefunden. Diese habe ich mal nach /tftpboot/tekxp installiert und dir das Verzeichnis dann mal in ein ZIP-Archiv gepackt. Damit müsstest Du besser zurechtkommen.


    Also:

    1. Das ZIP-Archiv im Verzeichnis /tftpboot extrahieren, dann hast Du drunter ein neues Verzeichnis Namens tekxp
    2. Versuche dann mal die Datei /tftpboot/tekxp/boot/os.10 zu laden.
    3. Wenn das nicht klappt, weil der Pfadname zu lang ist, kopiere die Datei os.10 direkt in das Verzeichnis /tftpboot und lade diese Datei
    4. Die Datei /tftpboot/tekxp/boot/config/xp.cnf in das Verzeichnis kopieren, wo die os.10 Datei liegt, die Du booten konntest, und auf Deine Bedürfnisse hin die Konfigurationsparameter darin setzen. Zum Testen, das X-Terminal neu booten.

    -- Klaus

    Ich habe das os.350, os.330 und auch os.10 ausprobiert. Es war immer das gleiche Ergebnis. Auch alle os-tr.*

    Hast Du mal die os-Datei aus dem Archiv ausprobiert, was ich oben gepostet hatte?


    Die einzelnen part*-Dateien, die Du nach dem entpacken des ZIP-Archivs siehst, sind ihrerseits tar-Archive (ausser part21). Wenn Du die direkt mit XP lesen willst, benenne sie mal um (mit Dateiendung ".tar") und schaue in part2 rein. da ist im Unterverzeichnis XP20 die os-Datei fuer das XP23.


    Falls XP noch keine tar-Archive lesen kann, besorge Dir mal GNU-tar fuer DOS. Mit dem Kommando tar xvf part02 kannst Du z.B. das 2. Archiv auspacken.


    (Der Grund, warum das alles in einzelnen Archiven ist, liegt einfach darin begruendet, dass auf den damals ueblichen verschiedenen UNIX-Derivaten die Dateien an unterschiedlichen Stellen extrahiert werden muessen. )


    -- Klaus

    oh, das kann ich Dir jetzt gar nicht sagen, da ich von den Dateien gebootet hatte, die das Install-Script nach /tftpboot kopiert hatte. ob os.350 die richtige os-Datei ist, kann ich nicht so sagen. Zumindestens meine ich mich noch zu erinnern, dass unter /tftpboot noch eine Konfigurationsdatei lag, die als nächstes geladen wurde (XP20.cfg AFAIK). Vielleicht versucht er die zu laden, findet sie aber nicht.


    Hast Du keinen UNIX-Rechner, auf dem Du das installieren kannst?


    -- Klaus

    Vielleicht um das Ganze ein wenig zu entzerren:


    Es gibt zwei Konfigurationsbereiche

    1. Konfiguration, damit das X-Terminal an seine OS-Dateien kommt
    2. Konfiguration, wie man sich vom X-Terminal mit dem Host verbindet.

    erstmal ist (1) zu erledigen, damit das X-Terminal anstaendig bootet.


    Dazu braucht es bootp oder dhcp zur Initialen Netzwerkkonfiguration und damit wird ihm dann auch mitgeteilt, wie sein initialer Bootfile heisst. Ich hab' das zulett mit dhcp abgefackelt, auf älteren Systemen nimmt man dazu bootp.


    Ich hab' im meiner dhcpd.conf noch Einträge für die X-Terminals, die kannst Du ggf. adaptieren:

    Code
    1. host ktf4 {
    2.     hardware ethernet 08:00:11:01:79:DF;
    3.     fixed-address ktf4.int.ktfnet.de;
    4.     option host-name "ktf4.int.ktfnet.de";
    5.     option bootfile-name "XP20/os";
    6.     filename "XP20/os";
    7. }


    wobei die Bootdatei dann unter /tftpboot/XP20/os zu finden sein sollte. Sieht ein wenig doppelt gemoppelt aus, hat aber dann so funktioniert.


    Wie es weitergeht, hängt von der Konfiguration ab. Entweder holt sich das X-Terminal alle Dateien via tftp (einfach zu konfigurieren) oder ab dem Zeitpunkt, wo es genug Informationen zusammen hat, einen NFS-mount durchzufuehren, via NFS (ist schneller, dazu muessen aber die notwendigen Verzeichnisse vom Host exportiert werden).


    Wenn das X-Terminal sauber starten konnte, (X11-Oberflaeche wurde gestartet), kommt dann erst Teil (2), die Konfiguration, wie man sich mit einem Host verbindet bzw. welcher Host einen XDM für das X-Terminal startet.

    -- Klaus

    So,


    anbei der Inhalt des Installationstapes. Siehe Datei README!


    Auf dem Tape sind mehrere Tar-Archive hintereinander, d.h. man muss die Parts einzeln nacheinander auf ein no-rewind device spielen (d.h. ein Device, das nicht nach einem Datentransfer zurückspult. Unter Linux wäre das heutzutage z.B. /dev/nst0 - je nach OS sind die Device-Namen unterschiedlich.


    Die Installation beginnt dann mit dem Extrahieren des ersten Archives und Ausführen des Installationsskriptes. Das liest dann die restlichen Archive und schreibt sie je nach Antworten beim Installieren ins System.


    Anbei noch ein Mini-Howto von damals. Kann hilfreich sein, weil der Autor sein XP23 auch von mir hatte ;-)


    Ich hab' hier noch Tektronix-Manuals zu den X-Terminals. funkenzupfer : Laut Ortsangabe wohnst Du ja im Braunkohlebagger - gibbet da auch Postzustellung? :/ Ansonsten wollt' ich eh' mal Toast_r besuchen wegen CBM-Disketten mit dem DOS fuer 8096er. Edit: Oder vielleicht in Krefeld oder Bruehl... hmm


    -- Klaus

    Ein glorreicher Kampf und doch erstmal mit Unentschieden in die Halbzeitpause:


    Tapes laufen jetzt an meinem Linux-Server, aber das Band lädt nicht - genauere Inspektion ergab, dass der Treibriemen im Cartridge gerrissen ist. Sieht so aus, als wenn hier die nächste Retro-Falle lauert...


    Das Datenband selbst sieht noch gut aus - ich muss jetzt also erstmal von eineem anderen Cartridge den Treibriemen transplantieren... *seufz*


    -- Klaus

    Nach Durchsicht von ~170 Tapes hab ich jetzt hoffentlich. Zumindestens hab' ich es mit 'tekxp' beschriftet... Ich hoffe das ist es, ansonsten war irgendwo hier noch ein dritter Karton mit QIC-Tapes...


    Jetzt gilt es nur noch, wieder ein QIC-Tape an irgendeinen Rechner zu stoepseln, um den Inhalt zu überprüfen. Mein damaliger Bandkonvertierungsrechner ist derzeit noch in Einzelteile zerlegt, da ich mir nach dem Umzug einen anderen zusammenschrauben wollte... Aber da ich eh einen HP SCSI-Scanner an meinen Server anschliessen wollte, waere das IMHO ein guter Zeitpunkt, mal nach einer SCSI-Schnittstelle dafuer zu kramen...

    -- Klaus

    Mea culpa!


    Wie bereits gesagt: Ich habe dafür noch die SW, hatte aber nach dem Umzug noch keine Zeit danach zu suchen. Der extrem trockene Sommer hat mich abends zuviel Zeit gekostet (Garten wässern...). Dazunoch der Job und die Familie... Ich hatte ja noch nicht mal Zeit für das Jahrestreffen :(


    Wäre schade, wenn das Gerät auf dem E-Kompost landet, dann hätte ich und Toast-r uns auch die Mühe mit Reinigen und Transport sparen können...


    Ich muss eh gleich mal ins Arbeitszimmer, dann schaue ich nochmal.


    -- Klaus

    :motz:Weil's IBM vergurkt hat!


    Die seriellen Schnittstellen des IBM PCs sind als Peripherieschnittstelle ausgelegt und nicht als Hostschnittstelle. Daher musste man immer die Daten- und Steuerleitungen kreuzen, wenn man Peripheriegeräte an PCs anschliessen wollte. Um des heiligen Grals der Rückwärtskompatibilität willen hat man das auch nie korrigiert. :bekehr:


    -- Klaus

    Hallo,


    Wieder eine Stern vom Apple:):)

    Und ich habe wieder eine fehlende Teil im meine Sammlung 8-)8-)8-)

    Oh, schick :-)


    Kannst Du von der Interfaceplatine des Keypads mal hochaufgelöste Fotos machen und in den Apple-Showroom posten? Ich hab' auch noch so ein externes Keypad für den IIer, aber mir fehlt die Interfaceplatine. Ich würde die gerne nachbauen.


    -- Klaus

    Back to the roots:


    Nachdem ich mich dieses Jahr extrem ausgetobt habe werde ich mich nächstes Jahr schwerpunktmäßig mit einer speziellen Architektur beschäftigen, und zwar dem S-100 Bus.
    (...)
    Eigentlich als Solo-Projekt angedacht ist meine Frage nun, ob sich hier noch jemand mit der Architektur beschäftigt und ggfls. an diesen Karten und weiterem Projektaustausch interessiert ist? Je nachdem kann ich entsprechend kalkulieren ..

    Was ist daraus eingentlich geworden? Es sind ja jetzt einige Jahre ins Land gezogen...


    -- Klaus

    Da kann was nicht stimmen: LInux kommt da nicht vor, obwohl Linux eine marktbeherrschende Dominanz bei Internetservern hat. Anscheinend ist das alles in Wintel vermatscht... .

    Nunja - verglichen mit den Endgeräten fallen die Server nicht besonders auf. Aber wenn es dich tröstet: Android ist ja auch Linux :-)


    -- Klaus

    Zieht man die Karten manuell durch?

    Bei dem TI59 ist ja leider dieser blöde Motor mit der aufgelösten Gummi-Rolle drinnen...

    Das konnte ich zwar mit einer Andruckrolle reparieren - aber so richtig gut läufts trotzdem nicht!

    Yep, beim Casio zieht man die Karten manuell durch. Deswegen ja auch die Streifen am unteren Ende der Karte, damit der Rechner erkennen kann, ob und wie schnell die Karte durchgezogen wird. Das macht die Karten zwar Aufwendiger bei der Herstellung, hat aber den Vorteil, dass die Batterien keinen Motor antreiben müssen. Das Ganze scheint recht zuverlässig zu funktionieren. Ich habe heute nochmal ein wenig mit meiner Selbstgebastelten getestet und hatte bis jetzt noch keinerlei Probleme.


    Hast Du denn auch Probleme, wenn Du den TI im Cradle oder am Netzteil betreibst? Evtl ist der Akku alleine zu schwach ?!


    -- Klaus

    Yep - daran hatte ich auch erst gedacht und das Laminiergerät auch schon ausgepackt, hatte mich dann aber als Sparfuchs vorerst dagegen entschieden, da ich erstmal testen wollte, ob ich die Markierungsstriche auch richtig hinbekommen hatte und die Koerzivität der Parkhauskarten-Magnetstreifen passt (ansonsten haette ich ein Stück von einem 1/2" reel tape getestet).


    Einlaminieren würde ich die Magnetstreifen nicht - wenn die nur mit Tesafilm befestigt sind, kann man die schnell mal ersetzen, wenn einer defekt ist.


    Wird aber bei (zeitlicher) Gelegenheit auch nochmal ausprobiert.


    -- Klaus

    Klasse gemacht! :anbet:


    Sollen wir jetzt Parkhauskarten für Dich sammeln? 8-)

    Hehe nicht notwendig - hier beim Aldi liegen immer haufenweise Karten auf dem Kartenleser der Ausfahrtschranke - da hab' ich mir einen ganzen Packen mitgenommen - bei Bedarf fahr ich da einfach wieder hin :-)


    Wollte eigentlich noch Testen, ob man die für die HP und TI auch nehmen kann (entsprechend geschnitten).


    -- Klaus

    ktf schon fast eine Stunde!

    Mann, jetzt machst Du es aber spannend... :rolleyes:

    Hehe - Nunja: Fotos von der Kamera begutachten, die passensten auswaehlen und skalieren, Artikel schreiben und formatieren, gegenlesen und korrigieren, Dateien hochladen ... das dauert halt.


    -- Klaus

    Aus der Rubrik "Ich liebe es, wenn ein Plan funktioniert":


    Anleitung zum Selberbauen einer Magnetic Data Card für den 1975er Taschenrechner CASIO PRO fx-1


    Der Rechner und die Karte (inklusive einer nicht unwichtigen Anleitung zur Benutzung der Karte) können hier begutachtet werden.


    Schritt 1: Erstellen einer Vorlage zum Drucken.


    Ich habe hier OpenOffice Draw verwendet. Als Vorlage diente mit die Abbildung der Karte unter dem Link oben, als Abmessungen habe ich die Größe einer normalen Scheckkarte vorausgesetzt. Dieser Schritt hat am längsten gedauert, aber ich habe Euch mal die Vorlage im Original und als PDF angefügt.




    Schritt 2: Organisieren einer nicht mehr benötigten Parkhauskarte mit Magnetstreifen und einer Overheadfolie für den Drucker


    Die Parkhauskarte kann man sich bei vielen Parkhäusern einfach abgreifen, da die dort oft Haufenweise an der ausgangsschranke rumliegen. Es sollte aber schon ein sauberes ungeknicktes Exemplar sein. Wahrscheinlich gehen auch die Magnetstreifen von HP- oder TI-Rechnern, aber die waren mir zum Basteln zu schade.


    Schritt 3: Drucken der Vorlage auf die Overhead-Folie


    Zum Drucken habe ich einen handelsüblichen Laser verwendet. Man braucht allerdings eine Overhead-Folie für Laserdrucker - wohl dem, der noch eine hat (hehe).




    Schritt 4: Ausschneiden einer Karte aus der Folie und des Magnetstreifens aus der Parkhauskarte



    Schritt 5: Zusammenkleben der Plastikkarte und des Magnetstreifens mit Tesafilm


    Das ist der heikelste Schritt. Der Tesafilm darf nicht auf dem Magnetstreifen kleben, wo der Schreib-/Lesekopf des Casio liest und schreibt. Aber glücklicherweise ist der Streifen auf den Parkkarten etwas breiter als auf der Casio-Karte.


    Der graue Streifen auf der Vorlage gibt einen Anhaltspunkt, wo auf dem Oiginal der Magnetstreifen ist. Den (breiteren) Magnetstreifen der Parkhauskarte dementsprechend an der oberen und unteren Seite überlappen lassen und mit Tesafilm fixieren. Dann noch mit einem Plastikspatel (Fingernagel geht zur Not auch) eventuelle Luftblasen aus der Region der schwarzen Striche herausstreichen.


    Da das ganze Konstrukt etwas labil wirkt (Overheadfolie ist halt dünner als eine Magnetkarte), habe ich auch noch auf der Rückseite ein paar Streifen Tesafilm zur Verstärkung aufgebracht. Wenn ich das nochmal mache, werde ich wahrscheinlich die Vorlage so ändern, dass ich die Overhead-Folie einmal an der oberen Kante knicken kann, um so zwei Lagen zu erhalten - dann sollte es stabiler sein.


    Schritt 6: Test


    Ein Test mit einem kleinen Programm war dann auf Anhieb erfolgreich (Programm eingetippt und getestet, dann auf Karte geschrieben, Rechner ausgeschaltet und danach verifiziert, dass kein Programm mehr im Speicher war und schliesslich das Programm wieder von Karte gelesen und ausgeführt (Erwartete Antwort "Speicher 3 enthält 8" wurde korrekt angezeigt):



    Viel Spaß beim Nachbasteln :)


    -- Klaus

    Die von Casio sind so groß wie normale Checkkarten. Zudem haben die am unteren Rand Markierungen, die - wie ich vermute - optisch gelesen werden, damit der Rechner weiss, wie schnell die Karte durchgezogen wird.

    Und sowas willst du basteln? Da bin ich aber gespannt...

    Du hältst uns aber auf dem Laufenden?!

    :juchee: Mission accomplished :!:


    Ich poste das aber mal in einen separaten Thread... Du wirst lachen, wie billig und einfach das war :mrgreen:


    -- Klaus