Apple IIgs Probleme mit "Floppy Emu" von BigMessoWires

  • Hallo miteinander,


    ich hoffe auf Hilfestellung bei einem mir noch unklaren Problem.


    Zur Vorgeschichte: nachdem ich meinen alten Apple II Europlus nach einigen Jahrzehnten wieder ans Tageslicht geholt habe und auch recht problemlos reaktivieren konnte, stolperte ich beim Durchsuchen des WWW auf so manche aktuelle Hardwareerweitung für die Apple II-Serie, unter anderem den Floppy Emu von Steve Chamberlin (BigMessOWires). Und über einen IIgs bei eBay, welchem ich nicht widerstehen konnte. Als dieser damals auf den Markt kam, war er so weit außerhalb meiner Reichweite, dass sich allein der Gedanke, einen zu besitzen, verbot.


    Nun ist er da, der IIgs. Und läuft eigentlich ganz prima. Der Selbsttest läuft durch mit "System good", allein die Pufferbatterie ist leer (Ersatz auf dem Weg) und seltsamerweise leuchtet die Power-LED nicht. Als Bildschirm habe einen aktuellen TFT mit dem RGB auf Scart-Kabel von Retrocables und einem Scart auf HDMI-Konverter verbunden, was ein ansehnliches Ergebnis bringt.


    Eine GG-Labs Speicherweiterung (8MB) ist auch noch drin.


    Eigentlich könnte ja alles gut sein, aber jetzt kommt o.g. Floppy-Emu ins Spiel.


    Ausgepackt, zusammengebaut, mit dem passenden Adapter an den Disk-Port des IIgs gestöpselt, 3.5"-Modus ausgewählt und gestartet - nichts passiert, es wird kein Laufwerk gefunden. Viele viele Tests und ebenso viele Mail mit dem Entwickler des Floppy-Emu (FE) komme ich nicht mehr weiter.


    Befindet sich der FE im Modus 3.5-Zoll-Disk, wird er vom IIgs überhaupt nicht wahrgenommen. Konfiguriert man ihn auf 5.25-Zoll-Disk, wird er erkannt und es wird versucht, ein Image zu laden. Dieser Vorgang bricht dann irgendwann ab und der IIgs steigt ins ROM aus.


    Verbindet man den FE mit dem Diskettenport des 3.5"-Laufwerks des IIgs, ist das Verhalten ähnlich. Im 3.5"-Modus keinerlei Reaktion des FE, im 5.25"-Modus werden Daten geladen ("Data"-LED blinkt, "Reading" im Display), allerdings erscheint kein Laufwerk auf der grafischen GS-Oberfläche.


    Verbinde ich den FE dagegen mit meinem II Europlus, klappt alles ganz wunderbar. Diverse Images lassen sich problemlos laden und starten, DOS, Spiele, CP/M...


    Jetzt stellt sich die Frage, wo der Fehler liegt. Am FE (allerdings klappt der super mit dem II Europlus) oder am Diskettenport des IIgs (allerdings klappt der super mit dem 3.5"-Laufwerk des IIgs). Steve Chamberlin vermutet mittlerweile einen Fehler an der Diskettenhardware des IIgs, bietet aber an, den Emu zurückzunehmen oder zu tauschen. Hier schrecken mich allerdings die Kosten für Rückversand und die erneuten Einfuhrkosten/Zoll ab.


    Für Ideen und Vorschläge bin ich dankbar und offen. Vielleicht gibt es sogar einen User im Raum Erftstadt / Hürth / Köln / Rösrath mit einem IIgs oder einem alten Mac, der sich für einen Test des Floppy-Emu bereit finden würde? Damit wäre dann klarer, ob der FE defekt ist oder mein "neuer" IIgs schwächelt.


    Vielen Dank!


    Marcus


    PS: Ich habe im Rahmen der Tests auch die Speicherweiterungskarte ganz ausgebaut und auch mal gegen die ursprünglich installierte 256MB-Erweiterung getauscht, ohne Erfolg.

  • Hi,


    hab hier ja ähnliches Setup..nen Emu bekomm ich die Tage wieder. Welche Revision hat dein Emu?

    Revision A hat öfters mal Probleme...Revision B hingegen fast einwandfrei.


    Welche ROM Revision hat dein IIgs?


    Grüße,

    Marcus

  • Hi Marcus,


    ich habe die Emu-Revision B, der IIgs hat das ROM01.


    Viele Grüße


    Marcus

  • Schau mal nach, ob im Control Panel der Disk Port als Bootoption eingestellt ist. Dazu beim Einschalten die Option-Taste drücken, dann "1" für Control Panel auswählen und danach "Slots" auswählen. Bei mir ist Slot 6 der Disk Port. Wenn nun der Floppy Emulator allein am Disk Port angeschlossen ist, kannst du dort, auf dem kleinen Display ein Disk-Image auswählen, das dann gebootet wird.

    Auf das Disk-Image kommt es natürlich auch an. Es muss zum Diskettenformat passen, dass beim Start des Floppy Emulators ausgewählt wurde und es muss das Image einer Bootdiskette sein. Bei 3,5" Disketten funktioniert beim mir am besten das 2mg-Format.

  • Danke, das werde ich ausprobieren.


    Auf alle Fälle ist "SCAN FOR BOOTDRIVES" (oder so) angehakt, habe leider erst Freitag wieder Zugriff auf den IIgs für den Test :-/


    Ein ähnlicher Test wurde bereits gefahren - ich habe ein bootfähiges Image (Loderunner) im 5.25"-Modus eingestellt und auf meinem Apple II Europlus ohne Probleme gestartet. Mit den gleichen Einstellungen am Disk port hat der IIgs zwar den Emu gefunden und versucht Daten zu lesen, bis irgendwann dann abgebrochen wurde.


    Ich versuche es aber nochmal dezidiert mit einem 3.5"-Image und dem Diskport auf Slot 6, vielleicht auch mal ohne Auto Scan.

  • Bei mir ist eine Festplatte eingebaut. Wenn "Scan" als Boot Slot ausgewählt ist, dann bootet der IIgs immer von Platte. Wenn dann aber GS/OS fertig gebootet hat und ich dann ein Disk-Image auswähle, dann erscheint es auf dem Desktop.

    Ich habe gerade auch mal ein 5.25" Image ausprobiert. Das hat der Floppy Emulator auch gebootet. Also gehen sollte das schon. Wie aber oben schon kurz erwähnt, bei mir ist extern nur der Floppy Emulator angeschlossen, keine Floppy-Laufwerke.

  • Hi,


    Also noch das alte/erste...will ich nicht ausschließen, dass es am Rev ROM01 liegt, zumindest beim ROM3 klappt's, mein altes ROM01 hatte ichcaber auch immerwieder Probleme..vorallem aber sogar von echten Disks..

  • Hmm...


    flowerking: Danke für die Rückmeldung. Das bestätigt, dass es eigentlich klappen müsste. Welche ROM-Version hat Dein IIgs? (Für den Fall, dass es in der Tat am ROM01 liegen könnte.)


    Das könnte dann überleiten zur nächsten Frage, ob ein ROM-Upgrade mit Bordmitteln möglich wäre oder ob auch das Motherboard dann einer entsprechend späteren Revision zugehören muss.

  • Einen Apple IIgs Rom 01 kann man nur durch einen Tausch des Motherboards zu einem Rom 03 upgraden.

    Ich habe sowohl mit Floppy Emu a als auch b bisher noch keine Probleme an einem Rom 01 oder Rom 03 Apple IIgs gehabt.

    Es gibt ein Programm mit dem man auch den Diskport testen kann, Vielleicht mal dieses Programm ausprobieren:

    http://apple2online.com/web_do…diagnostics_suite_4.1.zip

  • Ich hab auch einen Apple IIgs ROM 01.

    Das Einzige, das bei mir nicht funktioniert, ist ein Diskettenwechsel bei Spielen, die mehr als eine Diskettenseite benötigen.

  • Dann sollte der Floppy Emu ja funktionieren, sofern der Diskport ok ist. Davon gehe ich eigentlich aus, da ja das Diskettenlaufwerk einwandfrei funktioniert.


    Der nächste Schritt wäre dann der Versuch, via den Apple II Europlus das Diagnostik-Tool auf eine 5.25"-Diskette zu kopieren und dann mit dem ersteigerten 5.25"-Laufwerk für den IIgs, welches in den nächsten Tagen eintreffen sollte, den Port zu prüfen.


    Wenn dieser Test auch ok sein sollte liegt es vielleicht doch am Floppy Emu, den ich dann tauschen würde (nur doof wegen der erneuten Rücksende- und Einfuhrgebühren).


    Es bleibt spannend, bisher erstmal vielen Dank für die schnelle und super kompetente Hilfe! :-)