Posts by overCLK

    Der Schein trügt:


    eigentlich gibt es einen anderen Weg um PCS/ zu generierung. Wenn man keine Anschlussplan dabei hat, ist es sehr einfach Dinge zu vermissen. So sollte es sein:



    Da sollte die 48K Speicherkarte PCS/ null stellen, nur wenn die Addresse zwischen 4000H und FFFFH ist. Das passiert nicht mit meiner Karte, un deshalb muss der Fehler da sein, aber:

    - Die 74LS240 habe ich austauschen und dasselbe Ergebnis danach bekommen. Beide haben auch auf dem Logiktester keinen Fehler aufzeigen.

    - Die 7402 sieht auch gut auf dem Logiktester aus.


    Es könnte sein, dass die Fehler haben, die der Logiktester nicht gefunden hat. Ich habe auch gedacht daran, dass vielleicht gibt es etwas anderes, dass der PCS/ Linie zum Null gedrückt, aber auf diesen Fall, sollte dasselbe passiert, wenn die 16K Speicherkarte dabei ist.


    Leider habe ich keine Ersatz für die suspekte Chips. Ich wird sie bestellen und euch Bescheid danach geben.


    Vielen Dank für Eure Unterstützung.

    Da ist von dir gezeigt, dass damals genau nur die 48 kB dyn. KARTE ohne die 16 kB KArte aber bis BFFFH vom MOS benutzbar war. Plötzlich hattest du einfach die 16 kB Karte eingesteckt und dann hattest du bis FFFFh diese MOS Endspeicher anzeige!!!


    Ich denke nicht das die eine 16 kB Karte mit der 48 kB Karte (verheiratet) haben.

    Ich würde eher bei der dyn. Karte vom BUS VGL-Stecker also etwa dort die BUS Bausteine (keine Ahnug ? Latch, Busdriver oder sonstige Gatter) zu verfolgen/ messen.

    Richtig!!! Ich hatte das auch vergessen, aber ja. Ich erinnere mich nun daran, BFFFH als TOPRAM zu bekommen ohne die 16KB Karte. Das ist sehr hilfreich, weil es bedeutet, dass die Signale da sein sollen, auch ohne die 16Kb Speicherkarte.


    Ich muss alles nochmal wiederholen. Vielleicht gibt es verschiede Weisen, um die Steurungssignale zu generieren.


    Was wir nun kennen ist: Ohne die 16Kb Speicherkarte habe ich kein PCS Signal. Das muss schlecht sein.


    Meine Vermutung ist, deine 48K Speicherkarte hat die Logik für die 8202 und meine hat es nicht. BUS SIGNAL 75 ist privat für die Speicherkartepositionen (2, 3) und vielleicht nutzen es nur einige Speicherkarten.


    Zurzeit arbeite ich im Anschlussplan der 16K Speicherkarte. Leider gibt es viele Baustelle, die in PCS Generierung eine Rolle spielen und deshalb würde es schwer zu kennen, welche defectiv ist.


    @helwie: Könntest Du bitte ein Foto deiner 48K Speicherkarte hier hochladen? Ich würde gerne beide vergleichen um zu sehen, ob deine die 8202 Signale theoretisch generieren könnte.

    Ich habe was interessant (und vielleicht auch verrückt) gefunden :)


    Nachdem ich beide RAMKarte (48K und 16K) studiert habe, glaube ich, dass PCS/ aus der 16K RAMKarte generiert ist.

    Beide karten haben BUS pin 75 zusammen verbunden. In meiner 16K RAMKarte ist pin 75 mit einem Ausgang der 74LS38 verbunden, deshalb sollte pin 75 als OUT funktionieren.



    In meiner 48K RAMKarte ist pin 75 mit einem Eingangspin der 74LS06 verbunden, deshalb sollte pin 75 als IN funktionieren (es ist auch IN in der 8202)




    Nachdem ich nur die 48K RAMKarte installiert habe, es gibt kein Signal an 8202 PCS/ pin.

    Nachdem ich auch die 16K RAMKarte installiert habe, es gibt ein periodisch Impuls aus PCS/ pin!!!

    Wenn ich "D4000,6000" Befehl ausführe, gibt es selten anderen Impulse an PCS/ pin, aber nich einmal pro Lesung.


    Ich glaube, dass PCS/ Generierung fehlt. Jetzt muss ich warum finden :)


    Aber das würde auch bedeuten, dass meine 48K RAMKarte ohne die 16K RAMKarte funktionieren kann nicht. Ich finde es ein bisschen komisch, oder? Trotzdem finde ich keine andere Möchlichkeit, PCS/ zu generieren!

    Beide Signale - wenn cp/m 4300 auf Eingabe wartet:

    CH 1 ist NEU das 8202 PIN 33 PCS/ - und geht genau auf den 7406 PIN 13!

    CH 2 bekannt das XACK/ 8202 PIN 29.

    Es ist mir nicht klar, warum geht es zwei XACK/ bei jeder PCS/.

    Kannst Du bitte das Folgendes prüfen:

    - Gibt es bewegung an PCS/ auf MOS Prompt?

    - Gibt es bewegung an PCS/ wenn man D4000,4000 ausfürht?

    Ich habe bei dem 7406 nicht PIN 4 - sondern Pin 13 mit dem 8202 PCS Pin 33 gefunden!

    Mit Ohmmessung (akustische Signal gesucht) .

    Welcher 7406 gehört dazu?

    Ich glaube, dass beide PIN4 und PIN13 zusammen verbunden sind. Dass konnte theoretisch sein, um das Eingangsignal wieder zu herrichten (7406 ist eine "Open Collector"). Aber du muss auch PIN4 mit den 8202 PIN33 verbunden, oder?


    Irgendwie musste ein Ausgang der 7406 mit dem 8202 Pin 33 verbunden sein.





    Auf jeden Fall, könntest Du auf 8202 PIN33 direkt messen?

    Klasse Helmut!


    Es wäre schön, wenn du mir den Signal PCS (IN Signal in P8202 PIN 33) anzeigen könntest. Ich glaube, dass PCS gebraucht ist, um das lesen/Schreiben cyclus zu anfangen.

    In meinen 48K RAMKarte ist PCS verbunden mit 7406 pin 4 (Open Collector Inverter). Eingangpin ist pin 3, was mit Backplane PIN 75 (Dritte Reihe, pin 11.) verbunden ist. Aber ich weiss solange nicht mehr.

    Ich glaube PCS muss aktivieren werden, wenn ein RAM zugriff ausführen ist.


    Antworten zu deinen Fragen:

    - Mein 16K RAMKarte is DRAM.

    - Die 16K RAMKarte funktioniert richtig. MOS Befehle D/F in C000-FFFF können lesen und schreiben richtig.

    Hallo Manuel,

    dass vielleicht die 8202 Speichertreiber fehlerhaft ist

    ok - das könnte mit dem Bauteil (IC) das Problem sein.

    Ich würde mal einfach das SIGNAL mit dem Scope zu messen. Ist das BUSSIGNAL PIN 29 aus der A Reihe ( also 1..32 Zählung). Das Datenblatt vom 8202 suche ich im WEB. Ist da nur ein 8202 Baustein auf einer Baukarte? Sonst schaue ich gleich mal an meine P2U.

    Hallo Helmut.


    Das wäre schön zu haben.


    Ich meinte pin 29 der 8202, das ist XACK:



    Das ist mit andere Signale benutzt, um die SpeichernKarteAusgänge zu aktivieren. XACK ist auch an BUS 89 PIN verfügbar, wenn ich es richtig gemessen habe:



    108650-pasted-from-clipboard-png


    Ich vermute ich bekomme nicht genug Freischaltungen der Signal XACK, aber ich bin nicht sicher: Jeder /MEMR musste ein XACK haben.


    Vielleicht kannst Du prüfen, wie ist XACK wenn keine Speicherlesung gibt. Und auch was passieren, wenn man ein D4000,4000 Kommand von MOS ausführt.

    Hallo Helmut.

    Die Zwischenkarte ist aber ja eine prima Lösung um sicher mit dem Backplane Aufbau zu messen. Damit kann man schneller prüfen. Danke für die Fotos. :)


    Ich hatte zurzeit nicht mehr Zeit um meine Untersuchen weiterzugehen. Im moment glaube ich, dass vielleicht die 8202 Speichertreiber fehlerhaft ist. XACK (pol 29) musste bei jeder Speicherlesung aktiviert bekommen, was sehen nicht zur Verfügung aus. Wenn ich mehr Zeit habe, gehe ich weiter mit meinen Tests. Ich brauche auch mehr über die 8202 lesen :)

    Hallo Helmut,


    einverstanden. Ich glaube auch, dass irgendwie die RAM Karte nich aktiviert ist.


    Leider habe ich keine andere RAM Karte um zu vergleichen.


    Um die -5V Spannung zu generieren glaube ich, dass die 48K Karte ein "regulator" nutzt:



    da gehen -12V ein und -5V aus.


    Ich glaube dass die 16K Karte ein Spannunsteiler nutzt, einfach ein Widerstand auf die -12V Spannung.

    I think that this is all about the RAM card not being enabled when the address is in the range 4000H-BFFFH. I don't know exactly how this works but I understand that the right board must be enabled on read attempts and my feeling is that this logic is failing somehow:




    So far I have traced the activation path of the output latches for the 48K card (P8283) and came to this:


    the final output is the /OE pin of the output latches of the RAM card. I've been patiently soldering cables on all this path trying to pinpoint anything wrong, but even when I thought the NOR Gate (7402) could be defective, after desoldering it and tested it, it seemed to be okey.

    Anyways, I'm seeing very few activations of the output latches with the oscilloscope. I would expect one activation for each memory read taking place on the card, but it seems there are certainly less than those.


    I will keep reading and trying to understand how the 48K card is really activated, but I'm starting to think the failure could be even outside of the RAM card. Let´s see.

    Good idea to start testing the RAM embedded on the CPU card.

    I did experience issues with two "blue capacitors" in my computers. One was on the memory card, the other one on the floppy controller (capacitor next to the controller chips, issue occurred on two boards). Do you have the floppy controller board still in your computer when testing? I would remove it, just to be on the safe side (in my P3 the "memory issues" seem to be caused by floppy controller board problems actually).

    I've tried also with the floppy controller card removed and same results

    Seems the other memory areas are not affected, regardless of the RAM cards inserted or not. This is what I get in the 1800H area:



    In the 3000H area I can write and then the value is displayed accordingly:



    I've tested that with memory cards inserted and removed.

    I can summarize my experiences:

    • My first Alphatronic computer was a model P2 with 48K RAM card. Unfortunately it did not work at all when switching it on. I replaced the PSU, but still nothing. Finally I noticed that the RAM card was broken and created a power short, i.e. the computer turned on and showed the MOS message when the RAM card was removed. Consequently I tried to trace down the location of the problem on the RAM card, finally I identified one capacitor that created the issue. I did this with a "brute force" analysis, i.e. just checking resistance with a multimeter (without desoldering the capacitors). After removing the capacitor, the RAM card (and the whole computer) worked. Unfortunately it seems that @overCLK's problem is a bit more difficult and I would assume that either an address decoder or a RAM chip is broken.
    • I also had issues with a P3, which suddenly stopped working (it did not boot anymore and just showed the flashing "RESET" message). Here we also suspected some RAM-related issues and tried to understand the RAM addressing logic. We investigated the switching from 48K+ROM mode into 64K RAM mode and tried to understand differences between P2-48K, P2-64K and P3-64K configurations. Unfortunately we did not complete these analysis successfully, hence these experiments do not provide additional insights into the issue of @overCLK's P2.
    • Generic findings on memory boards for P2: I have one P2 with a 48K memory board and a second P2 with 3*16K memory boards. Hence I can confirm that the 16K boards work independently from 48K boards. However as mentioned above, I don't know if this is also true for the P2-64K setup. Usually there is this "adapter board" that is attached to the 48K board, allowing to "shift" the addressing (see http://www.wiertalla.de/pdf/Booten_Alphatronic_P2_cpm.pdf). Maybe in you case, this adapter board is now broken and you can try just the 48K RAM board in the machine (without adapter and extra 16K board).

    Thanks a lot for your feedback gpospi. Did you remember if you had issues with the non tantalum capacitors too (the blue ceramic -I guess- ones)?

    Regarding the memory cards being independent, seems you are right. I've seen that the 16K card generates the -5V with a simple resistor acting as voltage divider. I'm starting to suspect that either the memory controller (D8202A), buffers or latches in the card could be the problem and not the memory itself. The values displayed with D in MOS are very suspicious, but I'm not able to figure out yet what could produce such effect.


    Best regards,

    Manuel

    OMG. Das hatte ich komplett vergessen!

    Auch auf das Problem mit FFFF statt FFEF als TOPRAM mit meiner Rechner erinnere ich nicht. :)

    Konnte es sein, dass mein P2 einen verschiedenen MOS Version hat?

    Auf jeden Fall haben wir jetzt ein anderes Problem :)


    Viele Grüße,

    Manuel


    Hey Helmut!

    Yes, my Alphatronic is equipped with 48K and 16K memory boards. See photo below:



    I changed some of the capacitors (but only the shorted tantalum ones), the other ones seems to be good. I checked all the voltage lines and didn't detect any shorts. I have:

    - Around 300 Ohm between -5V and GND

    - Around 1K8 Ohm between 12V and GND

    - Around 5K4 Ohm between 5V and GND


    Trying with only the 16K inserted and the 48K removed I get errors trying to write (F) to any location with MOS. Now I get the pattern with the value = low address byte in both places:




    Is it expected that MOS returns an error when trying to fill (F) some of the defective positions? Maybe there is a check of what was written made automatically by MOS?


    What is also curious is that now without the 48K card in, the values are consistent with the addres low byte. With the 48K card in, sometimes there are glitches with some bits.


    I don't know how the memory layout would be in this case (only 16K card in), but is it reasonable to think that the 16K card gets shadowed in the 0000-4000 area and therefore not accessible at all from MOS after hard reset?


    I have the feeling the problem is in the 48K card :)


    Best regards

    Manuel

    Hallo zusammen :)


    after some good time letting it rest I tried to start again my Alphatronic and unfortunately got the following message from MOS boot:


    Seems that the 48K RAM is defective since TOPRAM is detected as 40FF.


    Even if there are alternatives to build a 48K or 64K board even simpler than the original design by using SRAM, my first idea would be to try to fix the defective board. The problem is that with the backplane design is quite difficcult and even risky to measure on the board pins directly. So first I will share here my observations and lets see if with your help and experience we can find out what the problem may be.


    My first question is how does MOS figure out what is the size of the RAM. I guess it probably tries to write/read on the different addresses until the values written and read differ?

    I tried to experiment a bit with the MOS commands to fill and display memory. I got surprised by the fact MOS allows me to fill memory from C000 onwards (I guess this belongs to the 16K memory board) and seems to work okey:



    But trying to write to lower positions (the ones in the failed card) returns an error (maybe MOS tries to read the value back and reports error if it doesn't match?). On the other side, trying to display memory in the 4000-BFFF range provides a pattern that seems interesting at least:



    As you can see the reported values are normally equal to the 8 lower bits of the address. I don't know if this can be related to the electronic design of the board or to some pattern MOS uses to check the RAM but seems to happen also on C000 if I remove the 16K board. It's also noticeable how not always the value is the expected one but some bits are changed (normally the lsb).


    Another thing I was wondering: does the 16K board needs the memory controller in the 48K one to function? Or is it completely autonomous: I've seen there is a good deal of logic chips on the 16K board (besides the RAM chips themselves) but I didn't see any way to generate the -5V on that board, so my guess is that the 48K board provides it to the backplane and the 16K board uses it from there, makes sense?


    Regarding other checks, I soldered cables to the regulator that generates -5V from -12V on the 48k memory board and seems to provide -5V properly. All voltage lines are properly connected to all the RAM chips and after having the board working for a while I didn't notice any chip that was particularly hot. On the contrary, only one column of RAM chips seem to get a bit warm whereas the others are quite cold.

    I also tried to switch the 48K and 16K to see if there was any problem in one of the backplane slots, but the result is the same. I checked that all the voltages are reaching both backplane slots properly.


    I'm open to any ideas, reports from similar behaviors and of course feedback about what I've written here, what probably can be wrong. :-)


    Viele Grüße,

    Manuel

    Zum Hintergrund der jeweiligen cp/m Diskettenvariationen?

    Sind beide 160 kB Floppys nur mit der unteren Seite belegbar?

    Obwohl die erzeugte .DSK doppelseitig leer eingerichtet werden?

    ( Ist aber kein Nachteil, weil ja über ein weiteres Laufwerk (C: / D: Oberseite) vom USER

    benutzt werden könnten.)

    Wenn man ein 160Kb Format auswählt, denn hat die generierte DSK nur eine Seite (40 Spuren)

    Benutzer System Spuren:

    Die Nutzer - Systemtracks sind über DROP & DRAG einzuschleusen oder über ein Browserfenster?

    Das funktioniert über ein Browserfenster.


    Ordner:

    Ist der Balken ein optisches Signal, für die belegten Director-Slots?

    Menge der Einträge belegt sind?

    Richtig. Auch wenn man über den Balken mit der Maus geht, wird ein Tipp gezeigt, wie hier:


    Viele Grüße

    Manuel

    Da komme ich noch mal mit einer neuen Version der Anwendung alphatronic-image-generator. :-)


    Neuigkeiten:

    - Man darf eigene System-Spuren benuzten, um eine DSK zu generieren. Neue Einstellungen:

    Da muss man eine Datei mit den zwei System-Spuren besorgen.


    - Falls man die Kapazität der DSK ubertritt, bekommt man nicht mehr einen Fehler. Auf dieser Fall wird die Fortschrittanzeige rot und die Schaltfläche "DSK bauen" abgeschaltet.


    Man muss Dateien löschen bis den Fortschrittanzeige wieder grün wird. Das bedeutet, dass es genug Platz in der DSK für die Dateien gibt. Das finde ich eigentlich mehr praktisch als früher.


    Ich habe auch die eingebautete 320K-System-Spuren modifizieren. Da habe ich die Offsets der DPH korrigieren.


    Viele Grüße


    Manuel

    Hier habe ich eine 320kB alphaTronic P2U "Ealphatronic_320_TAP100.dsk" mit deinem Generator erzeugt.

    Geht alles sehr einfach!

    Aber dann über die HxC Emu Anwendung - muss ich im Moment dieses FILE als z.B. "DSKA0067.hfe" hier ablegen. Dann funktioniert alles wie geölt!


    Grüße helwie44

    Wahrscheinlich weil dein HxC in Index-Modus arbeitet. Das ist normal, wenn man nur das 7-Segment Display habt. Deshalb muss man die Dateien nennen, wie du es gemacht hast. Es konnte auch sein, dass mit etwas wie DSKA0067.dsk funktioniert es... aber nicht sicher mit dem HxC Firmware.


    Ich habe alle meinen Gotek zum Flashfloppy migriert. Man kann sehr einfach einen Flashfloppy-Gotek mit ein OLED Display oder ein Quadratur-Encoder verbessern. Alle die Informationen zum Hardware-Mods stehen hier zur Verfügung: https://github.com/keirf/FlashFloppy/wiki/Hardware-Mods


    Viele Grüße

    Manuel

    Hallo helwie44. Danke schön für deine freundliche Wörter. :-)


    Du hast es richtig verstanden. Die drei Ausgabemöglichkeiten sind einfach verschiedene System-Spuren und auch natürlich, wie die Disk organiziert wird (ob es 40 oder 80 Spuren gibt, Usw.)


    Wenn man ein DSK (oder IMD) in der Anwendung stellt, sind alle die Dateien von der Disk entpackt. Man kann auch normale Dateien hinzufügen oder auch entfernen. Das kann nützlich sein, um modifierten in der Alphatronic Dateien später zu untersuchen.


    Es wäre möglich zu unterstützen, verschiedene System-Spuren zu nutzen. Zum Beispiel könnten wir diese Möglichkeit in der Einstellungenfenster zur Verfügung zu stehen. Falls man ein Datei besorgt, dann würde die Disk mit diese System-Spure generiert.


    Noch mal denke ich, dass der DSK sollte direkt mit dem HxC Gotek funktioniert. Ich erinnere mich daran, dass ich mit meine Amstrad CPC nur DSK-Dateien benutzt habe… aber leider habe ich alle meine Gotek nach FlashFloppy migriert und deshalb kann ich nicht mehr es prüfen.


    Viele Grüße

    Manuel

    Hallo helwie44.


    Eigentlich ist das genau, was ich schon ohne Erfolg verändert habe.

    MAXLW ist 4 in das originelle Code. Ich habe es gegen 2 ausgetauscht, aber funktioniert es nicht als erwartet. Vielleicht sollten wir auch etwas in BDOS verändern oder?


    Grüße

    Manuel

    Z80 Kompilator, es gibt Versionen für Windows, Linux und MacOS. Aber wenn du die Makefile nutzen möchtest, dann finde ich besser Linux zu nutzen (anderenfalls du kannst auch manuell alles zusammen bauen)


    https://github.com/sjasmplus/sjasmplus/wiki


    Dass kann sein. Als gesagt, habe ich nicht vorsichtig die Offsets geprüft. Ich war zu froh, dass es so einfach gut scheint. :-)

    Ja, das ist richtig. Das neue Format hat 128-Directory Einträge. Ich habe gedacht, dass es besser wäre, als sie eine größere Disk ist.


    Viele Grüße

    Manuel

    Hallo netmercer.

    Das macht voll Sinn. Ich muss da alle die Offsets wiederholen.

    Es gibt auch ein Problem mit SELDSK. Ich habe das code verändert, aber ich kann noch C: und D: in CCP auswählen… komisch.


    Viele Grüße

    Manuel

    Seltsam war allerdings, dass der Parameter EXM = 0 der Literatur zu CP/M widerspricht. Sollte bei einer Blocksize von 2048 eigentlich 1 sein (DSM < 256), funktioniert aber bei 22DISK nur mit 0 richtig. Bei EXM = 1 geht 22DISK beim Kopieren der Dateien in eine Endlosschleife. Habe keine Erklärung dafür.

    Ja, du hast Recht. Es sollte eigentlich EXM = 1 sein. Ich werde probieren, wie es mit EXM = 1 mit meiner Image läuft.

    Grüße

    Danke PAW für die Infos.

    WENN DU overCLK nur die Patches von alt := zu neu in hexa darstellt?

    Damit sind die Stellpositionen genau zu betrachten.

    Gute Nacht und Grüße.

    Kein Problem, aber…

    Ich habe zuertst das CP/M Code in Assemblersprache umwandelt. Als mir ist es schwerer, mit der Assemblersprache der 8080/8085 zu arbeiten, habe ich die Entscheidung getroffen, Assemblersprache des Z80 zu nutzen. Ich weiß ja, dass die nicht ganz kompatibel sind, aber meisten meiner Tools funktionieren mit Z80 besser.

    Dann habe ich das Code komentiert und danach die Änderungen erstellt.

    Als Kompilator habe ich sjasmplus benutzt. Damit muss man vorsichtich sind, um kein Z80 specifisches Code zu nutzen, aber ja, das ist nur ein kleiner Nachteil, glaube ich.


    Anbei meine modifizierte CP/M Source aus der CP/M 0100H und auch die Makefile, die ich benutzt habe, um alles zusammen zu bauen.


    binaries/booter.bin -> Erster Sektor (MOS Boot)

    binaries/loader.bin -> CP/M Loader

    binaries/cpm.bin -> CP/M Binär

    binaries/sectors.bin -> CP/M Spuren


    src/cpm-orig.asm -> cpm.bin Assemblersprache

    src/cpm-mod.asm -> modifiziertes CP/M

    src/Makefile -> Um die Binäre zu generieren:

    src/cpm-orig.bin -> Aus src/cpm-orig.asm generiert. Soll gleich wie binaries/cpm.bin sein

    src/cpm-mod.bin -> Aus src/cpm-mod.asm generiert.

    src/cpm0100-orig.bin -> Generierten CP/M Spuren

    src/cpm0100-ds.bin ->Modifiziertes CP/M (mit Booter und Loader).

    Files

    • cpm-p2.zip

      (93.25 kB, downloaded 10 times, last: )

    Ich überlege was die Unterschied sein kann.


    Ich nutzte ein Gotek mit dem Flashfloppy Software. Ich brauche nicht das DSK Image in einem HFE oder IMD verwandelt.

    Ich kann einfach das DSK-Image direkt nutzen, und ich vermute, dass es auch möglich mit dem HxC Software ist.


    Es konnte sein, dass es Probleme mit dem Verwandlung gibt, aber das R/O Meldung hat noch nie bei mir passiert.


    Das bedeutet natürlich nicht, dass es ein Problem mit meinem 320Kb DSK Image nicht geben könnte. Aber als gesagt, habe ich alle die Dateien im Disk-Image löschen ohne Fehler.


    Anbei ein Disk-Image mit den typischen CP/M Anwendungen (TPA 0100H). Bitte probiert mal, ob dein Gotek mit HXC kann das direkt unterstütz.


    Grüße

    Files

    Hallo helwie44.

    Entschuldigung, aber ich bin nicht sicher darauf, was du prüfen möchtest. Es sieht mir aus, dass du Probleme mit dem Löschen hast, oder?


    Ich habe mit meinem modifizierten Image getestet, dass ich alle die Dateien ohne Fehler löschen kann. Sie bitte mal:




    Deshalb weiß ich nicht, warum es mit deinem modifiziertes Image nicht richtig läuft.


    Wenn du möchtest, kann ich einfach ein Disk-Image bauen, dass die Dateien die du willst erhält. Damit kannst du vielleicht einfacher probieren.

    Schickt einfach bitte mir diese Dateien und ich werde gern so ein Image generiert. Eingentlich habe ich Zork benutzt, weil ich das Spiel mag und ich möchte die drei Versionen in einem Disk-Image stecken. :-)

    Hallo noch mal,


    anbei vorläufige Version der Anwendung.

    Man braucht mindestens Java 8, um sie zu laufen

    Es sind drei Ausgabeformaten ünterstutzt:

    - Disk-Image für CP/M 2.2 4300h TPA

    - Disk-Image für CP/M 2.2 0100h TPA

    - Disk-Image für CP/M 2.2 0100h TPA und doppelseitig.


    Man kann direkt normalle Dateien durch Drag-and-Drop von der Arbetisfläche zu der Anwendung zu importieren (oder auch exportieren).

    IMD Images für Alphatronic P2 sind auch unterstütz (einfach Drag-and-Drop sie drin)




    So generierten Images kann man direkt mit einen Gotek in der Alphatronic nützen.


    Viele Grüße

    Manuel