Posts by tuti

    Grundsätzlich geht sie. Habe das Beispielprogramm aus der Anleitung probiert.


    Allerdings liegen alle vier Ecken des Zeichenbereichs außerhalb des auf dem Monitor sichtbaren Bereiches. Die unteren sind zu tief, die oberen zu hoch und die beiden rechten auch zu weit rechts. Zeichne ich ein Rechteck (0,0)-(1,0)-(1,1)-(0,1)-(0,0) sehe ich nur die linke Kante.


    Vielleicht war ich bei der Einstellung des Monitors zu extrem und muss das (Text-)Bild ein wenig kleiner drehen? Auf der LSG gibt es ja nichts zum Justieren. Ich muss mal gucken wie weit ich überhaupt außerhalb liege.


    Beim Zeichnen von Text (im Beispielprogramm) erscheinen ein paar komische Geister-Pixel. Die RAMs hatte ich im RCT alle geprüft. Aber da schaue ich auch nochmal.


    Ein paar Baustellen sind also noch übrig. Aber das wird schon...

    Geht mir sonst immer so, dass ich zu langsam bin... :)


    Und... Trommelwirbel... Tadaaaa!



    Vielen Dank an alle Mitdenker. Ich habe jetzt in der Tat das File von CBM_Ba verwendet.


    Wer das hier irgendwann findet, sollte das auch tun (Post #99 ein bisschen höher).


    Und ich werde dem Steve Gray von der 6502-Seite mal einen Hinweis zukommen lassen.



    Und dann kann ich jetzt wohl auch mal an's Malen gehen. Zumindest probiere ich das als Nächstes...



    Nachtrag: Und das ROM erkennt offensichtlich wirklich den Chip und ist für beide Varianten EF9365/EF9366 geeignet. Das hatte ich oben ja auch schon mal vermutet.

    Also...


    Wenn ich von der HSG A000-AFFF.BIN die ersten beiden Bytes wegschneide und das Ergebnis mit der gerade von CBM_Ba angehängten Datei (vielen :thumbup: dafür) vergleiche, sind die beiden bis 0x0F00 identisch. Und danach kommt offensichtlich eh nur noch Füllzeug ohne Relevanz.


    Ich brenne dann mal...

    Es DARF btw in U12 kein Rom sitzen. Steht auch im Handbuch. Die Karte operiert ja in diesem Bereich.

    Eben. Das verwunderte mich bei diesem 4er Set am ROMs ja auch so. Vergessen wir dieses Set also erst einmal. Scheint murksig zu sein.


    Danke dir auch für die Aufklärungen bzgl. der Jumper.


    Eproms löschen mit Ultraschall? :grübel:

    Oops. :fp: Ihr wisst schon... UV... Ultra-Dingens halt... Schall? Licht? Ist das nicht alles eins in der Matrix? :nixwiss:


    Einfach die ersten beiden Bytes weglassen. Das ist die Startadresse.

    Das klingt spannend. War mir nicht aufgefallen. Das probiere ich aus. Müssen jetzt aber erst einmal nach Mutter und Schwiegermutter sehen. Ich werde berichten...

    So, EPROMs sind gelöscht (übrigens erstmal mit diesem Ultraschall-Ding, das letztens in einem anderen Thread Thema war :) ).



    Bei der Auswahl des nun zu brennenden BINs habe ich mir beide noch einmal angesehen:


    An Inhalten für das ROM habe ich folgende beiden Dateien ausprobiert (beide von http://www.6502.org/users/sjgray/computer/hsg/index.html ) :

    HSG A000-AFFF.BIN - EPROM from 512x256 res version.
    HSG-ROMS.ZIP - These are the ROMS that came in my 8032. They include the HSG roms plus modified PET roms to auto-run the HSG BASIC extensions)
    (aus diesem Zip-Archiv dann konkret die Datei "PET_HSG (2532).bin"; die anderen sind für das Mainboard)


    Das erste enthält durchaus lesbare Texte. Unter anderem auch die Initialisierungsmeldung. Insbesondere sieht diese so aus als würde sie zwischen der Ausgabe 512x512 und 512x256 umschalten. Dann wäre dieses ROM also wohl wirklich für beide Grafikchips geeignet. Aber es hat halt diese Byte 0x00 am Einsprungspunkt. Vielleicht ist der Einsprungspunkt hier ein anderer? Nur welcher?


    Das andere ROM (das eine aus dem ZIP-Archiv) enthält gar keine lesbaren Texte und scheint mir daher sehr suspekt.


    Ich brenne jetzt erst einmal nichts davon sondern wäre weiter an einer Datei von einem definitiv lauffähigen ROM interessiert.

    Juhu!


    Ich kann dir versichern, dass im aktuellen 8032 kein EPROM in UD12 sitzt. Es wird also nicht benötigt. ;)

    Was aber sein kann: Irgendwie falsche Daten für die Version mit 512x256 Pixeln. Oder irgendwas Richtung EPROM-Sockel, Verlötung, etc...

    Ich sehe mit einer PEEK-Schleife ja sogar die korrekten ROM-Inhalte. Ich probiere es jetzt aber noch mal mit einem anderen 2532. Der, der jetzt drin ist, ist mein historisches Stück. Ich habe ja noch die mit der "Dänischen Software", die ursprünglich im Gerät steckten und die neuer sind. Lösche ich gerade und dann geht das los.


    Dabei fällt mir ein. Beim Recycling dieser EPROMs fiel mir auf, dass einer der beiden gar kein 2532 sondern ein 2516 ist. Hatte mich schon über die so offensichtlich doppelten Inhalte gewundert. Ich werde das oben in dem alten Post nochmal ergänzen (wenn ich es denn noch darf). Das war Quatsch. Verwechselt.


    Schade, dass du keinen 512x512 Chip drin hast- dann könnten wir 1:1 vergleichen.

    In der Tat. Ich scheue mich noch immer das teure Ding bei eBay aus Hongkong zu bestellen: 1. teuer, 2. dauert's lange und 3. wer weiß was man da wirklich kriegt


    Gerade 3. wäre die nächste Unsicherheitsquelle...


    Ich les nix vom Jumper AB, der auf B stehen muss.

    Da hast du Recht. Habe ich gar nichts zu geschrieben. Der Jumper steckte und steckt aber in der Tat auf "B".


    Aber wo wir gerade bei Jumpern sind fällt mir ein:

    • Zu dem Jumper zwischen U3 und J8 habe ich nichts gefunden. Außer im Schaltplan. Den habe ich nicht bestückt. Passt das?
    • Dann ist da im Bestückungsdruck eine Brücke beim U19 angedeutet, zu der ich auch nichts finde. Neben PIn 9 und 11. Auch die habe ich nicht bestückt.

    Ich lese gerade nochmal "historisch":


    Du hast en 66er Chip mit 512x256 Pixeln (Typ B). Ich hab das Typ A board mit 512x512 interlaced (EF9365 IC).

    Beide haben aber das gleiche ROM - der Typ wird mit einem Jumper gewählt!

    Gestartet wird das Modul mit sys40960, da das ROM bei A000 eingeblendet wird.

    Anschließend hast du zusätzliche Basic Befehle.


    Das ROM sollte also nicht am 9366 scheitern...

    Hallo, Matthias.


    Das würde ich gerne mal testen/vergleichen. Ich würde hoffen, dass der Grafikchip mindestens bis zur Rückmeldung "graphic rev..." noch egal wäre. Vielleicht sogar komplett egal, nur dass man eben einen anderen Wertebereich in der Vertikalen zur Verfügung hätte (halt nur 256 statt 512 Bildpunkte).


    Beim NKC wäre das so. Da läuft das gleiche Grundprogramm mit beiden. Es gibt zwar ggf. Probleme mit dem Clipping beim Überschreiten des horizontalen Wertebereiches (einer der Chips malt dann wieder von links rein, der andere nicht). Solange man im Bereich bleibt, laufen aber grundsätzlich beide.


    Bei den ROMs von der Webseite oben (zumindest bei dem aus dem Viererset im Archiv) habe ich den Verdacht, dass es vielleicht doch nicht für sich alleine läuft, sondern dass dieses auch die anderen enthaltenen ROMs auf dem Mainboard voraussetzen könnte.


    Daher wäre ein Test mit einem bekanntermaßen laufenden ROM jetzt sehr hilfreich bei der Eingrenzung des Problems.


    Aber nicht hetzen. Genießt die Sonne! :sunny:


    Sonntägliche Grüße,


    Torsten

    Jetzt habe ich die Karte doch schon einmal in Betrieb nehmen wollen (auch ohne die stilechtere Verkabelung).


    So ganz will das Ding aber noch nicht. Und ich zweifle an dem ROM, das ich in den 2532 gebrannt habe.


    Doch nacheinander:

    • Ich habe die Verkabelung für Power und Grafik provisorisch mit Dupont-Käbelchen vorgenommen.
    • Den Schalter habe ich erst einmal weggelassen. Das entspricht der Mittelstellung und sollte ein softwaregesteuertes Umschalten von Text zu Grafik und zurück ermöglichen.
    • Die Lötjumper für das EPROM habe ich auf 2332 gesetzt (beide 1-2 verbunden). Eingesetzt ist eben ein 2532.
    • Das auf dem Mainboard angelötete Käbelchen steckt auf J10
    • Ich erhalte nach dem Einschalten das normale Bild vom BASIC 4 (was ja schon mal gut ist!)


    An Inhalten für das ROM habe ich folgende beiden Dateien ausprobiert (beide von http://www.6502.org/users/sjgray/computer/hsg/index.html ) :

    • HSG A000-AFFF.BIN - EPROM from 512x256 res version.
    • HSG-ROMS.ZIP - These are the ROMS that came in my 8032. They include the HSG roms plus modified PET roms to auto-run the HSG BASIC extensions)
      (aus diesem Zip-Archiv dann konkret die Datei "PET_HSG (2532).bin"; die anderen sind für das Mainboard)


    Die Inhalte beider ROMs kann ich auch per PEEK ab der Adresse 40960 "sehen". Habe mir nur die ersten 10 Bytes angesehen. Aber das zeigt ja zumindest, dass das gelötete Käbelchen und die Anbindung allgemein funktionieren.


    Laut Anleitung initialisiere ich den Grafik-Teil dann durch "SYS 40960".


    Beim ersten ROM lande ich da direkt im Monitor. Was aber auch kein großes Wunder sein dürfte. Das erste Byte in diesem ROM ist direkt ein 0x00 also ein BRK. Beim zweiten ROM lande ich in einer Endlosschleife. Es erscheint weder die in der Anleitung beschriebene Meldung "graphic rev..." noch komme ich zurück zur EIngabeaufforderung.


    Meine Frage an die Wissenden, insbesondere CBM_Ba: Welches ROM habt ihr im Einsatz? Eines dieser beiden und ich muss nach einem Fehler suchen? Oder gibt es andere ROMs, die ich noch nicht entdeckt habe, und diese beiden hier funktionieren einfach nicht?

    Bei #2 gab es noch ein bisschen was, das nach Texten eines Konfigurationsmenus aussah. Das doppelte sich aber mit den 80/132 Zeichen und der Baudrate. Daher habe ich das oben weggelassen.


    In #2 fanden sich in der Tat keine weiteren lesbaren Texte.

    ROM-inhalte haben doch fast immer einen Text, den sie bei bestimmten Konstellationen (Fehler, Einschalten, Hilfe) ausgeben.

    Schon mal mit nem Hex-Editor in das Image geschaut?


    Wen meinst du?


    Meine Texte sind oben in #1.


    6502 meinte eher, ob es nicht irgendwo eine geeignete, durchsuchbare Ablage für solche Images gäbe. Das wäre in der Tat cool. Tante Google wird auch den ein oder anderen verstreuten Hinweis finden, aber eine geordnete Ablage wäre schon nett. daher bin ich auf Antworten auf seine Frage auch gespannt...

    Ich las mal von dem Grundsatz "eine TTL-Last pro Karte" (vermutlich im NKC-Umfeld).


    Bei einer Karte ist es halt (fast) egal. Hat man 10 solcher Karten in einem System ist es dann ein Unterschied.

    Das Gerät sieht in der Tat sehr passend aus.


    Der Verkäufer hat viele EPROMs, RAMs und anderen Kram. Aber keine Einzelteile eines geschlachteten Terminals.


    Laut Verkaufsseiten löst er sein Lager auf, hat die Teile also vermutlich selbst einzeln bekommen/erworben. Für eine "Rettungsmission" dürfte das Jahre zu spät sein... :alt:

    Ich habe heute zwei EPROMs gelöscht und anderweitig verwendet, deren vorheriger Inhalt mir unklar ist. Es handelt sich um 2532-EPROMs.


    Für den Fall, dass jemand genau diese ROMs kennen (und suchen?) sollte, hier die lesbaren Texte, die ich entdecken konnte:


    ROM #1:

    #6 EXAMPLE OF DATA-SOFT KEYS

    ELECTRONIC OFFICE PRODUCTS DIVISION PALO ALTO CALIF


    ROM #2:

    TAB PRODUCTS CO. 1451 CALIFORNIA AVE., PALO ALTO, CAL. 94303, U.S.A.

    TAB 132/15 DISPLAY TERMINAL

    FEATURES: 132 CHARACTERS/ 4-PAGE MEMORY

    15" Non-glare screen Soft-key functions

    Speed: 50-19,200 bps

    80/132 Char x 27 lines Typomatic


    Vielleicht hilft es bei der Recherche/Zuordnung? Vielleicht gehören sie zusammen?


    Der Verkäufer hatte drei dieser EPROMs im Angebot, eines war aber schon weg. Evtl. gehören auch alle 3 zusammen und jetzt fehlt hier eines?

    Ich warte jetzt auf die Stecker und habe mich dann erst einmal den EPROMs zugewendet.


    Hatte mir extra "frische" 2532 bestellt. Aber 4 von 4 getesteten funktionieren nicht. Da beginne ich gerade eine Diskussion mit dem Verkäufer. Ich habe aber noch zwei so richtig schöne alte mit güldenen Beinchen, die ich eigentlich gar nicht verwenden wollte. Aber die lassen sich ohne Probleme beschreiben, so dass diese beiden jetzt auf der Karte und im 8032 auf UD12 stecken.


    Nun sind in dem einen gefundenen Archiv (HSG-ROMS.ZIP von http://www.6502.org/users/sjgray/computer/hsg/index.html) auch ROM-Inhalte für UD7 und UD8 dabei. Dabei steht "They include the HSG roms plus modified PET roms to auto-run the HSG BASIC extensions".


    Daneben gibt es aber auch ein einzelnes ROM nur für die Karte. Also nicht mal was in UD12. Letzteres ist eh nur minimalst gefüllt.


    Was habt ihr denn in Verwendung? Geht es bei diesem Paket mit 4 ROMs nur um den Autostart? Dann müsste ich mal in mich gehen. UD8 ist nicht gesockelt und ohne Not würde ich das Board nicht wieder rausholen und quälen wollen.

    Bassfrosch : Wo ich mir gerade das Foro vergrößert habe. Bevor Toshi es tut, gebe ich dir den Hinweis, dass du solche Elektronik besser nicht auf/in Luftpolsterfolie lagern solltest. Könnte elektrisch aufgeladen sein und dir was beschädigen...

    Hey! Cool! Danke!


    Wie drückst du die Käbelchen da rein? Stumpfer Schraubendreher? Das passende Tool dazu ist mit >50 EUR ja doch eher ein Witz (nur ein Stück Plastik, die richtige Zange ist noch viel teurer!).


    Habe noch nach solchen Kodier-Fitzel-Einsätzen geguckt aber keine gefunden. Laut einem gefundenen PDF hören die wohl auf die Nummer "PK 100-D". Gab es wohl auch mal bei TME, heute aber nicht mehr.


    Ist aber auch egal. Ein Klecks Heißkleber tut es sicher auch.

    Endlich sind heute dann auch die letzten noch fehlenden ICs gekommen.


    Was macht man als unverbesserlicher 80er-Jahre-Bastler dann in der Mittagspause (Home-Office sei Dank)?


    Richtig:


    Also +9V angelegt, am Video-Ausgang einen Monitor dran und PIN14 eines der DRAMs auf Masse gezogen.


    Ergibt:


    :dsc:


    Dann kann ich ja jetzt mal den Kabel-Verhau im Rechner vorbereiten.


    Weiß eigentlich jemand, ob es diese alten Stecker hier noch irgendwo gibt?

    Unbenannt.png



    Ansonsten wird das halt deutlich moderner aussehen müssen. Aber wenn der Deckel zu ist, sieht's ja niemand. angst

    Was noch klappen könnte: Wir fahren im April voraussichtlich auch nach Paderborn (DoReCo im HNF)

    Wir auch. Muss mal fragen, weil ich nicht selbst fahre, bin aber zuversichtlich das niemand was dagegen hat. Wir wollen nur Samstag da hin, morgens früh los und abends zurück, wann wärst Du da?

    Wir reisen am Freitag an und am Sonntag ab. Am Samstag werden wir länger vor Ort sein, am Sonntag noch mal am Vormittag (weil slabbi da noch Full-Service-RCT-Updates anbietet :thumbup: ).


    Lass uns mal Telefonnummern austauschen. Dann treffen wir uns vor Ort schon irgendwie...

    Hi.


    Du müsstest ja nicht persönlich kommen. So wie du Joe_IBM für die CC im September in's Spiel gebracht hast, könnte es ja auch jemanden geben, der eben in Paderborn dabei wäre und in deine Richtung führe.


    Wäre nur eine Anregung damit du nicht bis September wartet müsstest.


    Aber wie du schon schreibst: Ich warte jetzt erst einmal ab, ob und was da kommt. Ggf. hole ich das Ding und lagere bis September.