Posts by Trigger58

    Moin,

    ich habe ja den Olympia Boss Typ B oder C aus den Kleinanzeigen gekauft. Nach Sichtung des Computers und aller beiligenden Teile muss ich leider feststellen, das die Reparatur doch aufwendiger wird als gedacht.


    Eines vorweg: Der Vorbesitzer ist leider verstorben. Ich habe daher leider keinerlei Informationen darüber, was genau vorher alles an dem System verändert worden ist.


    Daher habe ich zwei Fragen:


    1.) Gibt es hier eine Schematic vom Z80 Mainboard des Olympia Boss?


    2.) In dem beiligenden kleinen Karton, wo diverse IC's mit bei waren, lag leider auch eine 1N4001G Sperrdiode 50V 1A. Weiß jemand zufällig, wo dieses Bauteil hin gehört?



    Danke :)

    Aquarius

    Guten Morgen,

    ich habe ein paar Neuigkeiten aber zuerst möchte ich deine Fragen beantworten.


    Habe das mit angesteckter Tastatur und ohne probiert. Keine Veränderung


    Ich besitze weder ein Oszilloskop noch ein Logiktester. Könnte damit auch nicht umgehen :(


    Den Wärmetest habe ich noch nicht gemacht. Kann ich gerne nachholen.


    Eprombrenner besitze ich auch nicht. Hier das selbe wie mit dem Oszi, kann ich nicht mit umgehen und kenne mich in der Thematik auch null aus. Sorry.


    Was einen Rechner mit R232 Schnittstelle betrifft, da hatte ich bereits am Anfang des Threads erwähnt, das ich soetwas nicht mehr besitze.


    Leider wohne ich nicht mal ansatzweise auf deiner Ecke. Um es genauer zu sagen, ich wohne im hohen Norden zwischen Elmshorn, Horst und Kiebitzreihe in einem kleinen Nest. Mit dem Auto knapp 8 Stunden entfernt. Das wird leider nichts :(



    Nun zu den Neuigkeiten:

    Gestern hatte ich ja geschrieben, das beim drücken auf die Reset-Taste nichts passieren würde. Das stimmt nicht. Ich habe heute mal alle IC's ausser der Z80-CPU, dem COM-IC und dem kleinen Universal Interrupt Controller entfernt. Dann denm BOSS eingeschaltet und es kam wieder das gleiche Flimmerbild.


    Dieses hier:



    Drücke ich nun ganz schnell hintereinander den Reset-Knopf, dann verändert sich das Bild für ein paar Sekunden in dieses hier


    Danach wechselt das Bild wieder in das erste zurück.

    Aquarius


    Ok. Eins nach dem anderen :)


    Alle IC's habe ich mehrfach abgezogen, kontrolliert und wieder eingesteckt. Natürlich habe ich auf die richtige Richtung geachtet ;)


    Reset habe ich zig mal gedrückt. Passieren tut nichts. Jedenfalls kann ich bei den Bildsalat nicht erkennen, daß etwas passiert.


    Auf Tastatureingaben passiert augenscheinlich auch nichts. Das gleiche Problem wie mit dem Reset. Man sieht ja nichts.


    Der falsch eingesteckte IC war ein Z80BSIO-2.


    Danke für die Info zum BIOS. Das beruhigt mich etwas.

    Aquarius

    Ich habe heute das neue Netzteil eingebaut und der Boss geht auch an. Auf dem Bildschirm bekomme ich leider nur Murks angezeigt.


    Hier ein Foto davon:


    Mir ist auch aufgefallen, daß der Floppy Controller Chip fehlt. Da steckte ein I/O Controller Chip drin. Habe jetzt einen 8272 bestellt. Keine Ahnung ob das dann hilft.


    Ich befürchte, daß das auch nicht helfen wird den Computer wieder Leben einzuhauchen.


    Weil ich keine Software habe, wäre eine Bootdisk für den Typ C echt klasse. Auch ein funktionierendes BIOS wäre auch toll. Ich kann ja nicht wirklich testen, ob meines überhaupt funktioniert :(

    fanhistorie Danke für das PDF. Werde später noch Bilder einstellen. Habe gerade ein ganz anderes Problem. Da das originale Netzteil komplett hinüber ist, habe ich mir das empfohlene, welches hier im Forum bereits mehrmals genannt wurde, von Reichelt bestellt. Das soll in den nächsten 2 Tagen eintreffen.


    Pinbelegung des Boards und der Laufwerke sind kein Problem. Doch was mich stark verwirrt ist der Anschluss des Ein/Aus-Schalters. Dieser ist ja am alten Netzteil mit dem Lüfter gekoppelt. Ich bekomme aber keine präzisen Messdaten vom Netzteil.


    Könnte mir jemand sagen, was genau an den 3 Anschlüssen von links aus gesehen anliegt?


    Danke euch für die Tips. Ich werde später gerne Bilder der Laufwerke posten. Interessant ist, das beide Laufwerke identisch sind aber auf einem der beiden 1 gesockelter IC mehr drauf ist und bei einem anderen IC andere Pins nach oben gebogen sind. Beim zweiten IC gehe ich von der Laufwerksselektierung aus. Aber wofür der andere ist, weiß ich nicht.


    Das Greaseweazle kann alle Disks im RAW Format auslesen. Das ist richtig. Hilft mir nur nicht, da ich überhaupt keine Software bekommen habe. Ich muss also mit den hier im Forum verfügbaren Images erst Disketten erstellen.


    Mein PC ist ganz neu und alte Modelle habe ich nicht. Dieses SAMconv lässt sich nicht installieren bzw. das notwendige FdInstall meckert, das es keine Floppy findet. Ist ja auch richtig. Mein PC besitzt keine Floppy Anschlüsse mehr.

    fishermansfriendtoo

    Danke für den Link. Da sind aber nur IMD-Dateien und keine IMG-Dateien in den Zips :(


    EDIT:

    Wie ich hier gelesen habe:


    Alternative Lösung zum Schreiben von 5,25" Disketten - gibts da schon was? - Robotrontechnik-Forum


    Soll es wohl so funktionieren, das man ein IMD-File mit dem HxC Floppy Emulator Software in das SCP-Format konvertiert und dieses dann mit der Greasweazle-Software zurück auf Diskette schreibt. Das habe ich eben mal gemacht und die BB_ZCPM2.IMD aus der Boss_B_Z80_Boot_disk_for_emulation.zip ins SCP-Format gewandelt und zurück auf eine echte Diskette geschrieben. Das hat problemlos gerklappt. Jetzt muss nur noch der BOSS wieder zum laufen gebracht werden und dann kann ich ja testen, ob das mit der Diskette geklappt. hat.

    Aquarius

    Das kann sein. Habe bereits ein neues Netzteil bei Reichelt bestellt. Wurde hier ja bereit in einem Reparatur-Thread erwähnt. Sobald das eingetroffen ist, werde ich das austauschen und dann den BOSS auf Herz und Nieren testen. Ich versuche es jedenfalls. Die beiden Diskettenlaufwerke habe ich berteits überholt. Bei beiden waren die Klappverschlüsse gebrochen. Die habe ich repariert. Das Laufwerk A war verstellt. Das habe ich dank des Greasweaszle resettet und die Spur neu eingestellt. Das funktioniert wieder. Bei Laufwerk B ist der Transistor auf der Motorsteuerungsplatine defekt. Ersatz ist bereits unterwegs.

    Das sollte ich auch wieder reparieren können.


    Momentan weiß ich noch nicht, wie ich vernünftig die Diskettenimages auf echte Disketten zurück schreiben kann. Das Greaseweazle ist zwar dafür ausgelegt, nur kann das leider keine IMD-Images verarbeiten. Und einen anderen alten PC mit XP habe ich momentan nicht. Sonst könnte ich ja SAMdisk und FdInstall nutzen. Das soll ja automatisch erkennen, was für ein Laufwerk angeschlossen ist und die Images korrekt zurück schreiben können.

    Guten Abend,

    ich bin seit gestern stolzer Besitzer eines Olympia Boss. Entweder Typ B oder Typ C. Das habe ich noch nicht genau herausfinden können. Außerdem muss ich diesen zuerst noch komplett zerlegen, reinigen und sehr wahrscheinlich noch diverse Dinge ersetzten bzw. reparieren, bis dieser wieder läuft.


    Da das Modell keine Festplatte hat und ich keinerlei Software erhalten habe, wollte ich gerne eine Bottdiskette für CP/M (Das war mein damaliges Betriebssystem auf dem guten Stück) wieder zurück auf eine echte Diskette schreiben. Ein 5 1/4" Laufwerk und ein Greaseweazle v4 habe ich bereits hier in Betrieb. Damit kann ich diverse Formate im RAW, SCP, DSK, IMG usw. zurück auf Diskette schreiben.


    Wie bekomme ich aber heraus, in exakt welchem Format diese Bootdisketten vorliegen?


    Ich besitze hier leider keinen alten DOS-PC oder ähnliches. Gibt es auch für aktuelle PC's Tools, womit man herausfinden kann, wie viele Tracks ein Diskettenimage hat und ob es einseitig oder zweiseitig bespielt ist?


    Das ist alles für mich ziemliches Neuland, weshalb ich mich über jede Hilfe sehr dankbar bin.