Günstige (intel PC) PCI-Karten für PCI-PPCs inbes. PM8200

  • Hallo,


    wie der Titel schon andeutet, sich ich günstige PCI-Karten, die ich in meinen PM8200/120 einbauen könnte.

    Das Gerät ist ganz und gar kein Sammlerstück. Die meisten Plastikteile sind extrem porös/brüchig und sind beim Anfassen schon zerbrochen. Trotzdem finde ich das Gerät als Brücke zu älteren Macs ganz geschickt, da er noch SCSI (25-pol) hat, ein HD-Floppy, ADB usw.

    Ausgestattet ist er mit 224MB-RAM ganz gut. Auch die 4GB-Platte ist reichlich. Als System ist ein 9.1 drauf.

    Geschickt fände ich halt USB, HD-Kontroller (IDE, SATA, ...), Grafik und evtl. auch Ethernet. Er hat zwar zum Glück neben dem AAUI auch eine RJ45-Buchse, aber halt nur 10MBit.


    Hat jemand Vorschläge zu Chipsätzen, die evtl. ohne Treiber gehen oder zu Karten mit BIOS, die man auf Apple umflashen kann. Beim HD-Kontroller wäre natürlich eine bootfähige Alternative optimal.:sunny:

  • Eine USB 1 Karte läuft eigentlich fast immer mit den generischen Apple USB Treibern, egal welcher Chipsatz.


    Für SATA schau dich nach Karten mit SIL3112 Chipsatz um. Die lassen sich nachdem ein passender Flashchip aufgelötet wurde mit der Firmtek/Sonnet Firmware flashen und sind dann ab System 7.5.5 bis OSX bootfähig. Du brauchst genau einen von drei möglichen Flashchips dafür, weil in der Firmware eine Überprüfung des Chiptyps stattfindet und die Karte sonst nicht funktioniert. Kann den Chiptyp bei Bedarf raussuchen und müsste auch noch passende Chips haben.


    Ethernet funktioniert am besten mit Realtek 81xx Chipsätzen. Treiber dafür gibts hier


    Grafikkarte - wobei du ja jetzt schon alle drei Steckplätze belegt hast - wäre wenn geflasht werden soll eigentlich nur die Radeon 7000 sinnvoll.

    Die hat aber ihre Tücken wenn sie in OldWorld PCI Macs eingesetzt wird - nach einem PRAM Reset bleibt da beispielsweise oft der Bildschirm dunkel bis das System einmal durchgebootet hat und den ATI Treiber geladen hat, der dann PRAM Einstellungen wieder gerade rückt.

    Ich würde auch in Anbetracht der eher schwachbrüstigen CPU Leistung im 8200 bei der onboard Grafik bleiben.

  • Danke für die Infos. EIne RTL8139 hab ich gefunden und eine USB-Karte mit NEC-Chipsatz auch. Die USB-Karte wird im Apple System Profiler auch als solche erkannt.

    Wie kann ich denn jetzt einen USB-Stick für File-Transfer vorbereiten? Auf PC-Seite hab ich Windows und Linux zur Verfügung.

  • Den USB Stick am Besten am Mac als "MS-DOS Dateisystem" formatieren. Dann musst du nur drauf achten, dass alle Dateien ordnungsgemäß gepackt sind, um die Resource-Forks nicht zu zerstören.

    Eventuell musst du auch die USB Treiber unter Mac OS erst nochmal nachinstallieren. Die werden eventuell nur installiert, wenn während der Installation eine USB Karte erkannt wird. Was passiert denn jetzt wenn du einen Stick an den Mac ansteckst?

  • Eventuell musst du auch die USB Treiber unter Mac OS erst nochmal nachinstallieren.

    Wie macht man das denn richtig?


    Mein Anliegen ist, USB zu nutzen, um eine richtige Maus verwenden zu können.

    Ich habe auf zwei Macs (9600/350, G3 beige tower 300MHz) sowohl mit MacOS 9.1 als auch 9.2.2 alles versucht.

    Installation mit und ohne USB-Karte mit oder ohne angeschlossener Maus. Als Mäuse habe ich quasi alles was ich an USB-Mäusen habe, ausprobiert.

    Meist geht nichtmal die Maus-LED an, und wenn sie angeht, dann passiert sonst nichts weiter, keine Reaktion auf Mausbewegung/klicks.


    Als USB-Karten habe ich diverse aus Macs entnommene Modelle probiert, einschliesslich Adaptec AUA-4000C, welcher in der inzwischen von der Microsemi-Seite verschwundenen Produktseite als spezifisches Mac-Modell angepriesen wurde, und angeblich ab MacOS 9 unterstützt wird.


    Die USB-Karten verhalten sich da alle gleich, werden in der System Information angezeigt.

    Game Sprockets ist auch installiert, aber das Verhalten der Mäuse ist gleich, funktionieren nicht, egal ob mit oder ohne Game Sprockets.


    Hast Du eine Idee, was ich falsch mache?

  • Den USB Stick am Besten am Mac als "MS-DOS Dateisystem" formatieren. Dann musst du nur drauf achten, dass alle Dateien ordnungsgemäß gepackt sind, um die Resource-Forks nicht zu zerstören.

    Eventuell musst du auch die USB Treiber unter Mac OS erst nochmal nachinstallieren. Die werden eventuell nur installiert, wenn während der Installation eine USB Karte erkannt wird. Was passiert denn jetzt wenn du einen Stick an den Mac ansteckst?

    Es passiert nichts, wenn ich den Stick einstecke. Ich wollte erstmal die Platte sichern, bzw. den Inhalt wegschreiben, bevor ich da was ändere. Aber dann such ich mal eine OS9.1-CD solang.

  • Ich hab jetzt auf eine andere Platte 9.1 installiert (vorher mit Silverlining formatiert), aber es bootet nicht vollständig. Ich bekomme die Uhr in der Menüleiste und einen Mauscursor, der hängen bleibt und dann geht nur noch der Affengriff. Ist das Silverlining 5.31 zu alt?

  • Der müsste einfach auftauchen beim Einstecken.

    So wie eine Diskette oder CD/DVD.

    ExFAT wird gemeinhin empfohlen.

    FAT32 sollte es aber auch tun.


    Den Download-Link zu Silverlining Pro 6.5 hatte ich oben schon gepostet. Ist das einzige was auch zusätzliche SCSI Hostadapter erkennt. Funktioniert wunderbar auf 7.5.5, 9.1, 9.22.

  • Irgendwie hab ich mit dem 8200 kein Glück. Die eingebauten Platte macht irgendwie Probleme. Ob es an der Platte selbst liegt weiß ich nicht. Eine andere SCSI zum platt machen hab ich grade nicht zur Hand. Das Verhalten war ganz seltsam. Mit SilverLining 6.5 konnte ich ein Volume einrichten, nach einem Reboot hing der Rechner selbst wenn ich von CD gestartet hab. Erst wenn ich unter Linux den Anfang der Platte genullt hab (dd if=/dev/zero ...) konnte ich den Rechner überhaupt wieder starten. Funktioniert hat haben dann einige ältere Formatter für MacOS 7.5.3, das ging aber dann icht mit 9.1. Ich hab die Platte dann nochmal genullt und mit SilverLinign 6.1 ging es dann. Ich konnte sogar 9.1 installieren. Ich hab dann angefangen ein paar Tools mit Diskette zu übertragen und dann ging wieder nichts mehr. Der Rechner bootet fast ganz. Der Balken im MacOS-Splash-Screen kommt bis zum Ende, der Bildschirm schaltet um auf HIntergrundfarbe und den Menübalken und dann ist Schluss. Keine Desktop-Icons, nix.

    Doof. :cry2:

    Einen SATA-Kontroller hab ich dafür inzwischen. Ist ein Sil3112 mit einem Winbond W29C011AP-15. Bolle kannst du mir bitte mal raussuchen, ob das der richtige ist und vielleicht einen Link posten zu einer Anleitung. Ich hab schon mal im Netz gesucht, aber vertrauenserweckende Seiten hab ich dazu nicht gefunden.

    Da ich mit dem 8200 so Probleme hab, hab ich noch einen 4400 bemüht, aber der zeigt kein Bild. Man hört ihn booten - von Platte und von CD, aber der Bildschirm blitzt nur manchmal ein bisschen auf. Ich hab so einen Adapter auf VGA, der mit dem 8200 und mit einem Performa 400 gut funktioniert. Ich hab auch schon diverse hohe und niedrige Auflösungen probiert.

    SCSI-Kontroller von Adaptec hab ich nur einen AHA2905/2920 und einen AHA39160.:grübel:

  • Winbond W29C011AP-15

    Mit dem gehts auf jeden Fall nicht.


    Was auf jeden Fall passt ist der MX29LV040. Da fällt mir grad noch ein, dass alle Chips die von der Firmware "unterstützt" werden 3.3V Versionen sind.

    Hat deine Karte einen 3.3V Wandler an Board? Die allermeisten Sil3112 Karten die ich bisher gesehen habe haben einen zusammen mit einem kleinen 0ohm Widerstand, der als Jumper dient um zwischen 5V und 3.3V Versorgung für den Flashchip umzuschalten.

    Hast du ein Foto von deiner Karte, dann kann ich dir sagen obs das bei deiner Karte gibt.

    Passenden Chip mit vorgeflashter Sonnet Firmware könnte ich dir zukommen lassen, habe ich hier noch.

  • Sorry für die Verzögerung. Hier schonmal ein Bild. Ein vorgeflashter Chip wäre natürlich der Hammer.


    Ein Bild vom Kontroller habe ich angehängt. Mit Lila hab ich zwei Verbindungen auf der Unterseite eingezeichnet, die mMn für die Stromversorgung relevant sind. Der rechte Spannungsregler ist ein LD1117 A33ARK, was ich gefunden hab ein 1,25-15V-Teil. Sagt also nichts.

    Ich hatte mal bei einem PC-Board ein Notfall-BIOS zum draufstecken. Was war ein doppelseitiger PLCC-Stecker, die eine Seite hat man auf das verlötete Onboard-BIOS gesteckt und auf der anderen Seite war ein BIOS-Chip, der das Onboard-Teil ersetzt hat. Das wäre hier natürlich DIE Lösung, so könnte man ganz ohne Löten einen anderen BIOS-Chip verwenden und evtl. sogar einen Spannungswandler dazwischen packen.

  • LD1117A33 ist fest bei 3.3V. LD1117ADJ wäre der Einstellbare.

    Wenn bei dir ein Pin am Wandler direkt auf Masse liegt und nicht über einen Spannungsteiler als Referenz auf Masse gelegt wird dann sollten da 3.3V rauskommen.

    Somit sollte das mit dem Austausch des Chips kein Problem sein.

    Ich mach dir die Tage einen Chip mit der Sonnet Firmware fertig, lass mich doch in einer PN schon mal deine Adresse wissen.

    Zur Sicherheit kannst du ja auch nochmal messen ob am Flashchip wirklich 3.3V ankommen, müsste aber wie gesagt der Fall sein wenn ich mir die Karte anschaue.

    Scheinbar ist der Winbond Chip da also recht tolerant was die Versorgung angeht. Laut Datenblatt ist der für 5V ausgelegt.