Frage zum II +

  • Hi,
    ich habe eine Frage zum II europlus.
    Das Programm
    10 input i
    20 print i
    startet bis zum Abfrageprompt, bei Eingabe einer Zahl (2) erscheint die Fehlermeldung ?Overflow und der Rechner stürzt bei &cc2c in den Monitor.
    Cpu und RAM sind laut Checkprogramm i.O. - kann es sein, dass eines der ROMS defekt ist?
    Was tun?

  • Update:
    Ich habe die ROMS D0, D8, E0, E8, F0, F8 sowie den IC 74LS13
    herausgezogen und die Kontakte gereinigt.
    Der Fehler ist geblieben.
    Frage: Sollte ich die ROMS besser komplett austauschen? Wenn ja, wo erhalte ich Ersatz?


    Da kann ich dir nicht helfen, aber frag mal auf comp.sys.apple2 nach. Da findest du viele alte Apple Enthusiasten die dir sicher hellen können. Falls du ein Rom benötigst habe ich sich noch 1-2 komplette Sets herum liegen.


    -Jonas

  • Ja, mit unterschiedlichen Resultaten. Einige Spiele funktionieren, ich kann Dos 3.3 laden und den Katalog ausgeben. Der MECC computer inspector läuft, ebenso xpsdiag - hier werden auch ROM-Fehler ermittelt. Kann aber auch daran liegen, dass hier ein //e erwartet wird. Ach so: Call -14544 zum Booten von Slot 7 schmeisst den Rechner in den Monitor, aber z.B. pr#6 funktioniert ...

  • Könntest du mir einen Satz ROMs schicken?


    Du solltest zuvor mal heraus finden welches Rom defekt ist. Dazu kannst du dir über einen eprom-brenner zuerst die Roms auslesen und dann mit den org. Roms vergleichen. Da die Apple-ROMs nicht auf Bäumen wachsen will ich nicht gleich einen ganzen Packen weg geben. Ausserdem kannst du dir auch einen eprom-adapter bauen:
    http://www.willegal.net/appleii/appleii-integer.htm
    Sobald du mir den defekten Rom nennen kannst, sende ich dir Ersatz zu.


    -Jonas

  • Du solltest zuvor mal heraus finden welches Rom defekt ist. Dazu kannst du dir über einen eprom-brenner zuerst die Roms auslesen und dann mit den org. Roms vergleichen. Da die Apple-ROMs nicht auf Bäumen wachsen will ich nicht gleich einen ganzen Packen weg geben. Ausserdem kannst du dir auch einen eprom-adapter bauen:
    http://www.willegal.net/appleii/appleii-integer.htm
    Sobald du mir den defekten Rom nennen kannst, sende ich dir Ersatz zu.


    -Jonas


    Ich habe gerade nachgeschaut:
    Apple II:
    ROM 1 1x
    ROM 2 1x
    ROM 3 1x


    Apple II+:
    ROM 11 2x
    ROM 12 2x
    ROM 13 3x
    ROM 14 3x
    ROM 15 3x


    Spezial:
    ROM 16 2x (Programmer)
    ROM 20 3x (Autostart)


    edit: gerade dein Posting auf csa2 gesehen. Wenn du keine definitive Antwort bekommst, sende ich dir ein Rom-set zu. Du sendest mir bitte dann dein Romset zu, damit ich den (eventuell) def. Rom ausfindig machen kann (Wenn es denn ein Romproblem ist)


    -Jonas

  • Hallo Jonas,


    hier noch ein kurzes Update:
    Ich habe Jim Sathers 48k RAM Test in den Monitor eingegeben. Du weißt schon: Läuft als Endlosschleife im HGR-Modus und zeigt im Textfenster wechselnd Fragezeichen und @ an. Ergebnis: Die 48k RAM sind definitiv in Ordnung. Habe den Test mit eingesteckter Language Card wiederholt: Identisches Ergebnis.


    Stelle außerdem fest, dass der Rechner bei CALL-151 abstürzt. Auch DOS3.3 kann ich nun nicht mehr laden, wohl aber alles, was in M-Code ist: zum Beispiele Spiele wie "Aztec".


    Ich gehe davon aus, dass es definitiv ein ROM-Fehler ist. Versuche das jetzt noch weiter einzugrenzen.


    Edit: Jonas, ich verstehe deine ROM-Nummer nicht. Ich kenne ROM D0, ROM D8, ...
    Edit 2: Ich habe mal E800.E8B7 im Monitor eingegeben, um zu sehen, ob es irgendwelche "addressing issues" gibt. Mein Ergebnis deckt sich mit diesem hier:
    http://www.applefritter.com/files/images/E8ROM_0.JPG

  • Okay. Dann schauen wir mal, ob sich über csa2 etwas ergibt. Im Moment kommt mir aber nichts anderes in den Sinn als ein ROM-Problem.
    Wobei ich es merkwürdig finde, dass der Rechner den Befehl "HOME" ausführt, bei CALL-151 aber einfriert ....


    Ich habe in jedem Fall genug Ersatzteile (ICs) aus der Zeit (1976-1981), damit du den Europlus wieder in den org. Zustand bekommst ohne dass man bemerken kann, dass da was geändert wurde.


    -Jonas

  • Kurzes Update:


    Hälfte aller ICs im Motherboard "reseated", Kontakte gereinigt.
    Ein Logic-IC SN74LS153N abgeraucht, Ersatz bestellt.
    Schnauze für heute voll: Trotz IC-Puller zweimal ordentlich gepieckt...


    Blood on the dance floor (äh) motherboard ... :rotwerd:


    @Jonas: Ich schrei dann um Hilfe, wenn ich so weit bin ...

  • Tja, das war erst mal nix:
    Alle ICs neu gesockelt, zwei stark korrodierte Logic-ICs ausgetauscht, aber es bleibt dabei:
    Bei dem "Programm"
    10 HOME
    20 FOR I= 1 to 100
    30 PRINT I
    40 NEXT I
    erscheint nach Programmstart wieder die Meldung
    ?Overflow
    und der Rechner stürzt in den Monitor.


    Ich wäre für Vorschläge dankbar ....

  • Hast Du noch einen zweiten, laufffähigen Apple II+? Dann würde ich Stück für Stück die IC's umtauschen.
    Was auch noch helfen kann: Logic-ICs die mehr als einmal vorhanden sind, untereinander austauschen - im Apple sind oft nich alle Gatter belegt und durch den Austausch kannst Du ein defektes Gatter mit einem unbenutzten tauschen. Mit einem Logik-Tester kannst Du ICs auch einzeln prüfen...ist aber viel Arbeit.
    Leihweise kann ich Dir mit einem funktionsfähigen Apple II+ aushelfen (würde mein "Schätzchen" aber nur ungern der Post anvertrauen ;)


    Gruß, Jochen

  • So, gemeinsam mit dem lieben Jochen haben wir meinen II europlus zerlegt und den Fehler gefunden: ROM E0 ist defekt.


    Unsere Versuche, einen Ersatz zu brennen, haben leider nicht gefruchtet - deshalb hier die Frage: Wer kann helfen und mir ein E0 schicken.


    Jonas?
    Andre?


    Könnt euch ja mal melden ...


  • Wolltest du nicht kurz in Brühl vorbei kommen (Retroumtrunk)?
    Ansonsten könnte ich dir ein Ersatzrom senden.


    -Jonas

  • Kann mir jemand helfen?
    Ich habe zwei Bastel-Apple-2+ (Bausatzgeräte mit Holzgehäuse und Eigenbau-Netzteil), beide hab ich halbwegs funktionsfähig, der zweite ist mir ein paarmal abgeraucht, aber funktioniert fast nackt mit nur der Language Card drin. Beide haben auch noch eine Z80, 80Z(eichen) und PAL-Farbkarte.
    Mein größtes Problem: Diskettencontroller.
    Ich habe ein 5 1/4 Zoll Doppellaufwerk und zwei 8-Zoll Laufwerke, sowie für jeden Apple und jedes Laufwerk einen Controller (also vier). Das sind
    alles Bausatzgeräte mit den gleichen Eigenschaften wie die Apples. Auf einem der Controller steht "Defekt", der verhält sich aber genauso wie
    die anderen drei. Keiner der Controller war bei einem Abrauchvorgang im Gerät.
    Die Controller sehen keinem bekannten Controller (Google Bildersuche) wirklich ähnlich, sie haben zwar den ROM und Anschlüsse für Drive 1 und 2, aber die werden nicht genutzt, stattdessen ein Anschluss an der Seite, an dem nachträglich herumgefrickelt wurde. Chipcount=18.
    Die Laufwerke sehen von innen noch viel verbastelter aus.
    Kurz gesagt: Ich kriege sie nicht zum Laufen. Wenn ich eine der Karten installiere, passiert entweder nichts (als wäre sie nicht installiert) oder er zeigt
    nur "APPLE ][" an, aber kein Prompt kommt. Er greift auch nicht zu, nur beim Ein- und Ausschalten klackt das Laufwerk kurz. Ich weiß leider nicht mehr genau, wie der verfrickelte Stecker auf dem verfrickelten Anschluss saß, aber es gibt nur eine Position, die Sinn macht, wenn man sie ändert, leuchtet bei einem Laufwerk die LED ständig und der Motor dreht sich ca. 1 Sekunde lang.
    Im Moment sind Kassetten jedenfalls meine einzigen Massenspeicher und die waren beim Apple leider nie auch nur annähernd so beliebt wie bei sämtlichen anderen 8 Bit Rechnern. Außer vielleicht dem TRS80.


    Infos zu den Maschinen: Altes Mainboard (fast ausschließlich 74xxxer Logikchips), Basic mit Nachkommastellen.
    Ich habe nicht vor, die 8 Zoll Floppies in Betrieb zu nehmen, da ich keine Datenträger habe. Die 5 1/4 Zoll will ich jedoch. Die verbauten Laufwerke scheinen SA400 zu sein, nicht SA390, und werden über 25 poligen D-Sub angeschlossen (beide Drives teilen sich einen Anschluss).
    Die 8 Zoll Controller sind monströs.


    Ich habe darüber hinaus eine unbestückte Karte, die ich nach der Bildersuche als Standard Apple 2 Floppycontroller identifizieren kann,
    sowie ein Bild (Google), das mir erlaubt, sie zu bestücken. Nur: Was müssen da für ROMs rein? EPROM-Alternativen? Romdump Download? Außerdem:
    Wie sind die Kontakte der Karte mit denen des Drives verschaltet? Hat da jemand Schaltpläne von? Oder wenn ich ein Foto von meinem Controller
    machen würde, könnte mir da jemand weiterhelfen?

  • @theart: Herzlich Glückwunsch. Dann hat sich die Mühe ja gelohnt.


    senildatasystems: Ja, mach mal Fotos. Es gab mal alternative Diskettencontroller für den Apple II, irgendwas mit "Shugart-kompatibel". Und wenn Du die 8-Zöller zum Laufen bekommst - 8 Zoll Disketten hab' ich noch...

  • Bild 1 ist das Innenleben des Doppelfloppies. Die schwarzen Stecker gehen zum Laufwerk (Motoren/Schrittmotoren/Sensoren), die weißen Stecker gehen zum rückseitigen Anschluss.
    Dass da offene Kabelenden rumbaumeln, liegt daran, dass die 30 Jahre alten Klebebänder nicht mehr halten. (sollen offen sein) (dass die um 1 Pin verschoben sind, soll auch so sein)
    In der Mitte ist noch eine Platine, die die Stromversorgung freigibt (es liegen nur 5V an den Drives an, bis ein Enable Signal kommt, dann gibt diese Platine auch die 12V frei).
    Bild 2 ist eine der beiden 5 1/4 Karten (Vista, gottseidank nicht Windows). Die rechte Seite sieht aus wie einer der etwas selteneren, aber doch normalen FDCs, die Chips stimmen, er hat aber nur einen 2k ROM. Die linke Seite kriegt nur Signale von den Standard-Laufwerksteckern (die auch standard belegt zu sein scheinen) und bastelt sich da irgend was anderes draus, was dann an dieses Floppy gesendet wird.
    @alleSchaltPlanJunkies: Ich habe eine unbestückte Platine dieser Sorte, die könnte ich einscannen, zusammen mit den bestückten Chips könnt ihr diese vielleicht reverseengineeren. Wartet aber lieber noch ab, ich komme morgen vielleicht in Kontakt mit demjenigen, der die Kisten gebaut hat.
    Für exakte Pinbelegungen (ohne zugeordnete Signale, da unbekannt) werde ich die Drives wohl nochmal komplett auseinandernehmen müssen.


    Bild 3 ist ein Scan von der 8 Zoll Controllerplatine. Beide 8 Zoll Laufwerke haben hinten Buchsen, wo das Flachbandkabel direkt reinpasst, sodass hier der Anschluss nicht das Problem wird (eher das Marke Eigenbau Netzteil) (und die Versorgung mit Datenträgern joe IBM: Danke, auf dein Angebot werde ich wohl noch irgendwann zurückkommen).

  • Hi senildatasystems,


    ich könnte dir einen funktionierenden Apple II Controller mit 2 Laufwerken zur Verfügung stellen. Dazu würde ich auch ein Paar Leerdisketten und ein wenig Software legen.
    Diese Controller benötigen oftmals ein speziell gepatches DOS. Leider ist diese Software (vor allem für die 8" Disketten) kaum zu bekommen. Bei dem 5.25" Controller (mit Laufwerken) könntest du jedoch Glück haben.


    -Jonas

  • Update: Der Konstrukteur hat keine Unterlagen mehr, und sämtliche Disketten vor Jahrzehnten entsorgt :( schlampig schlampig. Damit hat der die Drives und die Karten praktisch zur Nutzlosigkeit verdammt.


    Vista A800 3.1 (ich hab V2.4) scheint dieselbe Platine zu sein. Schön, dass Treiber Disk Images dabei sind.
    Die andere sieht n bisschen anders aus, aber ich vermute anhand der Service Manual, dass dieser linke Teil nur die Schrittmotorsteuerung umrechnet. Aber keine Treiber Disk Images dabei!!! Wenn IRGENDJEMAND weiß, wo ich ein passendes Boot-Image bekomme, dann raus damit! Würde es helfen, wenn ich den ROM der Karte auslese und poste?


    Doofe Frage, wofür sind eigentlich diese 4 Jumper gut? So einen Jumperblock finde ich auf fast jeder A][ Karte.
    stynx: Einkaufsliste wäre dann:
    5,25 Controller Karte, wenn möglich mit Einzellaufwerk statt Doppel (weniger Verpackung)
    Passende Master Bootdisk (Kopie, versteht sich), am Besten mit einem ADTpro Client, für Kassettenverbindung (habe weder serielle Karten noch Netzwerkkarten für A][) (ich seh grad auf adtpro, dass ich das auch selber hinbekommen könnte, eine bootfähige Disk mitzuliefern wäre trotzdem schön)
    Optional: Kopie einer CP/M Bootdisk, damit ich meine Z80 Karten testen kann, evtl mit Software drauf
    Mit den 8 Zoll Disketten warte ich noch bis die kleineren gehen.
    Wieviel willst du dafür?


    5,25 Leerdisketten hab ich üppig (naja leer sind die nicht, aber nix drauf worum es schad wäre, nur Kopien alter Spiele)


    Achso fast vergessen: Die 8 Zoll Laufwerke sind DS! Ich hab sogar 1 Satz Ersatzleseköpfe, allerdings nicht luftdicht verpackt und genauso verstaubt wie der Rest.

  • Toast_r nee das sind auch Shugart. Modell 850 um genau zu sein.
    Dir wärs lieber, die einzukassiern, bevor ich ausprobiere, sie einzuschalten, glaubs mir. Diese Marke Eigenbau Netzteile sind älter als ich und ich hab Angst, dass die das Controllerboard mit in Rauch auflösen. Obwohl das Netzteil von den 5,25 funktioniert wunderbar.