CBM8296-D Der Andere

  • welches sind die unteren 64k?


    Wenn ich den Schaltplan so richtig interpretiere, dann wäre UB der erste Bereich.

    Viele Grüße
    Thomas


    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • UA1...8 ist 'Addon RAM'
    UB1...8 ist 'Main RAM'


    Dann lag ich ja richtig. :)

    Viele Grüße
    Thomas


    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • Doof, echt gehofft es klappt. Hatte erstmal nur laut Schaltplan UB bestückt und UA leer gelassen. Mir fehlen Sockel. Hoffnung war es ist doch UA.


    Zumindest rödelt er irgendwie, erstmal werden die ROMs warm.


    Signale liegdn an den RAMs an, eine Leitung scheint zu hängen. Mal Schaltplan konsultieren.


    Boah, 16 ICs ...

  • hallo an alle,

    Das ROM, nächstes Bild hat den VCC Pin angehoben, wahrscheinlich gewollt?

    Die am Char-EPROM angelötete Brücke ist normal.

    Wozu ist die Brücke am Char-EPROM zwischen Pin 21 VPP und Pin 24 VCC gut?
    Mein 8296 hat einen 2532 Char-EPROM ohne diese Brücke und er funktioniert einwandfrei.
    Ich dachte den Pin 21 VPP braucht man nur zum Brennen?

    Im Schaltplan ist Pin 21 VPP über einen 1K Ohm Widerstand an +5V gelegt:

    Laut Datenblatt des 2532 muß Pin 21 (VPP) ausser zum Programmieren immer an +5V liegen.
    Beim Programmieren müssen dort +25V anliegen.
    Witzig daran ist, daß (nicht nur) beim 8296 dieser Pin auf dem Mainboard über einen Pullup-Widerstand auf +5V liegt.
    Trotzdem ist diese Brücke bei vielen Rechnern am Char-EPROM vorhanden.

    normal (ursprünglich) gehören ja keine EPROMs sondern ROMs in diese IC-sockel, bei allen commodore geräten.
    weil commodore viel günstiger die 23xxx masken roms produzieren und von anderen herstellern bekommen kann,
    als die teueren EPROMs die auch noch zeitaufwendig programmiert werden müssen.


    die masken ROMs (23xxx) haben mehrere CS pins, in diesem fall ist der pin20 low aktiv und der pin21 high aktiv.
    aber es gibt auch andere möglichkeiten. z.b. in den commodore floppys oder druckern.


    das charrom bei dem 3032 (4032alt) ist normal ein 2316 mask rom mit 3 cs pins. pin18 und pin20 low aktiv und pin21 high aktiv.
    er hat den pin21 über einen widerstand an +5V. aber der pin21 ist auch der /init pin der zu vielen anderen ics geht
    und für die abschaltung der video ausgabe, durch erweiterungsplatinen, benutzt wird.


    somit könnte der pin21 (auch bei dem 8032) auch low sein
    und damit er bei dem einsatz von einem eprom keine probleme macht wird er direkt an die +5V angeschlossen.


    die restlichen roms ($9xxx-$fxxx) im 3032 (4032alt) sind mit dem pin21 direkt an +5v angeschlossen.
    da muss keine brücke, an den eproms, gemacht werden.


    bei dem 8032 (4032neu, 8096, 8296) gibt es an pin5 der cpu 6502 die funktion /NO ROM.


    diese wird auch für manche erweiterungsplatinen benötigt. damit werden die kompletten roms ($9xxx-$fxxx) abgeschaltet.
    hatt man ein erweiterungplatine, die diese leitung benutzt, dürfen keine eproms ($9xxx-$fxxx) eingesetzt werden!
    da eproms ja kein high aktives cs haben und somit nicht tri-state (ab-) geschaltet werden können.


    dafür hatte ich adapterplatinen mit einem zusätzlichen ic.
    damit die eproms masken rom (23xxx) kompatibel sind. mit bis zu 3 cs pins.


    bei dem 8296 können eproms eingesetzt werden, da der cpu pin5 /NO ROM über die PLA gesteuert wird.

    Quote

    Der ist was für ein Treffen ;)

    ja, nächste retro treffen beim dirk, in brühl, ist am 2. juli.


    gruß
    helmut

  • Hallo Peter,


    bist Du noch was weiter gekommen?

    Viele Grüße
    Thomas


    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • Zwischenbericht:


    Alle RAMs haben jetzt Sockel, nur UB Reihe ist zur Zeit bestückt. Der evtl. defekte MUX 74LS257 ist getauscht. Adressleitungen sehen gut aus, Datenleitungen bleiben auf high da das RAS Signal auch einen weg hat. Die ICs in dem Bereich wo das 7474 sitzt sehen "komisch" aus, am Frequenzteiler sind sogar Beinchen lose in den Lötaugen. Da hat was korridiert, die wurden nicht ausgelötet. Die werde ich jetzt auch noch sockeln und hoffen dass dann das RAS Signal wieder sauber wird.


    Die Monitorplatine sieht optisch OK aus, Sicherung ist ok aber ansonsten passiert auf der Platine nichts.


    Gruss,
    Peter

  • Und weiter im Text:


    Der 74S74 als Teiler für das RAS war defekt, mein 10MHz Oskar kam beim RAS nicht hinterher, auch die Adressleitungen hatten nach einem Reset einen Schatten.


    Da in meinem Fundus nur ein 74HC74 war, musste der also rein. Das IC darüber, UD2 war stark korridiert. Diesen 74LS00 habe ich direkt mit gewechselt.


    Nach dem Tausch aller RAMs, eines MUX davor sowie UD1 und UD2 stabilisierte sich die Spannung bei 4,8 Volt, immerhin 0,2 Volt mehr als zu Anfang.


    Beim einschalten machte der Rechner nun einen leisen Plop, bei Reset selbiges. Da mit die Stromaufnahme immer noch sehr hoch vorkam habe ich nochmal alle ICs abgefühlt und UE6 wurde mit Abstand wärmer als die anderen. Also raus damit und in einen anderen 8296 getestet, Resultat: tot.


    Also UE6 mal quergetauscht und prompt machte der "Der Andere" ein Tödeldö.


    Jetzt muß ich mir einen UE6 Replika basteln, Anleitungen gibt es genug oder hier hat jemand guten Ersatz?


    Das Netzteil ist fast fertig, geht aber immer noch nicht.


    Gruss,
    Peter


    Bilder folgen!

  • Leider habe ich nach wie vor keine JEDEC-Datei für UE6, daher ist's mit 82S100 Programmieren an der Stelle Essig. :(
    Die einfachste der verfügbaren Ersatzlösungen ist die EPROM-Variante, die im 8296 im Gegensatz zum C64 ohne Probleme funktioniert.

  • Leider habe ich nach wie vor keine JEDEC-Datei für UE6, daher ist's mit 82S100 Programmieren an der Stelle Essig. :(
    Die einfachste der verfügbaren Ersatzlösungen ist die EPROM-Variante, die im 8296 im Gegensatz zum C64 ohne Probleme funktioniert.


    Gut, dann mache ich das!


    Der Bildschirm geht jetzt auch, zum Fehler komme ich später. Er zeigt aber nur die Sync-Linien an. Ich fürchte dann dürfte UE5 auch durch sein.


    CRTC und CHAR Eprom quergetauscht ohne Änderung.


    Danke an Alle soweit.


    Gruss,
    Peter

  • Na, dann bin ich gespannt, wie es weitergeht. :)

    Viele Grüße
    Thomas


    - CHECK64 - C64/C128 (D) Diagnose-Set -> Manuals
    - Anfertigung von Kühlkörperklammern - Kein lästiges Kleben mehr

    - EPROMs auslesen und brennen
    - Veranstaltung Kölner-Retrotreff -> zur Homepage: koelner-retrotreff.de

  • Jaaaaaaaa, ich habe eine Einschaltmeldung!


    Da die Taktleitungen am CRTC und am LS166 gut aussahen habe ich alle ICs am Videoteil getauscht, ls74 x 2, ls86 und den ls166.


    Oben hatte ich im jugendlichen Leichtsinn was vom Video-RAM geschrieben, das war Unsinn.


    Gruss,
    Peter

  • Könnte mal wer Detailfotos vom Netzteiläusseren machen? Also Lüfter mit evtl. Bezeichnung und wie das Oberteil aufgebaut ist.


    Beim Netzteil ist fast alles primärseitig getauscht, der BU508 fehlt noch, da hat auch einen Schluss.


    Gruss,
    Peter

  • Beim Netzteil ist fast alles primärseitig getauscht, der BU508 fehlt noch, da hat auch einen Schluss.

    problem ist, wenn man nicht alle defekten bauteile findet und erneuert, kann es sein, das
    nach dem einschalten, wieder alle bauteile sofort zerstört werden.


    ich hatte einen mitarbeiter, der die monitore und die schaltnetzteile, bei uns reparierte.
    er hatte den einschaltstrom begrenzt, durch einen zusätzlichen widerstand, in der primärseite,
    damit die bauteile nicht sofort, in der ersten sekunde, wieder zerstört werden.
    und erst wenn, alle defekten bauteile gefunden und ausgewechselt wurden und die primärspannung nicht mehr zusammenbrach
    wurde der widerstand wieder entfernt.


    manche schaltnetzteile dürfen auch nicht ohne last betrieben werden.


    gruß
    helmut

  • Bisher hatte ich das noch nicht an, nur offentsichtlich defektes und fehlendes getauscht, der 508 isg mir aufgefallen weil immer noch wo ein Schluss war.


    Den ersten Test macht das Netzteil hinter einer 200W Glühlampe...


    Ansonsten kennen mich Schaltnetzteile seit 30 Jahren ;)

  • falls doch noch ein kurzschluss, würden bei 200W fast 1A fließen.


    ich würde eine glühlampe mit einer kleineren wattzahl nehmen.
    da ist der innenwiderstand viel höher und es fließt dadurch ein geringerer strom.
    der die bauteile belastet.


    z.b. bei 40W fließt max. ja nur 0,17A und wenn die glühlampe voll hell leuchtet muss noch irgendwo
    ein kurzschluss sein. netzteil aber nicht am ausgang belasten. höchsten bei denen die ohne last nicht laufen.


    da genügt aber auch nur eine 12V glühlampe mit nur ein paar watt um den ausgang zu belasten.
    nie am ausgang ein board usw. als last benutzen, falls doch noch ein defekt im netzteil, könnte eine überspannung entstehen
    und das board zerstören. z.b. ein altes CD-laufwerk, als last, geht auch.
    aber besser ist immer eine glühlampe zu nehmen, da hat man sofort nach dem einschalten einen groben überblick.


    gruß
    helmut