Commodore CBM 610, SHIFT Taste liefert falsche Taste... und wie (doch) Datasette nutzen..

  • Hallo,..

    da ich für meinen PET8032 keinen passenden Monitor gefunden habe, bin ich im PET-Hobby erst einmal

    auf einen CBM610 umgestiegen.. (auch ein schönes Gerät, mit 128kB)


    Einschaltmeldung kommt normal und ich habe "normal" Texte eingeben.

    Habe auch ein kleines Mini-Basic Programm eingegeben,. kein Problem.


    ABER, ich kann keine SHIFT Taste drücken, es kommt die Taste "2" und somit kann ich keine Sonderzeichen erreichen.


    Auch die "SHIFT-LOCK" liefert immer "22222222222...." wenn man Sie drückt, also kein "Einzelproblem" der Einzel-SHIFT Taste...


    Seltsam, die anderen Tasten klappen ja alle, da kann es ja nicht die Tastatur-Matrix sein ??


    Jemand eine Idee ??


    und ich kann ja nicht viel "einladen",.. gibt es einen Trick (neues EPROM für das Kernal zum Beispiel ??)

    sodass man auch eine normale 1531 Datasette nutzen kann ??


    Danke für Tipps..

    Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • F1, CTRL, TAB und ESC gehen vermutlich auch nicht?


    Dann fehlt dir eine Spalte in der Tastatur-Matrix. Das kann an der Keyboard-Platine, dem Kabel oder an dem I/O-Chip (was da für einer drine ist weiß ich grad nicht aus dem Kopf... 6522,6526?) liegen.


    Gruß, Gerd

  • Am Besten mal die Matrix mit einem Multimeter durchmessen am Stecker. Ich kann mir nicht vorstellen, dass es am char rom liegt. Evtl hat auch ein VIA/PIA Baustein eine Macke ?!


    Gruss Jan

  • bei der Shift-Taste ist es ja nicht, dass Sie "Tod" ist, sondern dass stattdessen immer eine "2" kommt

    man hat ja "dreimal" eine Shift-Taste: Links/recht und Shift-lock,.. alle verhalten sich gleich.


    wenn ich TAB drücke springt der Cursor ca. auf die andere "Seite" bei Spalte "78" ??

    drücke ich F1 kommt "PRINT" als Befehl...


    wie ich CTRL testen kann, weiß ich nicht... es zeit sich keine Reaktion (auch nicht mit anderen Tasten)

    Ansonsten funktioniert der 10ner Block und die anderen Tasten tadellos...


    wie kann ich ESC testen ?? (habe gerade ESC und "wild andere Tasten gedrückt, und der Bildschirm war "invers weiß" ??)


    ich schraube gleich nochmal auf.....


    Danke fürs mitdenken!!


    Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Beide Shift-Tasten sowie die Shift-Lock Taste stellen in der Matrix die gleiche Verbindung her.

    Die Tastatur wird vom 6525 nahe dem Tastaturstecker abgefragt.

    Wenn beide gesockelt sind, einfach mal die beiden 6525 gegeneinader tauschen.

    Liegt's am 6525, wandert der Fehler zum IEEE-Bus oder zum Tape-Port.

    Da sich offenbar alle anderen Tasten normal verhalten, ist das ein ziemlich interessanter Fehler.

  • Hurra, Fehler gefunden...


    die erste Schwarze Ader war kurzgeschlossen...



    Die Alufolie war links nicht umgeklappt, ich weiß nicht ob die Schrauben oben vom Trafohalter nicht auch einfach zu lang sind...

    -

    ich habe den Stecker einfach testweise mit Isolierband isoliert, und das Alu umgeklappt..


    tataaaa.... Alle Tasten funktionieren... :)

    Danke fürs mitdenken...


    PS: Gibt es jetzt einen Trick, wie ich eine Datasette nutzen kann...


    mfG. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Ahrg ... ja, das ist typisch, da ist einfach zu wenig Platz.

    Ich habe daher die Stiftleiste für die Tastatur etwas umgebogen, so daß das ganze etwas schräg sitzt.


    Datassettenunterstützug gibts nur in den ersten Romversionen, die sind aber so fehlerhaft, damit ist der Rechner so gut wie unbrauchbar.

    Du kannst aber mit einem einfachen Adapter und einem geänderten Kernal eine 1541 an den Tape-Port anschließen, siehe Anhang.

  • ahja danke...


    wie ?? das sind nur die zwei Widerstände ?? (in der Schaltung) ... (und das Kernal)

    mehr nicht ?? Wahnsinn... DANKE!!


    wobei ich die IEE488 Adapterplatine (aus der 64er und jetzt F64( auch gut finde...

    oder ist das auch die gleiche Geschwindigkeit ? obwohl am Datasettenport ?


    an welchem Monitor hast du den CBM610 ?


    danke, mfG. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Das läuft so lahm, wie die 1541 ohne Speeder eben läuft. :)

    Eine zur 2031 umgebaute 1541 ist da natürlich deutlich flotter.

    Als Monitor eignen sich eigentlich alle Monochrom-Monitore mit BAS Eingang, z.B. Commodore (Philips) DM602.

    Klappt bei mir aber auch am TFT mit FBAS Eingang sehr gut.

  • Jau.. stimmt auch... CBM610 bringt am "TFT-TV" auch ein gutes Bild.. hatte es mit Composite nicht erkannt...


    So,.. da ich auch etwas "laden" möchte.. als erstes den "Toast_r" Tipp :applaus: (Danke) mit dem Kernal-EPROM umgesetzt..

    Natürlich "stilecht" mit einem Commodore C64 gebrannt... ;)


    Commodore ist ja so nett und hat direkt mit 28polig/24polig EPROM Adapter ausgeliefert... :D

    -

    gebrannt, getan...

    -

    => Eingeschaltet... "natürlich" keine Änderung zu sehen,.. oder gibt es nun ein "Test-Befehl" der vorher nicht da war ??

    -


    bzw... gibt es eine Anleitung für die richtigen (neuen ?) 1541 Load-Befehle ??

    (oder wie sonst auch beim CBM610 ?) => wobei ich auch die CBM610 LOAD Befehle erst einmal (im Vergleich zum C64) kennen lernen muss


    danke, mfG. Micha :sunny:

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Schonwieder ein C64 mit PET-Style Tasten.... :nixwiss::nixwiss::nixwiss:


    Vielleicht kann uns Micha etwas zu seinem C64 erzählen ?! Wieso PET-Style Tasten ?


    Gruss Jan

  • Schonwieder ein C64 mit PET-Style Tasten.... :nixwiss::nixwiss::nixwiss:


    Vielleicht kann uns Micha etwas zu seinem C64 erzählen ?! Wieso PET-Style Tasten ?


    Gruss Jan

    uppss.. ist mein Lieblings C64,. und natürlich ist die Tastatur aus einem VC20 (VIC20)...

    soweit ich weiß , gab es keinen einzigen C64 mit dieser Tastatur ab Werk ( zumindest dieser, denn ich habe auch das eckige "@" Zeichen...



    Du kannst aber mit einem einfachen Adapter und einem geänderten Kernal eine 1541 an den Tape-Port anschließen, siehe Anhang.

    Hallo Mr. Toas_r


    du scheinst ja echt alles vom PET&Co zu kennen ;)


    ich hatte (bei meinem derzeit leider noch defektem) CBM 4016/4032/8032 PET auch eine kleine Platine dabei..

    (die lag lose im Gehäuse)..


    nach der Info zur 1541 Adaption,... ist mir diese wieder eingefallen...


    kann man ausser am "TAPE-Port" noch so eine einfache 1541 Schaltung aufbauen ??


    die Platine sieht eigentlich genau danach aus ??? (beim CBM610 kann ich Sie ja leider nicht vervenden)...


    --


    Version RABE 9.85 ??

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Wir haben im C64 Bereich gerade einen Thread darüber. Deswegen hat das gerade gepasst... :-)

    Ich finde, dass das super aussieht ! Also falls noch jemand eine solche Tastatur einzeln über hat, bitte melden.... :-)


    Sorry für das off topic !



    Gruss Jan


  • Sowas kann man ja eigentlich über all machen, wo man noch genügend freie I/O Ports hat.

    So wie bei Deiner Platine für den Userport. Die finde ich ziemlich interessant.

    Hast Du auch die passende Software dazu?

    Ich würde erwarten, daß die in einem Zusatz-Eprom in dem Rechner vorhanden ist.

  • Hallöchen...


    leider nicht... ich habe den Rechner ja ohne Software bekommen...

    aber innen war ja auch diese "DATE-J" oder BTX (?) Schnittstelle verbaut...

    ich zeige im anderem Thread auch gerne noch mehr Bilder... (werde dann diesen Thread nicht damit mischen...)

    und stattdessen wie von dir vorgeschlagen noch einmal "selbst löten"...

    nur soviel... dieser "weiße Stecker" (Buchse) schein ja mehr beim C64 zu passen, als beim CMD 4032 oder CBM610 ?!


    ÄHm... nur noch die Frage: falls eine 1541 am CBM610 hängt...

    wie bekomme ich Software "aus dem Internet"?? auf die Diskette ??

    kann dieses Diskette dann auch am C64 mit 1541 gelesen / beschrieben werden ??


    danke, mfg. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Das Diskettenformat ist unabhängig von angeschlossenen Rechner, Du kannst die Disketten für den CBM610 also auch am C64 übertragen.

    Zoomfloppy oder X-1541 Kabel geht natürlich auch.

    Wenn Du ein SD2IEC hast, sollte das auch am 610er laufen.

  • ok... danke für die Rückinfo...


    ich habe das 1541U2+,.. damit übertrage ich dann von "SD-Karte" auf 1541 Floppy...


    muss mal schauen, ob ich gleich noch ein paar Widerstände und eine Lochrasterkarte finde...


    mfG. MIcha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Ist ja ein reines Kernal-Mod, das Basic bleibt unverändert.

    Die normalen BASIC 4 Befehle (DLOAD, DSAVE, CATALOG usw.) funktionieren damit.

    Super !! klappt echt prima !! Ich habe ein 1531-Adapter auf DIN-Cassettenadapter gelötet:

    --



    ich kann wirklich die Disketten am C64 oder am CBM610 formatieren,.. beide Gerät können diese "vertragen"..

    wenn ich dann vom C64 Programme auf Diskette Speicher, kann ich Sie auch auf dem CBM610 mit DLAOD"PROGRAMM" einladen

    und CATALOG geht auch...

    -

    wenn ich ein Programm auf dem CBM610 auf Diskette abspeichere (DSAVE"TEST1) dann kann ich es auch wieder

    beim CBM610 einladen und sehe es auch... aber auf dem C64 ist die "Datei leer"... (liegt das an der Basis-Einsprungadresse vom C64??)


    Ich habe jetzt .d64 Disketten über das 1541U2 auf eine leer Diskette mit einer 1541-II geschrieben und kann diese nun

    mit dem CBM610 und 1541 einlesen...


    Bisher habe ich anscheinend mehr PET Programme gefunden... die anscheinend auf dem CBM610 viele nicht laufen..

    aber generell klappt der Rechner ja erst einmal :))


    DANKE!!

    Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Die Basic-Startadresse beim CBM 610 ist $0002, das ist 'etwas' inkompatibel zum C64.

    Der lädt das zwar an die richtige Basic-Startadresse, wenn man load ohne ,1 verwendet, die Pointer auf die jeweils nächste Zeile stimmen dann aber nicht.

    Der CBM 610 passt diese beim Laden direkt an, wenn ich mich recht erinnere, daher sollte der umgekehrte Weg klappen.

    Echte CBM-II Software ist etwas dünner gesäht. Ein erster Anlaufpunkt ist der Server von Bo Zimmermann.

  • ich bin auch ein Freund von alten 300/2400baud Modems... :)

    ich möchte gerne den CBM610 mit einer "analogen Mailbox" sprechen lassen..


    habe jetzt dafür eine "DFÜe" Diskette gemacht....

    ---

    Programm kann ich auf dem CBM610 starten,... nur...


    Warum hat der CBM610 eine "weibliche" DSUB25 Buchse ?? da müsste doch eine männliche Stiftleiste sein ??!!

    soll ich einfach 1:1 mit Adapter lösen ?? oder hat das einen Grund...


    Die ersten Signale sind schon einmal da...




    Danke, mfG. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Die Marotte, einen DB25-M Anschluß für den RS-232 Port zu verbauen stammt vom IBM PC.

    Eigentlich alle gängigen Rechner haben bis dahin DB25-F verwendet.


    Ein Modem einfach 1:1 anschließen.

    Je nach verwendetem Terminalprogramm sind evtl. noch Brücken für Handshake-Leitungen erforderlich.

  • ok,.. danke,.. dann muss ich mal meinen SUB-D25,M/M Adapter suchen...


    ich wollte als erstes das oben genannte CBM Term V2.0 nutzen...


    ich hatte mal gelesen, dass du quasi das gleiche vor "einem" (?) VzekC Treffen 2016/2017 machen wolltest / gemacht hast ?.

    (in Verbindung mit Europ-PC oder s.ä.. war das...)


    Ich habe hier für einen Test eine "eigene" Mailbox auf einem PC-DOS Rechner...


    mfG. MIcha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • ok...
    ich möchte lieber mit den schönen AT Befehlen arbeiten,.. :)

    ich finde alleine den Anwahl Prozess mit ATDT 1234 und dem klingeln,.. so wunderbar...


    und dann die 300baud bei einer schönen FIDO Box :))

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Klar, das wäre schon schöner.

    Blöd ist halt, das die per Modem erreichbaren Boxen inzwischen ganz schön dünn gesät sind.

    Dazu kommt noch der Ärger mit VoIP.

  • deswegen habe ich mir ja eine kleine Mailbox auf eine DOS-Dose aufgesetzt.,.. :)

    klar, da ist nur wenig Inhalt drin...


    aber ist halt witzig, wenn man quasi jedes System mit einander verbinden kann und damit zentral Daten "uploaden" kann..





    eine sehr schöne "analoge" Box ist / war die Blup-BBS... habe ich jetzt noch garnicht ausprobiert, seitdem ich kein ISDN mehr habe...

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Eine zur 2031 umgebaute 1541 ist da natürlich deutlich flotter.

    ich bin "dran" ;-))


    erste Versuche sehen schon recht gut aus .-)))


    Eine 1541 wird mit IEEE488 Adapter Platine zur 2031 :-))