Ich habe (endlich) einen A5000, wer kann mir Tipps geben?

  • Mach unbedingt von allen BackUp's. Gerade die kommerziellen RComp oder Ant Webtool Sachen findest Du nicht mehr im Netz, bzw. waren da nie.


    Mittlerweile sind auch schon eine Reihe der Freenet Sachen weg - und vermutlich hat das auch nie jemand gesammelt. Wobei das wahrscheinlich mal spannend ist, wenn man so ein frühes Netzsystem aufbauen könnte. Etwa als Vergleich zum kommerziellen ANT Suite oder Acorns eigenem. Es gab da auch noch so Sachen wie Freeware Webbrowser ( !Web ? ) und Tools für die Einwahl per Telefon oder für die seriellen Schnittstellen. Wahrscheinlich mittlerweile viele "entsorgt" und weg. Aber eigentlich schon auch spannend.


    Die meisten Hardcore User werden nämlich die FreeNet Sachen benutzt haben, das so langsam losging interessant für den Privatgebrauch zu werden.


    Das ist auch als Programmierprojekt eine ganz spannende Geschichte, und wahrscheinlich nur in so einem "Ökosystem" ( die Nische , sic ) vorstellbar, wie es das RISC OS ist. Evtl. noch beim Amiga. Im Prinzip hat man sich dafür die Sachen von vielen Seiten zusammengesucht und damit dann eine eigene Suite zusammengestöpselt. Aus Tools, die viele Einzelleute in enger Absprache selbst geschrieben hatten. Mit maximalem Aufwand und vermutlich viel "Hassle". In DLand wird das vermutlich kaum jemand probiert haben, einfach weil es die sinnvollen Providerangebote zu dem Zeitpunkt noch gar nicht gab.

  • Was ist denn der beste Weg um Backups der Disketten anzulegen, gibts da ein gutes Tool für RiscOS um Images anzulegen? Oder eine SparkFS Lizenz holen und einfach damit alles in ein Archiv stopfen. Die könnt ich mir dann auf meinen Server schieben (z.B. per FTP)


    Oder kann ich die Images auch am PC machen? Bei ner Sektor-Kopie sollte ja nichts verloren gehen, Probleme gibts ja nur wenn man Dateien einzeln kopiert, oder?


    Bei den RComp Sachen ist auch ein !DialUp 2 mit dabei, vermutlich für Modem-Verbindung. Und bei beiden Ants ist auch die Upgrade Disk 131-132 mit dabei.

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Ja !DialUp klingt schwer nach Einwahl Programm per Telefon. Gibt da aber deutliche schönere Alternativen (einfach wegen der Optik ;) ), v.a. !Socketeer

    siehe da

    http://riscos.berlin/arcsite/m…axis/socketeer/index.html


    Man kann schon sehen, daß das nicht trivial war, das "aufzubauen". Umso schöner war, wenn es dann mal lief.


    Brauchst Du als Tool aber heut' nicht mehr installieren. Es ist aber eben wichtig, auf das Thema zu gucken, weil manche Einstellungen evtl. noch von Telefoneinwahl ausgehen. Deshalb auch der Link zu dem Broadband einstellen eines weiter oben.



    Disketten Images habe ich immer mal sporadisch mit !FCFS von Sergio Monesi gemacht. Das ist (uralte) Shareware, die man aber noch finden kann. Ist aber vermutlich nicht die beste Option, weil das auch Infos noch an den Diskdump anhängt.

    Die vermutlich momentan beste Variante ist der Diskettenarchivierer aus dem JASPP Projekt. Das würde ich vemutlich aktuell benutzen. https://forums.jaspp.org.uk/forum/index.php

    Nur die Bedienung ist irgendwie komplex.


    Ansonsten eignet sich eigentlich jeder DiskEditor, der ein Image schreiben kann.

    Er muß halt einfach alle Sektoren einzeln auslesen können und in eine Datei schreiben.

    Unter Linux nimmt man für sowas "dd" . Sollte auch mit Disketten funktionieren. Probiert habe ich das bisher nur mit Festplatten. Dort funktioniert das aber ganz vorzüglich, zumal man nämlich dann auch in die PlattenImages wieder reinsehen kann, da ADFS unter Linux unterstützt wird. Zumindest die alten Versionen.


    !OmniDisk bzw. !OmniFlop sind Tools die unter Windows sicher auch für sowas gut taugen.

    http://www.shlock.co.uk/Utils/OmniFlop/OmniFlop.htm

    Braucht aber NT oder XP. OmniDisk ist für DOS und W95.


    Alle haben aber gemeinsam, daß sie schon noch lesbare Sektoren brauchen.


    [ Für schwierige Fälle, wo man also einen Sektor 3mal lesen können muß, bis er komplett ist, bleibt in letzter Konsequenz dann nur Kryoflux. Den sollte man kennen, aber besser nicht brauchen müssen (ist eine Hardware/Software Kombi für Archivierung). ]

  • Oder eine SparkFS Lizenz holen und einfach damit alles in ein Archiv stopfen. Die könnt ich mir dann auf meinen Server schieben (z.B. per FTP)


    Das ist prinzipiell eine gute Idee. Einfach weil das nunmal das Standardformat geworden ist.


    Es gibt aber auch jede Menge andere (gute) Packprogramme. Man kann also auch gut ohne das !SparkFS Packprogramm hinkommen. Als Entpacker ist es aber wohl unumgänglich, weshalb es dafür das als Freeware !SparkPlug gibt.


    Alternativen sind z.B. !PackDir oder !InfoZIP oder für neuere Sachen das, was bei ROOL auf dem Server beiliegt.


    Vom Komfort kommt wohl keines an SparkFS heran.

    Und SparkFS kann nicht nur ZIP und Spark sondern auch noch ein paar andere Formate (zoo z.B.).


    Für's Auspacken von Spark Formaten kann man auch sehr schön !ArcFS2 benutzen. Das kann das auch und ist eine SEHR verträgliche Software unter RISC OS 3. Das war oft auf PD Disketten als Entpacker mit drauf. Gibt es auch noch als Seite im Netz

    https://armclub.org.uk/products/arcfs/


    Für das Wiedersetzen verlorener Filetypes gibt es sowas wie !GuessType oder !TypeInfo

    https://www.davidsharp.com/riscos/

    Kein Ahnung, ob das auf OS3 läuft. So ein Tool braucht man aber gelegentlich mal.

  • Ich hatte mal für die Hobby+Elektronik auf dem AUGE-Stand ein Festplatten-Image für einen A310/4MB/ARM3 erstellt mit vollem Internet-Zugriff über Ethernet, ich glaube das war 2007. Keine ANT Internet Suite, sondern normalen Acorn IP-Stack und "diverse Programme" von FTPc und FreeTerm über Browse bis Fresco, ArcWeb und Webster.

    Das Problem heutzutage ist tatsächlich, noch Gegenstellen zu finden, die man nicht selbst betreibt... HTTP und nicht HTTPS, nacktes FTP, echtes Telnet...und vielleicht noch Gopher :)

    Irgendwo muss es eine CD geben mit dem ganzen Zeugs, und der Mirror von Stuttgart FTP müsste auch noch eine gute Quelle sein.

    --

    Zu viel Hardware, zu wenig Zeit. Acorn Archimedes-, RISC OS- und Amstrad/Schneider CPC-Fan.

  • So, kleine Diashow:

    Rommodules:

    Ethernet:

    CDFS:


    Ich werd jetzt erst mal Ant installieren. (und mich demnächst auch mal um meinen Pentium 3 kümmern... wollte da OmniFlop installieren weil der Windows 2000 und noch ein echtes Floppy hat, aber das reagiert irgendwie nicht mehr, vielleicht aber auch nur der Stecker locker)

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • PS: hier noch der HDD Inhalt:



    und noch 3 Bilder zum SCSI Controller die ich über Weihnachten gemacht hatte beim probieren:


    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Zum CD-ROM hatte ich über Weihnachten noch n bissl bei meinem Bruder mit seinen Laufwerken getestet, aber kein einziges zum laufen bekommen. Immer der selbe Fehler vom CDFS. Was aber auffällt: wenn ich in die Diagnose-Software vom SCSI-Controller schau seh ich beim CD-Laufwerk immer ein Volume in der Größe der eingelegten CD. Es scheint also am CDFS zu liegen... gibt es eine Möglichkeit das auszutauschen gegen eine andere Version?

    Was Du siehst ist der generische CDFS-Fehler, der erst mal nach "komische CD, verstehe ich nicht" riecht, aber auch "Medienfehler" sein kann oder "Der Treiber passt nicht zum Laufwerk". Mit dem Plextor CD-ROM kann der Castle-SCSI2-CDROM-Treiber vom Podule auf jeden Fall zusammenarbeiten, da bin ich ganz sicher. Wenn die CD gepresst un nicht gebrannt ist, dazu Single Session, Mode 1 (also nicht aus versehen Mode 2 Form 1...), dann sind die Chancen maximal groß, sie lesen zu können.

    Eine neuere Version von CDFS wird gar nichts helfen, die sind alle gleich schlecht, also zumindest alle, die noch auf dem A5000 funktionieren...

    Ich habe irgendwo noch ein kleines BASIC-Tool, das einen Daten-Track von einer CD mittels SCSI-Kommandos (also ohne CDFS anzufassen) auslesen kann, das wäre ein guter Test wo genau das Problem liegt. Wenn es da auch Probleme gibt - Kabel, Terminierung, Stromversorgung, oder alles drei.


    Das was CDFS bei cddevices reported, ist das, was vom SCSI INQUIRY-Kommando kommt, das ist also "physisches Medium", es bedeutet nicht, dass CDFS irgendwas vom logischen Format auf der CD versteht.

    --

    Zu viel Hardware, zu wenig Zeit. Acorn Archimedes-, RISC OS- und Amstrad/Schneider CPC-Fan.

  • Wenn die CD gepresst un nicht gebrannt ist, dazu Single Session, Mode 1 (also nicht aus versehen Mode 2 Form 1...), dann sind die Chancen maximal groß, sie lesen zu können.

    Die CD mit der ich teste (zumindest aktuell, hab auch schon andere probiert) ist eine gepresste mit Bildern für den Archimedes (hatte die in einer der Softwarepakete mit dabei), die CD kann ich am PC problemlos lesen. Das Laufwerk hat an einem PC auch funktioniert, zumindest zum lesen, brennen lieferte Fehler.



    Aktuell kämpf ich auch n bissl mit Ant... welchen Treiber muss ich da auswählen? Direkt EtherH wie in den Modulen aufgelistet gibts nicht, aber EtherH8 und EtherH16. Ich habs mal mit EtherH16 probiert da an anderer Stelle stand die Karte hätte einen 16 Bit Treiber... ein Versuch im LAN hier ein anderes Gerät anzupingen scheitert aber (die Adressen sollten so stimmen, leider ist die DHCP Option ausgegraut...)


    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Zum CDROM: probier lieber, wenn, dann mit dem Plextor weiter. Mal Termination anschauen, evtl. Kabel wechseln oder mal nicht extern sondern intern mit 50pol Flachband anschließen.

    Rein formal hat das CDFS m.E. 4 Hersteller unterstützt und da auch nur ein paar wenige Laufwerke. SONY und HITACHI waren da dabei. Yamaha ziemlich sicher nicht.

    Wenn hubersn sagt, daß Plextor gehen muß, dann wird das wohl so sein.


    Vielleicht kannst Du auch noch ein Handbuch zum SCSI Controller finden (chriswhy z.B.) oder bei den alten Castle Webseiten auf Archive - wo evtl. was zu finden ist, welche Laufwerke offiziell unterstützt werden. Meist liefert das zumindest mal Hinweise, was überhaupt in Fage kommt.



    Zum Ethernet: EtherH16 hätte ich da auch angeklickt. Es gibt auch einen Ordner, wo die Netzwerktreiber drin sind. Dort liegt ein Helpfile drin. Das solltest Du mal bei Dir suchen/finden und anschauen. Hier im Blindversuch sah das so aus



    Eventuell ist ja beim Router noch was freizugeben ? Manchmal sind da die Numernbereiche beschränkt/beschränkbar. Wenn Du sowas mal eingerichtet hast und die .2.9 nicht zugelassen ist, müßte das ungefähr so aussehen.

  • Ansonsten: Deine Platte ist irgendwie schon mit Sachen bespielt, die nicht einfacher Standard sind. Wenn Du das nicht slebst nachträglich da drauf getan hast ... auf jeden Fall ist da ein "!SparkFS" drauf was aussieht wie eine Vollversion. Und !ADFimager ist genau ein Tool um DiscImages anzulegen. !RTracker ist auch irgendwas abseits der Normalinstallation.


    Mindesten das sind Sachen, die man auf jeden Fall auch sicher verwahren will. Ich hätte ja Interesse an dem !µEdit - das sieht irgendwie spannend aus und ich kenne das gar nicht. Üblicherweise heißt das schlicht !Edit.

  • Was man auch mal noch machen kann, ist Loopback einstellen und sich selber anpingen.

    Ist aber eigentlich albern.


    Vielleicht muß man auch einfach die ANTSuite nochmal ausmachen und wieder neu laden, nachdem man EtherH16 eingestellt hat.

  • auf jeden Fall ist da ein "!SparkFS" drauf was aussieht wie eine Vollversion. Und !ADFimager ist genau ein Tool um DiscImages anzulegen. !RTracker ist auch irgendwas abseits der Normalinstallation.

    Ja, ein paar Sachen hab ich selber schon ausprobiert, Elite ist auch schon auf der Platte mit drauf. Der !uE311 ist ein Micro-Emacs, hab ich irgendwo im Internet gefunden... (und ich kannte den so ähnlich noch vom Amiga) Das !SparkFS sollte aber ne read only Version sein (stand zumindest dabei), jedenfalls hab ich keine Lizenz dazu. Mit dem !ADFImager hab ich probiert Diskettenimages aus dem Internet wieder auf Disks zu schreiben, aber nicht sonderlich erfolgreich, muss mal schauen wie das Tool funktioniert. Der !RTracker ist n Player für MOD-Files um mal den Sound zu testen ;)


    Bei Ant bin ich einen Schritt weiter, ich musste beim Host-Name einen full Qualified angeben, da hatte er bei Start auch immer drüber gemeckert das ich angeblich gar keinen angegeben hätte... jetzt kommt aber "file 'routefix' not found" beim Start... evtl. ist da immer noch was faul. An meiner Fritzbox sollte es nicht liegen, der DHCP Range beginnt ab 100 und drunter hab ich auch schon andere Geräte mit fester Adresse im Netz.


    Den Plextor werd ich morgen mal aus dem PC schrauben (bin mir grad nicht sicher ob das genau der aus den Fotos ist oder ob da ein anderer von meinem Bruder dran war)

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Wenns kein Geheimnis ist, sag doch mal die Webseite an für den !µE311 . Danke.


    !RTracker und MODs : Sehr gut Idee !

    Auch mal nach Symphony Files und dem Player suchen. Sind auch nett.



    Das mit dem vollen Namen macht durchaus Sinn, da das zu großen Teilen eine eMail und News Suite ist. War sicher die Hauptanwendung.


    "file 'routefix' not found" ist unkritisch. Da fehlt entweder das File oder der Pfad ist nicht richtig gesetzt. Normalerweise liegt das in Internet/bin. Man kann auch mit MiddleKlick über dem !Appverzeichnis und dann unter !App -> Find das Verzeichnis durchsuchen. Dabei sind * erlaubt, z.B. route*. Mit View öffnet man dann direkt das Verzeichnis.

  • Geheimnis an sich nicht... ich musst nur selber erst wieder suchen wo ich den her hatte ;)


    Aber hab es gefunden, ich hab hier die 2 CD Images der APDL, da ist er auf der ersten mit drauf. Oder als Direktlink zur entsprechenden Diskette: http://www.apdl.org.uk/apdlpd/library/files/b/b185.zip

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Sehr schön, Danke. Werd ich mal anschauen.


    Im Gegenzug mal hier noch ein Link auf einen schönen Player, der fast alles abspielt - und immer noch gepflegte Software ist !! (+)

    http://www.riscos-digitalcd.net/digitalcd/player/intro.htm


    Ist zumindest am RiscPC sehr schön. Und sollte eigentlich auch mit 3.1 klarkommen. Wobei die aktuellen User wohl eher neues sogenanntes 32Bit Gerät benutzen (wobei das ja immer schon 32Bit war), weshalb man evtl. auch mal eine ältere Version probieren muß, wenns doch nicht geht.


    Für den ProTracker gab es auch ein reines Playermodul, was mit solchen MODs super war. Hatte das gleiche Icon, wie die ProTracker Files.

    Der schnellste Player war wohl lange Zeit was aus dem Demobereich von BASS (glaub ich). Auf dem A5000 ist das aber schon unkritisch, da genug Power da ist für sowas, auch nebenbei.

  • Den ProTracker Player hab ich auch drauf, bedient sich etwas besser als der RTracker. Sind aber beide recht eingeschränkt vom Formatsupport. DigitalCD werd ich mal testen, der sieht sehr gut aus.


    Das mit der Unterscheidung zwischen 26 und 32 Bit hab ich auch schon mitbekommen, hängt ja mit der Anzahl der Adressleitungen zusammen, was je nach dem was die Programmeirer für nen Quatsch getrieben haben auch zu Inkompatibilitäten führen kann...

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Zu EtherH: EtherH16 ist für Deinen Fall korrekt - das "8" bezieht sich auf "8-Bit-Mini-Podule", also die internen Podules für A3000, A3010, A3020 und A4000. Das "16" bezieht sich auf Standard-Podules, die 16bittig die Daten übertragen. Also externes Podule beim A3000 und interne Podules bei A3xx/A4xx/A540/Rxxx/A5000/RiscPC.

    --

    Zu viel Hardware, zu wenig Zeit. Acorn Archimedes-, RISC OS- und Amstrad/Schneider CPC-Fan.

  • Rein formal hat das CDFS m.E. 4 Hersteller unterstützt und da auch nur ein paar wenige Laufwerke. SONY und HITACHI waren da dabei. Yamaha ziemlich sicher nicht.

    Wenn hubersn sagt, daß Plextor gehen muß, dann wird das wohl so sein.

    Die mitgelieferten CDFSSoft-Treiber von EESOX werden in diesem Falle gar nicht aktiv, weil die spezifisch auf Gerätenamen wirken. Der CDFSSoftToshibaEESOX z.B. auf das 3201 und das 3301 - wenn die noch jemand hat, ist er echter Sammler :)

    Es gab mal ein Patch-Programm, um dem CDFSSoftChinonEESOX ein beliebiges anderes Laufwerk unterzujubeln - der Chinon-Treiber hat mit fast allen frühen SCSI2-CD-ROMs funktioniert, das war aber mehr ein Betriebsunfall bzw. -zufall.

    Im vorliegenden Fall wird aber der vom SCSI-Podule mitgelieferte CDFSSoftSCSI2_CT die Kontrolle übernehmen, und der ist sehr breit kompatibel, mit dem Plextor hatte ich den jahrelang im Betrieb (im Wechsel mit Power-Tec und EESOX), und er steckt auch in RISC OS 4.02, da sollte es wirklich keine Probleme geben. Auch nicht mit dem Yamaha-Brenner. Aber der ist recht stromhungrig, ob der vom altersschwachen A5000-Netzteil genügend Saft bekommt, würde ich in Frage stellen. Am besten sind externe SCSI-Geräte mit eigenem Netzteil, aber den Luxus hat nicht jeder vorrätig.

    --

    Zu viel Hardware, zu wenig Zeit. Acorn Archimedes-, RISC OS- und Amstrad/Schneider CPC-Fan.

  • Am besten sind externe SCSI-Geräte mit eigenem Netzteil, aber den Luxus hat nicht jeder vorrätig.

    Ich hab den Yamaha ja in der externen Ausführung als CDRW2100SX, also im original-Gehäuse von Yamaha mit eigenem Netzteil. Auch die anderen Laufwerke hab ich bisher in diesem Gehäuse verwendet. Aber ich kann den Plextor auch mal intern anschließen und schauen ob das was ändert.

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • OK, 2 neue Erkenntnisse:


    Der Plextor am internen Anschluss verhält sich auch nicht anders. Immer noch dieser generische CDFS Fehler.


    Ant scheint sich gestern irgendwie verschluckt zu haben was ein Reboot/Reset wohl nicht geregelt bekommen hat (ich konnt dann auch plötzlich !Ping+ nicht mehr starten, musste mit !Ping hantieren was nicht ganz so aussagekräftig ist). Heut bekomm ich bei Start der Suit nochmal ne Andere Meldung (System Variable 'FileSwitch$Ressources$CSD' not found)), dafür funktionieren lokale Pings (auch wieder mit !Ping+), z.B. auf die Fritzbox. Ins Internet kommt er noch nicht raus, muss noch mal schauen, aber Gateway ist eigentlich gesetzt...

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Das mit dem CD war wohl so zu erwarten, aber besser man probiert das. Komisch ist es aber doch. Du könntet nochmal schauen, ob evtl. irgendwo beim Booten ein zweites CDFS startet, was sich nicht mit der Software aus der Karte verträgt oder diese lahmlegt.

    Oder mal zurückbauen und im externen Gehäuse dann die SCSI ID ändern, z.B. auf "0".


    Zur InetSuite: Normalerweise hat RISC OS keine Selbstheilungsqualitäten. Ein Reset macht Sachen als nicht wieder besser. Es ist halt manchmal so, daß eine Variable o.ä. dann erst richtig (oder falsch) gelesen wird.


    Die Variable da sieht auch bißchen komisch aus. Üblicherweise haben die maximal ein "$" im Namen.


    Hast Du mal probiert eine externe Webseite direkt als Nummerncode anzugeben ? Das bekannteste dafür ist google.com was sich als 8.8.8.8 schreiben läßt.

    Wenn das gehen sollte, hängt es am Resolver Modul oder dem NameServer bzw. dessen Adresse.


    Was für ein RISC OS Boot System hast nun Du eigentlich auf der Platte installiert ? Ein klassisches ohne Internet Stack - oder ein !UniBoot, wo der bereits dabei ist ? Wenn es sowas im !Configure Dialog gibt, dann muß da unbedingt das Internet an dieser Stelle ausgeschaltet sein - sonst laufen beide Stacks parallel. Die ANT Suite bringt aber alles mit und regelt manches anders, als die Acorn Variante, weshalb man gewissermaßen mit der ANT Suite das Acorn Internet in den Systemeinstellungen ausschalten muß.

  • Hm, die Frage ist wie bekomm ich raus was das für ein System ist? In der !Boot ist nur eine Zeile drin die zumindest nichts mit CDFS oder INet zu tun hatte (RMLoad ADFS::IDEDisc4.$.!System.Modules.VProtect). In !Configure gibts nicht zu Internet und das Icon von Net ist ausgegraut und nicht anklickbar.


    Beim Ping auf extern hab ichs mit der 8.8.8.8 und der 1.1.1.1 probiert, der Fehler ist wieder "no route to host". Wobei Namensauflösung an sich geht mit dem Tool, aber als DNS ist ja auch die Fritzbox eingetragen. und intern geht auch der Ping.


    Was auch nicht startet ist der Webbroser (!Fresco), der meldet nur "system:modules.picker not found"


    Oder sollt ich die Platten einfach mal ausbauen, mit nem Linux per DD sichern und mal mit !UniBoot neu aufsetzen? Was besonderes scheint ja nicht wirklich auf den Platten gewesen zu sein. Wie viel Aufwand wäre das?


    SCSI ID 0 hab ich jetzt auch noch mal mit dem Plextor probiert, aber auch keine Änderung.


    Die IDEDisc5 ist ne zweite Platte die leer war. Hab die bisher auch n bissl zur Ablage von Daten zum Ausprobieren genutzt.

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Also wenn im Configure nix zu Internet steht und dem Bild nach, was Du gepostet hattest, ist das ein "normales" "klassisches" System. Eigentlich sollte das sogar besser möglich sein, da eine ANT Suite draufzusetzen. Das "Net" was da ausgegraut ist, ist dann der Einstellungsdialog für das Acorn eigene Netz, was mit dem TCP/IP Ethernet erstmal nichts zu tun hat. Das ist dann auch OK, wenn da nix wählbar ist.


    Das Ausbauen der Platten ist schon eine größere und aufwendigere Aktion. Vor allem, weil man die komplette Backplane und den Metalltragerahmen da herausnehmen muß. Sinn macht so ein BackUp vor allem dann, wenn da auf der Platte noch Software drauf ist. Also richtige große Anwendungen oder viele Tools, die Kauftools waren und, die man heute nicht mehr bekommt. !Sibelius7 oder sowas in der Art.



    "No route to host" heißt ja eigentlich nur, daß er keinen Weg zum gewünschten Server findet. Der kommt also vermutlich auch gar nicht über die Fritzbox hinaus.


    Vielleicht magst Du ja die installierte Suite nochmal löschen und das Ganze mit der v131 nochmal installieren, die ich oben verlinkt hatte. Vielleicht klappt es damit besser.


    Eine Idee hätte ich noch, was aber auch eher so ein Versuch ist: Du schaust mal in der Suite die Verzeichnisse durch und suchst die Datei EtherH16 . Das kannst Du mit der beschriebenen "Find" Funktion im Dateifenster machen und den kompletten ANT Suite Ordner durchsuch. Dann auf View klicken - da sollte ein Ordner so ähnlich wie in meinem Bild oben kommen. Dort klickkst Du doppelt auf EtherH16 und wenn dann der Rechner nicht einfriert, startest Du die Suite ganz normal und probierst das Ping mit der 8.8.8.8 nochmal.



    Zur Fresco Fehelrmeldung: Der vermißt ein Modul namens "Picker". Das kann man genauso wie das EtherH16 suchen. Wenn es gefunden wird, auch das mal doppelt anklicken. Dann sollte es aktiviert sein und wird nicht mehr im Systemordner gesucht - und der Fehler sollte dann weg sein.


    Vielleicht hast Du auch das Picker Modul einfach noch gar nicht installiert. Das liegt in einem Ordner der (zumindest hier) "InstallMe" heißt. Dort drin ist ein !System Verzeichnis. Das kann man mit SHIFT+Doppelklick öffnen und dann solltest Du da einen Ordner 'Modules' sehen, in dem unter 'Toolbox' dann auch Picker liegt.

  • Das Ausbauen der Platten ist schon eine größere und aufwendigere Aktion. Vor allem, weil man die komplette Backplane und den Metalltragerahmen da herausnehmen muß. Sinn macht so ein BackUp vor allem dann, wenn da auf der Platte noch Software drauf ist. Also richtige große Anwendungen oder viele Tools, die Kauftools waren und, die man heute nicht mehr bekommt. !Sibelius7 oder sowas in der Art.

    Ja, das ist etwas gefummel bis man vorne den Rahmen draußen hatte... ich hab ja das Disketten-Laufwerk getauscht, da musste ich auch alles zerlegen, kenn das also schon ;) Aber wenn man die Basisinstallation so wieder hinbekommen sollte ohne das ich ein Backup davon machen muss würd ichs wohl erst mal lassen. Ich hatte halt keine Disketten zu dem Rechner dazu um sowas zu machen, aber außer der Basissoftware scheint ja nichts weiter drauf gewesen zu sein (wurde auch als einfach nur der A5000 verkauft, ohne extra Software, der stammt ja von einem Händler aus UK, keine Privatkiste). Aber wenn man die Software um den wieder aufzusetzen im Netz findet wär ein Backup wohl überflüssig (an dem Punkt war ich mir unsicher ob man das so einfach herbekommt)


    Wichtiger ist da wohl eher ein Backup all meiner Disketten die ich mittlerweile hab (soweit sie sich noch lesen lassen, hatte ja im Startpost schon geschrieben das ein paar leider nicht mehr gehen und z.T. auch üble Schleifgeräusche verursachen...), aber da bin ich grad dabei meinen Win2k Rechner wieder ans laufen zu bekommen für OmniFlop. Laufwerksproblem ist gelöst, da war nur der Stromstecker am Floppy ab. Dafür muckt jetzt die erst vor kurzem eingebaute Grafikkarte rum... grml. Hab zwar ne andere, aber die hat kein DVI... bissl blöd an dem Monitor, da der VGA ja schon vom A5000 belegt ist. Aber taugt erst mal.


    Ich werd mal mit dem Ant nochmal n bissl rumprobieren und notfalls das ganze tatsächlich nochmal neu installieren. Zum "Deinstallieren" muss ich ja nur den Ordner löschen, oder?

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Mach mal unbedingt noch folgendes: Trag mal bei dem Nameserver erst die Adresse von Deiner Maschine ein, dann ein Komma und dann die Adresse vom Router


    also : 192.168.2.9, 192.168.2.1


    unbedingt in der Reihenfolge




    Ansonsten: ja, Deinstallieren ist einfach Anwendung löschen. Zumindest wenn der Installer nix erzählt hat, daß noch irgendwas anderes passieren muß. Aber eigentlich muß das Teil gehen ...

  • Die Systemsachen für 3.1 gibt es bei

    http://riscos.com/ftp_space/310/index.htm


    Im unteren Teil der Seite sind die Original-Install-Disx : App Disc 1 und App Disc 2 , dazu Support


    Das müßte das sein, was bei Dir da drauf ist.

    Es ist halt aber so, daß wenn die die Platte einfach nur von allem anderen befreit haben, dann kann es sein, daß in dem !System Ordner auf Deiner Platte im Hauptverzeichnis noch allerlei Module und Sachen aus der vorherigen Installation drin sein könnten. Die würde man natürlich evtl. gern behalten wollen. Insbesondere auch wenn da das Videoboard (digitizer) schon verbaut war. Manchmal braucht man nämlich doch ältere Module, weil irgendwas klemmt mit neueren oder bei spezieller Hardware, weil man es sonst gar nicht mehr findet. Deshalb würde ich vorschlagen, daß Du erst dann was weglöschst, wenn Du damit warmgeworden bist und genau weißt, was genau es so ist.

    Guck einfach mal in !System.Modules rein und vergleiche das mit den Inhalten aus dem AppDisc1 Analog von oben.


    Die Versionsnummer der Module stehen immer im Modul selbst ziemlich weit oben. Kann man sich gut mit !Zap anschauen. Oder !StrongEd. Der !µEdit kann das evtl. auch - muß halt eine Binärdatei als ASCII anzeigen können.



    Das !Uniboot ist dann quasi die Weiterentwicklung wobei dabei alle Ordner in einem !Boot Ornder zusammengefaßt werden. Dazu kommen neue Funktionen wie z.B. das AcornTCP und ein bißchen eine andere Anordnung.


    Fürs gute Kennenlernen des Systems ist es aber m.E. viel einfacher, sich erstmal das normale, klassische anzutun. Da versteht man einfach, was wo liegt und was man wie startet und auch wie man per Hand Configsachen selber bastelt, wenn nötig.

    Und fürs Anschauen von klassischen Sachen ist es völlig unerheblich, ob nun !UniBoot oder klassische Anordnung von !System, !Boot, !Fonts einzeln im Hauptordner wie bei Dir da.

  • Insbesondere auch wenn da das Videoboard (digitizer) schon verbaut war.

    Nö, die ganzen Karten hab ich mir zusätzlich geholt. Der Rechner an sich war völlig "nackt", da waren nur die 2 HDDs drin und Maus und Tastatur mit dabei (wobei sogar die extra verkauft wurden... stammen aber zumindest vom selben Händler). Deswegen denk ich dass da nur das Basissystem drauf ist.


    Aber ich kann das ja mal vergleichen in wie weit das wirklich dem Standard entspricht.

    - Acorn Archimedes 5000 - 4 MB - 2 IDE HDDs - Castle SCSI II - (Yamaha CRW2100SX) - Dell U2311h -

  • Na dann wird er Dir ein startbares Minmalsystem draufgemacht haben, daß es nicht ganz nackig kommt.


    Guck trotzdem vorher mal in die Ordner !System.Modules und in !System.310.Modules rein.


    Es ist auch - zum Ausprobieren - überhaupt kein Problem mal beide Varianten parallel zu haben. Dazu kopiert man sich die jetzigen Systemfiles also (!System, !Boot, !Fonts, !Printers, !Scrap; !Boot scheint ja evtl. zu fehlen) in einen selbstangelegten Ordner - mit SHIFT+Mausklick dahineinschieben - und legt sich dann die Sachen aus den Installdisks von der Webseite (AppDisc1 und AppDisc2) an deren Stelle in das Hauptverzeichnis. Dann hat man einen definierten Anfang.

    Wenn man will kann man dann auch stattdessen das !Uniboot (auch von dort) benutzen und diese in die oberste Ebene der Startplatte kopieren.

    Es geht aber eben immer nur eines - und man sollte tunlichst unterlassen Files (außer reine Modules) zwischen beiden Boot Varianten herumzukopieren. Das klappt nicht - oder nur bis zu einem gewissen Grad.



    RISC OS macht ja eigentlich beim Booten gar nichts - es bootet ja noch nichtmal wirklich.


    Was es tut ist:

    Es wird - wenn vorhanden eine Applikation namens !Boot gestartet, sofern diese im Hauptverzeichnis vorhanden ist.

    Diese setzt dann in erster Linie einfach ein paar wichtige Suchpfade und/oder startet weitere Anwendungen.

    Es ist also eigentlich mehr eine Art "Autostart", der aber ein paar skripte anschiebt, die "das System" besser lauffähig machen - aber eher im Sinne von "mehr Komfort".


    Weshalb sowas auch ohne Boot gut funktioniert, liegt dann daran, daß vieles davon das !Boot gar nicht selbst macht. Es 'startet' nämlich einfach nur z.B. die Systemapplikationen wie !Fonts oder !System und diese richten sich eigentlich ihre Pfade selbst ein. Und das passiert auch automatisch in dem Augenblick, wo man das Filerfenster der Platte das erste Mal aufmacht und !System und !Fonts "gesehen" werden, weshalb dann auch ohne eine !Boot Anwendung ein Systempfad da ist, wenn denn !System im Hauptverzeichnis liegt - so wie bei Deiner klassischen Variante.



    Sieh Dir mal auf Deiner Platte den Ordner !System an. SHIFT+Doppelklick öffnet den. Da sollte dann eine Datei !Boot und eine Datei !Run drin sein. Beide mal anschauen.

    Da müßte dann sowas in der Art drinstehen wie


    Set System$Dir <Obey$Dir>

    Set System$Path <Obey$Dir>.310, <Obey$Dir>.


    Später hat man das einfache System verlassen und z.B. das !Uniboot richtet die Systempfade mit einem Binary/Util ein, wo man aber nicht mehr sehen kann, was genau geschieht. Bei der "klassischen" Variante kann man das komplett nachvollziehen.


    Wenn dann z.B. eine Applikation wie !Fresco nach einem Modul sucht, was es selbst nicht mitbringt, aber was vorausgesetzt wird, versucht es das mit z.B.


    RMEnsure Picker 3.21 RMLoad System:Modules.Picker


    nachzuladen.

    Das RMEnsure versucht dann Picker zu laden und stellt dabei sicher, daß es nur geladen wird, wenn die Version >= 3.21 ist. Ansonsten gibt es eine Fehlermeldung aus. GEscuth wird Picker dabei im Pfad "System:", der ja oben beim Start schon definiert worden ist. Es wird also den beiden Orndern System:310.Modules und in System:Modules nach dem Modul suchen. In dieser Reihenfolge (!). Wenn das Modul dort überhaupt nicht gefunden werden kann, macht es die Fehlermeldung, die Du schon kennst.


    Ändern kann man das dann dadurch, daß man entweder das Modul per Hand in den System Ordner in das Verzeichnis Modules kopiert, oder es vor jedem Start von Fresco selbst doppelt anklickt, dann wird es ja auch geladen.


    In den !Uniboot Systemen ist das ein wenig ausgefeilter und es werden allerlei zugelassenen Modul Directories durchsucht - und zwar beginnend bei der zur Installierten ROM Version passenden Nummer. Bei Dir also 310.Modules für ein RISC OS 5 absteigend beginnend bei 500.Modules und immer ganz zum Schluß auch noch System:Modules selbst.