Commodore PC-40

  • Liebe Forumsgemeinde,


    nachdem ich vor kurzem hier im Forum (eigentlich wegen Fernschreibproblemen) gelandet bin, muss ich gestehen, dass mich das XT/AT Fieber wieder nach ca. 35 Jahren gepackt hat :)

    Resultat bisher: Bin glücklicher Besitzer eines Commodore PC-40 (80286) mit Hercules Grafikkarte und Hercules Monitor. Der Verkäufer bei Ebay hat angegeben, dass die Kiste zwar angeht, aber nach ca. 5 Minuten Betrieb der PC wieder ausgeht und die Haussicherung rausfliegt...

    Habe mir seit heute morgen das Teil mal genau angeschaut, ein solches zugestaubtes Teil habe ich in meinem Leben noch nie gesehen, Staub wohin man schaute... die Lüftungsschlitze und Löcher des Netzteils absolut dicht :(

    Habe die Kiste nun total zerlegt und gesäubert.. anschliessende Dauertests des Monitors und des Netzteils verliefen ausserst erfolgreich.


    Nun zum Problem, die Kiste hat wohl ein 1.2 MB 5 5.25 Lauferk und eine NEC Festplatte verbaut, nach dem Start möchte er eine MS-DOS Boot-Disk haben, die habe ich aber leider nicht...

    Die Startgeräusche der Festplatte klingen aber "normal", kein klackern, schrammen oder sonstiges...


    Also habe ich meine 3 alten 3 1/2 Laufwerke angeschlossen und versucht, mit DOS 6.22 (auf 3 1/2 Zoll Diskette) zu starten.


    Bei allen 3 Laufwerken das gleiche Problem... Es erscheint die Meldung "MS-DOS 6.22 wird geladen..." danach bleibt der Rechner stehen.. ohne Fehlermeldung.

    Kann es sein, dass die "alten" ATs von ca. 1986 mit dem "neumodischen" DOS 6.22 nicht klar kamen (kann ich mir aber eigentlich nicht vorstellen)


    Würde mich über jeden Tipp freuen, wie ich die Kiste wieder zum Wiederbeleben bringen könnte...


    Vielen Dank


    VG Franz

  • Hallo Franz,

    hast Du die Laufwerke im Bios richtig eingetragen?

    Das Kabel ok und die Stecker in Ordnung und nicht oxidiert?

    Laufwerke sauber (ausgeblasen, Köpfe mit IPA gereinigt?)

    Bootdisk ok (funktioniert an anderem Rechner sauber?)

    Der Rechner sollte mit beiden Laufwerksarten umgehen können. Ich habe noch keinen AT gesehen, der mit 3.5 oder 5.25" HD LW Probleme gemacht hätte.

    Alle PCs, die ich kenne und voll IBM Kompatibel sind, kommen auch mit DOS 6.22 zurecht.

    Was sein kann, ist, daß ein Treiber oder Programm geladen wird, was einen 386er oder spezielle Erweiterungen erfordert, aber nicht robust genug programmiert ist, um die unzureichende HW zu erkenne und daher abstürzt. Im Zweifelsfall mal die autoexec.bat und config.sys löschen oder umbenennen.

    Eine "nackte" 6.22 Bootdisk sollte funktionieren.

    Wenn Du nicht weiterkommst, kann ich Dir eine Bootsdisk schicken.

    Gruß

    Stephan

  • dass mich das XT/AT Fieber wieder nach ca. 35 Jahren gepackt hat

    Aaah ... noch jemand. Willkommen! ;)


    Würde mich über jeden Tipp freuen, wie ich die Kiste wieder zum Wiederbeleben bringen könnte...

    Der Commodore PC-40 ist ein 286er und kam ursprünglich mit MS-DOS 3.2. Ich würde maximal MS-DOS 5.0 verwenden.


    Hier gibt es Service Manuals/Manuals:


    http://www.zimmers.net/anonftp/pub/cbm-pc/schematics/


    http://www.zimmers.net/anonftp/pub/cbm-pc/manuals/

  • Beim booten SHIFT-Taste gedrückt halten. Dann werden die Startdateien CONFIG.SYS und AUTOEXEC.BAT nicht abgearbeitet.

    Wenn's dann klappt wird in den Startdateien irgendwas geladen, was der Rechner nicht mag.


    Überprüfungen:

    -Fährt der Kopf des Laufwerks beim Booten?

    -Mal ein anderes Floppykabel ausprobiert?

    -Verschiedene Bootdisketten ausprobiert?

  • Hi Toshi, vielen Dank für die schnelle Antwort...

    also im Bios habe ich nix eingetragen, habe einfach das 3 1/2 Zoll Laufwerk angeklemmt und gehofft , dass er das erkennt.

    Das Bios Boot Menü zeigt mir beim Booten nicht an, wie ich ins Bios komme... (nur 640 KB RAM ok)

    De DOS 6.22 Boot Disk hier ist eine "nackte" Boot Disk, also eine "jungfräuiche" und funktioniert an anderen Laptops wunderbar...


    Hab das leider alles vergessen, musste man damals bei den XT/ATs auch in Bios und die Laufwerke umstellen ?


    Vielen Dank.

    VLG Franz

  • Du musst im BIOS ein 1,44 MB Diskettenlaufwerk für A: Einstellen. Da kommst du mit Strg-Alt-ESC hin, wenn ich mich nicht irre!

  • Hallo, und danke für die Antwort...

    bin noch nicht so weit in der Materie wieder eingestiegen, aber alles sieht so aus wie vor 35 Jahren :-)

    Nach dem Einschalten kurzer Test des Floppy Laufwerkes, beim Start, dann Versuch auf die Platte zu gehen, danach "... Insert Boot Disk and Enter"

    Die Boot Diskette ist ok, funktioniert an anderen Laptops ohne Probleme...


    Mal schauen.... und vielen Dank, VG Franz

  • Du musst im BIOS ein 1,44 MB Diskettenlaufwerk für A: Einstellen. Da kommst du mit Strg-Alt-ESC hin, wenn ich mich nicht irre!

    Vielen Dank,


    werde ich gleich morgen ausprobieren, bin jetzt zu müde, da ich um 4.45 Uhr aufstehen muss :-(( Danke Dir.


    VLG Franz

  • Hallo Leute,

    wollte mich ganz herzlich für alle Tipps bedanken, das Ergebnis: Die Kiste läuft :):):)


    Entscheidend waren die Hinweise mit dem BIOS und der leeren CMOS Batterie. STRG-ALT-ESC. Damit kommt man in das absolute minimalistische Setup.

    Durch die leere CMOS Batterie stand natürlich alles auf "0". Datum 1986 :), kein Disklaufwerk, keine Platte etc.

    Nach Eingabe LW A = 1.2 MB (interessanterweise wird hier kein 720KB oder 1.44 MB LW angeboten, gabs damals offensichtlich noch nicht) und Festplatten Typ 1 (Auswahl 1 - 23) bootete auch die 20 MB NEC (D5126) anstandslos. DOS Version = 3.21 in deutsch. Ein Bandlaufwerk ist auch eingebaut, das mit einem Backup-Programm auf der FP angesprochen werden kann (Kassetten leider nicht vorhanden). Ach bin ich happy, jetzt kann ich mir mal die Norton Utilities von 1986 angucken und ausprobieren :P. Falls jemand Fragen zur Hardware hat oder Fotos möchte... sehr gerne. Grafikkarte ist eine AGA, die Herc./MDA sowie CGA/EGA kann.

    Festplatten/Diskettencontroller WD, ewig lange Karte.

    Danke nochmals und einen schönen sonnigen Sonntag 8)

    Grüße Franz

  • Bei den alten Bandlaufwerken immer erstmal prüfen,

    ob sich die Gummi-Antriebsrolle nicht inzwischen in zähflüssige Pampe verwandelt hat.

    Das kommt leider sehr häufig vor.

    Wenn man da dann ein Band einlegt, ist das dann auch direkt versaut.

  • Hallo, hier ein paar Bilder von Grafikkarte, Controller, ser/par-Karte, FP und Bandlaufwerk.

    Achtung: Die Bilder entstanden VOR der Intensivreinigung, die Teile sehen also noch dementsprechend aus :(


    Das Antriebsband vom Bandlaufwerk sieht noch recht gut aus... trotzdem, womit könnte ich es "einschmieren", damit es geschmeidig bleibt ?

    Danke ...

  • Die Entwickler von Commodore waren scheinbar arg verliebt in ihre PLAs.

    Sogar auf der einfachen Seriell/Parallel Karte haben die eine verbaut. :grübel:


    Der Antribsriemen ist weit weniger unproblematisch als die Rolle, die die eingelegte Bandkasette antreibt.

    Der Riemen ist gut zugänglich, wenn der sich auflöst kann man die Reste deutlich besser entfernen als die der Rolle,

    die sich im Kassettenschacht des Laufwerks befindet.

  • oder Fotos möchte... sehr gerne. Grafikkarte ist eine AGA, die Herc./MDA sowie CGA/EGA kann.

    Hallo Franz,


    freut mich , dass dein PC-40 wieder läuft.


    Bilder gerne ... insbesondere 1 Foto von der Grafikkarte würde mich sehr interessieren (ooh ... sind ja schon oben vorhanden ... THX!).


    Gruß,


    E.

  • Du kannst übrigens problemlos ein 1,44MB-Diskettenlaufwerk einbauen. Auch wenn es nicht zur Auswahl steht, einfach die logisch folgende Zahl drücken (müsste die 5 gewesen sein). Bin ich bei meinem damals™ durch Zufall drauf gekommen.

  • So isses, das ist eigentlich eine ATI Graphics Solution, der CW16800-Chip ist wie viele damals kompatibel zu Hercules, CGA und der Plantronics ColorPlus, wie zum Beispiel auch der Paradise Chip im PC10-III oder Schneider Euro PC.

  • Du kannst übrigens problemlos ein 1,44MB-Diskettenlaufwerk einbauen. Auch wenn es nicht zur Auswahl steht, einfach die logisch folgende Zahl drücken (müsste die 5 gewesen sein). Bin ich bei meinem damals™ durch Zufall drauf gekommen.

    Danke für die Info, werde ich auf jeden Fall machen, dann kann ich auch alte DOS Programme transferieren, INTERNET -> USB Stick -> USB STICK in LAPTOP von 2000 -> Laptop auf 1.44 MB DISK -> 1.44 MB DISK in 286 :-)