Reparaturversuch Tektronix 4006-1

  • Ich habe den Fehler verschlimmbessert, zeigt jetzt noch weniger als vorher. Ich kam aber auch beim Löten nicht gut an die Kontakte ran. Ich denke ich baue die Platine doch aus und setze den Sockel ordentlich rein. Da der AY (ser.- par. - Dekoder) auch defekt ist, muss ich den erstmal besorgen und auch sockeln. Liegt wegen Zeitmangel erstmal auf Eis.


    Gruß, Jochen

  • Ich habe einen 74LS74 statt dem original verbauten 7474 verwendet, geht das oder kann der vielleicht die Ausgänge nicht treiben?

    Da Pin 6 des 74LS74 nur einen Eingang treiben muss, ist das kein Problem - überraaschender Weise scheint mir der 74LS74 auch schneller als der7474 zu sein, so dass auch von daher keine Probleme zu erwarten sind.


  • Joe_IBM , da uns Toshi auf der CC nebeneinander gesetzt hat, kann ich gerne meinen LA mitbringen und wir machen ein Live-Debugging.

    Wenn du magst.


    Den LA kann ich ggf auch fuer meinen Micro Expander gebrauchen, wenn der mal wieder zickt. :-)

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • wir machen ein Live-Debugging.

    Wenn du magst.

    Ja, gerne! Ich versuche dann, auch alle nötigen Ersatzteile zu besorgen. Und mache Fitness-Training, damit ich den schweren Brocken tragen kann....

    Kannst Du dann auch Deine Entlötstation mitbringen? Dann könnte ich mir die mal ansehen und vielleicht auch mal selbst ausprobieren, wie ich damit klarkomme.


    Gruß, Jochen

  • Und mache Fitness-Training, damit ich den schweren Brocken tragen kann....

    Das IST das Training! :-)



    Kannst Du dann auch Deine Entlötstation mitbringen?

    Ja, mach ich.

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • Nachdem ich mir einen neuen Gebrauchtwagen zugelegt habe, kann ich mich wieder den interessanten Dingen widmen, z. B. das auf der CC frisch reparierte Tektronix Terminal. Wo ich niemals drauf gekommen wäre: der Fehler lag an durchgebrannten Widerständen in den beiden D-A-Wandlern für die X- und Y-Richtung. Und natürlich sitzen die nicht gut zugänglich auf der Platine, sondern sind in einen schwarzen Klotz integriert.

    Dank tatkräftiger Hilfe von funkenzupfer konnten wir das auf der CC reparieren. Im Standalone-Betrieb funktioniert alles, jetzt will ich es über die serielle Schnittstelle ansteuern.

    Die Software hatte ich ja schon geschrieben (und den Fehler der Darstellung zuerst bei der Software vermutet) also passende Kabel zusammen gesteckt und - tada - meine Software macht genau das, was sie soll. Skalierung noch etwas anpassen und auf dem Bildschirm erscheint genau die Grafikdemo, mit der ich auch schon meine Plotter getestet habe. Einfach klasse! Nachdem ich den Bildschirm abfotografiert habe, will ich ein Video davon machen (weil man da so schön die Linien sieht, die gerade gezeichnet werden). Doch was ist das - schon wieder ist die Darstellung verzerrt und sieht nicht mehr so aus wie gewollt. Vermutlich ist der nächste Widerstand des Arrays durchgebrannt.

    Ich überlege jetzt, ob ich nicht das ganze Array rauswerfen und statt dessen die Ersatzschaltung einbauen soll. Die Wahrscheinlichkeit, das noch mehr Widerstände in der nächsten Zeit ihren Geist aufgeben, schätze ich jedenfalls sehr hoch ein.

  • Die Werte für R13 und 'TEST' stehen da leider nicht, hast Du die denn?

    Wenn die Widerstände da nach und nach abrauchen, was kann die Ursache dafür sein?

  • Wenn die Widerstände da nach und nach abrauchen, was kann die Ursache dafür sein?

    Das sind ja keine "normalen" Widerstaende, sondern ist ein Modul.

    Die Widerstandswerte im Schaltplan sind mit 4-5 Stellen angegeben. Ich denke da ist irgendeine Dick/Duennschicht-Technologie verwendet und die Widerstaende werden geaetzt und per Laser o.ae. abgeglichen.

    Und ich denke das Alter spielt jetzt dieser Technologie einen Streich.


    Das Modul ist fuer einen diskreten R-2R DAC entwickelt worden, steht auch so sinngemaess in der Stueckliste.

    Da wird es lustig die richten Widerstande zu finden. In der E192-Reihe passt es langsam.


    R13 und TEST sind im Schaltplan nicht eingezeichnet. Kann man anscheinend weglassen.

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • Ich habe aus Spass mal die Werte fuer den U525 Ersatz aus der Stueckliste gesucht. Die sind genauso krum wie auf dem Modul.

    Und Toleranzen von 1% bis 0,01%.


    Anscheinend hat Tektronix damals auch die eigenen Widerstaende hergestellt. Anders kann ich mir solche Werte nicht erklaeren.

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)

  • Mit den richtigen Widerstaenden koennen wir auch eine logarithmische Skalenteilung einbauen. :-)

    ;------------------------------------
    ;----- ENABLE NMI INTERRUPTS
    (aus: IBM BIOS Source Listing)