Der „Beast-Umbau“ eines IBM XT 5160

  • Erinnert mich irgendwie an ein kürzliches Problem, wo ich einen zweiten Controller ( VL-Bus DC-680CD) in mein 486'iger eingebaut habe.

    Da war die Port address für Secondary bei 170-177. Und die Rom Bios Adresse vom VL Controller (C800:0) durfte nicht im Shadow bereich vom Mainboard CMOS liegen und bei Konflikten ist es wichtig die Karten der Reihe nach neu einzubauen um sie dem Bord neu mit zu teilen.:fp: Zum abwinken.

    Aber das hilft dir wohl auch nicht weiter:)

    ███▓▒░░♫☺Faszination der Heimcomputer☺♫░░▒▓███

  • - Ist die Inboard 386 start-software installiert? - wenn nein, installier sie mal.

    - Ist die Ram-Erweiterung auf dem Inboard gesteckt? - wenn ja, entferne die Erweiterung.

    - Sind die Spannungen des NT ok? - Das Inboard regiert sehr komisch auf Schwankungen bei 5V bei größer 5,2V gab es bei mir sporadisch Abstürze.

    - Ist das Mainboard mit 256k installiert? - Das Inboard läuft besser mit 256k statt mit 640k auf dem MB.

    - Ist der Bustakt des MB 4,7Mhz oder höher? - Das Inboard läuft auch mit 8Mhz aber es kann zu Problemen führen.

    - wird ein TTL Baustein ausser den PAL-chips warm/heiss? - Hinweis auf teil-defekt.

    - Wie ist das Inboard konfiguriert? - Ram/UMB


    -Jonas

  • - nein, das Setup führt bereits dazu, das der Bootsektor zerstört wird

    - nicht gesteckt

    - 5,01V, 12,01V

    - 256K

    - original IBM XT Board

    - kein Baustein wird mehr als handwarm

    - wie gesagt, das Setup führt bereits dazu, dass das der Rechner nicht von der CF bootet


    Welches IDE Universal-Bios verwendest du im XT-IDE mit dem Inboard ?

  • Ich verwende SCSI (TMC850 mit Bios), nachdem ich anfänglich Probleme mit dem XT-IDE hatte (konnte nicht booten und CF wurde nur erkannt, nachdem ich die extern formatiert hatte). Nachdem ich aber Alles mit SCSI am laufen hatte, habe ich auch mal den XT_IDE adapter wieder versucht und es lief alles einwandfrei. Es hat sich herausgestellt, dass der Floppy controller (NONAME mit bios) nicht mit dem XT-IDE zusammen funktionierte. Da ich aber das Turbo-XT Bios verwendet habe (selbst kompiliert) und dort support für Floppy controller und SCSI installiert hatte brauchte ich weder das SCSI-Bios noch das Floppy-Bios.


    https://sourceforge.net/projec…86/files/bios/pcxtbios25/


    -Jonas

  • Ich verwende SCSI (TMC850 mit Bios), nachdem ich anfänglich Probleme mit dem XT-IDE hatte (konnte nicht booten und CF wurde nur erkannt, nachdem ich die extern formatiert hatte). Nachdem ich aber Alles mit SCSI am laufen hatte, habe ich auch mal den XT_IDE adapter wieder versucht und es lief alles einwandfrei. Es hat sich herausgestellt, dass der Floppy controller (NONAME mit bios) nicht mit dem XT-IDE zusammen funktionierte. Da ich aber das Turbo-XT Bios verwendet habe (selbst kompiliert) und dort support für Floppy controller und SCSI installiert hatte brauchte ich weder das SCSI-Bios noch das Floppy-Bios.


    https://sourceforge.net/projec…86/files/bios/pcxtbios25/


    -Jonas

    Ok, ich verwende auch Turbo XT Bios, allerdings ohne Erweiterungen. Wie bekommt man das TMC-850 Bios in das Turbo XT Bios ? Ich besitze ja einen TMC-845, also einen SCSI-Controller ohne Bios. Der bootet halt nicht. Könnte ich das TMC-850 Bios dem Turbo-XT-Bios hinzufügen, würde der Controller booten, ich könnte auf den XT-IDE verzichten und eine SCSI-Platte einbauen. Auf sourceforge gibt ja z.B. das Binary für den TMC-850. Eine Hilfestellung wäre toll.

  • Ich könnte nochmal um 2MB erweitern, finde aber nichts über diese Karte: Fujitech Jumbo Memory Expansion. Die dip-Einstellungen wären interessant.



    Ich habe beim googeln eine ähnliche Karte unter "memo-2000k ram bank" gefunden. Aber auch zu der sind keine Info's zu finden. Vielleicht hat ja von euch einer so ein Ding ?

  • Danke für Links. Nachdem es wahrscheinlich ein Clone des Intel Above Board Plus 8 ist, werde ich schon irgendeine Einstellung finden, die passt. Hoffentlich verträgt sich das Memory Board mit dem Inboard 386.

  • Danke für Links. Nachdem es wahrscheinlich ein Clone des Intel Above Board Plus 8 ist, werde ich schon irgendeine Einstellung finden, die passt. Hoffentlich verträgt sich das Memory Board mit dem Inboard 386.

    Notfalls kann ich dir die Zahlenwerte von 2 x Above Boards geben, die in meinem IBM 5162 werkeln. Hast PN ...

  • Danke für all die Antworten.


    Mein Resume bzgl. des Inboard 386/PC:


    Die CPU Leistung wird auch unter DOS merklich erhöht, meines Erachtens der einzige positive Effekt. Der zusätzliche XMS-Speicher ist ziemlich nutzlos. Speichermanager wie QEMM386 oder HIMEM.SYS/EMM386 jedenfalls können mit dem durch das Inboard zur Verfügung gestellten Speicher oberhalb 1MB nichts anfangen. Ohne Speichermanager kann DOS und auch sonst nichts hochgeladen werden. Durch meine SCSI Treiber verringert sich der konventionelle Speicher unter DOS in meinem Fall auf 471K. DOS/32A- oder DPMI-Programme können so ebenfalls den zusätzlichen Speicher nicht nutzen.


    Nur um ein speziell gepatchtes Windows 3.0 zu betreiben ist mir das zu wenig. Ich wollte das Inboard 386/PC hauptsächlich für aufwändige DOS Programme wie Norton Desktop für DOS, PC Tools Desktop, DOS Navigator und sonstiges nutzen. Dabei sollte der konventionelle Speicher mindestens 620K betragen und viel XMS Speicher zur Verfügung stehen. Das ist alles nicht der Fall, daher werde ich das Inboard 386/PC wieder ausbauen und säuberlich verpackt als "Kuriosum" in meine Sammlung legen.


    Mit weiteren Experimenten (z.B. Speicherkarten, für RAM-Disk und Laufwerks-Cache) sowie mit NEC V20/V30 oder Intel 8086 werde ich jetzt weitermachen. Mit einem "Beast" wirds so wohl nichts mehr werden. Aber immerhin habe ich jetzt bereits Turbo-XT-Bios, eine 4GB SCSI Platte, HD-FDD's, eine RTC, ein generalüberholtes 150W NT und ein SCSI-Zip-Laufwerk am Laufen.



  • Ist das eine IBM DCAS ?


    Tipp:


    das 50pol SCSI Flachkabel habe ich vorsichtig nach jedem 5ten Steg getrennt und so braucht es weniger Platz (sozusagen ein pre - Rundkabel)


    Nicht schön aber wirkungsvoll.



  • Ich habe bei meinem Inboard >600k frei. Der Speichermanager, den ich nutze kann die 64k High erkennen. Zusätzlich nutze ich eine UMB-Karte, die mir nochmal 128K einbindet.


    Ich muss mal meine autoexec.bat und config.sys posten ... wenn ich die Zeit finde ;-)


    Windows 3.1 funktioniert auch, wenn man einige Dateien von der Win 3 Inboard version kopiert. Zudem unterstützt DOS4GW das Inboard direkt automatisch. Alle Spiele, die das verwenden erkennen den XMS vom Inboard.


    -Jonas

  • Die Konfiguration wäre nett, auch welche Dateien man von der speziellen Windows 3.0 Version in Windows 3.1x kopieren muss. Vor allem interessiert mich, welchen Speichermananger du verwendest. Und was ist eine "UMB-Karte" ? Du siehst, ich bin immerhin flexibel, dann baue ich sie halt wieder ein :nixwiss::anbet:<3

  • Schau mal hier zu Win 3.1:

    http://www.vcfed.org/forum/sho…-5150-with-Inboard-386-pc


    Im vcfed gibt es eine Menge zum Inboard zu lesen.

    Die User nc_mike und Cimonvg haben beide Ihr Inboard auf 486 bzw 586 aufgerüstet (wie ich auch). Jedoch besitze ich nur die 2Mb Ram-Karte.


    Falls du auch einen 386->486 adapter haben willst, kann ich dir einen überlassen (ich habe noch 5 Stück oder so)


    Ich werde auch versuchen heute die config.sys und autoexec.bat bereit zu stellen. (eventuell mache ich auch ein Image der CF-Karte)


    -Jonas

  • Ok, hier ist meine DOS-Bastel Partition (als Dateien).

    Mit der Konfiguration bekomme ich 614k unter DOS 6.22

    Ob dort auch Windows funktioniert, weiss ich nicht mehr.


    Config.sys:

    Autoexec.bat:

    Code
    1. @ECHO OFF
    2. SET BLASTER=A220 I5 D1 T3
    3. PROMPT $p$g
    4. PATH C:\WFW31;C:\DOS
    5. KEYB GR,,C:\DOS\KEYBOARD.SYS
    6. MODE CON CODEPAGE PREPARE=((850) C:\DOS\EGA.CPI)
    7. MODE CON CODEPAGE SELECT=850
    8. LH MSCDEX /D:MSCD000 /L:D
    9. LH MMOUSE.COM
    10. SET TEMP=C:\DOS
  • Jedoch besitze ich nur die 2Mb Ram-Karte.

    Als Zusatzplatine gabs auch nur maximal 2MB. Weiteren Speicher konnte man nur über Zusatzkarten wie z.B. das Above Board/PC realisieren.


    Falls du auch einen 386->486 adapter haben willst, kann ich dir einen überlassen (ich habe noch 5 Stück oder so)

    Ich hätte einen Intel Overdrive DX20DPR66 und einen Cyrix DX266. Beide müssten eigentlich passen.

  • Für das Inboard gab es auch eine 4Mb Erweiterungskarte. Bilder davon hatte mir der Nutzer Cimonvg bereit gestellt. Ich hatte ein wenig experimentiert und dabei heraus gefunden, dass das Inboard insgesamt 4 Bänke besitzt. Eine Bank mit 1Mb habe ich auf einer Experimentier-Karte zum Laufen bekommen. Leider gab es Probleme mit dem Parity-bit und ich bin nicht wirklich weiter gekommen. Die 2Mb-Karte nutzt 2 Bänke mit jeweils 1Mb. Die 4Mb-Karte nutzt nur eine Bamk mit 4Mb. auf dem Inbaord ist eine Bank mit 1Mb direkt integriert. Der vom Inboard belegte Speicherbereich ist 16Mb und ermöglicht über den Ramerweiterungs Anschluss maximal 12Mb zusätzlich, wenn alle 3 zusätzlichen Bänke mit jeweils 4Mb belegt sind.


    Intel hat aber nur eine 2Mb und eine 4Mb Version angeboten, obwohl es auch eine Ankündigung für eine 8Mb Erweiterung gegeben haben soll.


    Zum 386->486 Adapter: Der Adapter verhindert unter Umständen die Nutzung der Ramkarte. Ich habe der Ramkarte mit pinleisten ein wenig mehr abstand verschafft. Ganz toll ist das Zwar nicht, aber es funktioniert :-)

    Jedoch besitze ich nur die 2Mb Ram-Karte.

    Als Zusatzplatine gabs auch nur maximal 2MB. Weiteren Speicher konnte man nur über Zusatzkarten wie z.B. das Above Board/PC realisieren.


    Falls du auch einen 386->486 adapter haben willst, kann ich dir einen überlassen (ich habe noch 5 Stück oder so)

    Ich hätte einen Intel Overdrive DX20DPR66 und einen Cyrix DX266. Beide müssten eigentlich passen.

  • Ich bringe eine 2MB Karte nicht ans Laufen. Zu diesem Board ("Fujitech Jumbo Expansion Memory") mit 2MB (8 Bänke mit je 9 x 41256 von NEC) habe ich keine Beschreibung finden können, vermute aber, das es ein Clone des "Intel Above Board/PC" ist.


    Folgendes ist passiert: ich hab mit verschiedenen Speicheradressen rumexperimentiert. Die Above-Board-Software "setboard" hat mit der Einstellung 248H das Board plötzlich gefunden. EMS.SYS erkannte das Board dann auch, stellte aber einen Speicherfehler fest (nur 1796K). Bei der Kontrolle des Boards stach mir dann folgendes ins Auge, siehe Pfeil:



    Gut, den Speicherchip raus und erst mal in einem anderen XT getestet. Der 41256 ist immer noch OK. Richtig positioniert wieder eingebaut, aber das Memory Board wird seitdem nicht mehr erkannt. Auch mit einem neuen 41256 nicht. Fällt da jemanden was dazu ein ?

  • Fällt da jemanden was dazu ein ?

    Es gibt 2 unterschiedliche setboard.exe und die setupab.exe ... dazu noch die testabpc.exe sowie testab.exe's ... schaue doch noch mal richtig ... ;-) ... und ausprobieren ... bei mir was das auch sehr tricky ... habe gut 3 Stunden gebraucht, bis alles richtig erkannt wurde und lief. Karte raus ... durchstarten ... und wieder neu rein ... kann auch nicht schaden.

  • Fällt da jemanden was dazu ein ?

    Es gibt 2 unterschiedliche setboard.exe und die setupab.exe ... dazu noch die testabpc.exe sowie testab.exe's ... schaue doch noch mal richtig ... ;-) ... und ausprobieren ... bei mir was das auch sehr tricky ... habe gut 3 Stunden gebraucht, bis alles richtig erkannt wurde und lief. Karte raus ... durchstarten ... und wieder neu rein ... kann auch nicht schaden.

    Das hab ich doch alles ausprobiert. Ich habe einfach das Problem, dass ich mich auf meine Dip-Schalter-Stellungen nicht verlassen kann, weil ich nicht weiss, ob es wirklich ein 100%iger Clone eines Above-Boards ist. "testabpc" z.B. zeigt eine andere DIP-Schalterstellung an. Ich weiss nicht, ob das Board wirklich ein Clone des Above-Board/PC ist, oder des Above-Board Plus oder des Above Board 8 oder doch ganz was anderes.

  • Ich weiss nicht, ob das Board wirklich ein Clone des Above-Board/PC ist, oder des Above-Board Plus oder des Above Board 8 oder doch ganz was anderes.

    ... verstehe ... steht eine Jahreszahl drauf ... oder auf den ICs ... kannst du es zeitlich irgendwie einordnen?


    Bitte schaue doch noch mal in #11 von


    Speichererweiterung für XT


    Da sind ein paar gute Manuals dabei, die dir weiterhelfen können, was die DIP-Switches betrifft ... schon geschaut?

  • Da sind ein paar gute Manuals dabei, die dir weiterhelfen können, was die DIP-Switches betrifft ... schon geschaut?

    Nein, demnach wäre es eine "Memo 2000 XT", denn mein Board ist fast baugleich. Also müssten die Treiber des "Above Board 8" funktionieren. Der DIP Schalter ist natürlich ganz anders belegt, muss ich ausprobieren.

  • Nein, demnach wäre es eine "Memo 2000 XT", denn mein Board ist fast baugleich. Also müssten die Treiber des "Above Board 8" funktionieren. Der DIP Schalter ist natürlich ganz anders belegt, muss ich ausprobieren.

    Hier mal eine Memo2000XT aus einem laufenden System ... rekomstruiere mal die DIP-Switch-Stellung auf dem Bild.

    Hab's so eingestellt, und auch viele andere Stellungen ausprobiert, ausgehend von der "MEMO-2000X".. Krieg's nicht hin, die Karte ist wohl defekt. "testab" erkennt die Karte zwar und prüft sie auch, meldet aber 100% defekte RAM's. "setboard" erkennt zumindest kein Above-Board und bricht mit dieser Meldung ab.