W95 Konfiguration / Konflikte

  • Interessant, direkt der erste Eintrag dort stimmt nicht.

    Da steht, daß für Windows 95 mindestens ein 80386 DX Prozessor erforderlich ist.

    Allerdings läuft das auch auf einem 80386 SX.

    Damit kann man dann zwar keine Geschwindigkeitsrekorder aufstellen (höchstens Negativrekorde), aber es läuft.

    Und sicher wird es auf einem 80386 SX mit 16MB RAM besser laufen, als auf einem 80386 DX mit 4 MB RAM (was als mindest RAM-Ausstattung angegeben ist).


    Windows 95 mit 4MB RAM: Wenn erstmal der Tastaturtreiber aus dem Hauptspeicher rausgeswappt ist, läuft der Maustreiber dann auch ohne ohne zu ruckeln. :fp:

  • Toshi : Vermutlich verwenden sowohl der SCSI-Controller als auch der IDE-Controller auf der Soundkarte IRQ 10.

    So einfach mal ins blaue geraten.

    Ach, die Freuden von Plug'n'Play...

  • Toshi : Vermutlich verwenden sowohl der SCSI-Controller als auch der IDE-Controller auf der Soundkarte IRQ 10.

    So einfach mal ins blaue geraten.

    Ach, die Freuden von Plug'n'Play...

    So, ich habe jetzt alle Karten ausgebaut, außer PCI Graka (IRQ11) und SCSI Adapter (IRQ10). Treiber neu installiert. Noch keinen Erfolg. Karte ist unter DOS unauffällig.


    EDIT: SCSI Karte in anderen Slot gesteckt, keine Änderung. IDE Controller ist auf IRQ14.

  • Was heißt kein Erfolg ? Wie zeigt sich der Nichterfolg?


    Bitte Bild von den 'schlechten' Karten und Gerätemanager.

    Im Gerätemanager kannst du die Ressourcen manuell konfigurieren was manchmal notwendig ist.


    Auch mal lesen:

    http://www-pc.uni-regensburg.d…WIN95/TECHDOC/drivers.htm

  • IRQ 14 ist Standard für IDE. Früher mochte ich die ATI-Grakas am liebsten, weil die keinen IRQ für sich krallen.

    Ist bei Grakas auch nicht notwendig.

    Ich nehme mal an, dass das PCI-Device mit dem Fragezeichen der SCSI-Kontroller ist.

    Sind denn die Treiber dafür drauf? Bei Win95 kam es oft auch auf die richtige Art der Treiberinstallation an.

    Bei manchen waren die von Windows erkannten am besten, bei anderen Karten durften auf keinen Fall die

    von Windows, sondern die von der Treiber Diskette verwendet werden. Auch da gibt es wieder zwei Möglichkeiten:

    Über Windows-Treiberinstallation oder über das eigene Setup des Treibers. Leider gab es keinen

    "Königsweg", der immer zum Ziel führt.

    (Bin ich froh, dass ich inzwischen beruflich nur noch Windows-User bin 8))

  • Im BIOS mal die Einstellungen überprüfen:

    Plug'n'Play Operating System auf ENABLED/YES stellen


    Auch den IRQ für die Grafikkarte kann man normalerweise im BIOS deaktivieren:

    Assign IRQ for VGA auf DISABLED/NO stellen

  • fritzeflink , kpanic : Ich habe mal die BIOS Settings, Startbildschirm und Windows-Device-Anzeige photographiert. Vielleicht findet ihr ja den Fehler. Ich bin gerade ziemlich ratlos, da ich ja schon alles halbwegs sinnvolle durch Versuch ohne Änderung des Status ausprobiert habe. Vielleicht noch Windows neu installieren?

  • Sieht eigentlich alles ganz gut aus.

    Mach mal folgendes:

    Entferne in Windows den Controller aus der Geräteliste.

    Dann startest du den Rechner neu, gehst ins BIOS, setzt "Reset NVRAM" auf "Yes", speicherst.

    Dann sollte das BIOS den PlugNPlay-Scheiss zurücksetzen, und Windows nach dem Start den Controller wieder finden.

  • Entferne in Windows den Controller aus der Geräteliste.

    Dann startest du den Rechner neu, gehst ins BIOS, setzt "Reset NVRAM" auf "Yes", speicherst.

    Dann sollte das BIOS den PlugNPlay-Scheiss zurücksetzen, und Windows nach dem Start den Controller wieder finden.

    Hab ich gemacht. BIOS meldet Reset des NVRAMs, Windows findet den Controller wieder und behauptet, die Treiber zu installieren. Aber die Fehlermeldung bleibt die gleiche....


    Das Thema "Windows" beginnt mit zu ärgern. Aber ich will meine SCSI ZIP LW mal ordentlich testen.


    Nochmal neu installieren? Neuen Controller beschaffen? Aber eigentlich sind die Adaptecs doch Standardware und müßten laufen?

  • Alles wird gut .... wenn Du beim nächsten Versuch Windows NT installierst. :mrgreen:

    Ich habe es neu installiert. Jetzt geht zusätzlich zum SCSI Problem der Druckerport nicht mehr (ja, er wurde im BIOS vorher wieder eingeschaltet).


    Welche NT Version meinst Du soll ich installieren?


    Ich glaube mir fault eher die Hand ab als das ich diesen Müll von Betriebssystem nochmal anfasse.

  • Meine Empfehlung wäre Windows NT 4.0 Workstation.

    Windows 2000 würde ich mit 32 MB RAM nicht empfehlen.

    Du mußt aber mit ein paar Einschränkungen leben:

    - Garkeine USB Unterstützung

    - Dateisysteme FAT und NTFS. FAT32 / VFAT ist nicht.

    Wenn Du damit klarkommst, sollte alles laufen.

    Treiber für nicht völlig exotische Hardware sind normalerweise alle aufzutreiben.

    Die SB16 / SB32AWE Installation ist etwas tricky, dabei auf jeden Fall vorher das Readme lesen.


    Wichtige Hinweise:

    Die Service Packs der Reihe nach installieren.

    Zwar sind die eigentlich kumulativ, eines darf man aber nicht überspringen, sonst zerballert man sich das System.

    Welches es war, weiß ich leider nicht mehr. :(

    Nach jeder Treiberinstallation und Änderungen der Netzwerkkonfiguration, bei der Treiberdateien kopiert werden, das letzte Service Pack erneut drüberlaufen lassen, da die Treiber von der Intallations-CD kopiert werden.

    Wenn Du eine Installations-CD mit integriertem Service Pack auftreiben kannst, ist das also eine deutliche Vereinfachung.

    Die Original-CDs waren meist mit SP1 integriert, es gab aber auch mal findige Leute, die spätere integriert haben.


    Ach ja... Lass mich wissen, ob Du der Dialogbox mit den drei Buttons 'Ja', 'Nein' und 'Vielleicht' begegnest. :mrgreen:

  • Da gibts eine BIOS-Einstellung "PCI IRQ Priority Auto Setting", die steht bei dir auf "No". Stelle die mal auf Yes. Darunter sind 4 IRQs, die du einstellen kannst. Entweder das geht dann nicht mehr, was eher gut ist (lass das BIOS das entscheiden), oder wenn doch, dann stelle die alle auf IRQ 11. Das hört sich brutal an, aber PCI kann zwischen PCI-Karten Interrupt-Sharing, das konnte schon EISA zwischen EISA-Karten, außen vor bleiben dabei aber ISA-Karten. Dann darf auch ruhig die Grafikkarte zusammen mit dem SCSI-Controller auf IRQ 11 liegen, und noch zwei weitere Karten, das sollte normalerweise kein Problem sein. Es gab allerdings ab und zu Treiberprobleme mit damaligen PCI-Karten, die Treiber glaubten damals teils, entgegen den PCI-Specs dass ein IRQ ihnen alleine gehört. Wenn sowas passierte, und das resultierte immer in (!) im Gerätemanager, dann wurde das damals meistens durch Treiber-Updates gelöst.


    IRQ 5 auf PCI zu legen, ist eher Unsinn, wenn eine Soundblaster ISA Karte im System steckt, siehe zu, dass die SB auf IRQ 5 kommt, das ist für die Spiele-Kompatiblität besser.

  • IRQ 5 auf PCI zu legen, ist eher Unsinn, wenn eine Soundblaster ISA Karte im System steckt, siehe zu, dass die SB auf IRQ 5 kommt, das ist für die Spiele-Kompatiblität besser.


    Oh ja, der ISA SB muß IRQ 5 fest zugeordnet werden. Dafür gibt es bestimmt einen Eintrag in BIOS ähnlich:


    IRQ X/DMA X Used By ISA: Festlegen des IRQ/DMA einer ISA-Karte



    Gleiches wäre mit einem ISA AHA1542CF IRQ11 muß da auch fest dem ISA zugeordnet werden

  • Wie hängen PCI- und ISA-IRQs miteinander zusammen?

    Eine Logikschaltung ordnet die vier PCI-Interruptleitungen den 15 IRQ-Eingängen des PIC zu. Man muss nun darauf achten, dass keiner der PCI-Interrupts einer IRQ-Leitung zugeordnet wird, die eine ISA-Karte bereits benutzt. Deshalb muss man diese von ISA-Karten benötigten IRQs per BIOS-Setup für die Verwendung durch PCI-Geräte sperren.

    Bei besseren Mainboards kann man per BIOS-Setup noch weiter in die Zuordnung der PCI-Interrupts eingreifen und etwa festlegen, welcher PCI-Slot welche IRQ-Nummer bekommen soll. Das funktioniert natürlich nur im Rahmen der elektrischen Gegebenheiten, also: Wenn zwei PCI-Slots elektrisch an dieselbe Interruptleitung angeschlossen sind, kann man das nicht per BIOS-Setup ändern. In diesem Fall muss man die Karten in den PCI-Slots vertauschen.


    ####################################

    Ich war der Meinung die SB ist eine PCI Karte. :-(

  • IRQ 5 auf PCI zu legen, ist eher Unsinn, wenn eine Soundblaster ISA Karte im System steckt, siehe zu, dass die SB auf IRQ 5 kommt, das ist für die Spiele-Kompatiblität besser.


    Oh ja, der ISA SB muß IRQ 5 fest zugeordnet werden. Dafür gibt es bestimmt einen Eintrag in BIOS ähnlich:


    IRQ X/DMA X Used By ISA: Festlegen des IRQ/DMA einer ISA-Karte


    Das ist schon in Ordnung so. Die meisten neueren SoundBlaster 16 unterstützen ISA Plug&Play, die krallt sich dann ihren IRQ5 schon selbst.

    Den IRQ explizit auf "Legacy/ISA" setzen muss man nur bei alten Karten, die ihren IRQ5 per Jumper konfiguriert bekommen.

  • Der letzte Satz von @fritzeflink ist falsch. Jeder PCI-Slot hat 4 INT-Leitungen, INT-A bis INT-D. Und jede PCI-Karte sollte jede dieser INT-Leitungen nutzen können. Man kann jede dieser INT-Leitungen einem IRQ zuordnen, der kann dann aber nicht mehr für ISA-Karten verwendet werden. Am schlauesten ist es, alle vier INT-Leitungen auf den selben IRQ zu legen, z.B. auf IRQ 11, dann landen alle PCI-Karten eben dort, egal welche INT-Leitung sie nutzen. Nochmal zurück zu den 4 Int-Leitungen: Üblicherweise werden die durchrotiert, das heiß an den 4 INT-Pins des PCI-Slots sind die in ihrer Reihenfolge vertauscht, z.B:

    PCI-Slot 1: INT A, B, C, D

    PCI-Slot 2: INT B, C, D, A

    PCI-Slot 3: INT C, D, A, B

    PCI-Slot 4:, INT D, A, B, C
    Wenn ein Board mehr als 4 PCI-Slots hat, dann gehts bei Slot 5 meistens wieder mit INT A, B, C, D usw. los. Oder ganz durcheinander, dieses INT-Routing war dem Mainboardhersteller frei überlassen. Onboard-PCI-Komponenten liegen auf den 4 INT-Leitungen auch noch drauf. Ausnahmen sind meistens Onboard PCI-IDE-Controller, die über eigen INT-Leitungen auf IRQ 14 (erster Controller) und 15 (zweiter Controller) gelegt werden. Ich kann mich übrigens noch an frühe PCI-Karten erinnern, bei denen man per Jumper manuell die INT-Leitung auswählen musste.

  • Die JEH.PDF hatte ich schon weiter oben verlinkt.

    Aber nicht in diesem Thread, ansonsten darf jeder die gleichen Links posten die ich auch schon irgendwo / irgendwann vorher mal gepostet habe.

    Und wenn auf einen Fehler hingewiesen wird "Der letzte Satz von @fritzeflink ist falsch." dann bitte diesen Fehler richtig zitieren.


    Und jetzt gehe ich lieber angeln.

  • Entferne in Windows den Controller aus der Geräteliste.

    Dann startest du den Rechner neu, gehst ins BIOS, setzt "Reset NVRAM" auf "Yes", speicherst.

    Dann sollte das BIOS den PlugNPlay-Scheiss zurücksetzen, und Windows nach dem Start den Controller wieder finden.

    Hab das jetzt nach der Neuinstallation noch ein weiteres Mal gemacht. Jetzt läuft es. Warum auch immer.