Acorn Archimedes 310

  • Hallo allerseits


    Bin neu hier und wurde aufmerksam durch zwei erworbene SGI Rechner.


    Nun habe ich noch ein Acorn Archimedes 310 mit Eizo 9060s Monitor Geschenkt bekommen.

    Er ist recht gut ausgestattet , RiscOS 2,4MB Ram ,Arm 3 mit FPU,Linguenuity SCSI Controller.


    Nun kommen aber die Probleme Diskettenlaufwerk zeigt immer Drive Empty an

    zweites Problem SCSI Festplatte wird unter Devices erkannt aber man hört kein hochfahren der Platte, ist eine neue die noch nicht Formatiert ist.

    Alte Platte ist hin..

    Durch das Defekte Floppy kann ich keine Module für den ARM3 und FPU Laden.

    könnt ihr eventuell HELFEN.



    Ein Diskettenlaufwerk wir wohl keiner mehr haben?

    Kann ich die Festplatte aus den Modulen heraus Partitionieren bzw. Formatieren.


    Bin für jeden Tipp Dankbar.


    Gruß

    Thomas

  • Schönes Gerät. Vor allem voll aufgerüstet, mehr geht da fast nicht. Und RISC OS 2 ist zwar wahrscheinlich fürs Handling ein bißchen hakelig an manchen Stellen, aber vom Retro-Faktor her wahrscheinlich sogar besser als die 3er Version, urig und passend zum 310er.


    Die alte Festplatte solltest Du evtl. erstmal noch aufheben, bis Du bißchen "mit dem System warm geworden" bist, bevor Du sie als unrettbar defekt ansiehst.


    Eine neue Festplatte kann man da, prinzipiell und sinnvollerweise, nicht mit Boardmitteln formatieren.


    Dazu benötigst Du normalerweise das Tool !HForm, was man z.B. bei riscos.com in der FTP Abteilung finden kann. Die Bedienung ist allerdings alles andere als komfortabel.

    Außerdem gibt es das Stuttgart-Archiv , wo es unter Utils auch sowas gibt. Diese Sammlung willst Du auf jeden Fall mal komplett "ziehen", nicht daß sie jemand aus Datenschutzgründen entfernt ..., da sind noch allerlei klassische Sachen dabei. Und Games, und Demos, und Software aller Art.


    Aber: Da du ein Lingenuity SCSI Interface hast, wirst Du wohl eher dafür ein Formatiertool brauchen. Speziell zu diesem Interface. Sowas sucht man IMMER zuerst bei ChrisWhy - der Sammlung über Acorn Hardware schlechthin.

    http://chrisacorns.computinghi…g.uk/AcornCollection.html

    und wird da auch fündig , der Sofwarelink ist ganz unten.


    Handbuch gibt es dort auch. Bevor Du was Formatierst, werde Dir klar, was damit gemeint ist und lies das Handbuch zweimal. Normalerweise sind Festplatten schon vorformatiert und man muß das nicht nochmal machen (macht manchmal mehr kaputt). Danach muß dann i.a. noch ein Filesystem drauf. Bei einer sonst intakten neuen unbenutzten SCSI Platte, reicht aber das neue Filesystem vollauf. Welchen der beiden Schritte das Handbuch da jetzt mit Formatieren und was mit Initialisieren bezeichnet, geht da nicht draus hervor. Wenn das Programm Abfragen macht, kannst Du quasi die erste mal verneinen und nur den zweiten Schritt machen. ( Wenn der Formatierschritt, was in dem Fall ein LowLevelFormat ist, angelaufen ist, sollte man den dann auch durchlaufen lassen, ohne zu unterbrechen, was auch mal eine halbe Stunde dauern kann. )



    Problem bei allen DownloadSachen: meist sind sie gepackt.

    Da man sie schlecht auf anderen Systemen auspacken kann, da dann bestimmte Infos verlorengehen, die es in der Form nur in Acorns FileSystem gibt, ist das allererste Tool ein selbstentpackendes SparkPlug namens splug2.sfx, was man ebenfall bei Stuttgart findet - inkl. einem wichtigen ReadmeFile. ( Ist das gleiche Spiel (Henne-Ei), wie bei den Klassik Macs mit ihrem StuffIt Expander, den man nur in gepackter Form bekommt. )


    Auf den Rechner bekommt man die über die Floppy.

    Du müßtest evtl. mal den Fehler näher beschreiben, etwa, wann er auftritt, ob eine Floppy im Laufwerk ist etc.

    DiscDrive Empty kann nämlich auch einfach heißen, daß ein allgemeiner Fehler am Floppy auftrat, etwa keines gefunden wird, obwohl es angemeldet ist. Etwa weil das Kabel nicht richtig steckt oder oxidiert ist, oder mal noch ein zweites Laufwerk verbaut war, und jemand beim Ausbau das mit der Gerätenummer 0 ausgebaut hat, wo zuerst gesucht wird.


    Die Laufwerkskonfiguration macht man unter Apps auf der Iconbar und da gibt es ein Config Icon. Dann irgendwas mit Disc's.

    Man kann sich auch den Status dieser Einstellungen in einem Rutsch anzeigen lassen, indem man F12 drückt und *status eingibt. Für Schreibfaule reicht auch ein *st.

    Dort sollten zumindest Zahl und Art der Laufwerke passen. Alte Handbücher finden sich u.a. auch bei riscos.com - siehe oben. Minimum sind ein UserGuide und ziemlich bald dann auch das BasicHandbuch. Fürs tiefere Verständnis gibt es die PRMs etc. Nimm erstmal die User-Ecke.

  • Danke mal wieder für Deine ausführliche und schnelle Antwort.


    Das anlegen einer Partion würde ich schon hinbekommen , habe früher ja selbst diverse Acorn Rechner gehabt.

    Das Tool würde ich sogar noch auf Diskette bekommen können..


    Es war immer nur ein Disklaufwerk im Rechner verbaut gewesen,

    Das Problem scheint zu sein das der Rechner bzw. das Laufwerk garnicht mit bekommt ob eine Disk eingelegt wurde oder nicht.

    Wenn ich eine Diskette einlege und vom Desktop aus anklicke geht kurz die Lampe an und dann erscheint die Meldung ,Drive Empty.

    Ich höre aber keine Motorengeräusche oder irgend ein zugriff.

    Das Laufwerk hat ein Schalter der wohl dazu dient zu überprüfen ob der Schreibschutz auf oder zu ist, ich kann aber nichts finden was überprüft

    ob eine Disk eingelegt ist oder nicht.


    Was ich auch merkwürdig finde ,wenn die SCSI Platte an Strom angeschlossen ist müsste sie doch eigentlich hochfahren.? oder wird sie vom Controller aus angesprochen damit sie hochfährt .

    Wenn der Rechner eingeschaltet wird höre ich von der Platte nichts.


    Bilder wollte ich eigentlich heute einstellen ,muss aber mal wieder feststellen das seit IOS 11 ein neues Format eingesetzt wird (hiec),

    muss nun ein Converter laden um sie nach jpg umzuwandeln .


    PS: habe den Rechner komplett zerlegt um ihn zu entstauben , habe auch das Diskettenlaufwerk gereinigt bzw. entstaubt.



  • Viele SCSI-Festplatten bieten die Möglichkeit, den Spindelmotor erst durch einen Spinup-Befehl des Controllers zu starten. Dadurch kann der Controller bei mehreren Festplatten diese nacheinander starten. Würden die Festplatten alle gleichzeitig starten, könnte das das Netzteil überlasten.

    Normalerweise kann man das Verhalten der Festplatte aber per Jumper konfigurieren.

    Kann natürlich auch sein, dass die Platte fest ist. (pun intended...)

  • Hallo Kpanic


    also ich glaube nicht das die Platte Defekt sind, an einer SGI verhält sie sich normal.

    Bei der SGI wird aber auch das System hochgefahren und die Platte wird dementsprechend angesprochen.

    Also könntest Du wohl recht haben mit dem Spinup Befehl.


    Gruß

    Thomas

  • Die Festplatte die im Rechner war ist eine Quantum ProDrive LPS#.

    Momentan ist eineDDRS-34560W IBM über ein Adapter eingebaut.

    Mit eine Conner CFP2105S habe ich es auch versucht, ohne erfolg.


    Sind natürlich alle viel zu groß aber wäre ja schon froh wenn ein teil hiervon gehen würde.

  • Und die werden alle mit *devices erkannt ? Und laufen alle nicht an ?

    Mal die 12V Leitung genauer anschauen, Kabeldefekt direkt im Stecker o.ä. ?


    Hast Du mal die *configure SCSIFSLink 4 00 Geschichte aus dem Handbuch eingegeben ?

  • Hallo

    außer die Quantum Festplatte werden alle über debatte den Befehl Devices erkannt.

    Wenn die Festplatte kein Strom ziehen würde kann der Controller dann trotzdem die Daten der Platte über das SCSI Kabel auslesen?

    Beim Stomanschlusss ist nichts zu sehen , muss mir aber noch einen Stromprüfer besorgen um die Leitungen einmal zu überprüfen.

    Mich wundert auch das der Lüfter nicht , mir wurde aber gesagt das er eventuell Defekt ist.


    Mit SCSIFSLINK bekomme ich die Fehlermeldung bad number.

    Festplatte wird mit ID 4 angezeigt ,Controller mit ID 7.

    Bei der Fesplatte stehen aber nur Capacity ??????MB


    Gruß

    Thomas

  • muss mir aber noch einen Stromprüfer besorgen um die Leitungen einmal zu überprüfen.


    Ja, mach das mal.


    Mit SCSIFSLINK bekomme ich die Fehlermeldung bad number.


    Wenn Deine eingestellte SCSI ID der Platte 4 ist, mußt Du natürlich *configure scsifslink 4 04 schreiben.

    Die erste 4 ist die für das Filesystem (SCSIFS::4 und so eine Art Gerätenummer), die zweite die SCSI ID. So wie es aussieht "koppelt" der Befehl Treiber und FileSystem aneinander. Bei den Acornkarten (AKA30, AKA31, AKA32) gibt es das nicht. Ich hab' das so ähnlich aber schonmal gesehen, ich glaube bei einer VerticalTwist Karte. Danach sollte dann, sofern die SCSI Module im EPROM der Karte vorhanden sind und nicht abgeschaltet ( *unplug ) sind, irgendwie vielleicht schon ein Icon auf der Iconbar erscheinen.

  • Hallo

    mir ist gerade nochmal eingefallen das ich noch einen Internen SCSi CD Brenner habe ,

    würde sofort angeschlossen , wird nicht erkannt unter Devices ,es blinkt vorne nur die Lampe Orange , grün .

    Das Laufwerk läßt sich nicht öffnen ?

    kann es sein das das Netzteil teilweise Defekt ist?

    Ausdem Netzteil kommen ja einmal die vier Anschlüsse fürs Board , drei für die Backplane, und der Stromanschluss für Floppy und Festplatte.


    Thomas

  • Hallo Thoralf

    bitte schau dir mal Bild 2 an , wenn ich mir c37 anschaue würde ich meinen der Kondensator ist hinüber .

    Auf der Seite https://www.retro-kit.co.uk/pa…-Archimedes-A310-RISCOS2/

    heißt es das dieser und zwei andere c38,c39, statt 12volt nur 1,4volt liefern.

    Das würde ja einiges erklären ,oder liege ich hier falsch.?


    Gruß

    Thomas

  • Na komisch verfärbt sieht der schon aus.

    Da wirst Du wohl wirklich mal mit einem Meßgerät die Spannungen messen müssen.


    Würde auf jeden Fall auch schön zu dem Verdacht passen, daß die Platten mangels Strom nicht anlaufen wollen.

    Am Besten mal alle Spannungen messen und da es ja jetzt sowieso schon auseinandergebaut ist, auch die reinen Spannungen, die das Netzteil liefert, wenn es nicht am Board angeschlossen ist. Und dazu die, wenn der Rechner an ist ( und dabei keine Kurzschlüsse bauen ) - evtl. einfach am Harddiskstromstecker der vom NT kommt.


    Keine Ahnung was die Hardwarekenner hier dazu sagen.

    Solltest Du auf jeden Fall mal noch so einen Kommentar abwarten, bevor Du anfängst da rumzulöten.

  • So bin jetzt ein ganzes Stück weiter😄😄

    Habe nun ein externes Netzteil verwendet und als erstes das Diskettenlaufwerk ausprobiert.

    Ein lächeln kamm in mein Gesicht es läuft.


    Als nächstes eine Conner SCSI Festplatte mit dem externen Netzteil verbunden und vom Controller aus nit dem SCSI Kabel

    Platte fährt hoch und wird auch vom Controller angezeigt , auch die Fragezeichen beim Punkt Capazität tauchen nicht mehr auf ,es wird die richtige größe

    angegeben.

    Jetzt die Original Platte eingebaut , fährt hoch und unter Devices werden 115 MB angezeigt mit der ID 4.

    Leider kann ich nicht drauf zugreifen ,es kommt die Sanduhr.


    Habe die Platte nochmal über SCSIFSLINK und SCSIFSDRIVE configuriert , keine änderung.


    Bekomme wahrscheinlich Morgen noch weitere unterlagen und Software (Disketten)


    Fakt ist auf jedenfall das die Kondensatoren erneuert werden müssen.


    Gruß

    Thomas

  • Sehr schön !


    Da kam doch der richtige Vorschag zur richtigen Zeit.

    Nachdem Du nun weißt, daß da vermutlich zumindest der eine Kondensator die 12V Leitung gegen Masse ableitet, quasi vom Kondensator zum Widerstand geworden ist, zumindest würde ich das ja so deuten ( und wahrscheinlich ist es falsch ... ), kannst Du Dir Gedanken machen, wie man den ersetzt.

    Dabei solltest Du beachten, daß Acorn zu der Zeit ganz gut auf der Höhe der Zeit war, weshalb das Board durchaus schon eine Vier-Layer-Platine sein kann. Daher empfiehlt sich möglicherweise, wenn man erstmal nur den einen C37 tauschen will, nicht die Beinchen aus der Platine zu löten sondern diese stehen zu lassen und den neuen Kondensator oben an diese beiden, dann Stifte, anzulöten.


    (Ansonsten: Such mal Infos zu A310 und 2Slot vs. 4Slot Backplane. Die ersten Geräte kamen mit 2Slot Backplane und es gab dann irgenwie solche "Ertüchtigungsumbauten" damit die 4Slot auch da benutzt werden konnten. Soll heißen, wenn das so ein eigentliches 2Slot Gerät ist, kann evtl. auch nach Reparatur das schnell wieder auftreten.)



    Zur Softwareseite:

    Wenn die Sanduhr kommt kann das bei SCSI an allerlei liegen. Die häufigste Ursache ist ein nicht gesetzter Terminator.

    Je nachdem was Du so bereits eingegeben hast, kann da auch einfach auf weitere Platten gewartet werden, was dann jeweils mindestens 30sec pro Platte sind.


    Wahrscheinlich wäre aber auch folgendes: *configure scsifslink 4 04

    Variante 1) der akzeptiert die 04 nicht, und man muß da 4 schreiben

    Variante 2) *configure Befehle schreiben ihre Daten in ein CMOS NVRAM mit Batteriepufferung. Normalerweise sollten gesetzte Werte daher beim nächsten Start noch da sein, was mit *status abfragbar ist. Evtl. muß man die Batterien erneuern, sollten beim A310 normale AAA(?) in einem Halter sein, der extra meist vorn links im Gehäuse sitzt. Insbesondere aber muß das SCSIFS diese Werte lesen können, d.h. es muß einmal geresetet werden, bevor sie akzeptiert werden. Wenn jetzt die Werte bei Neustart weg sind, klappt das so natürlich nicht. Aber man kann mit *rmreinit SCSIFS direkt nach Setzen der *configure Sachen das ganze Modul auch per Hand neustarten.

    Und, wenns mal läuft, SCSIform und ähnliche Kommandos am Besten nur dann nutzen, wenn die alte Originalplatte sicher verwahrt und unangeschlossen ist. Da willst Du ja schließlich noch die alten Schätze drauf finden ...

  • 😁😁😁Archimedes 310 laüft😀😀😀


    So nachdem ich einwenig experimentiert habe könnte ich aus dem CLI heraus auf die Festplatte zugreifen.

    Auf dieser war alles zu finden um den Controller bzw. die Festplatte wieder so zu Konfigurieren das ich nun auch vom Desktop als alles aufrufen kann.

    Arm3,FPA diverse Spiele , Grafikprogramme ArtWorks,Revolution, Easy Writer, Impression.

    Also fast alles was das Herz begehrt.


    Aber num kommt das Beste , habe heute nochmal mit meinen Freund gesprochen und nachgefragt ob eventuell nochwas an Software vorhanden ist.

    Darauf hin ist er nochmal im Keller runter und fand tatsächlich noch eine Kiste.

    Alle Original Disketten von Athur an, Cumana SCSI Controller, Computer Concept Colourcard,Zip Laufwerk , Syquest Laufwerk;

    Alle Handbücher,mehr geht schon fast nicht.

    Und mit ganz viel Glück könnte auch noch ein IDE Controller dabei sein , wahr sich nicht sicher ob er ihn noch hat.


    Jetzt muss ich nur noch den Kondensator austauschen bzw. lassen , da ich noch nie Gelötet habe werde ich es wohl besse machen lassen.


    Nun noch eine frage an unsere Profis , wo bekomme ich den Kondensator her, 25V 100uf


    Beste Grüße

    Thomas

  • Der Kondensator ist ein absolutes Massen-Standard-Teil, das gibt's bei jedem Elektronikhändler.

    Und auch fast jeder Elektronikbastler wird sowas rumliegen haben.

    Wo wohnst Du denn?

    Vielleicht gibt es ja jemanden in Deiner Nähe, der Dir das mal eben löten kann.

  • Hallo Tast_r

    hatte ich mir fast gedacht, aber da ich keine Ahnung von sowas habe und diese Kondensatoren in sämtlichen Farben auftauchen

    war ir mir doch recht unsicher.


    Wäre natürlich super wenn sich jemand finden würde der dies übernehmen kann, würde dies selbstverständlich Bezahlen.

    Komme aus 45359 Essen.


    Gruß

    Thomas

  • Hallo Jens


    finde ich auch , das Diskettenlaufwerk hat mir am meisten sorgen gemacht da diese sehr schwer zu bekommen sind.

    Für dem Kodensator werde ich schon jemanden finden ,ansonsten mache ich halt selber.


    Danke


    Gruß

    Thomas

  • Wenn sich niemand findet, der näher dran ist, und Dir der Weg nicht zu weit ist,

    kannst Du mit der Kiste gerne zu mir nach 47918 Tönisvorst kommen.

    Das ist von Essen aus ja noch eine halbwegs humane Entfernung.

    Das wäre für mich ja auch eine Gelegenheit,

    mir so eine Maschine mal im Betrieb zeigen zu lassen,
    Bisher habe ich damit nämlich überhaupt keine Erfahrung.

  • Hallo


    Heute habe ich die restlichen Acorn Teile abgeholt,leider kein IDE und keine Colourcard dabei😫

    Dafür Welcome und User Guide für Athur und Risc OS 2, 2x Basic V in Deutsch,Risc OS 3 Handbuch,Risc PC Handbücher

    Athur Roms, 4 MB Speicherkarte A5000, SCSI Karte von Cumana .

    Internes Zip 100(scsi) und ein externes Syquest Laufwerk mit Medien 270MB.


    Mit etwas Glück tauchen eventuell noch andere Schätze auf.


    Gruß

    Thomas

  • Selbstverständlich kann man hier nicht meckern aber wie der Mensch halt so ist , nie zufrieden .

    Bin auch sehr happy , sind recht viele brauchbare sachen dabei.

    Ein IDE Controller hätte die ganze Geschichte etwas leichter gemacht , ein IDE Adapter mit einer Speicherkarte hätte schön die Festplatte ersetzen

    können.


    Gruß

    Thomas